[PART 1] CCNA 200-125 Dumps Questions and Answers Latest (VCE + PDF)

[PART 1] CCNA 200-125 Dumps Questions and Answers Latest (VCE + PDF)
4 (21) vote[s]

1.  Which technology supports the stateless assignment of IPv6 addresses? (Choose two.)

  • DNS
  • DHCPv6*
  • DHCP
  • autoconfiguration*
Show (Hide) Explanation/Reference
DHCPv6 Technology Overview
IPv6 Internet Address Assignment Overview
IPv6 has been developed with Internet Address assignment dynamics in mind. Being aware that IPv6 Internet addresses are 128 bits in length and written in hexadecimals makes automation of address- assignment an important aspect within network design. These attributes make it inconvenient for a user to manually assign IPv6 addresses, as the format is not naturally intuitive to the human eye. To facilitate address assignment with little or no human intervention, several methods and technologies have been developed to automate the process of address and configuration parameter assignment to IPv6 hosts. The various IPv6 address assignment methods are as follows:

1. Manual Assignment
An IPv6 address can be statically configured by a human operator. However, manual assignment is quite
open to errors and operational overhead due to the 128 bit length and hexadecimal attributes of the addresses, although for router interfaces and static network elements and resources this can be an appropriate solution.
2. Stateless Address Autoconfiguration (RFC2462)
Stateless Address Autoconfiguration (SLAAC) is one of the most convenient methods to assign Internet
addresses to IPv6 nodes. This method does not require any human intervention at all from an IPv6 user. If one wants to use IPv6 SLAAC on an IPv6 node, it is important that this IPv6 node is connected to a network with at least one IPv6 router connected. This router is configured by the network administrator and sends out Router Advertisement announcements onto the link. These announcements can allow the on-link connected IPv6 nodes to configure themselves with IPv6 address and routing parameters, as specified in RFC2462, without further human intervention.
3. Stateful DHCPv6
The Dynamic Host Configuration Protocol for IPv6 (DHCPv6) has been standardized by the IETF through
RFC3315. DHCPv6 enables DHCP servers to pass configuration parameters, such as IPv6 network addresses, to IPv6 nodes. It offers the capability of automatic allocation of reusable network addresses and additional configuration flexibility. This protocol is a stateful counterpart to “IPv6 Stateless Address Autoconfiguration” (RFC 2462), and can be used separately, or in addition to the stateless autoconfiguration to obtain configuration parameters.
4. DHCPv6-PD
DHCPv6 Prefix Delegation (DHCPv6-PD) is an extension to DHCPv6, and is specified in RFC3633. Classical
DHCPv6 is typically focused upon parameter assignment from a DHCPv6 server to an IPv6 host running a DHCPv6 protocol stack. A practical example would be the stateful address assignment of “2001:db8::1” from a DHCPv6 server to a DHCPv6 client. DHCPv6-PD however is aimed at assigning complete subnets and other network and interface parameters from a DHCPv6-PD server to a DHCPv6-PD client. This means that instead of a single address assignment, DHCPv6-PD will assign a set of IPv6 “subnets”. An example could be the assignment of “2001:db8::/60” from a DHCPv6-PD server to a DHCPv6-PD client. This will allow the DHCPv6-PD client (often a CPE device) to segment the received address IPv6 address space, and assign it dynamically to its IPv6 enabled interfaces.
5. Stateless DHCPv6
Stateless DHCPv6 is a combination of “stateless Address Autoconfiguration” and “Dynamic Host Configuration Protocol for IPv6” and is specified by RFC3736. When using stateless-DHCPv6, a device will use Stateless Address Auto-Configuration (SLAAC) to assign one or more IPv6 addresses to an interface, while it utilizes DHCPv6 to receive “additional parameters” which may not be available through SLAAC. For example, additional parameters could include information such as DNS or NTP server addresses, and are provided in a stateless manner by DHCPv6. Using stateless DHCPv6 means that the DHCPv6 server does not need to keep track of any state of assigned IPv6 addresses, and there is no need for state refreshment as result. On network media supporting a large number of hosts associated to a single DHCPv6 server, this could mean a significant reduction in DHCPv6 messages due to the reduced need for address state refreshments. From Cisco IOS 12.4(15)T onwards the client can also receive timing information, in addition to the “additional parameters” through DHCPv6. This timing information provides an indication to a host when it should refresh its DHCPv6 configuration data. This behavior (RFC4242) is particularly useful in unstable environments where changes are likely to occur.

2.  What are two requirements for an HSRP group? (Choose two.)

  • A. exactly one active router*
  • B. one or more standby routers*
  • C. one or more backup virtual routers
  • D. exactly one standby active router
  • E. exactly one backup virtual router
Show (Hide) Explanation/Reference
From this paragraph:

“A set of routers that run HSRP works in concert to present the illusion of a single default gateway router to the hosts on the LAN. This set of routers is known as an HSRP group or standby group. A single router that is elected from the group is responsible for the forwarding of the packets that hosts send to the virtual router. This router is known as the active router. Another router is elected as the standby router. If the active router fails, the standby assumes the packet forwarding duties. Although an arbitrary number of routers may run HSRP, only the active router forwards the packets that are sent to the virtual router IP address.

In order to minimize network traffic, only the active and the standby routers send periodic HSRP messages after the protocol has completed the election process. Additional routers in the HSRP group remain in the Listen state. If the active router fails, the standby router takes over as the active router. If the standby router fails or becomes the active router, another router is elected as the standby router.”

Reference: https://www.cisco.com/c/en/us/support/docs/ip/hot-standby-router-protocol-hsrp/10583-62.html#anc6

-> There is exactly one active router and one standby router in an HSRP group. Answer A is surely a correct but other answers are not correct. Answers C, D and E are wrong terminologies so they are surely not correct. Therefore answer B is a best choice left (although it is not totally correct).

3.  After you configure the Loopback0 interface, which command can you enter to verify the status of the interface and determine whether fast switching is enabled?

  • Router#show ip interface loopback 0*
  • Router#show run
  • Router#show interface loopback 0
  • Router#show ip interface brief
Show (Hide) Explanation/Reference
Output from real device

Router2901#sh int g0/0
GigabitEthernet0/0 is up, line protocol is up
Hardware is CN Gigabit Ethernet, address is c471.fe99.9999 (bia c471.fe99.9999)
Description: Lan
Internet address is 10.1.1.1/25
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1Gbps, media type is RJ45
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of “show interface” counters never
Input queue: 0/75/61/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 39000 bits/sec, 30 packets/sec
5 minute output rate 73000 bits/sec, 37 packets/sec
41068530 packets input, 3905407112 bytes, 0 no buffer
Received 8678853 broadcasts (0 IP multicasts)
0 runts, 0 giants, 45 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 79853 multicast, 0 pause input
39267208 packets output, 2262399504 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
79926 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
Router2901#
Router2901 ip int g0/0
GigabitEthernet0/0 is up, line protocol is up
Internet address is 10.1.1.1/25
Broadcast address is 255.255.255.255
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Secondary address 192.168.1.7/24
Multicast reserved groups joined: 224.0.0.10
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is enabled, interface in domain inside
BGP Policy Mapping is disabled
Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, CAR, MCI Check
Output features: NAT Inside, Common Flow Table, Stateful Inspection, NAT ALG proxy, CAR
Post encapsulation features: CAR
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
Router2901#

4.  Which command sequence can you enter to create VLAN 20 and assign it to an interface on a switch?

  • Switch(config)#vlan 20
    Switch(config)#Interface gig x/y
    Switch(config-if)#switchport access vlan 20  *
  • Switch(config)#Interface gig x/y
    Switch(config-if)#vlan 20
    Switch(config-vlan)#switchport access vlan 20
  • Switch(config)#vlan 20
    Switch(config)#Interface vlan 20
    Switch(config-if)#switchport trunk native vlan 20
  • Switch(config)#vlan 20
    Switch(config)#Interface vlan 20
    Switch(config-if)#switchport access vlan 20
  • Switch(config)#vlan 20
    Switch(config)#Interface vlan 20
    Switch(config-if)#switchport trunk allowed vlan 20

5.  Which three commands can you use to set a router boot image? (Choose three.)

  • Router(config)# boot system flash c4500-p-mz.121-20.bin*
  • Router(config)# boot system tftp c7300-js-mz.122-33.SB8a.bin*
  • Router(config)#boot system rom c7301-advipservicesk9-mz.124-24.T4.bin*
  • Router> boot flash:c180x-adventerprisek9-mz-124-6T.bin
  • Router(config)#boot flash:c180x-adventerprisek9-mz-124-6T.bin
  • Router(config)#boot bootldr bootflash:c4500-jk9s-mz.122-23f.bin
Show (Hide) Explanation/Reference
The correct syntax of the “boot” command is “boot system” path. In which the popular for path can be:
+ flash
+ rom
+ tftp
+ ftp
+ IP address (IP address of the server containing the system image file)

Therefore answers A, B, C are correct.

6.  Which two statements about IPv6 and routing protocols are true? (Choose two.)

  • Link-local addresses are used to form routing adjacencies.*
  • OSPFv3 was developed to support IPv6 routing.*
  • EIGRP, OSPF, and BGP are the only routing protocols that support IPv6.
  • Loopback addresses are used to form routing adjacencies.
  • EIGRPv3 was developed to support IPv6 routing.

Link-local addresses only used for communications within the local subnetwork (automatic address configuration, neighbor discovery, router discovery, and by many routing protocols). It is only valid on the current subnet. It is usually created dynamically using a link-local prefix of FE80::/10 and a 64-bit interface identifier (based on 48-bit MAC address).

7.  If primary and secondary root switches with priority 16384 both experience catastrophic losses, which tertiary switch can take over?

  • a switch with priority 20480*
  • a switch with priority 8192
  • a switch with priority 4096
  • a switch with priority 12288
Show (Hide) Explanation/Reference
This is a tricky question. We know the switch with lowest value of priority is elected the root switch. Therefore in this question the switches with priority of 4096, 8192, 12288 (which are lower than the current value of the root bridge 16384) are not joining the root bridge election by somehow. The only suitable answer is the switch with priority 20480 will become the root bridge.

8.  Which two statements about late collisions are true? (Choose two.)

  • They may indicate a duplex mismatch.*
  • By definition, they occur after the 512th bit of the frame has been transmitted.*
  • They indicate received frames that did not pass the FCS match.
  • They are frames that exceed 1518 bytes.
  • They occur when CRC errors and interference occur on the cable.
Show (Hide) Explanation/Reference
A late collision is defined as any collision that occurs after the first 512 bits of the frame have been transmitted. The usual possible causes are full-duplex/half-duplex mismatch, exceeded Ethernet cable length limits, or defective hardware such as incorrect cabling, non-compliant number of hubs in the network, or a bad NIC.

Note: On an Ethernet connection, a duplex mismatch is a condition where two connected devices operate in different duplex modes, that is, one operates in half duplex while the other one operates in full duplex.

9.  Which command can you enter to set the default route for all traffic to an interface?

  • router(config)#ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1*
  • router(config)#ip route 0.0.0.0 255.255.255.255 GigabitEthernet0/1
  • router(config-router)#default-information originate
  • router(config-router)#default-information originate always

10. Which two spanning-tree port states does RSTP combine to allow faster convergence? (Choose two.)

  • blocking*
  • listening*
  • learning
  • forwarding
  • discarding
Show (Hide) Explanation/Reference
There are only three port states left in RSTP that correspond to the three possible operational states. The 802.1D blocking, and listening states are merged into the 802.1w discarding state.

* Discarding – the port does not forward frames, process received frames, or learn MAC addresses – but it does listen for BPDUs (like the STP blocking state)
* Learning – receives and transmits BPDUs and learns MAC addresses but does not yet forward frames (same as STP).
* Forwarding – receives and sends data, normal operation, learns MAC address, receives and transmits BPDUs (same as STP).

STP State (802.1d) RSTP State (802.1w)
Blocking Discarding
Listening Discarding
Learning Learning
Forwarding Forwarding

Although the learning state is also used in RSTP but it only takes place for a short time as compared to STP. RSTP converges with all ports either in forwarding state or discarding state.

11.  If a router has four interfaces and each interface is connected to four switches, how many broadcast domains are present on the router?

  • 1
  • 2
  • 4*
  • 8
Show (Hide) Explanation/Reference
Remember that only route interface can separate broadcast domain (while switch interface separate collision domain) so the broadcast domains are equal to the number of router interfaces, which is four in this case.

12. Question about HTTP API :

  • Rest*
  • OpenFlow
  • COpflex
  • OpenStack

13. What two state that lacp forwarding (something like this)

  • Passive *
  • Active*
  • Auto
  • Desirable

14.  Which command enables IPv6 forwarding on a Cisco router?

  • ipv6 local
  • ipv6 host
  • ipv6 unicast-routing*
  • ipv6 neighbor
Show (Hide) Explanation/Reference
An example of configuring RIPng (similar to RIPv2 but is used for IPv6) is shown below:

Router(config)#ipv6 unicast-routing (Enables the forwarding of IPv6 unicast datagrams globally on the router)
Router(config)#interface fa0/0
Router(config-if)#ipv6 rip 9tut enable (9tut is the process name of this RIPng)

15.  Refer to the exhibit. What is the most appropriate summarization for these routes?

  • 10.0.0.0 /21
  • 10.0.0.0 /22*
  • 10.0.0.0 /23
  • 10.0.0.0 /24

Show (Hide) Explanation/Reference
The 10.0.0.0/22 subnet mask will include the 10.0.0.0, 10.0.1.0, 10.0.2.0, and 10.0.3.0 networks, and only those four networks.

16.  Which set of commands is recommended to prevent the use of a hub in the access layer?

  • switch(config-if)#switchport mode trunk
    switch(config-if)#switchport port-security maximum 1
  • switch(config-if)#switchport mode trunk
    switch(config-if)#switchport port-security mac-address 1
  • switch(config-if)#switchport mode access
    switch(config-if)#switchport port-security maximum 1*
  • switch(config-if)#switchport mode access
    switch(config-if)#switchport port-security mac-address 1
Show (Hide) Explanation/Reference
Port security is only used on access port (which connects to hosts) so we need to set that port to “access” mode, then we need to specify the maximum number of hosts which are allowed to connect to this port -> C is correct.

Note: If we want to allow a fixed MAC address to connect, use the “switchport port-security mac-address ” command.

17.  A router has learned three possible routes that could be used to reach a destination network. One route is from EIGRP and has a composite metric of 20514560. Another route is from OSPF with a metric of 782. The last is from RIPv2 and has a metric of 4. Which route or routes will the router install in the routing table?

  • the OSPF route
  • the EIGRP route*
  • the RIPv2 route
  • all three routes
  • the OSPF and RIPv2 routes
Show (Hide) Explanation/Reference
When one route is advertised by more than one routing protocol, the router will choose to use the routing protocol which has lowest Administrative Distance. The Administrative Distances of popular routing protocols are listed below:

18.  Two routers named Atlanta and Brevard are connected via their serial interfaces as illustrated, but they are unable to communicate. The Atlanta router is known to have the correct configuration.
Given the partial configurations, identify the fault on the Brevard router that is causing the lack of connectivity

  • incompatible IP address
  • insufficient bandwidth
  • incorrect subnet mask
  • incompatible encapsulation*
  • link reliability too low
  • IPCP closed

19.  A network administrator needs to configure a serial link between the main office and a remote location. The router at the remote office is a non-Cisco router. How should the network administrator configure the serial interface of the main office router to make the connection?

  • Main(config)# interface serial 0/0
    Main(config-if)# ip address 172.16.1.1 255.255.255.252
    Main(config-if)# no shut
  • Main(config)# interface serial 0/0
    Main(config-if)# ip address 172.16.1.1 255.255.255.252
    Main(config-if)# encapsulation ppp
    Main(config-if)# no shut *
  • Main(config)# interface serial 0/0
    Main(config-if)# ip address 172.16.1.1 255.255.255.252
    Main(config-if)# encapsulation frame-relay
    Main(config-if)# authentication chap
    Main(config-if)# no shut
  • Main(config)# interface serial 0/0
    Main(config-if)#ip address 172.16.1.1 255.255.255.252
    Main(config-if)#encapsulation ietf
    Main(config-if)# no shut

20.  Which Layer 2 protocol encapsulation type supports synchronous and asynchronous circuis and has built-in security mechanisms?

  • HDLC
  • PPP*
  • X.25
  • Frame Relay
Show (Hide) Explanation/Reference
PPP supports both synchronous (like analog phone lines) and asynchronous circuits (such as ISDN or digital links). With synchronous circuits we need to use clock rate.

Note: Serial links can be synchronous or asynchronous. Asynchronous connections used to be only available on low-speed (<2MB) serial interfaces, but now, there are the new HWICs (High-Speed WAN Interface Cards) which also support asynchronous mode. To learn more about them please visit http://www.cisco.com/en/US/prod/collateral/modules/ps5949/ps6182/prod_qas0900aecd80274424.html.

21.  Refer to the exhibit. The two connected ports on the switch are not turning orange or green. What would be the most effective steps to troubleshoot this physical layer problem? (Choose three.)

  • Ensure that the Ethernet encapsulations match on the interconnected router and switch ports.
  • Ensure that cables A and B are straight-through cables.*
  • Ensure cable A is plugged into a trunk port.
  • Ensure the switch has power.*
  • Reboot all of the devices.
  • Reseat all cables.*

22.  A network administrator is troubleshooting the OSPF configuration of routers R1 and R2. The routers cannot establish an adjacency relationship on their common Ethernet link.
The graphic shows the output of the show ip ospf interface e0 command for routers R1 and R2. Based on the information in the graphic, what is the cause of this problem?

  • The OSPF area is not configured properly.
  • The priority on R1 should be set higher.
  • The cost on R1 should be set higher.
  • The hello and dead timers are not configured properly.*
  • A backup designated router needs to be added to the network.
  • The OSPF process ID numbers must match.
Show (Hide) Explanation/Reference
D is correct because these entries must match on neighboring routers:

– Hello and dead intervals
– Area ID (Area 0 in this case)
– Authentication password
– Stub area flag

In this case Ethernet0 of R1 has Hello and Dead Intervals of 5 and 20 while R2 has Hello and Dead Intervals of 10 and 40 -> R1 and R2 cannot form OSPF neighbor relationship.

23.  What will happen if a private IP address is assigned to a public interface connected to an ISP?

  • Addresses in a private range will be not be routed on the Internet backbone.*
  • Only the ISP router will have the capability to access the public network.
  • The NAT process will be used to translate this address to a valid IP address.
  • A conflict of IP addresses happens, because other public routers can use the same range.

24.  Refer to the exhibit. The Bigtime router is unable to authenticate to the Littletime router. What is the cause of the problem?

  • The usernames are incorrectly configured on the two routers.
  • The passwords do not match on the two routers.*
  • CHAP authentication cannot be used on a serial interface.
  • The routers cannot be connected from interface S0/0 to interface S0/0.
  • With CHAP authentication, one router must authenticate to another router. The routers cannot be configured to authenticate to each other.
Show (Hide) Explanation/Reference
Both routers must use the same password for CHAP to authentication.

25.  What will be the result if the following configuration commands are implemented on a Cisco switch?

Switch(config-if)# switchport port-security
Switch(config-if)# switchport port-security mac-address sticky

  • A dynamically learned MAC address is saved in the startup-configuration file.
  • A dynamically learned MAC address is saved in the running-configuration file.*
  • A dynamically learned MAC address is saved in the VLAN database.
  • Statically configured MAC addresses are saved in the startup-configuration file if frames from that address are received.
  • Statically configured MAC addresses are saved in the running-configuration file if frames from that address are received.

26.  Refer to the exhibit. The following commands are executed on interface fa0/1 of 2950Switch.

2950Switch(config-if)# switchport port-security
2950Switch(config-if)# switchport port-security mac-address sticky
2950Switch(config-if)# switchport port-security maximum 1

The Ethernet frame that is shown arrives on interface fa0/1. What two functions will occur when this frame is received by 2950Switch? (Choose two.)

  • The MAC address table will now have an additional entry of fa0/1 FFFF.FFFF.FFFF.
  • Only host A will be allowed to transmit frames on fa0/1.*
  • This frame will be discarded when it is received by 2950Switch.
  • All frames arriving on 2950Switch with a destination of 0000.00aa.aaaa will be forwarded out fa0/1.*
  • Hosts B and C may forward frames out fa0/1 but frames arriving from other switches will not be forwarded out fa0/1.
  • Only frames from source 0000.00bb.bbbb, the first learned MAC address of 2950Switch, will be forwarded out fa0/1.
Show (Hide) Explanation/Reference
The first command 2950Switch(config-if)#switchport port-security is to enable the port-security in a switch port.

In the second command 2950Switch(config-if)#switchport port-security mac-address sticky, we need to know the full syntax of this command is switchport port-security mac-address sticky [MAC]. The STICKY keyword is used to make the MAC address appear in the running configuration and you can save it for later use. If you do not specify any MAC addresses after the STICKY keyword, the switch will dynamically learn the attached MAC Address and place it into your running-configuration. In this case, the switch will dynamically learn the MAC address 0000.00aa.aaaa of host A and add this MAC address to the running configuration.

In the last command 2950Switch(config-if)#switchport port-security maximum 1 you limited the number of secure MAC addresses to one and dynamically assigned it (because no MAC address is mentioned, the switch will get the MAC address of the attached MAC address to interface fa0/1), the workstation attached to that port is assured the full bandwidth of the port.Therefore only host A will be allowed to transmit frames on fa0/1 -> B is correct.

After you have set the maximum number of secure MAC addresses for interface fa0/1, the secure addresses are included in the “Secure MAC Address” table (this table is similar to the Mac Address Table but you can only view it with the show port-security address command). So in this question, although you don’t see the MAC address of host A listed in the MAC Address Table but frames with a destination of 0000.00aa.aaaa will be forwarded out of fa0/1 interface -> D is correct.

27.  Which command would you configure globally on a Cisco router that would allow you to view directly connected Cisco devices?

  • enable cdp
  • cdp enable
  • cdp run*
  • run cdp
Show (Hide) Explanation/Reference
CDP is enabled by default on all Cisco routers. If it is turned off by any reason, we can turn it on again with the following command on global configuration mode:

Router(config)#cdp run

Note: CDP can be turned on or turned off on each interface. For example to turn off CDP on an interface we use this command:

Router(config-if)#no cdp enable

28.  A Cisco router is booting and has just completed the POST process. It is now ready to find and load an IOS image. What function does the router perform next?

  • It checks the configuration register.*
  • It attempts to boot from a TFTP server.
  • It loads the first image file in flash memory.
  • It inspects the configuration file in NVRAM for boot instructions.
Show (Hide) Explanation/Reference
When you turn the router on, it runs through the following boot process.

The Power-On Self Test (POST) checks the router’s hardware. When the POST completes successfully, the System OK LED indicator comes on.
The router checks the configuration register to identify where to load the IOS image from. A setting of 0×2102 means that the router will use information in the startup-config file to locate the IOS image. If the startup-config file is missing or does not specify a location, it will check the following locations for the IOS image:

1. Flash (the default location)
2. TFTP server
3. ROM (used if no other source is found)

The router loads the configuration file into RAM (which configures the router). The router can load a configuration file from:

+ NVRAM (startup-configuration file)
+ TFTP server
If a configuration file is not found, the router starts in setup mode.

29.  What are three advantages of VLANs? (Choose three.)

  • VLANs establish broadcast domains in switched networks.*
  • VLANs utilize packet filtering to enhance network security.
  • VLANs provide a method of conserving IP addresses in large networks.
  • VLANs provide a low-latency internetworking alternative to routed networks.
  • VLANs allow access to network services based on department, not physical location.*
  • VLANs can greatly simplify adding, moving, or changing hosts on the network.*

30.  Refer to the exhibit. The output that is shown is generated at a switch. Which three statements are true? (Choose three.)

  • All ports will be in a state of discarding, learning, or forwarding.*
  • Thirty VLANs have been configured on this switch.
  • The bridge priority is lower than the default value for spanning tree.*
  • All interfaces that are shown are on shared media.
  • All designated ports are in a forwarding state.*
  • This switch must be the root bridge for all VLANs on this switch.
Show (Hide) Explanation/Reference
From the output, we see that all ports are in Designated role (forwarding state) -> A and E are correct.

The command “show spanning-tree vlan 30″ only shows us information about VLAN 30. We don’t know how many VLAN exists in this switch -> B is not correct.

The bridge priority of this switch is 24606 which is lower than the default value bridge priority 32768 -> C is correct.

All three interfaces on this switch have the connection type “p2p”, which means Point-to-point environment – not a shared media -> D is not correct.

The only thing we can specify is this switch is the root bridge for VLAN 30 but we can not guarantee it is also the root bridge for other VLANs -> F is not correct.

31.  Which two commands can be used to verify a trunk link configuration status on a given Cisco switch interface? (Choose two.)

  • show interface trunk*
  • show interface interface
  • show ip interface brief
  • show interface vlan
  • show interface switchport*
Show (Hide) Explanation/Reference
The “show interfaces trunk” command and “show interfaces switchport” command can be used to verify the status of an interface (trunking or not). The outputs of these commands are shown below (port Ethernet 1/0 has been configured as trunk):

The “show ip interface brief” command only gives us information about the IP address, the status (up/down) of an interface:

The “show interfaces vlan” command only gives us information about that VLAN, not about which ports are the trunk links:

32.  Which two states are the port states when RSTP has converged? (Choose two.)

  • discarding*
  • listening
  • learning
  • forwarding*
  • disabled
Show (Hide) Explanation/Reference
RSTP only has 3 port states that are discarding, learning and forwarding. When RSTP has converged there are only 2 port states left: discarding and forwarding.

33.  Refer to the exhibit. A technician has installed Switch B and needs to configure it for remote access from the management workstation connected to Switch A . Which set of commands is required to accomplish this task?

  • SwitchB(config)# interface FastEthernet 0/1
    SwitchB(config-if)# ip address 192.168.8.252 255.255.255.0 SwitchB(config-if)# no shutdown
  • SwitchB(config)# interface vlan 1
    SwitchB(config-if)# ip address 192.168.8.252 255.255.255.0 SwitchB(config-if)# ip default-gateway 192.168.8.254 255.255.255.0 SwitchB(config-if)# no shutdown
  • SwitchB(config)# ip default-gateway 192.168.8.254
    SwitchB(config)# interface vlan 1
    SwitchB(config-if)# ip address 192.168.8.252 255.255.255.0 SwitchB(config-if)# no shutdown*
  • SwitchB(config)# ip default-network 192.168.8.254
    SwitchB(config)# interface vlan 1
    SwitchB(config-if)# ip address 192.168.8.252 255.255.255.0 SwitchB(config-if)# no shutdown
  • SwitchB(config)# ip route 192.168.8.254 255.255.255.0
    SwitchB(config)# interface FastEthernet 0/1
    SwitchB(config-if)# ip address 192.168.8.252 255.255.255.0 SwitchB(config-if)# no shutdown

34.  Which of the following are benefits of VLANs? (Choose three.)

  • They increase the size of collision domains.
  • They allow logical grouping of users by function.*
  • They can enhance network security.*
  • They increase the size of broadcast domains while decreasing the number of collision domains.
  • They increase the number of broadcast domains while decreasing the size of the broadcast domains.*
  • They simplify switch administration.
Show (Hide) Explanation/Reference
When using VLAN the number and size of collision domains remain the same -> A is not correct.

VLANs allow to group users by function, not by location or geography -> B is correct.

VLANs help minimize the incorrect configuration of VLANs so it enhances the security of the network -> C is correct.

VLAN increases the size of broadcast domains but does not decrease the number of collision domains -> D is not correct.

VLANs increase the number of broadcast domains while decreasing the size of the broadcast domains which increase the utilization of the links. It is also a big advantage of VLAN -> E is correct.

VLANs are useful but they are more complex and need more administration -> F is not correct.

35.  What are three benefits of implementing VLANs? (Choose three.)

  • A higher level of network security can be reached by separating sensitive data traffic from other network traffic.*
  • A more efficient use of bandwidth can be achieved allowing many physical groups to use the same network infrastructure.
  • A more efficient use of bandwidth can be achieved allowing many logical networks to use the same network infrastructure.*
  • Broadcast storms can be mitigated by increasing the number of broadcast domains, thus reducing their size.*
  • Broadcast storms can be mitigated by decreasing the number of broadcast domains, thus increasing their size.
  • VLANs make it easier for IT staff to configure new logical groups, because the VLANs all belong to the same broadcast domain.
  • Port-based VLANs increase switch-port use efficiency, thanks to 802.1Q trunks.

36.  Which three statements accurately describe Layer 2 Ethernet switches? (Choose three.)

  • Spanning Tree Protocol allows switches to automatically share VLAN information.
  • Establishing VLANs increases the number of broadcast domains.*
  • Switches that are configured with VLANs make forwarding decisions based on both Layer 2 and Layer 3 address information.
  • Microsegmentation decreases the number of collisions on the network.*
  • In a properly functioning network with redundant switched paths, each switched segment will contain one root bridge with all its ports in the forwarding state. All other switches in that broadcast domain will have only one root port.*
  • If a switch receives a frame for an unknown destination, it uses ARP to resolve the address.
Show (Hide) Explanation/Reference
Microsegmentation is a network design (functionality) where each workstation or device on a network gets its own dedicated segment (collision domain) to the switch. Each network device gets the full bandwidth of the segment and does not have to share the segment with other devices. Microsegmentation reduces and can even eliminate collisions because each segment is its own collision domain

Note: Microsegmentation decreases the number of collisions but it increases the number of collision domains.

37.  Which of the following correctly describe steps in the OSI data encapsulation process? (Choose two.)

  • The transport layer divides a data stream into segments and may add reliability and flow control information.*
  • The data link layer adds physical source and destination addresses and an FCS to the segment.
  • Packets are created when the network layer encapsulates a frame with source and destination host addresses and protocol-related control information.
  • Packets are created when the network layer adds Layer 3 addresses and control information to a segment.*
  • The presentation layer translates bits into voltages for transmission across the physical link.
Show (Hide) Explanation/Reference
The transport layer segments data into smaller pieces for transport. Each segment is assigned a sequence number, so that the receiving device can reassemble the data on arrival.

The transport layer also use flow control to maximize the transfer rate while minimizing the requirements to retransmit. For example, in TCP, basic flow control is implemented by acknowledgment by the receiver of the receipt of data; the sender waits for this acknowledgment before sending the next part.

-> A is correct.

The data link layer adds physical source and destination addresses and an Frame Check Sequence (FCS) to the packet (on Layer 3), not segment (on Layer 4) -> B is not correct.

Packets are created when network layer encapsulates a segment (not frame) with source and destination host addresses and protocol-related control information. Notice that the network layer encapsulates messages received from higher layers by placing them into datagrams (also called packets) with a network layer header -> C is not correct.

The Network layer (Layer 3) has two key responsibilities. First, this layer controls the logical addressing of devices. Second, the network layer determines the best path to a particular destination network, and routes the data appropriately.

-> D is correct.

The Physical layer (not presentation layer) translates bits into voltages for transmission across the physical link -> E is not correct.

38.  Which of the following describes the roles of devices in a WAN? (Choose three.)

  • A CSU/DSU terminates a digital local loop.*
  • A modem terminates a digital local loop.
  • A CSU/DSU terminates an analog local loop.
  • A modem terminates an analog local loop.*
  • A router is commonly considered a DTE device.*
  • A router is commonly considered a DCE device.
Show (Hide) Explanation/Reference
The idea behind a WAN is to be able to connect two DTE networks together through a DCE network. The network’s DCE device (includes CSU/DSU) provides clocking to the DTE-connected interface (the router’s serial interface).

A modem modulates outgoing digital signals from a computer or other digital device to analog signals for a conventional copper twisted pair telephone line and demodulates the incoming analog signal and converts it to a digital signal for the digital device. A CSU/DSU is used between two digital lines -> A & D are correct but B & C are not correct.

For more explanation of answer D, in telephony the local loop (also referred to as a subscriber line) is the physical link or circuit that connects from the demarcation point of the customer premises to the edge of the carrier or telecommunications service provider’s network. Therefore a modem terminates an analog local loop is correct.

39.  Which interface counter can you use to diagnose a duplex mismatch problem?

  • no carrier
  • late collisions*
  • giants
  • CRC errors
  • deferred
  • runts
Show (Hide) Explanation/Reference
A late collision is defined as any collision that occurs after the first 512 bits of the frame have been transmitted. The usual possible causes are full-duplex/half-duplex mismatch, exceeded Ethernet cable length limits, or defective hardware such as incorrect cabling, non-compliant number of hubs in the network, or a bad NIC.

We can check the interface counter with the “show interface <interface>” command on a Cisco device. For example:

On an Ethernet connection, a duplex mismatch is a condition where two connected devices operate in different duplex modes, that is, one operates in half duplex while the other one operates in full duplex.

Note:
+ Runts are frames which do not meet the minimum frame size of 64 bytes. Runts are usually created by collisions.
+ Giants: frames that are larger than 1,518 bytes

40.  Which feature can you implement to reserve bandwidth for VoIP calls across the call path?

  • PQ
  • CBWFQ
  • round robin
  • RSVP*
Show (Hide) Explanation/Reference
The Resource Reservation Protocol (RSVP) protocol allows applications to reserve bandwidth for their data flows. It is used by a host, on the behalf of an application data flow, to request a specific amount of bandwidth from the network. RSVP is also used by the routers to forward bandwidth reservation requests.

41.  When an interface is configured with PortFast BPDU guard, how does the interface respond when it receives a BPDU?

  • It continues operating normally.
  • It goes into a down/down state.
  • It becomes the root bridge for the configured VLAN.
  • It goes into an errdisable state.*
Show (Hide) Explanation/Reference
PortFast BPDU guard prevents loops by moving a nontrunking port into an errdisable state when a BPDU is received on that port. When you enable BPDU guard on the switch, spanning tree shuts down PortFast-configured interfaces that receive BPDUs instead of putting them into the spanning tree blocking state.

In a valid configuration, PortFast-configured interfaces do not receive BPDUs (because PortFast should only be configured on interfaces which are connected to hosts). If a PortFast-configured interface receives a BPDU, an invalid configuration exists. BPDU guard provides a secure response to invalid configurations because the administrator must manually put the interface back in service.

Reference: http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4000/8-2glx/configuration/guide/stp_enha.html

42.  What are three characteristics of the TCP protocol? (Choose three.)

  • It uses a single SYN-ACK message to establish a connection.
  • The connection is established before data is transmitted.*
  • It ensures that all data is transmitted and received by the remote device.*
  • It supports significantly higher transmission speeds than UDP.
  • It requires applications to determine when data packets must be retransmitted.
  • It uses separate SYN and ACK messages to establish a connection.*
Show (Hide) Explanation/Reference

Note: Answer F is not correct because TCP does not require applications to determine the retranmission. TCP itself will determine if the data packets should be retransmitted or not.

43.  Which command can you enter to determine whether serial interface 0/2/0 has been configured using HDLC encapsulation?

  • router#show platform
  • router#show interfaces Serial 0/2/0*
  • router#show ip interface s0/2/0
  • router#show ip interface brief
Show (Hide) Explanation/Reference
Output from real device

Router2901#sh int g0/0
GigabitEthernet0/0 is up, line protocol is up
Hardware is CN Gigabit Ethernet, address is c471.fe99.9999 (bia c471.fe99.9999)
Description: Lan
Internet address is 10.1.1.1/25
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1Gbps, media type is RJ45
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of “show interface” counters never
Input queue: 0/75/61/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 39000 bits/sec, 30 packets/sec
5 minute output rate 73000 bits/sec, 37 packets/sec
41068530 packets input, 3905407112 bytes, 0 no buffer
Received 8678853 broadcasts (0 IP multicasts)
0 runts, 0 giants, 45 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 79853 multicast, 0 pause input
39267208 packets output, 2262399504 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
79926 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
Router2901#
Router2901 ip int g0/0
GigabitEthernet0/0 is up, line protocol is up
Internet address is 10.1.1.1/25
Broadcast address is 255.255.255.255
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Secondary address 192.168.1.7/24
Multicast reserved groups joined: 224.0.0.10
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is enabled, interface in domain inside
BGP Policy Mapping is disabled
Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, CAR, MCI Check
Output features: NAT Inside, Common Flow Table, Stateful Inspection, NAT ALG proxy, CAR
Post encapsulation features: CAR
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
Router2901#

44.  Which two statements about IPv4 multicast traffic are true? (Choose two.)

  • It burdens the source host without affecting remote hosts.
  • It uses a minimum amount of network bandwidth.*
  • It is bandwidth-intensive.
  • It simultaneously delivers multiple streams of data.
  • It is the most efficient way to deliver data to multiple receivers.*
Show (Hide) Explanation/Reference
http://www.cisco.com/c/dam/en_us/about/ciscoitatwork/downloads/ciscoitatwork/pdf/cisco_it_case_study_multicast.pdf
Cisco IOS IP Multicast in the Cisco Network
“IP Multicast as defined in RFC1112, the standard for IP Multicast across networks and the Internet, supports one-to-many content needs by delivering application-source traffic to multiple users without burdening the source or the network, using a minimum amount of network bandwidth. At the point where paths diverge, Cisco routers replace IP Multicast packets in the network, resulting in the most efficient delivery of data to multiple receivers.”

Even low-bandwidth applications can benefit fro IP Multicast when there are thousands of receivers. High-bandwidth applications, such as MPEG video, may need a large portion of the available network bandwidth for a
single stream. In these applications, IP Multicast is the only way to efficiently send the same content to more than one
receiver simultaneously, because it makes sure that only one copy of the data stream is sent across any one network
link. It relies on each router in the stream to intelligently copy the data stream whenever it needs to deliver it to
multiple receivers.

45.  What are two benefits of private IPv4 IP addresses? (Choose two.)

  • They are routed the same as public IP addresses.
  • They are less costly than public IP addresses.*
  • They can be assigned to devices without Internet connections.*
  • They eliminate the necessity for NAT policies.
  • They eliminate duplicate IP conflicts.
Show (Hide) Explanation/Reference
Usually using private IPv4 addresses in a organization is free so surely they are less costly than public IP addresses which you have to buy -> B is correct.

Also we can use private IPv4 addresses to devices that do not need to connect to the Internet because Internet requires public IPv4 addresses -> C is correct.

Answer D is not correct as we still need to use NAT policies to limit which private IPv4 addresses in our company can access our resources.

46.  What is the authoritative source for an address lookup?

  • a recursive DNS search*
  • the operating system cache
  • the ISP local cache
  • the browser cache

47.  Which command can you enter to verify that a BGP connection to a remote device is established?

  • show ip bgp summary*
  • show ip community-list
  • show ip bgp paths
  • show ip route
Show (Hide) Explanation/Reference
This command can be used to verify if a BGP connection to a BGP neighbor is good or not. Let’s see an example:

Please pay attention to the “State/PfxRcd” column of the output. It indicates the number of prefixes that have been received from a neighbor. If this value is a number (including “0”, which means BGP neighbor does not advertise any route) then the BGP neighbor relationship is good. If this value is a word (including “Idle”, “Connect”, “Active”, “OpenSent”, “OpenConfirm”) then the BGP neighbor relationship is not good.

In the outputs above we see the BGP neighbor relationship between R1 & 10.1.1.1 is good with 2 Prefix Received (PfxRcd) while the BGP neighbor relationships between R1 & 10.2.2.2; R1 & 10.3.3.3 are not good (they are in “Active” and “Idle” state).

48.  During which phase of PPPoE is PPP authentication performed?

  • the PPP Session phase*
  • Phase 2
  • the Active Discovery phase
  • the Authentication phase
  • Phase 1
Show (Hide) Explanation/Reference
PPPoE provides a standard method of employing the authentication methods of the Point-to-Point Protocol (PPP) over an Ethernet network. When used by ISPs, PPPoE allows authenticated assignment of IP addresses. In this type of implementation, the PPPoE client and server are interconnected by Layer 2 bridging protocols running over a DSL or other broadband connection.

PPPoE is composed of two main phases:
Active Discovery Phase: In this phase, the PPPoE client locates a PPPoE server, called an access concentrator. During this phase, a Session ID is assigned and the PPPoE layer is established.
PPP Session Phase: In this phase, PPP options are negotiated and authentication is performed. Once the link setup is completed, PPPoE functions as a Layer 2 encapsulation method, allowing data to be transferred over the PPP link within PPPoE headers.

Reference: http://www.cisco.com/c/en/us/td/docs/security/asa/asa92/configuration/vpn/asa-vpn-cli/vpn-pppoe.html

49.  Which three circumstances can cause a GRE tunnel to be in an up/down state? (Choose three.)

  • The tunnel interface IP address is misconfigured.
  • The tunnel interface is down.*
  • A valid route to the destination address is missing from the routing table.*
  • The tunnel address is routed through the tunnel itself.*
  • The ISP is blocking the traffic.
  • An ACL is blocking the outbound traffic.

50.  Which two statements about using leased lines for your WAN infrastructure are true? (Choose two.)

  • Leased lines provide inexpensive WAN access.
  • Leased lines with sufficient bandwidth can avoid latency between endpoints.*
  • Leased lines require little installation and maintenance expertise.*
  • Leased lines provide highly flexible bandwidth scaling.
  • Multiple leased lines can share a router interface.
  • Leased lines support up to T1 link speeds.
Show (Hide) Explanation/Reference
The advantages of leased lines include:

+ Simplicity: Point-to-point communication links require minimal expertise to install and maintain.

+ Quality: Point-to-point communication links usually offer high service quality, if they have adequate bandwidth. The dedicated capacity removes latency or jitter between the endpoints.

+ Availability: Constant availability is essential for some applications, such as e-commerce. Point-to-point communication links provide permanent, dedicated capacity, which is required for VoIP or Video over IP.

The disadvantages of leased lines include:

+ Cost: Point-to-point links are generally the most expensive type of WAN access. The cost of leased line solutions can become significant when they are used to connect many sites over increasing distances. In addition, each endpoint requires an interface on the router, which increases equipment costs.

+ Limited flexibility: WAN traffic is often variable, and leased lines have a fixed capacity, so that the bandwidth of the line seldom matches the need exactly (therefore answer D is not correct). Any change to the leased line generally requires a site visit by ISP personnel to adjust capacity.

(Reference: Connecting Networks Companion Guide Book published by Cisco Networking Academy – Page 54)

51.  Which two statements about wireless LAN controllers are true? (Choose two.)

  • They can simplify the management and deployment of wireless LANs.*
  • They rely on external firewalls for WLAN security.
  • They are best suited to smaller wireless networks.
  • They must be configured through a GUI over HTTP or HTTPS.
  • They can manage mobility policies at a systemwide level.*
Show (Hide) Explanation/Reference
Cisco Wireless is designed to provide 802.11 wireless networking solutions for enterprises and service providers. Cisco Wireless simplifies deploying and managing large-scale wireless LANs and enables a unique best-in-class security infrastructure. The operating system manages all data client, communications, and system administration functions, performs radio resource management (RRM) functions, manages system-wide mobility policies using the operating system security solution, and coordinates all security functions using the operating system security framework.

Reference: http://www.cisco.com/c/en/us/td/docs/wireless/controller/8-2/config-guide/b_cg82/b_cg82_chapter_01.html

52.  Which two statements about northbound and southbound APIs are true? (Choose two.)

  • Only southbound APIs allow program control of the network.
  • Only northbound APIs allow program control of the network.*
  • Only southbound API interfaces use a Service Abstraction Layer.*
  • Only northbound API interfaces use a Service Abstraction Layer.
  • Both northbound and southbound API interfaces use a Service Abstraction Layer.
  • Both northbound and southbound APIs allow program control of the network.
Show (Hide) Explanation/Reference
A northbound interface is an interface that allows a particular component of a network to communicate with a higher-level component. Conversely, a southbound interface allows a particular network component to communicate with a lower-level component.

The northbound APIs on an SDN controller enable applications and orchestration systems to program the network and request services from it.

Southbound interfaces are implemented with a Service Abstraction Layer (SAL) which speak to network devices using SNMP and CLI (Command Line Interface) of the elements that make up the network. The main functions of SAL are:
+ Expose device services and capabilities to apps
+ Determine how to fulfill requested service irrespective of the underlying protocol

Note:
+ An API is a method for one application (program) to exchange data with another application.
+ Interface here refers to the “software interface”, not the physical interfaces.

53.  Which command can you enter to set the default route for all traffic to an interface?

  • router(config)#ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1*
  • router(config-router)#default-information originate always
  • router(config)#ip route 0.0.0.0 255.255.255.255 GigabitEthernet0/1
  • route(config-router)#default-information originate

54.  Which statement about RADIUS security is true?

  • It supports EAP authentication for connecting to wireless networks.*
  • It provides encrypted multiprotocol support.
  • Device-administration packets are encrypted in their entirety.
  • It ensures that user activity is fully anonymous.

55.  If you are configuring syslog messages specifying `logging trap warning’, which log messages will the router send?

  • 0-4*
  • 0-5
  • 0-2
  • 0-6
  • 0-1

Show (Hide) Explanation/Reference
0 emergencies System is unusable
1 alerts Immediate action is needed
2 critical Critical conditions exist
3 errors Error conditions exist
4 warnings Warning conditions exist
5 notification Normal, but significant, conditions exist
6 informational Informational messages
7 debugging Debugging messages

56.  What is true about Ethernet? (Choose Two.)

  • 802.2 Protocol
  • 802.3 Protocol*
  • 10BaseT half duplex
  • CSMA/CD Stops transmitting when congestion occurs*
  • CSMA/CA Stops transmitting when congestion occurs
Show (Hide) Explanation/Reference
Carrier sense multiple access with collision detection (CSMA/CD) is a media access control method used most notably in early Ethernet (IEEE 802.3) technology for local area networking. When collision detection (CD) observes a collision (excess current above what it is generating, i.e. > 24 mA for coaxial Ethernet), it stops transmission immediately and instead transmits a 32-bit jam sequence.

Note: CSMA/CA (Carrier Sense Multiple Access/Collision Avoidance) is a protocol for carrier transmission used in wireless networks. Unlike CSMA/CD (Carrier Sense Multiple Access/Collision Detect) which deals with transmissions after a collision has occurred, CSMA/CA acts to prevent collisions before they happen.

57.  What IP SLA ICMP Echo measures?

  • A. Packet loss
  • B. Congestion
  • C. Hop-by-hop “something”
  • D. End-to-end response time*
  • E. ?
Show (Hide) Explanation/Reference
The Internet Control Message Protocol (ICMP) Echo operation measures the end-to-end response time between two devices that use IPv4. The response time is computed by measuring the time taken between sending an ICMP Echo request message to the destination and receiving an ICMP Echo reply.

An IP SLA can be used to performs network performance monitoring, including measure the latency, packet loss, jitter and response time in the network. The example below shows how to configure an IP SLA ICMP Echo (send an ICMP request to 192.168.1.254 every 300 second with a timeout of 500ms):

Device(config)#ip sla 1

Device(config-ip-sla)#icmp-echo 192.168.1.254
Device(config-ip-sla-echo)#frequency 300 //send an ICMP
Device(config-ip-sla-echo)#timeout 500
Device(config-ip-sla-echo)#exit
Device(config)#ip sla schedule 1 start-time now

58.  What are types of IPv6 static routes? (Choose Three )

  • Recursive routes*
  • Directly connected routes*
  • Fully specified routes*
  • Advertised routes
  • Virtual links
  • Redistributed routes
Show (Hide) Explanation/Reference
Directly connected routes: In directly attached static routes, only the output interface is specified. The destination is assumed to be directly attached to this interface, so the packet destination is used as the next-hop address. This example shows such a definition:

ipv6 route 2001:DB8::/32 gigabitethernet1/0/0

The example specifies that all destinations with address prefix 2001:DB8::/32 are directly reachable through interface GigabitEthernet1/0/0.

Recursive Static Routes: In a recursive static route, only the next hop is specified. The output interface is derived from the next hop. This example shows such a definition:

ipv6 route 2001:DB8::/32 2001:DB8:3000:1

This example specifies that all destinations with address prefix 2001:DB8::/32 are reachable via the host with address 2001:DB8:3000:1.

Fully Specified Static Routes: In a fully specified static route, both the output interface and the next hop are specified. This form of static route is used when the output interface is a multi-access one and it is necessary to explicitly identify the next hop. The next hop must be directly attached to the specified output interface. The following example shows a definition of a fully specified static route:

ipv6 route 2001:DB8:/32 gigabitethernet1/0/0 2001:DB8:3000:1

A fully specified route is valid (that is, a candidate for insertion into the IPv6 routing table) when the specified IPv6 interface is IPv6-enabled and up.

Besides three of the static IPv routes, there is one more type of IPv6 static route, that is Floating Static Routes (static route with a higher administrative distance than the dynamic routing protocol it is backing up)

For more information about these IPv6 routes, please read: http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipv6/configuration/xe-3s/ipv6-xe-36s-book/ip6-stat-routes.html

59.  What is the status of port-channel if LACP is misconfigured?

  • Forwarding
  • Enabled
  • Disabled*
  • Errdisabled
Show (Hide) Explanation/Reference
EtherChannel misconfiguration occurs when the channel parameters do not match on both sides of the EtherChannel, resulting in the following message:

%PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po3, putting E1/3 in err-disable state

Therefore from the output above we can see that when miconfigured, the physical (member) interface is put into err-disable state.

But this question asks above “the status of port-channel” (not the physical member interface) so answer “Disabled” is a better choice.

60.  What is true about DTP? (Choose Three.)

  • Layer 2 protocol*
  • Layer 3 protocol
  • Proprietary protocol*
  • enabled by default*
  • disabled by default
Show (Hide) Explanation/Reference
The Dynamic Trunking Protocol (DTP) is a proprietary networking protocol developed by Cisco Systems for the purpose of negotiating trunking on a link between two VLAN-aware switches, and for negotiating the type of trunking encapsulation to be used. It is a Layer 2 protocol and it is enabled by default on Cisco switches (so the interfaces of your switches will be in “dynamic auto” or “dynamic desirable” mode). If you want to turn it off, use the “switchport nonegotiate” under interface mode.

61.  How to create a trunk port and allow VLAN 20? (Choose Three.)

  • switchport trunk encapsulation dot1q*
  • switchport mode trunk*
  • switchport trunk allowed vlan 20*
  • switchport trunk native vlan 20
  • switchport mode dynamic desirable
Show (Hide) Explanation/Reference
In switches that support both InterSwitch Link (ISL) and 802.1Q trunking encapsulations, we need to specify an trunking protocol so we must use the command “switchport trunk encapsulation dot1q” command first to set the trunk mode to 802.1Q. Then we configure trunking interface with the “switchport mode trunk” command. Then we explicitly allow vlan 20 with the command “switchport trunk allowed vlan 20” command. By default all VLANs are allowed to pass but after entering this command, only VLAN 20 is allowed.

62.  What 8-bit field exists in IP packet for QoS?

  • Tos Field*
  • DSCP
  • IP Precedence
  • Cos
  • -ANOTHER OPTION-
Show (Hide) Explanation/Reference
The IP datagram header contains an 8-bit field called ToS (Type of Service). The field has been part of the IP header since the beginning, but it was rarely used until the recent introduction of Differentiated Services (Diff-Serv).

Note:
+ CoS does not exists in an IP header. It appears in the header of a 802.1Q frame only. CoS is used for QoS on a trunk link.
+ DSCP uses the first 6 bits of the TOS field.

63.  What feature uses a random time to re-sent a frame?

  • CSMA/CA
  • -ANOTHER OPTION-
  • -ANOTHER OPTION-
  • CSMA/CD*

64.  Which mode is compatible with Trunk, Access, and desirable ports?

  • Trunk Ports
  • Access Ports
  • Dynamic Auto*
  • Dynamic Desirable

Show (Hide) Explanation/Reference
Explanation from http://www.9tut.com/trunking-questions
Maybe this question wanted to ask “if the other end is configured with trunk/access/desirable mode” then which mode is compatible so that the link can work. In that case both “dynamic auto” and “dynamic desirable” mode are correct. The difference between these two modes is “dynamic auto” is passively waiting for the other end to request to form a trunk while “dynamic desirable” will actively attempt to negotiate to convert the link into a trunk.

65.  If you configure syslog messages without specifying the logging trap level, which log messages will the router send?

  • 0-4
  • 0-5
  • 0-2
  • 0-6*
  • 0-1

Show (Hide) Explanation/Reference
Router(config)# logging trap level – Specifies the kind of messages, by severity level, to be sent to the syslog server. The default is informational (6) and lower ( 0 ­ 6). The possible values for level are as follows:
Emergency: 0
Alert: 1
Critical: 2
Error: 3
Warning: 4
Notice: 5
Informational: 6
Debug: 7

66.  Which command can you execute to set the user inactivity timer to 10 seconds?

  • SW1(config-line)#exec-timeout 0 10*
  • SW1(config-line)#exec-timeout 10
  • SW1(config-line)#absolute-timeout 0 10
  • SW1(config-line)#absolute-timeout 10
Show (Hide) Explanation/Reference
The “exec-timeout” command is used to configure the inactive session timeout on the console port or the virtual terminal. The syntax of this command is:

exec-timeout minutes [seconds]

Therefore we need to use the “exec-timeout 0 10” command to set the user inactivity timer to 10 seconds.

67.  Which standards-based First Hop Redundancy Protocol is a Cisco supported alternative to Hot Standby Router Protocol?

  • VRRP*
  • GLBP
  • TFTP
  • DHCP
Show (Hide) Explanation/Reference
Virtual Router Redundancy Protocol (VRRP) is one of the First Hop Redundancy Protocols that is supported by Cisco. Unlike HSRP and GLBP (which are Cisco proprietary protocols), VRRP is an industry standard protocol.

68.  Two hosts are attached to a switch with the default configuration. Which statement about the configuration is true?

  • IP routing must be enabled to allow the two hosts to communicate.
  • The two hosts are in the same broadcast domain.*
  • The switch must be configured with a VLAN to allow the two hosts to communicate.
  • Port security prevents the hosts from connecting to the switch.
Show (Hide) Explanation/Reference
All ports on a Layer 2 switch are in the same broadcast domain. Only router ports separate broadcast domains.

69.  If there are 3 hosts connected in one port of a switch and two other hosts connected in another port, how many collision domains are present on the router?

  • 5
  • 2*
  • 3
  • 4
Show (Hide) Explanation/Reference
Each port of a switch is a separate collision domain. This switch uses two ports (for 5 hosts) so there are two collision domains in total.

70.  What are three parts of an IPv6 global unicast address? (Choose three.)

  • an interface ID that is used to identify the local host on the network.*
  • an interface ID that is used to identify the local network for a particular host.
  • a subnet ID that is used to identify networks inside of the local enterprise site*
  • a global routing prefix that is used to identify the network portion of the address that has been provided by an ISP*
  • a global routing prefix that is used to identify the portion of the network address provided by a local administrator
Show (Hide) Explanation/Reference
IPv6 includes two different unicast address assignments:

+ Global unicast address
+ Link-local address

The global unicast address is globally unique in the Internet. The example IPv6 address that is shown below is a global unicast address.

Site prefix (global routing prefix): defines the public topology of your network to a router. You obtain the site prefix for your enterprise from an ISP or Regional Internet Registry (RIR).
Site Topology and Subnet ID: the subnet ID defines an administrative subnet of the network and is up to 16 bits in length. You assign a subnet ID as part of IPv6 network configuration. The subnet prefix defines the site topology to a router by specifying the specific link to which the subnet has been assigned
Interface ID: identifies an interface of a particular node. An interface ID must be unique within the subnet.

Reference: https://docs.oracle.com/cd/E23823_01/html/816-4554/ipv6-overview-10.html

Download PDF File below:


Related Articles

4
Leave a Reply

avatar
Photo and Image Files
 
 
 
Audio and Video Files
 
 
 
Other File Types
 
 
 
3 Comment threads
1 Thread replies
0 Followers
 
Most reacted comment
Hottest comment thread
1 Comment authors
mulumbwa Recent comment authors
newest oldest
mulumbwa
Guest
mulumbwa

hi guy’s!!!! i’m here to tell you that you are doing great job.
have you already update for 2019 ccna routing and switchin certfication exam?
we need

mulumbwa
Guest
mulumbwa

hi guys !!!! is there an other to download the pdf dumps for ccna routing and switching ?

mulumbwa
Guest
mulumbwa

many thanks for these pdf. i’m kindly asking if you can provide for us a downloaded pdf please

mulumbwa
Guest
mulumbwa

many thanks for these pdf. i’m kindly asking if you can provide for us a downloaded PDF for all parties please

Send this to a friend