Lab 2.5.3 – Troubleshooting PPP Configuration (Answers)

Lab 2.5.3 – Troubleshooting PPP Configuration (Answers)

Topology Diagram

Lab 2.5.3 - Troubleshooting PPP Configuration (Answers) 2

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
R1 Fa0/1 10.0.0.1 255.255.255.128 N/A
S0/0/0 172.16.0.1 255.255.255.252 N/A
S0/0/1 172.16.0.9 255.255.255.252 N/A
R2 Lo0 209.165.200.161 255.255.255.224 N/A
S0/0/0 172.16.0.2 255.255.255.252 N/A
S0/0/1 172.16.0.5 255.255.255.252 N/A
R3 Fa0/1 10.0.0.129 255.255.255.128 N/A
S0/0/0 172.16.0.10 255.255.255.252 N/A
S0/0/1 172.16.0.6 255.255.255.252 N/A
PC1 NIC 10.0.0.10 255.255.255.128 10.0.0.1
PC3 NIC 10.0.0.139 255.255.255.128 10.0.0.129

Learning Objectives

To complete this lab:

  • Cable a network according to the topology diagram
  • Erase the startup configuration and reload a router to the default state
  • Load routers with scripts
  • Find and correct network errors
  • Document the corrected network

Scenario

The routers at your company were configured by an inexperienced network engineer. Several errors in the configuration have resulted in connectivity issues. Your boss has asked you to troubleshoot and correct the configuration errors and document your work. Using your knowledge of PPP and standard testing methods, find and correct the errors. Make sure that all of the serial links use PPP CHAP authentication, and that all of the networks are reachable.

Task 1: Load Routers with the Supplied Scripts

[Instructor Note: Missing or misconfigured commands are shown in red.]

R1

enable
configure terminal
!
hostname R1
!
!
enable secret class
!
!
!
no ip domain lookup
!
username R2 password 0 cisco
username R3 password 0 cisco
!This command was left out
!
!
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.128
 !A common error in configuring networks is to place the correct
configuration in the wrong place. In this case, a close examination of the
diagram reveals that FastEthernet0/1 is supposed to have this IP address.
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.1 255.255.255.128
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 172.16.0.1 255.255.255.248
 !incorrect subnet mask. The correct subnet mask is 255.255.255.252
 no fair-queue
 clockrate 64000
!
interface Serial0/0/1
 ip address 172.16.0.9 255.255.255.252
 encapsulation ppp
 ppp authentication pap
 ppp authentication chap
!PPP PAP authentication was mistakenly configured rather than CHAP
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.127 area 0
 network 172.16.0.4 0.0.0.3 area 0
 network 172.16.0.8 0.0.0.3 area 0
 network 172.16.0.0 0.0.0.3 area 0
!An incorrect subnet was being announced in OSPF
!
ip classless
!
ip http server
!
!
control-plane
!
banner motd ^CUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
line aux 0
line vty 0 4
 password cisco
 login
!
end

R2

enable
configure terminal
!
hostname R2
!
!
enable secret class
!
!
no ip domain lookup
!
username R11 password 0 cisco
!R1 was typed as R11. This is a common mistake in configuration.
username R1 password 0 cisco
username R3 password 0 class
!
!
!
interface Loopback0
 no ip address
 ip address 209.165.200.161 255.255.255.224
!The correct IP address was placed on the wrong interface (FastEthernet0/1)
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
 ip address 209.165.200.161 255.255.255.224
 ip address 10.0.0.1 255.255.255.128
!A close examination of the topology diagram reveals that the correct IP
address was placed on the wrong interface. This IP address belongs on
interface Loopback0
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 172.16.0.2 255.255.255.252
encapsulation ppp
no fair-queue
ppp authentication chap
!
interface Serial0/0/1
ip address 172.16.0.5 255.255.255.252
!The default serial encapsulation of HDLC was left in place. The following
commands were omitted:
encapsulation ppp
clockrate 64000
ppp authentication chap
!
router ospf 1
log-adjacency-changes
network 172.16.0.0 0.0.0.3 area 0
network 172.16.0.4 0.0.0.3 area 0
network 209.165.200.128 0.0.0.31 area 0
network 209.165.200.160 0.0.0.31 area 0
!The incorrect subnet was announced in OSPF for the 209 network
ip classless
!
ip http server
!
!
control-plane
!
banner motd ^CUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
!
end

R3

enable
configure terminal
!
hostname R3
!
!
enable secret class
!
!
no ip domain lookup
!
username R1 password 0 cisco
username R3 password 0 ciscco
username R3 password 0 cisco
!Another typo. This time the password is breaking this configuration.
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.129 255.255.255.0
ip address 10.0.0.129 255.255.255.128
!Because so many labs use the /24 subnet, it is easy to get in the habit of
typing this subnet without checking the diagram and without thinking.
duplex auto
speed auto
!
interface Serial0/0/0
 ip address 172.16.0.10 255.255.255.252
no fair-queue
clockrate 64000
!Both PPP and CHAP have NOT been configured on this interface. The following
commands are missing:
encapsulation ppp
ppp authentication chap
!
interface Serial0/0/1
no ip address
ip address 172.16.0.6 255.255.255.252
encapsulation ppp
ppp authentication pap
ppp authentication chap
!
router ospf 1
log-adjacency-changes
network 10.0.0.128 0.0.0.127 area 0
network 192.16.0.4 0.0.0.3 area 0
network 172.16.0.4 0.0.0.3 area 0
network 192.16.0.8 0.0.0.3 area 0
network 172.16.0.8 0.0.0.3 area 0
!
ip classless
!
ip http server
!
!
control-plane
!
banner motd ^CUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
!
end

Task 2: Find and Correct Network Errors

Using standard troubleshooting methods, find, document, and correct each error.

Note: If I were troubleshooting a production network and the configuration task was to configure PPP CHAP, and if it was not working, the first item I would check is the PPP CHAP configuration. However, in the broken network configurations in this lab, that would only get you part of the way toward restoring the network. I frequently encounter very advanced network engineers who focus only on the main configuration task while troubleshooting without checking the basics. Are the network addresses correctly typed? Are the subnets correctly typed? Is basic routing working? If focusing on the main troubleshooting task solves the problem, great. If not, you should go back to basics. This is a sound troubleshooting methodology.

Task 3: Document the Corrected Network

Now that you have corrected all errors and tested connectivity throughout the network, document the final configuration for each device.

R1

R1#show run
!<output omitted>
!
hostname R1
!
!
enable secret class
!
!
no ip domain lookup
!
username R3 password 0 cisco
username R2 password 0 cisco
!
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.128
no shutdown
!
interface Serial0/0/0
ip address 172.16.0.1 255.255.255.252
encapsulation ppp
clockrate 64000
ppp authentication chap
no shutdown
!
interface Serial0/0/1
ip address 172.16.0.9 255.255.255.252
encapsulation ppp
ppp authentication chap
no shutdown
!
!
router ospf 1
network 10.0.0.0 0.0.0.127 area 0
network 172.16.0.0 0.0.0.3 area 0
network 172.16.0.8 0.0.0.3 area 0
!
!
banner motd ^CUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
!
end

R2

R2#show run
!<output omitted>
!
hostname R2
!
!
enable secret class
!
!
no ip domain lookup
!
username R1 password 0 cisco
username R3 password 0 cisco
!
!
!
interface Loopback0
ip address 209.165.200.161 255.255.255.224
!
!
interface Serial0/0/0
ip address 172.16.0.2 255.255.255.252
encapsulation ppp
ppp authentication chap
no shutdown
!
interface Serial0/0/1
ip address 172.16.0.5 255.255.255.252
encapsulation ppp
clockrate 64000
ppp authentication chap
no shutdown
!
!
router ospf 1
network 172.16.0.0 0.0.0.3 area 0
network 172.16.0.4 0.0.0.3 area 0
network 209.165.200.160 0.0.0.31 area 0
!
!
banner motd ^CUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
 login
line aux 0
line vty 0 4
password cisco
login
!
end

R3

R3#show run
!<output omitted>
!
hostname R3
!
!
enable secret class
!
!
no ip domain lookup
!
username R1 password 0 cisco
username R2 password 0 cisco
!
!
interface FastEthernet0/1
ip address 10.0.0.129 255.255.255.128
no shutdown
!
interface Serial0/0/0
ip address 172.16.0.10 255.255.255.252
encapsulation ppp
clockrate 64000
ppp authentication chap
no shutdown
!
interface Serial0/0/1
ip address 172.16.0.6 255.255.255.252
encapsulation ppp
ppp authentication chap
no shutdown
!
router ospf 1
network 10.0.0.128 0.0.0.127 area 0
network 172.16.0.4 0.0.0.3 area 0
network 172.16.0.8 0.0.0.3 area 0
!
!
banner motd ^CUnauthorized access strictly prohibited and prosecuted to the
full extent of the law^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
!
end

Task 4: Clean Up

Erase the configurations and reload the routers. Disconnect and store the cabling. For PC hosts that are normally connected to other networks, such as the school LAN or the Internet, reconnect the appropriate cabling and restore the TCP/IP settings.

 

 

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x