6.3.4 Packet Tracer – Troubleshoot EtherChannel (Instructions Answer)

6.3.4 Packet Tracer – Troubleshoot EtherChannel (Instructor Version)

6.3.4 Packet Tracer – Troubleshoot EtherChannel (Instructions Answer) 1

Objectives

  • Part 1: Examine the Physical Layer and Correct Switch Port Mode Issues
  • Part 2: Identify and Correct Port Channel Assignment Issues
  • Part 3: Identify and Correct Port Channel Protocol Issues

Background

A junior technician recently configured four switches. Users are complaining that the network is running slowly, and they would like you to investigate.

Port Channel Table

Channel Group Ports Protocol
1 S1: G0/1, G0/2
S2: G0/1, G0/2
LACP active
2 S2: G0/1, G0/2
S4: G0/1, G0/2
LACP active
3 S1: F0/23, F0/24
S2: F0/23, F0/24
LACP active
4 S3: F0/23, F0/24
S4: F0/23, F0/24
LACP active
5 S1: F0/21, F0/22
S4: F0/21, F0/22
LACP active
6 S2: F0/21, F0/22
S3: F0/21, F0/22
LACP active

Device Table

Device Group Ports
S1 1 G0/1, G0/2
3 F0/23, F0/24
5 F0/21, F0/22
S2 2 G0/1, G0/2
3 F0/23, F0/24
6 F0/21, F0/22
S3 1 G0/1, G0/2
4 F0/23, F0/24
6 F0/21, F0/22
S4 2 G0/1, G0/2
4 F0/23, F0/24
5 F0/21, F0/22

Instructions

Part 1: Examine the Physical Layer and Correct Switch Port Mode Issues

Step 1: Look for access ports.

Examine the switches. When two or more redundant links connect the same switches, Spanning Tree protocol will only put one port in forwarding mode to prevent switching loops. You can see this in Packet Tracer. When physical ports are assigned to an EtherChannel port, they behave as one logical port. Each pair will either be operational or down.

Step 2: Verify ports are in trunk mode.

On S2, the port channel interfaces and physical interfaces that have been configured in the port channels are all configured as access ports. The physical interfaces should be configured as trunks. The port channel interfaces should also be configured as trunks.

S2#show running-config 
.
.
!
interface FastEthernet0/21
 switchport mode access
 channel-group 6 mode active
!
interface FastEthernet0/22
 switchport mode access
 channel-group 6 mode active
!
interface FastEthernet0/23
 switchport mode access
 channel-group 3 mode active
!
interface FastEthernet0/24
 switchport mode access
 channel-group 3 mode active
!
interface GigabitEthernet0/1
 switchport mode access
 channel-group 2 mode active
!
interface GigabitEthernet0/2
 switchport mode access
 channel-group 2 mode active

!
!
end

a. Verify that all physical ports in the topology are configured as trunks. Correct any ports that are in access mode.

S2(config)#interface range f0/21-24, g0/1-2
S2(config-if-range)#switchport mode trunk

b. Correct any EtherChannel ports that are not configured as trunks.

Instructor Note: Packet Tracer versions 7.2.1 and earlier do not grade the switchport mode trunk command on port-channel interfaces.

S1(config)#interface port-channel 1
S1(config-if)#switchport mode trunk
S2(config)#interface port-channel 2
S2(config-if)#switchport mode trunk
S2(config-if)#interface port-channel 3
S2(config-if)#switchport mode trunk
S2(config-if)#interface port-channel 6
S2(config-if)#switchport mode trunk

Part 2: Identify and Correct Port Channel Assignment Issues

Port channel interface assignment can be confusing. It is a possible that errors can occur when assigning physical ports to port channels. In this case, ports F0/21 and F0/22 on S4 have been assigned to port channel group 4. They should be reassigned to port channel group 5.

Step 1: Examine port channel assignments.

The Packet Tracer topology and the Port Channel and Device tables provide details about the physical ports and their EtherChannel assignments. Use the show etherchannel summary command to learn how the EtherChannel links are configured. Verify that the switches are configured as shown in the documentation.

S1#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 3
Number of aggregators:           3

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------

1      Po1(SD)           LACP   Gig0/1(I) Gig0/2(I) 
3      Po3(SU)           LACP   Fa0/23(P) Fa0/24(P) 
5      Po5(SU)           LACP   Fa0/21(P) Fa0/22(P)

S2#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 3
Number of aggregators:           3

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------

2      Po2(SU)           LACP   Gig0/1(P) Gig0/2(P) 
3      Po3(SU)           LACP   Fa0/23(P) Fa0/24(P) 
6      Po6(SD)           LACP   Fa0/21(I) Fa0/22(I)

S3#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

Number of channel-groups in use: 3
Number of aggregators: 3

Group Port-channel Protocol Ports
------+-------------+-----------+----------------------------------------------

1 Po1(SD) PAgP Gig0/1(I) Gig0/2(I)
4 Po4(SD) PAgP Fa0/23(I) Fa0/24(I)
6 Po6(SD) PAgP Fa0/21(I) Fa0/22(I) 

S4#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

Number of channel-groups in use: 3
Number of aggregators: 3

Group Port-channel Protocol Ports
------+-------------+-----------+----------------------------------------------

2 Po2(SU) LACP Gig0/1(P) Gig0/2(P)
4 Po4(SU) LACP Fa0/21(P) Fa0/22(P) Fa0/23(I) Fa0/24(I)
5 Po5(SD) -

Step 2: Correct port channel assignments.

Correct any switch ports that are not assigned to the correct EtherChannel port.

S4(config)#interface range f0/21-22
S4(config-if-range)#channel-group 5 mode active

Part 3: Identify and Correct Port Channel Protocol Issues

The Network Design Team has made it a requirement that all EtherChannel links actively negotiate LACP. The physical ports on switch S3 have been configured to unconditionally establish PAgP, not LACP, EtherChannels. This must be corrected on S3 in order that the EtherChannels can be established.

Step 1: Identify protocol issues.

In 2000, the IEEE released 802.3ad (LACP), which is an open standard version of EtherChannel. For compatibility reasons, the network design team chose to use LACP across the network. The design team has made it a requirement that all ports that participate in EtherChannel need to actively negotiate the link as LACP. Verify that the physical ports are configured as indicated in the topology and Port Channel Table.

S3#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 3
Number of aggregators:           3

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------

1      Po1(SD)           PAgP   Gig0/1(I) Gig0/2(I) 
4      Po4(SD)           PAgP   Fa0/23(I) Fa0/24(I) 
6      Po6(SD)           PAgP   Fa0/21(I) Fa0/22(I)
Step 2: Correct Protocol issues.

a. Correct any switch ports that are not negotiating using LACP.

S3(config)# interface range g0/1-2
S3(config-if-range)# no channel-group
S3(config-if-range)# channel-group 1 mode active
S3(config-if-range)# interface range f0/21-22
S3(config-if-range)# no channel-group
S3(config-if-range)# channel-group 6 mode active
S3(config-if-range)# interface range f0/23-24
S3(config-if-range)# no channel-group
S3(config-if-range)# channel-group 4 mode active

b. Reissue the show etherchannel summary command to verify that all EtherChannel links are now correctly configured.

S3#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 3
Number of aggregators:           3

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------

1      Po1(SU)           PAgP   Gig0/1(P) Gig0/2(P) 
4      Po4(SU)           PAgP   Fa0/23(P) Fa0/24(P) 
6      Po6(SU)           PAgP   Fa0/21(P) Fa0/22(P)

Answer scripts

Switch S1

enable
conf t
interface port-channel 1
 switchport mode trunk

Switch S2

enable
conf t
interface range f0/21-24, g0/1-2
switchport mode trunk
interface port-channel 2
switchport mode trunk
interface port-channel 3
switchport mode trunk
interface Port-channel 6
switchport mode trunk

Switch S3

enable
conf t
interface range g0/1 - 2
no channel-group
channel-group 1 mode active
interface range f0/21 - 22
no channel-group
channel-group 6 mode active
interface range f0/23 - 24
no channel-group
channel-group 4 mode active

Switch S4

enable
conf t
interface range f0/21 - 22
channel-group 5 mode active

Download PDF & PKA file:



Related Articles

guest
0 Comments
Inline Feedbacks
View all comments