16.3.2 Lab – Troubleshoot IPv4 and IPv6 Static and Default Routes (Answers)

Lab – Troubleshoot IPv4 and IPv6 Static and Default Routers (Instructor Version)

Topology

16.3.2 Lab - Troubleshoot IPv4 and IPv6 Static and Default Routes (Answers) 2

Addressing Table

Device Interface IP Address / Prefix
R1 G0/0/0 192.168.0.1 /28
2001:db8:acad::1 /64
G0/0/1 192.168.0.17 /28
2001:db8:acad:16::1 /64
Loopback1 172.16.1.1 /24
2001:db8:acad:171::1 /64
Loopback2 209.165.200.1 /25
2001:db8:acad:209::1 /64
R2 G0/0/0 192.168.0.14 /28
2001:db8:acad::14 /64
G0/0/1 192.168.0.30 /28
2001:db8:acad:16::2 /64
Loopback1 172.16.2.1 /24
2001:db8:acad:172::1 /64
Loopback2 209.165.200.129 /25
2001:db8:acad:210::1 /64

Objectives

  • Part 1: Evaluate Network Operation
  • Part 2: Gather information, create an action plan, and implement corrections

Background / Scenario

Instructor Note: Preconfiguration scripts for all the devices are located below. Cut and paste or otherwise use these to pre-configure the equipment for the student.

Router R1

enable
config terminal
hostname R1
ipv6 unicast-routing
interface g0/0/1
 ip address 192.168.0.17 255.255.255.240
 ipv6 address fe80::1 link-local
 ipv6 address 2001:db8:acad:16::1/64
 no shutdown
interface g0/0/0
 ip address 192.168.0.1 255.255.255.240
 ipv6 address fe80::1 link-local
 ipv6 address 2001:db8:acad::1/64
 no shutdown
interface loopback 1
 ip address 172.16.1.1 255.255.255.0
 ipv6 address fe80::1 link-local
 ipv6 address 2001:db8:acad:171::1/64
interface loopback 2
 ip address 209.165.200.1 255.255.255.128
 ipv6 address fe80::1 link-local
 ipv6 address 2001:db8:acad:209::1/64
!ip route 209.165.200.128 255.255.255.128 192.168.0.30
ip route 209.165.200.128 255.255.255.128 192.168.0.3
ip route 0.0.0.0 0.0.0.0 192.168.0.14 80
!ip route 0.0.0.0 0.0.0.0 192.168.0.14
!ip route 0.0.0.0 0.0.0.0 192.168.0.30 80
ip route 0.0.0.0 0.0.0.0 192.168.0.3
ipv6 route ::/0 2001:db8:acad:16::2

Router R2

enable
config terminal
hostname R2
no ip domain lookup
ipv6 unicast-routing
interface g0/0/0
 ip address 192.168.0.14 255.255.255.240
 ipv6 address fe80::2 link-local
 ipv6 address 2001:db8:acad::14/64
 no shutdown
interface g0/0/1
 ip address 192.168.0.30 255.255.255.240
 ipv6 address fe80::2 link-local
 ipv6 address 2001:db8:acad:16::2/64
 no shutdown
interface loopback 1
 ip address 172.16.2.1 255.255.255.0
 ipv6 address fe80::2 link-local
 ipv6 address 2001:db8:acad:172::1/64
interface loopback 2
 ip address 209.165.200.129 255.255.255.128
 ipv6 address fe80::2 link-local
 ipv6 address 2001:db8:acad:210::1/64
! ipv6 route 2001:db8:acad:209::/64 2001:db8:acad:16::1
ipv6 route 2001:db8:acad:209::/64 2001:db7:acad:16::1
! ipv6 route ::/0 2001:db8:acad::1
ipv6 route ::/0 2001:db8:acad::1 90
! ipv6 route ::/0 2001:db8:acad:16::1 80
ipv6 route ::/0 2001:db8:acad:15::1
ip route 0.0.0.0 0.0.0.0 192.168.0.17
end

Switch S1

enable
config terminal
hostname S1
interface range f0/1-3, f0/6-24, g0/1-2
 shutdown
end

Switch S2

enable
config terminal
hostname S2
interface range f0/1-3, f0/6-24, g0/1-2
 shutdown
end

Your instructor has preconfigured all the network equipment and has included intentional errors that are keeping the configured routes from working. Your task is to evaluate the network, identify, and correct the configuration errors to restore full connectivity. You may find errors with the route statements or with other configurations that impact the accuracy of the route statements.

Note: The static routing approach used in this lab is used to assess your ability to configure different types of static routes only. This approach may not reflect networking best practices.

Note: The routers used with CCNA hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). The switches used in the labs are Cisco Catalyst 2960s with Cisco IOS Release 15.2(2) (lanbasek9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of the lab for the correct interface identifiers.

Note: Ensure that the routers and switches have been erased and have no startup configurations. If you are unsure contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 2 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 2 Switches (Cisco 2960 with Cisco IOS Release 15.2(2) lanbasek9 image or comparable)
  • 1 PC (Windows with a terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Instructions

Part 1: Evaluate Network Operation.

Use Ping and/or Traceroute from the router console to test the following criteria and record the results.

a. Traffic from R1 to R2’s 172.16.2.1 address use the next hop 192.168.0.14.

b. Traffic from R1 to R2’s 209.165.200.129 address use the next hop 192.168.0.30.

c. When R1’s G0/0/0 interface is shut down, traffic from R1 to R2’s 172.16.2.1 use the next hop 192.168.0.30.

d. Traffic from R2 to R1’s 2001:db8:acad:171::1 address use the next hop 2001:db8:acad::1.

e. Traffic from R2 to R1’s 2001:db8:acad:209::1 address use the next hop 2001:db8:acad:16::1.

f. When R2’s G0/0/0 interface is shut down, traffic from R2 to R1’s 2001:db8:acad:171::1 use the next hop 2001:db8:acad:16::1.

Part 2: Gather information, create an action plan, and implement corrections.

a. For each criterion that is not met, gather information by examining the running configuration and routing tables and develop a hypothesis for what is causing the malfunction.

b. Create an action plan that you think will fix the issue. Develop a list of all the commands you intend to issue to fix the issue, and a list of all the commands you need to revert the configuration, should your action plan fail to correct the issue.

c. Execute your action plans one at a time for each criterion that fails and record the fix actions.

Routing problems on both routers:

1. Wrong IP for next hop

2. AD set high versus default

3. Default AD used and wrong next hop IP

Router R1

no ip route 209.165.200.128 255.255.255.128 192.168.0.3
ip route 209.165.200.128 255.255.255.128 192.168.0.30
no ip route 0.0.0.0 0.0.0.0 192.168.0.14 80
ip route 0.0.0.0 0.0.0.0 192.168.0.14
no ip route 0.0.0.0 0.0.0.0 192.168.0.3
ip route 0.0.0.0 0.0.0.0 192.168.0.30 80

Router R2

no ipv6 route 2001:db8:acad:209::/64 2001:db7:acad:16::1
ipv6 route 2001:db8:acad:209::/64 2001:db8:acad:16::1
no ipv6 route ::/0 2001:db8:acad::1 90
ipv6 route ::/0 2001:db8:acad::1
no ipv6 route ::/0 2001:db8:acad:15::1
ipv6 route ::/0 2001:db8:acad:16::1 80

Router Interface Summary Table

Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
4221 Gigabit Ethernet 0/0/0 (G0/0/0) Gigabit Ethernet 0/0/1 (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
4300 Gigabit Ethernet 0/0/0 (G0/0/0) Gigabit Ethernet 0/0/1 (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Final Configuration

Router R1

enable
config terminal
hostname R1
ipv6 unicast-routing
interface g0/0/1
 ip address 192.168.0.17 255.255.255.240
 ipv6 address fe80::1 link-local
 ipv6 address 2001:db8:acad:16::1/64
 no shutdown
interface g0/0/0
 ip address 192.168.0.1 255.255.255.240
 ipv6 address fe80::1 link-local
 ipv6 address 2001:db8:acad::1/64
 no shutdown
interface loopback 1
 ip address 172.16.1.1 255.255.255.0
 ipv6 address fe80::1 link-local
 ipv6 address 2001:db8:acad:171::1/64
interface loopback 2
 ip address 209.165.200.1 255.255.255.128
 ipv6 address fe80::1 link-local
 ipv6 address 2001:db8:acad:209::1/64
ip route 209.165.200.128 255.255.255.128 192.168.0.30 
ip route 0.0.0.0 0.0.0.0 192.168.0.14 
ip route 0.0.0.0 0.0.0.0 192.168.0.30 80 
ipv6 route ::/0 2001:db8:acad:16::2

Router R2

enable
config terminal
hostname R2
no ip domain lookup
ipv6 unicast-routing
interface g0/0/0
 ip address 192.168.0.14 255.255.255.240
 ipv6 address fe80::2 link-local
 ipv6 address 2001:db8:acad::14/64
 no shutdown
interface g0/0/1
 ip address 192.168.0.30 255.255.255.240
 ipv6 address fe80::2 link-local
 ipv6 address 2001:db8:acad:16::2/64
 no shutdown
interface loopback 1
 ip address 172.16.2.1 255.255.255.0
 ipv6 address fe80::2 link-local
 ipv6 address 2001:db8:acad:172::1/64
interface loopback 2
 ip address 209.165.200.129 255.255.255.128
 ipv6 address fe80::2 link-local
 ipv6 address 2001:db8:acad:210::1/64
ipv6 route 2001:db8:acad:209::/64 2001:db8:acad:16::1
ipv6 route ::/0 2001:db8:acad::1
ipv6 route ::/0 2001:db8:acad:16::1 80
ip route 0.0.0.0 0.0.0.0  192.168.0.17
end

Switch S1

enable
config terminal
hostname S1
interface range f0/1-3, f0/6-24, g0/1-2
 shutdown
end

Switch S2

enable
config terminal
hostname S2
interface range f0/1-3, f0/6-24, g0/1-2
 shutdown
end

Download Packet Tracer (.pka) file:

Subscribe
Notify of
guest

1 Comment
Inline Feedbacks
View all comments
Lou
Lou
3 months ago

These instructions are too vague. What does it mean to “traffic” data from one router to another with the next hop address?

1
0
Would love your thoughts, please comment.x
()
x