16.1.2 Lab – Configure Route Redistribution Between EIGRP and OSPF (Answers)

16.1.2 Lab – Configure Route Redistribution Between EIGRP and OSPF (Answers)

Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

16.1.2 Lab - Configure Route Redistribution Between EIGRP and OSPF (Answers) 2

Addressing Table

Device Interface IPv4 Address/Mask IPv6 Address/Prefix IPv6 Link Local
R1 G0/0/0 10.1.12.1/24 2001:db8:acad:12::1/64 fe80::12:1
G0/0/1 10.1.11.1/24 2001:db8:acad:11::1/64 fe80::11:1
Loopback 0 10.1.1.1/24 2001:db8:acad:1::1/64 fe80::1:1
R2 G0/0/0 10.1.12.2/24 2001:db8:acad:12::2/64 fe80::12:2
G0/0/1 10.1.23.2/24 2001:db8:acad:23::2/64 fe80::23:2
R3 G0/0/0 10.1.23.3/24 2001:db8:acad:23::3/64 fe80::23:3
G0/0/1 10.1.32.1/24 2001:db8:acad:32::3/64 fe80::32:3
Loopback 0 10.3.3.3/24 2001:db8:acad:3::3/64 fe80::3:3
D1 G1/0/11 10.1.11.2/24 2001:db8:acad:11::2/64 fe80::11:2
Loopback 0 209.165.201.1/25 2001:db8:209:165:201::1/80 fe80::209:1
D2 G1/0/11 10.1.32.2/24 2001:db8:acad:32::2/64 fe80::32:2
Loopback 0 198.51.100.1/25 2001:db8:198:51:100::1/80 fe80::198:1

Objectives

  • Part 1: Build the Network and Configure Basic Device Settings
  • Part 2: Verify OSPFv3 AF Neighborships and Routing for IPv4 and IPv6
  • Part 3: Verify EIGRP Neighborships and Routing for IPv4 and IPv6
  • Part 4: Configure Redistribution from OSPFv3 to EIGRP
  • Part 5: Configure Redistribution from EIGRP to OSPFv3

Background / Scenario

In this lab, you will configure redistribution from OSPF into EIGRP for IPv4 and IPv6, and redistribution of EIGRP into OSPF for IPv4 and IPv6. You will also change the metric type for EIGRP routes redistributed into OSPF.

D1, R1 and R2 are configured with OSPFv3 for IPv4 and IPv6 address families, while R2, R3 and D2 are configured with EIGRP using named mode for IPv4 and IPv6 address families.

Note: This lab is an exercise in configuring and verifying two-way route redistribution on R2. Route redistribution in this lab does not reflect networking best practices.

Note: The routers used with CCNP hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). The switches used in the labs are Cisco Catalyst 3650 with Cisco IOS XE Release 16.9.4 (universalk9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs.

Note: Make sure that all the devices have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

• 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
• 2 Switches (Cisco 3650 with Cisco IOS XE release 16.9.4 universal image or comparable)
• 1 PC (Choice of operating system with terminal emulation program installed)
• Console cables to configure the Cisco IOS devices via the console ports
• Ethernet cables as shown in the topology

Instructions

Part 1: Build the Network and Configure Basic Device Settings

In Part 1, you will set up the network topology and configure basic settings.

Step 1: Cable the network as shown in the topology.

Attach the devices as shown in the topology diagram, and cable as necessary.

Step 2: Configure basic settings for each device.

a. Console into each device, enter global configuration mode, and apply the basic settings for the lab. Initial configurations for each device are listed below.

Router R1

hostname R1
no ip domain lookup
ipv6 unicast-routing
banner motd # R1, Configure Route Redistribution Between EIGRP and OSPF # 
line con 0
 exec-timeout 0 0
 logging synchronous
 exit
router ospfv3 1
 router-id 1.1.1.1
exit
interface g0/0/0
 ip address 10.1.12.1 255.255.255.0
 ipv6 address FE80::12:1 link-local
 ipv6 address 2001:DB8:ACAD:12::1/64
 ospfv3 1 ipv6 area 0
 ospfv3 1 ipv4 area 0
 no shutdown
 exit
interface g0/0/1
 ip address 10.1.11.1 255.255.255.0
 ipv6 address fe80::11:1 link-local
 ipv6 address 2001:db8:acad:11::1/64
 ospfv3 1 ipv6 area 11
 ospfv3 1 ipv4 area 11
 no shutdown
 exit
interface loopback 0
 ip address 10.1.1.1 255.255.255.0
 ipv6 address FE80::1:1 link-local
 ipv6 address 2001:DB8:ACAD:1::1/64
 ospfv3 network point-to-point
 ospfv3 1 ipv4 area 0
 ospfv3 1 ipv6 area 0
 no shutdown
 exit
router ospfv3 1
address-family ipv4 unicast
  passive-interface Loopback0
 exit-address-family
 address-family ipv6 unicast
  passive-interface Loopback0
 exit-address-family
end

Router R2

hostname R2
no ip domain lookup
ipv6 unicast-routing
banner motd # R2, Configure Route Redistribution Between EIGRP and OSPF #
line con 0
 exec-timeout 0 0
 logging synchronous
 exit
router ospfv3 1
 router-id 2.2.2.2
 address-family ipv4 unicast
 exit-address-family
address-family ipv6 unicast
 exit-address-family
interface g0/0/0
 ip address 10.1.12.2 255.255.255.0
 ipv6 address FE80::12:2 link-local
 ipv6 address 2001:DB8:ACAD:12::2/64
 ospfv3 1 ipv6 area 0
 ospfv3 1 ipv4 area 0
 no shutdown
 exit
interface g0/0/1
 ip address 10.1.23.2 255.255.255.0
 ipv6 address fe80::23:2 link-local
 ipv6 address 2001:db8:acad:23::2/64
 no shutdown
 exit
router eigrp CISCO
address-family ipv4 unicast autonomous-system 64512
  af-interface default
   shutdown
  exit-af-interface
  af-interface GigabitEthernet0/0/1
   no shutdown
  exit-af-interface
  topology base
  exit-af-topology
  network 10.1.23.0 0.0.0.255
  eigrp router-id 2.2.2.2
 exit-address-family
address-family ipv6 unicast autonomous-system 64512
  af-interface default
   shutdown
  exit-af-interface
  af-interface GigabitEthernet0/0/1
   no shutdown
  exit-af-interface
  topology base
  exit-af-topology
 exit-address-family
end

Router R3

hostname R3
no ip domain lookup
ipv6 unicast-routing
banner motd # R3, Configure Route Redistribution Between EIGRP and OSPF # 
line con 0
 exec-timeout 0 0
 logging synchronous
 exit
interface g0/0/0
 ip address 10.1.23.3 255.255.255.0
 ipv6 address fe80::23:3 link-local
 ipv6 address 2001:db8:acad:23::3/64
 no shutdown
 exit
interface g0/0/1
 ip address 10.1.32.3 255.255.255.0
 ipv6 address fe80::32:3 link-local
 ipv6 address 2001:db8:acad:32::3/64
 no shutdown
 exit
interface loopback 0
 ip address 10.3.3.3 255.255.255.0
 ipv6 address fe80::3:3 link-local
 ipv6 address 2001:db8:acad:3::3/64
 no shutdown
 exit
router eigrp CISCO
address-family ipv4 unicast autonomous-system 64512
  af-interface default
   shutdown
  exit-af-interface
  af-interface GigabitEthernet0/0/0
   no shutdown
  exit-af-interface
  af-interface GigabitEthernet0/0/1
   no shutdown
  exit-af-interface
  af-interface Loopback0
   no shutdown
  exit-af-interface
  topology base
  exit-af-topology
  network 10.1.23.0 0.0.0.255
  network 10.1.32.0 0.0.0.255
  network 10.3.3.0 0.0.0.255
  eigrp router-id 3.3.3.3
 exit-address-family
address-family ipv6 unicast autonomous-system 64512
  af-interface default
   shutdown
  exit-af-interface
  af-interface GigabitEthernet0/0/0
   no shutdown
  exit-af-interface
  af-interface GigabitEthernet0/0/1
   no shutdown
  exit-af-interface
  af-interface Loopback0
   no shutdown
  exit-af-interface
  topology base
  exit-af-topology
  eigrp router-id 3.3.3.3
 exit-address-family
end

Switch D1

hostname D1
no ip domain lookup
ip routing
ipv6 unicast-routing
banner motd # D1, Configure Route Redistribution Between EIGRP and OSPF # 
line con 0
 exec-timeout 0 0
 logging synchronous
 exit
router ospfv3 1
 router-id 11.11.11.11
 exit
interface range g1/0/1-24
 shutdown
 exit
interface g1/0/11
 no switchport
 ip address 10.1.11.2 255.255.255.0
 ipv6 address fe80::11:2 link-local
 ipv6 address 2001:db8:acad:11::2/64
 ospfv3 1 ipv6 area 11
 ospfv3 1 ipv4 area 11
 no shutdown
 exit
interface loopback 0
 ip address 209.165.201.1 255.255.255.128
 ipv6 address fe80::209:1 link-local
 ipv6 address 2001:db8:209:165:201::1/80
 no shutdown
 exit
router ospfv3 1
address-family ipv4 unicast
  passive-interface Loopback0
  default-information originate
 exit-address-family
address-family ipv6 unicast
  passive-interface Loopback0
  default-information originate
 exit-address-family
ip route 0.0.0.0 0.0.0.0 Loopback0
ipv6 route ::/0 Loopback0
exit

Switch D2

hostname D2
no ip domain lookup
ip routing
ipv6 unicast-routing
banner motd # D2, Configure Route Redistribution Between EIGRP and OSPF #
line con 0
 exec-timeout 0 0
 logging synchronous
 exit
interface range g1/0/1-24
 shutdown
 exit
interface g1/0/11
 no switchport
 ip address 10.1.32.2 255.255.255.0
 ipv6 address fe80::32:2 link-local
 ipv6 address 2001:db8:acad:32::2/64
 no shutdown
 exit
interface loopback 0
 ip address 198.51.100.1 255.255.255.128
 ipv6 address fe80::198:2 link-local
 ipv6 address 2001:db8:198:51:100::1/80
 no shutdown
 router eigrp CISCO
 address-family ipv4 unicast autonomous-system 64512
  af-interface default
   shutdown
  exit-af-interface
  af-interface Loopback0
   no shutdown
   passive-interface
  exit-af-interface
  af-interface GigabitEthernet1/0/11
   no shutdown
  exit-af-interface
  topology base
  exit-af-topology
  network 10.1.32.0 0.0.0.255
  network 198.51.100.0 0.0.0.127
  eigrp router-id 22.22.22.22
 exit-address-family
 address-family ipv6 unicast autonomous-system 64512
  af-interface default
   shutdown
  exit-af-interface
  af-interface Loopback0
   no shutdown
   passive-interface
  exit-af-interface
  af-interface GigabitEthernet1/0/11
   no shutdown
  exit-af-interface
  topology base
  exit-af-topology
  eigrp router-id 22.22.22.22
 exit-address-family
 exit

b. Set the clock on all devices to UTC time.

c. Save the running configuration to startup-config on all devices.

Part 2: Verify OSPFv3 AF Neighborships and Routing for IPv4 and IPv6

In this part, you will verify that OSPF has established neighbor relationships and routing for IPv4 and IPv6.

Step 1: Verify OSPFv3 AF neighborships on R1.

a. Verify R1 has OSPFv3 neighbors: two neighbors from IPv4 address family and two from IPv6 address family.

R1# show ospfv3 neighbor

          OSPFv3 1 address-family ipv4 (router-id 1.1.1.1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:36    6               GigabitEthernet0/0/0
11.11.11.11       1   FULL/BDR        00:00:31    38              GigabitEthernet0/0/1

          OSPFv3 1 address-family ipv6 (router-id 1.1.1.1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
2.2.2.2           1   FULL/BDR        00:00:39    6               GigabitEthernet0/0/0
11.11.11.11       1   FULL/BDR        00:00:39    38              GigabitEthernet0/0/1

b. The output shows four OSPFv3 neighbors: two neighbors from IPv4 address family and two from IPv6 address family.

Step 2: Verify the IPv4 OSPFv3 routing table on R2.

a. Verify the OSPFv3 IPv4 routing table on R2. Notice the default route, the intra–area, and inter–area OSPF routes are installed and received from 10.1.12.1, which is R1.

R2# show ip route ospfv3 | begin Gateway
Gateway of last resort is 10.1.12.1 to network 0.0.0.0

O*E2  0.0.0.0/0 [110/1] via 10.1.12.1, 02:41:28, GigabitEthernet0/0/0
      10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
O        10.1.1.0/24 [110/1] via 10.1.12.1, 02:49:12, GigabitEthernet0/0/0
O IA     10.1.11.0/24 [110/2] via 10.1.12.1, 02:44:58, GigabitEthernet0/0/0

b. From R2, ping the Loopback 0 address on D1. The ping should be successful.

R2# ping 209.165.201.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.201.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

Step 3: Verify IPv6 OSPFv3 routing table on R2.

a. Verify the OSPFv3 IPv4 routing table on R2. Notice the default route, the intra–area, and inter–area OSPF routes are installed and received from fe80::12:1, which is R1.

R2# show ipv6 route ospf
< some output omitted  >
OE2 ::/0 [110/1], tag 1
     via FE80::12:1, GigabitEthernet0/0/0
O   2001:DB8:ACAD:1::/64 [110/2]
     via FE80::12:1, GigabitEthernet0/0/0
OI  2001:DB8:ACAD:11::/64 [110/2]
     via FE80::12:1, GigabitEthernet0/0/0

b. From R2, ping the IPv6 Loopback 0 address on D1. The ping should be successful.

R2# ping 2001:db8:209:165:201::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:209:165:201::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms

c. The output for the ping in the previous step and this step confirms that R2 has learned OSPFv3 routes for IPv4 and IPv6, including a default route for IPv4 and IPv6. The output also confirms R2 can ping the Loopback 0 address from both IPv4 and IPv6.

Part 3: Verify EIGRP Neighborships and Routing for IPv4 and IPv6

In this part, you will verify that EIGRP has established neighbor relationships and routing for IPv4 and IPv6.

Step 1: Verify EIGRP for IPv4 neighborships on R3.

Issue the command to verify EIGRP has two IPv4 neighbors, as shown.

R3# show ip eigrp neighbors
EIGRP-IPv4 VR(CISCO) Address-Family Neighbors for AS(64512)
H   Address                 Interface              Hold Uptime   SRTT   RTO  QSeq
                                                   (sec)         (ms)       CntNum
1   10.1.32.2               Gi0/0/1                  10 20:13:56    3   100  013
0   10.1.23.2               Gi0/0/0                  13 20:31:08    1   100  019

Notice the two IPv4 neighbors, 10.1.23.2 and 10.1.32.2.

Step 2: Verify the EIGRP for IPv6 neighborships on R3.

Issue the command to verify EIGRP has two IPv6 neighbors, as shown.

R3# show ipv6 eigrp neighbors
EIGRP-IPv6 VR(CISCO) Address-Family Neighbors for AS(64512)
H   Address                 Interface              Hold Uptime   SRTT   RTO  QSeq
                                                   (sec)         (ms)       CntNum
1   Link-local address:     Gi0/0/1                  13 20:13:20    3   100  09
    FE80::32:2
0   Link-local address:     Gi0/0/0                  11 20:32:08    1   100  019
    FE80::23:2

Notice the two IPv6 neighbors, fe80::23:2 and fe80::32:2.

Step 3: Verify EIGRP for IPv4 routing table on R2.

Issue the command to display the EIGRP IPv4 routing table on R2, as shown.

R2# show ip route eigrp | begin 10.0
      10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
D        10.1.32.0/24 [90/15360] via 10.1.23.3, 20:35:38, GigabitEthernet0/0/1
D        10.3.3.0/24 [90/10880] via 10.1.23.3, 20:44:06, GigabitEthernet0/0/1
      198.51.100.0/25 is subnetted, 1 subnets
D        198.51.100.0 [90/16000] via 10.1.23.3, 20:29:04, GigabitEthernet0/0/1

Notice three internal EIGRP routes from 10.1.23.3, which is R3.

Step 4: Verify EIGRP for IPv6 routing table on R2.

Issue the command to display the IPv6 EIGRP routing table on R2, as shown.

R2# show ipv6 route eigrp | begin 2001
D   2001:DB8:198:51:100::/80 [90/16000]
     via FE80::23:3, GigabitEthernet0/0/1
D   2001:DB8:ACAD:3::/64 [90/10880]
     via FE80::23:3, GigabitEthernet0/0/1
D   2001:DB8:ACAD:32::/64 [90/15360]
     via FE80::23:3, GigabitEthernet0/0/1

The output above confirms R2 has learned EIGRP routes for IPv4 and IPv6.

Part 4: Configure Redistribution from OSPFv3 to EIGRP

Recall that every protocol provides a seed metric at the time of redistribution. By default, when source protocols, such as, OSPF, RIP, and IS-IS, are redistributed into EIGRP, they are given an administrative distance of 170 and a seed metric of infinity. This prevents the installation of the redistributed routes into the EIGRP topology table. The seed metric can be set using the redistribute or default-metric command. Additionally, when using a route map, the seed metric can be configured using the set metric option.

For IPv4, you will set the seed metric using the redistribute command and the default-metric command.

Step 1: Redistribute OSPFv3 into EIGRP for IPv4.

In this step were going to the destination EIGRP AS 64512 to perform redistribution. Since EIGRP is using named mode the redistribute command is entered in the address family topology configuration mode, as shown.

R2(config)# router eigrp CISCO
R2(config-router)# address-family ipv4 autonomous-system 64512
R2(config-router-af)# topology base
R2(config-router-af-topology)# redistribute ospfv3 1 metric 1000000 10 255 1 1500
R2(config-router-af-topology)# end
Step 2: On D2, verify redistribution of OSPFv3.

Issue the show ip route eigrp on D2 to see the external EIGRP routes from OSPFv3.

D2# show ip route eigrp | begin Gateway
Gateway of last resort is 10.1.32.3 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/66560] via 10.1.32.3, 00:03:59, GigabitEthernet1/0/11
      10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D EX     10.1.1.0/24
           [170/66560] via 10.1.32.3, 00:03:59, GigabitEthernet1/0/11
D EX     10.1.11.0/24
           [170/66560] via 10.1.32.3, 00:03:59, GigabitEthernet1/0/11
D EX     10.1.12.0/24
           [170/66560] via 10.1.32.3, 00:03:59, GigabitEthernet1/0/11
D        10.1.23.0/24
           [90/15360] via 10.1.32.3, 21:20:07, GigabitEthernet1/0/11
D        10.3.3.0/24 [90/10880] via 10.1.32.3, 21:20:07, GigabitEthernet1/0/11

Notice the gateway of last resort has been set and D2 has learned four external EIGRP routes which originated from OSPFv3. The OSPFv3 routes are imported into EIGRP as external, D EX routes with an administrative distance of 170, which are higher than the internal EIGRP routes of 90.

Step 3: Redistribute OSPFv3 into EIGRP for IPv6.

Again, go to the destination protocol to perform redistribution. In this example you will set the seed metric using the default-metric command. Both commands are configured in the IPv6 address-family topology base, as shown.

R2(config)# router eigrp CISCO
R2(config-router)# address-family ipv6 autonomous-system 64512
R2(config-router-af)# topology base
R2(config-router-af-topology)# default-metric 1000000 10 255 1 1500
R2(config-router-af-topology)# redistribute ospf 1

Note: Do not leave AF topology configuration mode.

In the example above, the seed metric was set using the default-metric command.

Notice the include-connected option was not configured using the redistribute ospf 1 command. The include-connected command must be set for OSPFv3 IPv6 connected interface on R2, in our example, 2001:db8:acad:12::/64 to be redistributed into EIGRP. With IPv4, connected interfaces are automatically advertised into the routing protocol for connected interfaces the source protocol is advertising. For IPv6, the administrator decides whether the connected subnets are included into redistribution.

Also notice under the EIGRP IPv6 address family, it is not possible to specify OSPFv3 as the source protocol for redistribution. Instead the ospf keyword automatically assumes OSPFv3 since the command is entered under the IPv6 address family.

Step 4: On D2 Verify OSPFv3 redistribution for IPv6.

Issue the command to view the IPv6 routing table for EIGRP.

D2# show ipv6 route eigrp | begin EX  ::
EX  ::/0 [170/66560], tag 1
     via FE80::32:3, GigabitEthernet1/0/11
EX  2001:DB8:ACAD:1::/64 [170/66560]
     via FE80::32:3, GigabitEthernet1/0/11
D   2001:DB8:ACAD:3::/64 [90/10880]
     via FE80::32:3, GigabitEthernet1/0/11
EX  2001:DB8:ACAD:11::/64 [170/66560]
     via FE80::32:3, GigabitEthernet1/0/11
D   2001:DB8:ACAD:23::/64 [90/15360]
     via FE80::32:3, GigabitEthernet1/0/11

Notice the three highlighted external routes. The 2001:db8:acad:12::/64 prefix was not redistributed because of the missing include-connected keyword.

Step 5: Redistribute OSPFv3 connected routes into EIGRP for IPv6.

a. From the EIGRP IPv6 address family topology configuration mode configure redistribution with the same command as the previous step, but this time add include-connected as shown.

R2(config-router-af-topology)# redistribute ospf 1 include-connected
R2(config-router-af-topology)# end

b. On D2, verify the IPv6 prefixes are being redistributed as before, as well as the connected prefix, which is included and highlighted in the routing table.

D2# show ipv6 route eigrp | begin EX  ::
EX  ::/0 [170/66560], tag 1
     via FE80::32:3, GigabitEthernet1/0/11
EX  2001:DB8:ACAD:1::/64 [170/66560]
     via FE80::32:3, GigabitEthernet1/0/11
D   2001:DB8:ACAD:3::/64 [90/10880]
     via FE80::32:3, GigabitEthernet1/0/11
EX  2001:DB8:ACAD:11::/64 [170/66560]
     via FE80::32:3, GigabitEthernet1/0/11
EX  2001:DB8:ACAD:12::/64 [170/66560]
     via FE80::32:3, GigabitEthernet1/0/11
D   2001:DB8:ACAD:23::/64 [90/15360]
     via FE80::32:3, GigabitEthernet1/0/11

Part 5: Configure Redistribution from EIGRP for IPv4 into OSPFv3

In this part, you will perform EIGRP for IPv4 redistribution into OSPFv3.

Note: When redistributing into OSPFv2, you must include the subnets keyword. The keyword subnets is required for classless networks to be advertised. If omitted only classful networks using a classful mask will be redistributed.

Step 1: On R2, redistribute EIGRP into OSPFv3.

The redistribute command is always performed on the destination protocol. Start by accessing the OSPFv3 address family for IPv4. Then redistribute the source protocol, EIGRP 64512 into the destination protocol, as shown.

R2(config)# router ospfv3 1
R2(config-router)# address-family ipv4 unicast
R2(config-router-af)# redistribute eigrp 64512

Note: Do not leave AF configuration mode.

Step 2: Verify redistribution on D1.

Issue the show ip route ospfv3 on D1 to see the external OSPF routes from EIGRP.

D1# show ip route ospfv3 | begin Gateway
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

      10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA     10.1.1.0/24 [110/2] via 10.1.11.1, 02:52:36, GigabitEthernet1/0/11
O IA     10.1.12.0/24 [110/2] via 10.1.11.1, 1d01h, GigabitEthernet1/0/11
O E2     10.1.23.0/24 [110/20] via 10.1.11.1, 00:03:55, GigabitEthernet1/0/11
O E2     10.1.32.0/24 [110/20] via 10.1.11.1, 00:03:55, GigabitEthernet1/0/11
O E2     10.3.3.0/24 [110/20] via 10.1.11.1, 00:03:55, GigabitEthernet1/0/11
      198.51.100.0/25 is subnetted, 1 subnets
O E2     198.51.100.0 [110/20] via 10.1.11.1, 00:03:55, GigabitEthernet1/0/11

Notice the highlighted external E2 OSPF routes. By default, external LSAs appear in the routing table marked as E2 with an external cost of 20.

Step 3: Redistribute EIGRP into OSPFv3 using a Type 1.

From the address family configuration mode, modify the redistribute command configured in Step 1 to specify an external type 1.

R2(config-router-af)# redistribute eigrp 64512 metric-type ?
  1  Set OSPF External Type 1 metrics
  2  Set OSPF External Type 2 metrics

R2(config-router-af)# redistribute eigrp 64512 metric-type 1
R2(config-router-af)# exit
Step 4: Verify redistribution again on D1.

a. Issue the show ip route ospfv3 on D1 to see the external OSPF routes.

D1# show ip route ospfv3 | begin Gateway
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

      10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA     10.1.1.0/24 [110/2] via 10.1.11.1, 03:10:29, GigabitEthernet1/0/11
O IA     10.1.12.0/24 [110/2] via 10.1.11.1, 1d02h, GigabitEthernet1/0/11
O E1     10.1.23.0/24 [110/22] via 10.1.11.1, 00:10:11, GigabitEthernet1/0/11
O E1     10.1.32.0/24 [110/22] via 10.1.11.1, 00:10:11, GigabitEthernet1/0/11
O E1     10.3.3.0/24 [110/22] via 10.1.11.1, 00:10:11, GigabitEthernet1/0/11
      198.51.100.0/25 is subnetted, 1 subnets
O E1     198.51.100.0 [110/22] via 10.1.11.1, 00:10:11, GigabitEthernet1/0/11

Notice the highlighted external E1 OSPF routes. These E1 routes have a cost of 22 which includes the default cost of 20 plus the internal cost of 2.

b. From D2 ping the Loopback address on D1 using Loopback address of D2. The ping should be successful. This verifies successful two-way redistribution on R2 and end-to-end connectivity for IPv4.

D2# ping 209.165.201.1 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.165.201.1, timeout is 2 seconds:
Packet sent with a source address of 198.51.100.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms
Step 5: Configure redistribution of EIGRP for IPv6 routes into OSPFv3 using a route map.

Next, you will redistribute EIGRP for IPv6 routes into OSPFv3 using a route map to set the external LSA to a metric type 1, or E1.

a. First, you create a route map name E2O with a permit statement using a sequence number of 10. Because you are not going to use the match command, the default action is to match all. Then you set the metric type to an E1, or m, as shown.

R2(config)# route-map E2O permit 10 
R2(config-route-map)# set metric-type type-1
R2(config-route-map)# exit

b. Next, you access the OSPFv3 IPv6 address family. Then you issue the redistribute command and specify the route map name. Ensure to add the include-connected after the route map name, as shown.

R2(config)# router ospfv3 1 
R2(config-router)# address-family ipv6
R2(config-router-af)# redistribute eigrp 64512 route-map E2O include-connected
R2(config-router-af)# exit

The route map E2O will match all redistributed routes, including connected interfaces advertised in EIGRP 64512.

Step 6: On D1 verify that routes from EIGRP for IPv6 are imported into OSPFv3 with the external metric type 1.

a. Issue the show ipv6 route ospf on D1 to see the external EIGRP routes. Notice the highlighted external E1 OSPF routes.

D1# show ipv6 route ospf
>  output omitted  >
OE1 2001:DB8:198:51:100::/80 [110/22]
     via FE80::11:1, GigabitEthernet1/0/11
OI  2001:DB8:ACAD:1::/64 [110/2]
     via FE80::11:1, GigabitEthernet1/0/11
OE1 2001:DB8:ACAD:3::/64 [110/22]
     via FE80::11:1, GigabitEthernet1/0/11
OI  2001:DB8:ACAD:12::/64 [110/2]
     via FE80::11:1, GigabitEthernet1/0/11
OE1 2001:DB8:ACAD:23::/64 [110/22]
     via FE80::11:1, GigabitEthernet1/0/11
OE1 2001:DB8:ACAD:32::/64 [110/22]
     via FE80::11:1, GigabitEthernet1/0/11

b. From D2, ping the Loopback address on D1 using Loopback address of D2. The ping should be successful. This verifies full successful two-way redistribution on R2 and end-to-end connectivity for IPv6.

D2# ping 2001:db8:209:165:201::1 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:209:165:201::1, timeout is 2 seconds:
Packet sent with a source address of 2001:DB8:198:51:100::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/9 ms

Reflection Questions

1. What is the difference between an external OSPF E2 and E1?
OSPF metric type E2 is the default, if not specified. An E2 has an external cost of 20. Metric type 1 or E1 calculates the cost by adding the external cost to the internal cost for each link the packet traverses. Use an E1 when there are multiple ASBRs advertising an external route to the same AS.

2. What are three ways to set a seed metric during redistribution?
Using the redistribute command, using the default-metric command and using a route map with the set metric command

3. What is the default action in a route map if you do not include the match command?
The default action is to match any

Router Interface Summary Table

Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
4221 Gigabit Ethernet 0/0/0 (G0/0/0) Gigabit Ethernet 0/0/1 (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
4300 Gigabit Ethernet 0/0/0 (G0/0/0) Gigabit Ethernet 0/0/1 (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs – Final

Router R1

R1# show run
Building configuration...


Current configuration : 2238 bytes
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
no ip domain lookup
!
subscriber templating
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
spanning-tree extend system-id
!
redundancy
 mode none
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
 ipv6 address FE80::1:1 link-local
 ipv6 address 2001:DB8:ACAD:1::1/64
 ospfv3 network point-to-point
 ospfv3 1 ipv4 area 0
 ospfv3 1 ipv6 area 0
!
interface GigabitEthernet0/0/0
 ip address 10.1.12.1 255.255.255.0
 negotiation auto
 ipv6 address FE80::12:1 link-local
 ipv6 address 2001:DB8:ACAD:12::1/64
 ospfv3 1 ipv6 area 0
 ospfv3 1 ipv4 area 0
!
interface GigabitEthernet0/0/1
 ip address 10.1.11.1 255.255.255.0
 negotiation auto
 ipv6 address FE80::11:1 link-local
 ipv6 address 2001:DB8:ACAD:11::1/64
 ospfv3 1 ipv4 area 11
 ospfv3 1 ipv6 area 11
!
interface Serial0/1/0
 no ip address
!
interface Serial0/1/1
 no ip address
!
router ospfv3 1
 router-id 1.1.1.1
 !
 address-family ipv4 unicast
  passive-interface Loopback0
 exit-address-family
 !
 address-family ipv6 unicast
  passive-interface Loopback0
 exit-address-family
!
ip forward-protocol nd
no ip http server
ip http secure-server
control-plane
!
banner motd ^C R1, Configure Route Redistribution Between EIGRP and OSPF ^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end

Router R2

R2# show running-config
Building configuration...


Current configuration : 2716 bytes
!
version 16.6
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
no ip domain lookup
!
login on-success log
!
subscriber templating
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
spanning-tree extend system-id
!
redundancy
 mode none
!
interface GigabitEthernet0/0/0
 ip address 10.1.12.2 255.255.255.0
 negotiation auto
 ipv6 address FE80::12:2 link-local
 ipv6 address 2001:DB8:ACAD:12::2/64
 ospfv3 1 ipv4 area 0
 ospfv3 1 ipv6 area 0
!
interface GigabitEthernet0/0/1
 ip address 10.1.23.2 255.255.255.0
 negotiation auto
 ipv6 address FE80::23:2 link-local
 ipv6 address 2001:DB8:ACAD:23::2/64
!
router eigrp CISCO
 !
 address-family ipv4 unicast autonomous-system 64512
  !
  af-interface default
   shutdown
  exit-af-interface
  !
  af-interface GigabitEthernet0/0/1
   no shutdown
  exit-af-interface
  !
  topology base
   redistribute ospfv3 1 metric 1000000 10 255 1 1500
  exit-af-topology
  network 10.1.23.0 0.0.0.255
  eigrp router-id 2.2.2.2
 exit-address-family
 !
 address-family ipv6 unicast autonomous-system 64512
  !
  af-interface default
   shutdown
  exit-af-interface
  !
  af-interface GigabitEthernet0/0/1
   no shutdown
  exit-af-interface
  !
  topology base
   default-metric 1000000 10 255 1 1500
   redistribute ospf 1 include-connected
  exit-af-topology
 exit-address-family
!
router ospfv3 1
 router-id 2.2.2.2
 !
 address-family ipv4 unicast
  redistribute eigrp 64512 metric-type 1
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute eigrp 64512 route-map E2O include-connected
 exit-address-family
!
ip forward-protocol nd
no ip http server
ip http secure-server
!
route-map E2O permit 10
 set metric-type type-1
!
control-plane
!
banner motd ^C R2, Configure Route Redistribution Between EIGRP and OSPF ^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
end

Router R3

R3# show running-config
Building configuration...


Current configuration : 2770 bytes
!
version 16.6
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
no ip domain lookup
!
login on-success log
!
subscriber templating
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
Spanning-tree extend system-id
!
redundancy
 mode none
!
interface Loopback0
 ip address 10.3.3.3 255.255.255.0
 ipv6 address FE80::3:3 link-local
 ipv6 address 2001:DB8:ACAD:3::3/64
!
interface GigabitEthernet0/0/0
 ip address 10.1.23.3 255.255.255.0
 negotiation auto
 ipv6 address FE80::23:3 link-local
 ipv6 address 2001:DB8:ACAD:23::3/64
!
interface GigabitEthernet0/0/1
 ip address 10.1.32.3 255.255.255.0
 negotiation auto
 ipv6 address FE80::32:3 link-local
 ipv6 address 2001:DB8:ACAD:32::3/64
!
interface Serial0/1/0
 no ip address
!
interface Serial0/1/1
 no ip address
!
router eigrp CISCO
 !
 address-family ipv4 unicast autonomous-system 64512
  !
  af-interface default
   shutdown
  exit-af-interface
  !
  af-interface GigabitEthernet0/0/0
   no shutdown
  exit-af-interface
  !
  af-interface GigabitEthernet0/0/1
   no shutdown
  exit-af-interface
  !
  af-interface Loopback0
   no shutdown
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 10.1.23.0 0.0.0.255
  network 10.1.32.0 0.0.0.255
  network 10.3.3.0 0.0.0.255
  eigrp router-id 3.3.3.3
 exit-address-family
 !
 address-family ipv6 unicast autonomous-system 64512
  !
  af-interface default
   shutdown
  exit-af-interface
  !
  af-interface GigabitEthernet0/0/0
   no shutdown
  exit-af-interface
  !
  af-interface GigabitEthernet0/0/1
   no shutdown
  exit-af-interface
  !
  af-interface Loopback0
   no shutdown
  exit-af-interface
  !
  topology base
  exit-af-topology
  eigrp router-id 3.3.3.3
 exit-address-family
!
ip forward-protocol nd
no ip http server
ip http secure-server
!
control-plane
!
banner motd ^C R3, Configure Route Redistribution Between EIGRP and OSPF ^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
end

Switch D1

D1# show running-config
Building configuration...

Current configuration : 4574 bytes
!
version 16.9
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
! Call-home is enabled by Smart-Licensing.
service call-home
no platform punt-keepalive disable-kernel-core
!
hostname D1
!
vrf definition Mgmt-vrf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
no aaa new-model
switch 1 provision ws-c3650-24ps
!
ip routing
!
no ip domain lookup
!
ipv6 unicast-routing
!
diagnostic bootup level minimal
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
redundancy
 mode sso
!
transceiver type all
 monitoring
!
class-map match-any system-cpp-police-topology-control
  description Topology control
class-map match-any system-cpp-police-sw-forward
  description Sw forwarding, L2 LVX data, LOGGING
class-map match-any system-cpp-default
  description DHCP Snooping, EWLC control, EWCL data
class-map match-any system-cpp-police-sys-data
  description Learning cache ovfl, Crypto Control, Exception, EGR Exception, NFL SAMPLED DATA, RPF Failed
class-map match-any system-cpp-police-punt-webauth
  description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
  description L2 LVX control packets
class-map match-any system-cpp-police-forus
  description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
  description MCAST END STATION
class-map match-any system-cpp-police-multicast
  description Transit Traffic and MCAST Data
class-map match-any system-cpp-police-l2-control
  description L2 control
class-map match-any system-cpp-police-dot1x-auth
  description DOT1X Auth
class-map match-any system-cpp-police-data
  description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
  description Stackwise Virtual
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
  description Routing control
class-map match-any system-cpp-police-protocol-snooping
  description Protocol snooping
class-map match-any system-cpp-police-system-critical
  description System Critical and Gold
!
policy-map system-cpp-policy
!
interface Loopback0
 ip address 209.165.201.1 255.255.255.128
 ipv6 address FE80::209:1 link-local
 ipv6 address 2001:DB8:209:165:201::1/80
!
interface GigabitEthernet0/0
 vrf forwarding Mgmt-vrf
 no ip address
 speed 1000
 negotiation auto
!
interface GigabitEthernet1/0/1
 shutdown
!
interface GigabitEthernet1/0/2
 shutdown
!
interface GigabitEthernet1/0/3
 shutdown
!
interface GigabitEthernet1/0/4
 shutdown
!
interface GigabitEthernet1/0/5
 shutdown
!
interface GigabitEthernet1/0/6
 shutdown
!
interface GigabitEthernet1/0/7
 shutdown
!
interface GigabitEthernet1/0/8
 shutdown
!
interface GigabitEthernet1/0/9
 shutdown
!
interface GigabitEthernet1/0/10
 shutdown
!
interface GigabitEthernet1/0/11
 no switchport
 ip address 10.1.11.2 255.255.255.0
 ipv6 address FE80::11:2 link-local
 ipv6 address 2001:DB8:ACAD:11::2/64
 ospfv3 1 ipv6 area 11
 ospfv3 1 ipv4 area 11
!
interface GigabitEthernet1/0/12
 shutdown
!
interface GigabitEthernet1/0/13
 shutdown
!
interface GigabitEthernet1/0/14
 shutdown
!
interface GigabitEthernet1/0/15
 shutdown
!
interface GigabitEthernet1/0/16
 shutdown
!
interface GigabitEthernet1/0/17
 shutdown
!
interface GigabitEthernet1/0/18
 shutdown
!
interface GigabitEthernet1/0/19
 shutdown
!
interface GigabitEthernet1/0/20
 shutdown
!
interface GigabitEthernet1/0/21
 shutdown
!
interface GigabitEthernet1/0/22
 shutdown
!
interface GigabitEthernet1/0/23
 shutdown
!
interface GigabitEthernet1/0/24
 shutdown
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
 no ip address
!
router ospfv3 1
 router-id 11.11.11.11
 !
 address-family ipv4 unicast
  passive-interface Loopback0
  default-information originate
 exit-address-family
 !
 address-family ipv6 unicast
  passive-interface Loopback0
  default-information originate
 exit-address-family
!
ip forward-protocol nd
ip http server
ip http secure-server
ip route 0.0.0.0 0.0.0.0 Loopback0
!
ipv6 route ::/0 Loopback0
!
control-plane
 service-policy input system-cpp-policy
!
banner motd ^C D1, Configure Route Redistribution Between EIGRP and OSPF ^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
end

Switch D2

D2# show running-config
Building configuration...

Current configuration : 4972 bytes
!
version 16.6
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname D2
!
vrf definition Mgmt-vrf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
no aaa new-model
switch 1 provision ws-c3650-24ps
!
ip routing
!
no ip domain lookup
!
ipv6 unicast-routing
!
diagnostic bootup level minimal
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
redundancy
 mode sso
!
transceiver type all
 monitoring
!
class-map match-any system-cpp-police-topology-control
  description Topology control
class-map match-any system-cpp-police-sw-forward
  description Sw forwarding, L2 LVX data, LOGGING
class-map match-any system-cpp-default
  description DHCP Snooping, EWLC control, EWCL data
class-map match-any system-cpp-police-sys-data
  description Learning cache ovfl, Crypto Control, Exception, EGR Exception, NFL SAMPLED DATA, RPF Failed
class-map match-any system-cpp-police-punt-webauth
  description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
  description L2 LVX control packets
class-map match-any system-cpp-police-forus
  description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
  description MCAST END STATION
class-map match-any system-cpp-police-multicast
  description Transit Traffic and MCAST Data
class-map match-any system-cpp-police-l2-control
  description L2 control
class-map match-any system-cpp-police-dot1x-auth
  description DOT1X Auth
class-map match-any system-cpp-police-data
  description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
  description Stackwise Virtual
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
  description Routing control
class-map match-any system-cpp-police-protocol-snooping
  description Protocol snooping
class-map match-any system-cpp-police-system-critical
  description System Critical and Gold
!
policy-map system-cpp-policy
!
interface Loopback0
 ip address 198.51.100.1 255.255.255.128
 ipv6 address FE80::198:2 link-local
 ipv6 address 2001:DB8:198:51:100::1/80
!
interface GigabitEthernet0/0
 vrf forwarding Mgmt-vrf
 no ip address
 speed 1000
 negotiation auto
!
interface GigabitEthernet1/0/1
 shutdown
!
interface GigabitEthernet1/0/2
 shutdown
!
interface GigabitEthernet1/0/3
 shutdown
!
interface GigabitEthernet1/0/4
 shutdown
!
interface GigabitEthernet1/0/5
 shutdown
!
interface GigabitEthernet1/0/6
 shutdown
!
interface GigabitEthernet1/0/7
 shutdown
!
interface GigabitEthernet1/0/8
 shutdown
!
interface GigabitEthernet1/0/9
 shutdown
!
interface GigabitEthernet1/0/10
 shutdown
!
interface GigabitEthernet1/0/11
 no switchport
 ip address 10.1.32.2 255.255.255.0
 ipv6 address FE80::32:2 link-local
 ipv6 address 2001:DB8:ACAD:32::2/64
!
interface GigabitEthernet1/0/12
 shutdown
!
interface GigabitEthernet1/0/13
 shutdown
!
interface GigabitEthernet1/0/14
 shutdown
!
interface GigabitEthernet1/0/15
 shutdown
!
interface GigabitEthernet1/0/16
 shutdown
!
interface GigabitEthernet1/0/17
 shutdown
!
interface GigabitEthernet1/0/18
 shutdown
!
interface GigabitEthernet1/0/19
 shutdown
!
interface GigabitEthernet1/0/20
 shutdown
!
interface GigabitEthernet1/0/21
 shutdown
!
interface GigabitEthernet1/0/22
 shutdown
!
interface GigabitEthernet1/0/23
 shutdown
!
interface GigabitEthernet1/0/24
 shutdown
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
 no ip address
!
router eigrp CISCO
 !
 address-family ipv4 unicast autonomous-system 64512
  !
  af-interface default
   shutdown
  exit-af-interface
  !
  af-interface Loopback0
   no shutdown
   passive-interface
  exit-af-interface
  !
  af-interface GigabitEthernet1/0/11
   no shutdown
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 10.1.32.0 0.0.0.255
  network 198.51.100.0 0.0.0.127
  eigrp router-id 22.22.22.22
 exit-address-family
 !
 address-family ipv6 unicast autonomous-system 64512
  !
  af-interface default
   shutdown
  exit-af-interface
  !
  af-interface Loopback0
   no shutdown
   passive-interface
  exit-af-interface
  !
  af-interface GigabitEthernet1/0/11
   no shutdown
  exit-af-interface
  !
  topology base
  exit-af-topology
  eigrp router-id 22.22.22.22
 exit-address-family
!
ip forward-protocol nd
ip http server
ip http secure-server
!
control-plane
 service-policy input system-cpp-policy
!
banner motd ^C D2, Configure Route Redistribution Between EIGRP and OSPF ^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
end

Download 16.1.2 Lab – Configure Route Redistribution Between EIGRP and OSPF .PDF file:


Related Articles

guest
0 Comments
Inline Feedbacks
View all comments