CCNP ROUTE Chapter 3 Lab 3-1, OSPF Virtual Links (Version 7)

Topology

CCNP ROUTE Chapter 3 Lab 3-1, OSPF Virtual Links (Version 7) 1

Objectives

  • Configure multi-area OSPF on a router.
  • Verify multi-area behavior.
  • Create an OSPF virtual link.
  • Summarize an area.
  • Generate a default route into OSPF.

Background

You are responsible for configuring the new network to connect your company’s engineering, marketing, and accounting departments, represented by loopback interfaces on each of the three routers. The physical devices have just been installed and connected by serial cables. Configure multiple-area OSPFv2 to allow full connectivity between all departments.

In addition, R1 has a loopback interface representing a connection to the Internet. This connection will not be added into OSPFv2. R3 will have four additional loopback interfaces representing connections to branch offices.

Note: This lab uses Cisco 1941 routers with Cisco IOS Release 15.4 with IP Base. The switches are Cisco WSC2960- 24TT-L with Fast Ethernet interfaces, therefore the router will use routing metrics associated with a 100 Mb/s interface. Depending on the router or switch model and Cisco IOS Software version, the commands available and output produced might vary from what is shown in this lab.

Required Resources

  • 3 routers (Cisco IOS Release 15.2 or comparable)
  • Serial and Ethernet cables

Step 0: Suggested starting configurations.

a. Apply the following configuration to each router along with the appropriate hostname. The exec timeout 0 0 command should only be used in a lab environment.

Router(config)# no ip domain-lookup
Router(config)# line con 0
Router(config-line)# logging synchronous
Router(config-line)# exec-timeout 0 0

Step 1: Configure addressing and loopbacks.

Using the addressing scheme in the diagram, apply IP addresses to the serial interfaces on R1, R2, and R3. Create loopbacks on R1, R2, and R3, and address them according to the diagram.

R1# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)# interface loopback 1
R1(config-if)# description Engineering Department
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# interface loopback 30
R1(config-if)# ip address 172.30.30.1 255.255.255.252
R1(config-if)# interface serial 0/0/0
R1(config-if)# ip address 10.1.12.1 255.255.255.0
R1(config-if)# clockrate 64000
R1(config-if)# no shutdown

R2# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)# interface loopback 2
R2(config-if)# description Marketing Department
R2(config-if)# ip address 10.1.2.1 255.255.255.0
R2(config-if)# interface serial 0/0/0
R2(config-if)# ip address 10.1.12.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# interface serial 0/0/1
R2(config-if)# ip address 10.1.23.2 255.255.255.0
R2(config-if)# clockrate 64000
R2(config-if)# no shutdown

R3# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)# interface loopback 3
R3(config-if)# description Accounting Department
R3(config-if)# ip address 10.1.3.1 255.255.255.0
R3(config-if)# interface loopback 100
R3(config-if)# ip address 192.168.100.1 255.255.255.0
R3(config-if)# interface loopback 101
R3(config-if)# ip address 192.168.101.1 255.255.255.0
R3(config-if)# interface loopback 102
R3(config-if)# ip address 192.168.102.1 255.255.255.0
R3(config-if)# interface loopback 103
R3(config-if)# ip address 192.168.103.1 255.255.255.0
R3(config-if)# interface serial 0/0/1
R3(config-if)# ip address 10.1.23.3 255.255.255.0
R3(config-if)# no shutdown

Step 2: Add interfaces into OSPF.

a. Create OSPF process 1 and OSPF router ID on all three routers. Using the network command, configure the subnet of the serial link between R1 and R2 to be in OSPF area 0. Add loopback 1 on R1 and loopback 2 on R2 into OSPF area 0.

Note: The default behavior of OSPF for loopback interfaces is to advertise a 32-bit host route. To ensure that the full /24 network is advertised, use the ip ospf network point-to-point command. Change the network type on the loopback interfaces so that they are advertised with the correct subnet.

R1(config)# router ospf 1
R1(config-router)# router-id 1.1.1.1
R1(config-router)# network 10.1.12.0 0.0.0.255 area 0
R1(config-router)# network 10.1.1.0 0.0.0.255 area 0
R1(config-router)# exit
R1(config)# interface loopback 1
R1(config-if)# ip ospf network point-to-point
R1(config-if)# end

The show ip ospf command should be used to verify the OSPF router ID. If the OSPF router ID is using a 32-bit value other than the one specified by the router-id command, you can reset the router ID by using the clear ip ospf pid process command and re-verify using the command show ip ospf.

R1# show ip ospf
 Routing Process "ospf 1" with ID 172.30.30.1
 Start time: 04:19:23.024, Time elapsed: 00:31:01.416
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Supports NSSA (compatible with RFC 3101)
 Event-log enabled, Maximum number of events: 1000, Mode: cyclic
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa

R1# clear ip ospf 1 process
Reset OSPF process 1? [no]: yes
R1# show ip ospf
 Routing Process "ospf 1" with ID 1.1.1.1
 Start time: 04:19:23.024, Time elapsed: 00:31:01.416
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Supports NSSA (compatible with RFC 3101)
 Event-log enabled, Maximum number of events: 1000, Mode: cyclic
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa

R1#

R2(config)# router ospf 1
R2(config-router)# router-id 2.2.2.2
R2(config-router)# network 10.1.12.0 0.0.0.255 area 0
R2(config-router)# network 10.1.2.0 0.0.0.255 area 0
R2(config-router)# exit
R2(config)# interface loopback 2
R2(config-if)# ip ospf network point-to-point
R2(config-if)# end

Again, the show ip ospf command should be used to verify the OSPF router ID. If the OSPF router ID is using a 32-bit value other than the one specified by the router-id command, you can reset the router ID by using the clear ip ospf pid process command and re-verify using the command show ip ospf.

b. Verify that you can see OSPF neighbors in the show ip ospf neighbors output on both routers. Verify that the routers can see each other’s loopback with the show ip route command.

R1# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:00:30 10.1.12.2 Serial0/0/0
R1# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.1.1.0/24 is directly connected, Loopback1
L        10.1.1.1/32 is directly connected, Loopback1
O        10.1.2.0/24 [110/65] via 10.1.12.2, 00:05:04, Serial0/0/0
C        10.1.12.0/24 is directly connected, Serial0/0/0
L        10.1.12.1/32 is directly connected, Serial0/0/0
      172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.30.30.0/30 is directly connected, Loopback30
L        172.30.30.1/32 is directly connected, Loopback30
R1#

R2# show ip ospf neighbor

Neighbor ID      Pri      State         Dead Time     Address      Interface
1.1.1.1            0      FULL/  -      00:00:30      10.1.12.1    Serial0/0/0

R2# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O        10.1.1.0/24 [110/65] via 10.1.12.1, 00:06:33, Serial0/0/0
C        10.1.2.0/24 is directly connected, Loopback2
L        10.1.2.1/32 is directly connected, Loopback2
C        10.1.12.0/24 is directly connected, Serial0/0/0
L        10.1.12.2/32 is directly connected, Serial0/0/0
C        10.1.23.0/24 is directly connected, Serial0/0/1
L        10.1.23.2/32 is directly connected, Serial0/0/1
R2#

c. Add the subnet between R2 and R3 into OSPF area 23 using the network command. Add loopback 3 on R3 into area 23.

R2(config)# router ospf 1
R2(config-router)# network 10.1.23.0 0.0.0.255 area 23

R3(config)# router ospf 1
R3(config-router)# router-id 3.3.3.3
R3(config-router)# network 10.1.23.0 0.0.0.255 area 23
R3(config-router)# network 10.1.3.0 0.0.0.255 area 23
R3(config-router)# exit
R3(config)# interface loopback 3
R3(config-if)# ip ospf network point-to-point

Again, the show ip ospf command should used to verify the OSPF router ID. If the OSPF router ID is using a 32- bit value other than the one specified by the router-id command, you can reset the router ID by using the clear ip ospf pid process command and re-verify using the command show ip ospf.

d. Verify that this neighbor relationship comes up with the show ip ospf neighbors command.

R2# show ip ospf neighbor

Neighbor ID      Pri   State        Dead Time        Address      Interface
1.1.1.1            0   FULL/  -     00:00:35         10.1.12.1    Serial0/0/0
3.3.3.3            0   FULL/  -     00:00:33         10.1.23.3    Serial0/0/1
R2#

Step 3: Create a virtual link.

e. Add loopbacks 100 through 103 on R3 to R3’s OSPF process in area 100 using the network command. Change the network type to advertise the correct subnet mask.

R3(config)# router ospf 1
R3(config-router)# network 192.168.100.0 0.0.3.255 area 100
R3(config-router)# exit
R3(config)# interface loopback 100
R3(config-if)# ip ospf network point-to-point
R3(config-if)# interface loopback 101
R3(config-if)# ip ospf network point-to-point
R3(config-if)# interface loopback 102
R3(config-if)# ip ospf network point-to-point
R3(config-if)# interface loopback 103
R3(config-if)# ip ospf network point-to-point

f. Look at the output of the show ip route command on R2. Notice that the routes to those networks do not appear. The reason for this behavior is that area 100 on R3 is not connected to the backbone. It is only connected to area 23. If an area is not connected to the backbone, its routes are not advertised outside of its area.

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
O        10.1.1.0/24 [110/65] via 10.1.12.1, 00:09:22, Serial0/0/0
C        10.1.2.0/24 is directly connected, Loopback2
L        10.1.2.1/32 is directly connected, Loopback2
O        10.1.3.0/24 [110/65] via 10.1.23.3, 00:08:03, Serial0/0/1
C        10.1.12.0/24 is directly connected, Serial0/0/0
L        10.1.12.2/32 is directly connected, Serial0/0/0
C        10.1.23.0/24 is directly connected, Serial0/0/1
L        10.1.23.2/32 is directly connected, Serial0/0/1
R2#

What would happen if routes could pass between areas without going through the backbone?
____________________________________________________________________

You can get around this situation by creating a virtual link. A virtual link is an OSPF feature that creates a logical extension of the backbone area across a regular area, without actually adding any physical interfaces into area 0.

Note: Prior to creating a virtual link you need to identify the OSPF router ID for the routers involved (R2 and R3), using a command such as show ip ospf, show ip protocols or show ip ospf interface. The output for the show ip ospf command on R1 and R3 is shown below.

R2# show ip ospf
Routing Process "ospf 1" with ID 2.2.2.2
<output omitted>

R3# show ip ospf
Routing Process "ospf 1" with ID 3.3.3.3
<output omitted>

g. Create a virtual link using the area transit_area virtual-link router-id OSPF configuration command on both R2 and R3.

R2(config)# router ospf 1
R2(config-router)# area 23 virtual-link 3.3.3.3
R2(config-router)#

R3(config)# router ospf 1
R3(config-router)# area 23 virtual-link 2.2.2.2
*Aug 9 12:47:46.110: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on OSPF_VL0 from
LOADING to FULL, Loading Done
R3(config-router)#

Notice after virtual links are established IOS will report full adjacency between both routers.

h. After you see the adjacency over the virtual interface come up, issue the show ip route command on R2 and see the routes from area 100. You can verify the virtual link with the show ip ospf neighbor and show ip ospf interface commands.

R2# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
O        10.1.1.0/24 [110/65] via 10.1.12.1, 00:18:16, Serial0/0/0
C        10.1.2.0/24 is directly connected, Loopback2
L        10.1.2.1/32 is directly connected, Loopback2
O        10.1.3.0/24 [110/65] via 10.1.23.3, 00:16:57, Serial0/0/1
C        10.1.12.0/24 is directly connected, Serial0/0/0
L        10.1.12.2/32 is directly connected, Serial0/0/0
C        10.1.23.0/24 is directly connected, Serial0/0/1
L        10.1.23.2/32 is directly connected, Serial0/0/1
O IA 192.168.100.0/24 [110/65] via 10.1.23.3, 00:03:28, Serial0/0/1
O IA 192.168.101.0/24 [110/65] via 10.1.23.3, 00:03:28, Serial0/0/1
O IA 192.168.102.0/24 [110/65] via 10.1.23.3, 00:03:28, Serial0/0/1
O IA 192.168.103.0/24 [110/65] via 10.1.23.3, 00:03:28, Serial0/0/1
R2#

R2# show ip ospf neighbor
Neighbor ID      Pri    State          Dead Time     Address      Interface
3.3.3.3            0    FULL/  -           -         10.1.23.3    OSPF_VL0
1.1.1.1            0    FULL/  -       00:00:38      10.1.12.1    Serial0/0/0
3.3.3.3            0    FULL/  -       00:00:35      10.1.23.3    Serial0/0/1

R2# show ip ospf interface
OSPF_VL0 is up, line protocol is up
  Internet Address 10.1.23.2/24, Area 0, Attached via Not Attached
  Process ID 1, Router ID 2.2.2.2, Network Type VIRTUAL_LINK, Cost: 64
  Topology-MTID    Cost    Disabled    Shutdown    Topology Name
        0           64        no          no            Base
  Configured as demand circuit
  Run as demand circuit
  DoNotAge LSA allowed
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
   oob-resync timeout 40
   Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 3/4, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 3.3.3.3 (Hello suppressed)
  Suppress hello for 1 neighbor(s)
<output omitted>

When are virtual links useful?
______________________________________________________________________

Why are virtual links a poor long-term solution?
______________________________________________________________________

Step 4: Summarize an area.

Loopbacks 100 through 103 can be summarized into one supernet of 192.168.100.0 /22. You can configure area 100 to be represented by this single summary route.

i. Configure R3 (the ABR) to summarize this area using the area area range network mask command.

R3(config)# router ospf 1
R3(config-router)# area 100 range 192.168.100.0 255.255.252.0

j. You can see the summary route on R2 with the show ip route and show ip ospf database commands.

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
O        10.1.1.0/24 [110/65] via 10.1.12.1, 00:24:14, Serial0/0/0
C        10.1.2.0/24 is directly connected, Loopback2
L        10.1.2.1/32 is directly connected, Loopback2
O        10.1.3.0/24 [110/65] via 10.1.23.3, 00:22:55, Serial0/0/1
C        10.1.12.0/24 is directly connected, Serial0/0/0
L        10.1.12.2/32 is directly connected, Serial0/0/0
C        10.1.23.0/24 is directly connected, Serial0/0/1
L        10.1.23.2/32 is directly connected, Serial0/0/1
O IA 192.168.100.0/22 [110/65] via 10.1.23.3, 00:00:04, Serial0/0/1
R2#

R2# show ip ospf database

            OSPF Router with ID (2.2.2.2) (Process ID 1)

               Router Link States (Area 0)
Link ID        ADV Router       Age           Seq#          Checksum Link count
1.1.1.1        1.1.1.1          98            0x80000006    0x00AA98 3
2.2.2.2        2.2.2.2          608           0x80000006    0x00AF0B 4
3.3.3.3        3.3.3.3          1       (DNA) 0x80000002    0x00ADFC 1

               Summary Net Link States (Area 0)

Link ID        ADV Router       Age            Seq#          Checksum
10.1.3.0       2.2.2.2          1408           0x80000001    0x002ABB
10.1.3.0       3.3.3.3          1        (DNA) 0x80000002    0x008799
10.1.23.0      2.2.2.2          1482           0x80000001    0x00438F
10.1.23.0      3.3.3.3          1        (DNA) 0x80000002    0x0023AA
192.168.100.0  3.3.3.3          1        (DNA) 0x80000003    0x00243F

               Router Link States (Area 23)

Link ID        ADV Router       Age            Seq#          Checksum Link count
2.2.2.2        2.2.2.2          608            0x80000003    0x0099A1 2
3.3.3.3        3.3.3.3          609            0x80000005    0x00E92B 3

               Summary Net Link States (Area 23)

Link ID        ADV Router       Age            Seq#          Checksum
10.1.1.0       2.2.2.2          1482           0x80000002    0x003EA8
10.1.2.0       2.2.2.2          1482           0x80000002    0x00B075
10.1.12.0      2.2.2.2          1482           0x80000002    0x00BA22
192.168.100.0  3.3.3.3          43             0x80000002    0x00263E
R2#

k. Notice on R3 that OSPF has generated a summary route pointing toward Null0.

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O       10.1.1.0/24 [110/129] via 10.1.23.2, 00:02:17, Serial0/0/1
O       10.1.2.0/24 [110/65] via 10.1.23.2, 00:02:17, Serial0/0/1
C       10.1.3.0/24 is directly connected, Loopback3
L       10.1.3.1/32 is directly connected, Loopback3
O       10.1.12.0/24 [110/128] via 10.1.23.2, 00:02:17, Serial0/0/1
C       10.1.23.0/24 is directly connected, Serial0/0/1
L       10.1.23.3/32 is directly connected, Serial0/0/1
O    192.168.100.0/22 is a summary, 00:02:17, Null0
     192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.100.0/24 is directly connected, Loopback100
L       192.168.100.1/32 is directly connected, Loopback100
     192.168.101.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.101.0/24 is directly connected, Loopback101
L       192.168.101.1/32 is directly connected, Loopback101
     192.168.102.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.102.0/24 is directly connected, Loopback102
L       192.168.102.1/32 is directly connected, Loopback102
     192.168.103.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.103.0/24 is directly connected, Loopback103
L       192.168.103.1/32 is directly connected, Loopback103
R3#

This behavior is known as sending unknown traffic to the “bit bucket.” This means that if the router advertising the summary route receives a packet destined for something covered by that summary but not in the routing table, it drops it.

What is the reasoning behind this behavior?
_______________________________________________________

Step 5: Generate a default route into OSPF.

You can simulate loopback 30 on R1 to be a connection to the Internet. You do not need to advertise this specific network to the rest of the network. Instead, you can just have a default route for all unknown traffic to go to R1.

l. To have R1 generate a default route, use the OSPF configuration command default-information originate always. The always keyword is necessary for generating a default route in this scenario. Without this keyword, a default route is generated only into OSPF if one exists in the routing table.

R1(config)# router ospf 1
R1(config-router)# default-information originate always

m. Verify that the default route appears on R2 and R3 with the show ip route command.

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 10.1.12.1 to network 0.0.0.0

O*E2 0.0.0.0/0 [110/1] via 10.1.12.1, 00:00:13, Serial0/0/0
     10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
O       10.1.1.0/24 [110/65] via 10.1.12.1, 00:28:42, Serial0/0/0
C       10.1.2.0/24 is directly connected, Loopback2
L       10.1.2.1/32 is directly connected, Loopback2
O       10.1.3.0/24 [110/65] via 10.1.23.3, 00:27:23, Serial0/0/1
C       10.1.12.0/24 is directly connected, Serial0/0/0
L       10.1.12.2/32 is directly connected, Serial0/0/0
C       10.1.23.0/24 is directly connected, Serial0/0/1
L       10.1.23.2/32 is directly connected, Serial0/0/1
O IA 192.168.100.0/22 [110/65] via 10.1.23.3, 00:04:32, Serial0/0/1
R2#

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 10.1.23.2 to network 0.0.0.0

O*E2 0.0.0.0/0 [110/1] via 10.1.23.2, 00:00:45, Serial0/0/1
     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O       10.1.1.0/24 [110/129] via 10.1.23.2, 00:05:08, Serial0/0/1
O       10.1.2.0/24 [110/65] via 10.1.23.2, 00:05:08, Serial0/0/1
C       10.1.3.0/24 is directly connected, Loopback3
L       10.1.3.1/32 is directly connected, Loopback3
O       10.1.12.0/24 [110/128] via 10.1.23.2, 00:05:08, Serial0/0/1
C       10.1.23.0/24 is directly connected, Serial0/0/1
L       10.1.23.3/32 is directly connected, Serial0/0/1
O    192.168.100.0/22 is a summary, 00:05:08, Null0
     192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.100.0/24 is directly connected, Loopback100
L       192.168.100.1/32 is directly connected, Loopback100
     192.168.101.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.101.0/24 is directly connected, Loopback101
L       192.168.101.1/32 is directly connected, Loopback101
     192.168.102.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.102.0/24 is directly connected, Loopback102
L       192.168.102.1/32 is directly connected, Loopback102
     192.168.103.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.103.0/24 is directly connected, Loopback103
L       192.168.103.1/32 is directly connected, Loopback103
R3#

n. You should be able to ping the interface connecting to the Internet from R2 or R3, despite never being advertised into OSPF.

R3# ping 172.30.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms
Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments