CCNP ROUTE Chapter 3 Lab 3-3, OSPFv3 Address Families (Version 7)

Topology

CCNP ROUTE Chapter 3 Lab 3-3, OSPFv3 Address Families (Version 7) 1

Objectives

  • Configure multi-area OSPFv3 for IPv4 AF.
  • Configure multi-area OSPFv3 for IPv6 AF.
  • Verify multi-area behavior.
  • Configure stub and totally stubby areas for both IPv4 and IPv6 AFs.

Background

In this lab, you will configure the network with multi-area OSPFv3 routing using the address family feature for both IPv4 and IPv6. For both OSPFv2 and OSPFv3, area 51 will be configured as a normal OSPF area, a stub area and then a totally stubby area.

Note: This lab uses Cisco 1941 routers with Cisco IOS Release 15.4 with IP Base. The switches are Cisco WSC2960-24TT-L with Fast Ethernet interfaces, therefore the router will use routing metrics associated with a 100 Mb/s interface. Depending on the router or switch model and Cisco IOS Software version, the commands available and output produced might vary from what is shown in this lab.

Required Resources

  • 4 routers (Cisco IOS Release 15.2 or comparable)
  • 4 switches (LAN interfaces)
  • Serial and Ethernet cables

Step 0: Suggested starting configurations.

a. Apply the following configuration to each router along with the appropriate hostname. The exec-timeout 0 0 command should only be used in a lab environment.

Router(config)# no ip domain-lookup
Router(config)# line con 0
Router(config-line)# logging synchronous
Router(config-line)# exec-timeout 0 0

Step 1: Configure the addressing and serial links.

a. Using the topology, configure the IPv4 and IPv6 addresses on the interfaces of each router.

R1(config)# interface GigabitEthernet0/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# ipv6 address FE80::1 link-local
R1(config-if)# ipv6 address 2001:DB8:CAFE:1::1/64
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface Serial0/0/0
R1(config-if)# ip address 192.168.2.1 255.255.255.252
R1(config-if)# ipv6 address FE80::1 link-local
R1(config-if)# ipv6 address 2001:DB8:CAFE:2::1/64
R1(config-if)# clock rate 64000
R1(config-if)# no shutdown
R2(config)# interface GigabitEthernet0/0
R2(config-if)# ip address 192.168.3.1 255.255.255.0
R2(config-if)# ipv6 address FE80::2 link-local
R2(config-if)# ipv6 address 2001:DB8:CAFE:3::1/64
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# interface Serial0/0/0
R2(config-if)# ip address 192.168.2.2 255.255.255.252
R2(config-if)# ipv6 address FE80::2 link-local
R2(config-if)# ipv6 address 2001:DB8:CAFE:2::2/64
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# interface Serial0/0/1
R2(config-if)# ip address 192.168.4.1 255.255.255.252
R2(config-if)# ipv6 address FE80::2 link-local
R2(config-if)# ipv6 address 2001:DB8:CAFE:4::1/64
R2(config-if)# clock rate 64000
R2(config-if)# no shutdown
R3(config)# interface GigabitEthernet0/0
R3(config-if)# ip address 192.168.5.1 255.255.255.0
R3(config-if)# ipv6 address FE80::3 link-local
R3(config-if)# ipv6 address 2001:DB8:CAFE:5::1/64
R3(config-if)# no shutdown
R3(config-if)# exit
R3(config)# interface Serial0/0/1
R3(config-if)# ip address 192.168.4.2 255.255.255.252
R3(config-if)# ipv6 address FE80::3 link-local
R3(config-if)# ipv6 address 2001:DB8:CAFE:4::2/64
R3(config-if)# no shutdown
R3(config-if)# exit
R3(config)# interface Serial0/1/0
R3(config-if)# ip address 192.168.77.2 255.255.255.0
R3(config-if)# ipv6 address FE80::3 link-local
R3(config-if)# ipv6 address 2001:DB8:FEED:77::2/64
R3(config-if)# clock rate 64000
R3(config-if)# no shutdown
R3(config-if)#
R4(config)# interface Serial0/0/0
R4(config-if)# ip address 192.168.77.1 255.255.255.0
R4(config-if)# ipv6 address FE80::4 link-local
R4(config-if)# ipv6 address 2001:DB8:FEED:77::1/64
R4(config-if)# no shutdown
R4(config-if)# exit
R4(config)# interface gigabitethernet 0/0
R4(config-if)# ip address 192.168.99.1 255.255.255.0
R4(config-if)# ipv6 address 2001:db8:99:1::1/64
R4(config-if)# no shutdown
R4(config-if)# exit
R4(config)# ipv6 unicast-routing
R4(config)# ipv6 route 2001:DB8:CAFE::/48 2001:DB8:FEED:77::2
R4(config)# ip route 0.0.0.0 0.0.0.0 192.168.77.2
R4(config)#

b. Verify connectivity by pinging across each of the local networks connected to each router.

c. Issue the show ip interface brief and the show ipv6 interface brief command on each router. These commands display a brief listing of the interfaces, their status, and their IP addresses. Router R1 is shown as an example.

R1# show ip interface brief 
Interface                  IP-Address      OK? Method Status                Protocol 
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down
GigabitEthernet0/0         192.168.1.1     YES manual up                    up       
GigabitEthernet0/1         unassigned      YES unset  administratively down down     
Serial0/0/0                192.168.2.1     YES manual up                    up       
Serial0/0/1                unassigned      YES unset  administratively down down     
R1# show ipv6 interface brief 
Em0/0                  [administratively down/down] 
    unassigned 
GigabitEthernet0/0     [up/up] 
    FE80::1 
    2001:DB8:CAFE:1::1 
GigabitEthernet0/1     [administratively down/down]
     unassigned 
Serial0/0/0            [up/up] 
    FE80::1 
    2001:DB8:CAFE:2::1 
Serial0/0/1            [administratively down/down] 
    unassigned 
R1#

Step 2: Configure and verify OSPFv3 address families for IPv4 and IPv6.

OSPFv3 with the addresses family (AF) unifies OSPF configuration for both IPv4 and IPv6. OSPFv3 with address families also combines neighbor tables and the LSDB under a single OSPF process. OSPFv3 messages are sent over IPv6 and therefore requires that IPv6 routing is enabled and that the interface has a link-local IPv6 address. This is the requirement even if only the IPv4 AF is configured.

Note: After configuring the OSPFv3 address families, the show ospfv3 command should used to verify the OSPF router ID for both the IPv4 and IPv6 AF. If the OSPF router ID is using a 32-bit value other than the one specified by the router-id command, you can reset the router ID by using the clear ospfv3 pid process command and reverify using the command show ospfv3.

a. After enabling IPv6 unicast routing, configure the OSPFv4 IPv4 AF on R3 using the router ospf pid command.

The ? is used to see the two address families available.
R3(config)# ipv6 unicast-routing
R3(config)# router ospfv3 1
R3(config-router)# address-family ?
  ipv4 Address family
  ipv6 Address family
R3(config-router)#

b. Enter the IPv4 address family configuration mode using the command address-family ipv4 unicast. The ? is used to examine the options in the address-family configuration mode. Some of the more common configuration commands are high-lighted. Use the router-id command to configure the router ID for the IPv4 AF.

R3(config-router)# address-family ipv4 unicast 
R3(config-router-af)# ? 
Router Address Family configuration commands: 
  area                   OSPF area parameters 
  authentication         Authentication parameters 
  auto-cost              Calculate OSPF interface cost according to bandwidth 
  bfd                    BFD configuration commands 
  compatible             Compatibility list 
  default                Set a command to its defaults 
  default-information    Control distribution of default information 
  default-metric         Set metric of redistributed routes 
  discard-route          Enable or disable discard-route installation 
  distance               Define an administrative distance 
  distribute-list        Filter networks in routing updates 
  event-log              Event Logging 
  exit-address-family    Exit from Address Family configuration mode 
  graceful-restart       Graceful-restart options 
  help                   Description of the interactive help system 
  interface-id           Source of the interface ID 
  limit                  Limit a specific OSPF feature 
  local-rib-criteria     Enable or disable usage of local RIB as route criteria 
  log-adjacency-changes  Log changes in adjacency state 
  max-lsa                Maximum number of non self-generated LSAs to accept 
  max-metric             Set maximum metric 
  maximum-paths          Forward packets over multiple paths                       
  no                     Negate a command or set its defaults 
  passive-interface      Suppress routing updates on an interface 
  prefix-suppression     Enable prefix suppression 
  queue-depth            Hello/Router process queue depth 
  redistribute           Redistribute information from another routing protocol 
  router-id              router-id for this OSPF process 
  shutdown               Shutdown the router process 
  snmp                   Modify snmp parameters 
  summary-prefix         Configure IP address summaries 
  timers                 Adjust routing timers 

R3(config-router-af)# router-id 3.3.3.3 
R3(config-router-af)#

c. Use the passive-interface command to configure the G0/0 interface as passive for the IPv4 AF.

R3(config-router-af)# passive-interface gigabitethernet 0/0

d. Exit the IPv4 address family configuration mode and enter the IPv6 address configuration mode. The exitaddress-family (or a shorter version of exit) command is used exit address family configuration mode. Issue the address-family ipv6 unicast command to enter the IPv6 AF. For the IPv6 AF, use the router-id command to configure the router ID and the passive-interface command to configure G0/0 as a passive interface. Although it isn’t necessary, a different router ID is being used for the IPv6 AF. The exit command is used to return to global configuration mode.

R3(config-router-af)# exit-address-family
R3(config-router)# address-family ipv6 unicast
R3(config-router-af)# router-id 3.3.3.6
R3(config-router-af)# passive-interface gigabitethernet 0/0
R3(config-router-af)# exit-address-family
R3(config-router)# exit
R3(config)#

e. OSPFv3 is enabled directly on the interfaces for both IPv4 and IPv6 AFs using the ospfv3 pid [ ipv4 | ipv6 ] area area-id interface command. Use this command to enable OSPFv3 on both of R3’s interfaces in area 0.

R3(config)# interface gigabitethernet 0/0
R3(config-if)# ospfv3 1 ipv4 area 0
R3(config-if)# ospfv3 1 ipv6 area 0
R3(config-if)# exit
R3(config)# interface serial 0/0/1
R3(config-if)# ospfv3 1 ipv4 area 0
R3(config-if)# ospfv3 1 ipv6 area 0
R3(config-if)#

f. Apply similar commands used on R3 to configure OSPFv3 IPv4 and IPv6 AFs on R2. Router R2 is an ABR so be sure to configure the proper area ID to each interface. The OSPF process ID does not need to match other routers.

R2(config)# router ospfv3 1
R2(config-router)# address-family ipv4 unicast
R2(config-router-af)# router-id 2.2.2.2
R2(config-router-af)# passive-interface gigabitethernet 0/0
R2(config-router-af)# exit-address-family
R2(config-router)# address-family ipv6 unicast
R2(config-router-af)# router-id 2.2.2.6
R2(config-router-af)# passive-interface gigabitethernet 0/0
R2(config-router-af)# exit-address-family
R2(config-router)# interface serial 0/0/1
R2(config-if)# ospfv3 1 ipv4 area 0
R2(config-if)# ospfv3 1 ipv6 area 0
R2(config-if)# exit
R2(config)# interface gigabitethernet 0/0
R2(config-if)# ospfv3 1 ipv4 area 0
R2(config-if)# ospfv3 1 ipv6 area 0
R2(config-if)# exit
R2(config)# interface serial 0/0/0
R2(config-if)# ospfv3 1 ipv4 area 51
R2(config-if)# ospfv3 1 ipv6 area 51
R2(config-if)#

g. Finally, issue these same type of commands to configure OSPFv3 for the IPv4 and IPv6 AFs on R1, an internal router in area 51.

R1(config)# ipv6 unicast-routing
R1(config)# router ospfv3 1
R1(config-router)# address-family ipv4 unicast
R1(config-router-af)# router-id 1.1.1.1
R1(config-router-af)# passive-interface gigabitethernet 0/0
R1(config-router-af)# exit-address-family
R1(config-router)# address-family ipv6 unicast
R1(config-router-af)# router-id 1.1.1.6
R1(config-router-af)# passive-interface gigabitethernet 0/0
R1(config-router-af)# exit-address-family
R1(config-router)# exit
R1(config)# interface gigabitethernet 0/0
R1(config-if)# ospfv3 1 ipv4 area 51
R1(config-if)# ospfv3 1 ipv6 area 51
R1(config-if)# exit
R1(config)# interface serial 0/0/0
R1(config-if)# ospfv3 1 ipv4 area 51
R1(config-if)# ospfv3 1 ipv6 area 51
R1(config-if)#

h. Verify that the routers have OSPFv3 neighbors. First, issue both the show ip ospf neighbors and show ipv6 ospf neighbors command on R2. Notice which router IDs are displayed in the show ipv6 ospf neighbor output.

R2# show ip ospf neighbor
R2#
R2# show ipv6 ospf neighbor

              OSPFv3 Router with ID (2.2.2.6) (Process ID 1)

Neighbor ID    Pri      State         Dead Time    Interface ID   Interface
3.3.3.6          0      FULL/    -    00:00:39     6              Serial0/0/1
1.1.1.6          0      FULL/    -    00:00:36     6              Serial0/0/0
R2#

Why doesn’t the show ip ospf neighbor command display any output?

______________________________________________________________________

 

Why does the show ipv6 ospf neighbor command only display OSPFv3 neighbors in the IPv6 AF?
______________________________________________________________________

i. Issue the show ospfv3 neighbor command to verify OSPFv3 neighbor adjacencies for both the IPv4 and IPv6 AFs. The output for R2 is displayed.

R2# show ospfv3 neighbor

              OSPFv3 1 address-family ipv4 (router-id 2.2.2.2)

Neighbor ID        Pri    State            Dead Time   Interface ID   Interface
3.3.3.3              0    FULL/   -        00:00:30    6              Serial0/0/1
1.1.1.1              0    FULL/   -        00:00:34    6              Serial0/0/0

              OSPFv3 1 address-family ipv6 (router-id 2.2.2.6)

Neighbor ID        Pri    State            Dead Time   Interface ID   Interface
3.3.3.6              0    FULL/   -        00:00:30    6              Serial0/0/1
1.1.1.6              0    FULL/   -        00:00:35    6              Serial0/0/0
R2#

d. The IPv4 and IPv6 routing tables can be verified by using the show ip route and show ipv6 route commands. Each router should see all IPv4 networks and IPv6 prefixes in the OSPFv3 routing domain including those with passive interfaces. The output for R3 is shown below.

R3# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

O IA 192.168.1.0/24 [110/129] via 192.168.4.1, 00:07:37, Serial0/0/1
     192.168.2.0/30 is subnetted, 1 subnets
O IA 192.168.2.0 [110/128] via 192.168.4.1, 00:07:37, Serial0/0/1
O  192.168.3.0/24 [110/65] via 192.168.4.1, 00:07:47, Serial0/0/1
     192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
C      192.168.4.0/30 is directly connected, Serial0/0/1
L      192.168.4.2/32 is directly connected, Serial0/0/1
     192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C      192.168.5.0/24 is directly connected, GigabitEthernet0/0
L      192.168.5.1/32 is directly connected, GigabitEthernet0/0
     192.168.77.0/24 is variably subnetted, 2 subnets, 2 masks
C      192.168.77.0/24 is directly connected, Serial0/1/0
L      192.168.77.2/32 is directly connected, Serial0/1/0
R3#
R3# show ipv6 route
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       a - Application
OI 2001:DB8:CAFE:1::/64 [110/129]
    via FE80::2, Serial0/0/1
OI 2001:DB8:CAFE:2::/64 [110/128]
    via FE80::2, Serial0/0/1
O 2001:DB8:CAFE:3::/64 [110/65]
    via FE80::2, Serial0/0/1
C 2001:DB8:CAFE:4::/64 [0/0]
    via Serial0/0/1, directly connected
L 2001:DB8:CAFE:4::2/128 [0/0]
    via Serial0/0/1, receive
C 2001:DB8:CAFE:5::/64 [0/0]
    via GigabitEthernet0/0, directly connected
L 2001:DB8:CAFE:5::1/128 [0/0]
    via GigabitEthernet0/0, receive
C 2001:DB8:FEED:77::/64 [0/0]
    via Serial0/1/0, directly connected
L 2001:DB8:FEED:77::2/128 [0/0]
    via Serial0/1/0, receive
L FF00::/8 [0/0]
    via Null0, receive
R3#

e. Understanding the difference between commands associated with OSPFv2 and OSPFv3 can seem challenging at times. The show ip route ospfv3 command is used to view OSPFv3 routes in the IPv4 routing table. The show ipv6 route ospf command is used to view OSPFv3 routes in the IPv6 routing table. The show ipv6 route ospf command is the same command used in with traditional OSPFv3 for IPv6.

R3# show ip route ospf
R3#
R3# show ip route ospfv3
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

O IA  192.168.1.0/24 [110/129] via 192.168.4.1, 00:17:13, Serial0/0/1
      192.168.2.0/30 is subnetted, 1 subnets
O IA     192.168.2.0 [110/128] via 192.168.4.1, 00:17:13, Serial0/0/1
O     192.168.3.0/24 [110/65] via 192.168.4.1, 00:17:23, Serial0/0/1
R3#
R3# show ipv6 route ospf
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       a - Application
OI  2001:DB8:CAFE:1::/64 [110/129]
     via FE80::2, Serial0/0/1
OI  2001:DB8:CAFE:2::/64 [110/128]
     via FE80::2, Serial0/0/1
O  2001:DB8:CAFE:3::/64 [110/65]
     via FE80::2, Serial0/0/1
R3#

Why doesn’t the show ip route ospf command display any routes?
______________________________________________________________________

f. Configure IPv4 and IPv6 default routes on the ASBR R3 forwarding traffic to R4. Propagate both default routes into OSPFv3 within the appropriate address family.

R3(config)# ip route 0.0.0.0 0.0.0.0 192.168.77.1
R3(config)# ipv6 route ::/0 2001:db8:feed:77::1
R3(config)# router ospfv3 1
R3(config-router)# address-family ipv4 unicast
R3(config-router-af)# default-information originate
R3(config-router-af)# exit-address-family
R3(config-router)# address-family ipv6 unicast
R3(config-router-af)# default-information originate
R3(config-router-af)# exit-address-family
R3(config-router)# end
R3#

g. Issue the show ip route static and show ipv6 route static commands on R3 to verify the static route is in the IPv4 and IPv6 routing tables.

R3# show ip route static
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.77.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.77.1
R3# show ipv6 route static
IPv6 Routing Table - default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       a - Application
S  ::/0 [1/0]
    via 2001:DB8:FEED:77::1
R3#

h. Configure IPv4 and IPv6 static routes on the ASBR, R3 for the 192.168.99.0/24 and 2001:db8:99:1::/64 network on R4. Redistribute the static route into OSPFv3 IPv4 and IPv6 AFs using the redistribute static command in each address family configuration mode. The redistribute command is discussed in more detail in later chapters.

R3(config)# ip route 192.168.99.0 255.255.255.0 192.168.77.1
R3(config)# ipv6 route 2001:db8:99:1::/64 2001:db8:feed:77::1
R3(config)# router ospfv3 1
R3(config-router)# address-family ipv4 unicast
R3(config-router-af)# redistribute static
R3(config-router-af)# exit-address-family
R3(config-router)# address-family ipv6 unicast
R3(config-router-af)# redistribute static
R3(config-router-af)# end
R3#

i. Issue the show ip route ospfv3 and show ipv6 route ospf commands on R1 to verify that the default route and the redistributed static route are being advertised into the OSPFv3 domain.

R1# show ip route ospfv3
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.2.2 to network 0.0.0.0

O*E2  0.0.0.0/0 [110/1] via 192.168.2.2, 00:13:18, Serial0/0/0
O IA  192.168.3.0/24 [110/65] via 192.168.2.2, 00:54:00, Serial0/0/0
      192.168.4.0/30 is subnetted, 1 subnets
O IA     192.168.4.0 [110/128] via 192.168.2.2, 00:54:00, Serial0/0/0
O IA  192.168.5.0/24 [110/129] via 192.168.2.2, 00:54:00, Serial0/0/0
O E2  192.168.99.0/24 [110/20] via 192.168.2.2, 00:03:40, Serial0/0/0
R1#
R1# show ipv6 route ospf
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       a - Application
OE2 ::/0 [110/1], tag 1
     via FE80::2, Serial0/0/0
OE2 2001:DB8:99:1::/64 [110/20]
     via FE80::2, Serial0/0/0
OI 2001:DB8:CAFE:3::/64 [110/65]
     via FE80::2, Serial0/0/0
OI 2001:DB8:CAFE:4::/64 [110/128]
     via FE80::2, Serial0/0/0
OI 2001:DB8:CAFE:5::/64 [110/129]
     via FE80::2, Serial0/0/0
R1#

Step 3: Configure an OSPFv2 stub area.

a. Under the OSPFv3 process for R1 and R2, for both the IPv4 and IPv6 AFs, configure area 51 as a stub area using the area area stub command. The adjacency between the two routers might go down during the transition period, but it should come back up afterwards.

R1(config)# router ospfv3 1
R1(config-router)# address-family ipv4 unicast
R1(config-router-af)# area 51 stub
R1(config-router-af)# exit-address-family
R1(config-router)# address-family ipv6 unicast
R1(config-router-af)# area 51 stub
R2(config)# router ospfv3 1
R2(config-router)# address-family ipv4 unicast
R2(config-router-af)# area 51 stub
R2(config-router-af)# exit-address-family
R2(config-router)# address-family ipv6 unicast
R2(config-router-af)# area 51 stub

b. Confirm that both R1 and R2 are neighbors for both IPv4 and IPv6 AFs using the show ospfv3 neighbors command on R2.

R2# show ospfv3 neighbor

           OSPFv3 1 address-family ipv4 (router-id 2.2.2.2)

Neighbor ID     Pri    State          Dead Time   Interface ID    Interface
3.3.3.3           0    FULL/  -       00:00:34    6               Serial0/0/1
1.1.1.1           0    FULL/  -       00:00:32    6               Serial0/0/0

           OSPFv3 1 address-family ipv6 (router-id 2.2.2.6)

Neighbor ID     Pri    State           Dead Time   Interface ID   Interface
3.3.3.6           0    FULL/  -        00:00:36    6              Serial0/0/1
1.1.1.6           0    FULL/  -        00:00:32    6              Serial0/0/0
R2#

c. Issue the show ip route ospfv3 and show ipv6 route ospf commands on R1. Notice that R1 still has a default route pointing toward R2 but with a different cost than it had prior to being configured in a stub area. This is not the default route propagated by the ASBR R1, but the default route injected by the ABR of the stub area. R1 also does not receive any external routes, so it no longer has the 192.168.99.0/24 or the 2001:DB8:99:1::/64 networks in its IPv4 and IPv6 routing tables. Stub routers continue to receive inter-area routes.

R1# show ip route ospfv3
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.2.2 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/65] via 192.168.2.2, 00:07:17, Serial0/0/0
O IA  192.168.3.0/24 [110/65] via 192.168.2.2, 00:07:17, Serial0/0/0
      192.168.4.0/30 is subnetted, 1 subnets
O IA     192.168.4.0 [110/128] via 192.168.2.2, 00:07:17, Serial0/0/0
O IA  192.168.5.0/24 [110/129] via 192.168.2.2, 00:07:17, Serial0/0/0
R1#
R1# show ipv6 route ospf
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       a - Application
OI  ::/0 [110/65]
     via FE80::2, Serial0/0/0
OI  2001:DB8:CAFE:3::/64 [110/65]
     via FE80::2, Serial0/0/0
OI  2001:DB8:CAFE:4::/64 [110/128]
     via FE80::2, Serial0/0/0
OI  2001:DB8:CAFE:5::/64 [110/129]
     via FE80::2, Serial0/0/0
R1#

d. View the output of the show ospfv3 command on ABR R2 to see what type each area is and the number of interfaces in each area. Prior to issuing this command notice the show ip ospf command displays no output. Once again, this command is for OSPFv2, we are using OSPFv3. The show ip ospfv3 command might seem like a logical alternative, however it is not a legitimate option. OSPFv3 is a single process for both IPv4 and IPv6 address families, so the correct command is show ospfv3. This will display OSPFv3 information for both AFs.

R2# show ip ospf
R2#
R2# show ip ospfv3

% Invalid input detected at '^' marker.

R2# show ospfv3
 OSPFv3 1 address-family ipv4
 Router ID 2.2.2.2
 Supports NSSA (compatible with RFC 3101)
 Event-log enabled, Maximum number of events: 1000, Mode: cyclic
 It is an area border router
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Retransmission limit dc 24 non-dc 24
 Number of external LSA 2. Checksum Sum 0x012EE4
 Number of areas in this router is 2. 1 normal 1 stub 0 nssa
 Graceful restart helper support enabled
 Reference bandwidth unit is 100 mbps
 RFC1583 compatibility enabled
    Area BACKBONE(0)
        Number of interfaces in this area is 2
        SPF algorithm executed 4 times
        Number of LSA 9. Checksum Sum 0x03231F
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 51
        Number of interfaces in this area is 1
        It is a stub area
        Generates stub default route with cost 1
        SPF algorithm executed 5 times
        Number of LSA 10. Checksum Sum 0x03F9E0
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

OSPFv3 1 address-family ipv6
Router ID 2.2.2.6
Supports NSSA (compatible with RFC 3101)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Retransmission limit dc 24 non-dc 24
Number of external LSA 2. Checksum Sum 0x00CD5F
Number of areas in this router is 2. 1 normal 1 stub 0 nssa
Graceful restart helper support enabled
Reference bandwidth unit is 100 mbps
RFC1583 compatibility enabled
   Area BACKBONE(0)
       Number of interfaces in this area is 2
       SPF algorithm executed 6 times
       Number of LSA 9. Checksum Sum 0x05479C
       Number of DCbitless LSA 0
       Number of indication LSA 0
       Number of DoNotAge LSA 0
       Flood list length 0
   Area 51
       Number of interfaces in this area is 1
       It is a stub area
       Generates stub default route with cost 1
       SPF algorithm executed 6 times
       Number of LSA 10. Checksum Sum 0x052FC7
       Number of DCbitless LSA 0
       Number of indication LSA 0
       Number of DoNotAge LSA 0
       Flood list length 0
R2#

Step 4: Configure a totally stubby area.

Remember that a totally stubby area is a modified version of a stubby area. A totally stubby area ABR only allows in a single, default route from the backbone, injected by the ABR. To configure a totally stubby area, you only need to change a command at the ABR, R2 in this scenario. Under the router OSPFv3 process, you will enter the area 51 stub no-summary command for both the IPv4 and IPv6 AFs to replace the existing stub command for area 51. The no-summary option tells the router that this area will not receive summary (inter-area) routes.

a. To see how this works, issue the show ip route ospfv3 and show ipv6 route ospf commands on R1. Notice the inter-area routes, in addition to the default route generated by R2.

R1# show ip route ospfv3
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.2.2 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/65] via 192.168.2.2, 00:07:17, Serial0/0/0
O IA  192.168.3.0/24 [110/65] via 192.168.2.2, 00:07:17, Serial0/0/0
      192.168.4.0/30 is subnetted, 1 subnets
O IA     192.168.4.0 [110/128] via 192.168.2.2, 00:07:17, Serial0/0/0
O IA  192.168.5.0/24 [110/129] via 192.168.2.2, 00:07:17, Serial0/0/0
R1#
R1# show ipv6 route ospf
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       a - Application
OI  ::/0 [110/65]
     via FE80::2, Serial0/0/0
OI  2001:DB8:CAFE:3::/64 [110/65]
     via FE80::2, Serial0/0/0
OI  2001:DB8:CAFE:4::/64 [110/128]
     via FE80::2, Serial0/0/0
OI  2001:DB8:CAFE:5::/64 [110/129]
     via FE80::2, Serial0/0/0
R1#

b. Look at the output of the show ospfv3 database command on R2 to see which LSAs are in its OSPFv3 database. Notice that both the IPv4 and IPv6 AF LSAs are in the same LSDB. You will also notice OSPFv3 changed the names of two types of LSAs and added two others. For a comparison of OSPFv2 and OSPFv3 LSAs go to: https://supportforums.cisco.com/document/97766/comparing-ospfv3-ospfv2-routing-protocol

R2# show ospfv3 database

          OSPFv3 1 address-family ipv4 (router-id 2.2.2.2) 

                Router Link States (Area 0) 
ADV Router       Age         Seq#        Fragment ID  Link count  Bits 
 2.2.2.2         1251        0x80000007  0            1           B 
 3.3.3.3         764         0x80000009  0            1           E 

                Inter Area Prefix Link States (Area 0) 

ADV Router       Age         Seq#        Prefix 
 2.2.2.2         1251        0x80000003  192.168.2.0/30 
 2.2.2.2         1245        0x80000001  192.168.1.0/24 

                Link (Type-8) Link States (Area 0) 

ADV Router       Age         Seq#        Link ID    Interface 
 2.2.2.2         1251        0x80000003  3          Gi0/0 
 2.2.2.2         1251        0x80000003  6          Se0/0/1 
 3.3.3.3         1275        0x80000004  6          Se0/0/1 

                Intra Area Prefix Link States (Area 0) 

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID 
 2.2.2.2         1251        0x80000003  0          0x2001      0 
 3.3.3.3         1275        0x80000004  0          0x2001      0 

                Router Link States (Area 51) 
ADV Router       Age         Seq#        Fragment ID  Link count  Bits 
 1.1.1.1         1248        0x80000007  0            1           None 
 2.2.2.2         1247        0x80000008  0            1           B 

                Inter Area Prefix Link States (Area 51) 

ADV Router       Age         Seq#        Prefix 
 2.2.2.2         1251        0x80000003  192.168.5.0/24 
 2.2.2.2         1251        0x80000003  192.168.4.0/30 
 2.2.2.2         1251        0x80000003  192.168.3.0/24 
 2.2.2.2         1255        0x80000001  0.0.0.0/0 

                Link (Type-8) Link States (Area 51) 

ADV Router       Age         Seq#        Link ID    Interface 
 1.1.1.1         1250        0x80000004  6          Se0/0/0 
 2.2.2.2         1250        0x80000006  5          Se0/0/0 

                Intra Area Prefix Link States (Area 51) 

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID 
 1.1.1.1         1250        0x80000003  0          0x2001      0 
 2.2.2.2         1251        0x80000005  0          0x2001      0 

                Type-5 AS External Link States 

ADV Router       Age         Seq#        Prefix 
 3.3.3.3         764         0x80000002  0.0.0.0/0 
 3.3.3.3         259         0x80000002  192.168.99.0/24 

          OSPFv3 1 address-family ipv6 (router-id 2.2.2.6) 

                Router Link States (Area 0) 

ADV Router       Age         Seq#        Fragment ID  Link count  Bits 
 2.2.2.6         1287        0x80000008  0            1           B 
 3.3.3.6         752         0x8000000C  0            1           E 

                Inter Area Prefix Link States (Area 0) 

ADV Router       Age         Seq#        Prefix 
 2.2.2.6         1287        0x80000003  2001:DB8:CAFE:2::/64 
 2.2.2.6         1228        0x80000001  2001:DB8:CAFE:1::/64 

                Link (Type-8) Link States (Area 0) 

ADV Router       Age         Seq#        Link ID    Interface 
 2.2.2.6         1287        0x80000003  3          Gi0/0 
 2.2.2.6         1287        0x80000003  6          Se0/0/1 
 3.3.3.6         1268        0x80000003  6          Se0/0/1 

                Intra Area Prefix Link States (Area 0) 

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID 
 2.2.2.6         1287        0x80000003  0          0x2001      0 
 3.3.3.6         1268        0x80000003  0          0x2001      0 

                Router Link States (Area 51) 

ADV Router       Age         Seq#        Fragment ID  Link count  Bits 
 1.1.1.6         1233        0x80000008  0            1           None 
 2.2.2.6         1232        0x8000000A  0            1           B 

                Inter Area Prefix Link States (Area 51) 

ADV Router       Age         Seq#        Prefix 
 2.2.2.6         1287        0x80000003  2001:DB8:CAFE:4::/64 
 2.2.2.6         1287        0x80000003  2001:DB8:CAFE:3::/64 
 2.2.2.6         1287        0x80000003  2001:DB8:CAFE:5::/64 
 2.2.2.6         1240        0x80000001  ::/0 

                Link (Type-8) Link States (Area 51) 

ADV Router       Age         Seq#        Link ID    Interface 
 1.1.1.6         1304        0x80000004  6          Se0/0/0 
 2.2.2.6         1240        0x80000004  5          Se0/0/0 

                Intra Area Prefix Link States (Area 51) 

ADV Router       Age         Seq#        Link ID    Ref-lstype  Ref-LSID 
 1.1.1.6         1390        0x80000003  0          0x2001      0 
 2.2.2.6         1287        0x80000003  0          0x2001      0 

                Type-5 AS External Link States 

ADV Router       Age         Seq#        Prefix 
 3.3.3.6         752         0x80000002  ::/0 
 3.3.3.6         243         0x80000002  2001:DB8:99:1::/64 
R2#

c. Enter the area 51 stub no-summary command on R2 (the ABR) for both IPv4 and IPv6 AFs in the OSPFv3 process.

R2(config)# router ospfv3 1
R2(config-router)# address-family ipv4 unicast
R2(config-router-af)# area 51 stub no-summary
R2(config-router-af)# exit-address-family
R2(config-router)# address-family ipv6 unicast
R2(config-router-af)# area 51 stub no-summary
R2(config-router-af)#

d. Go back to R1 and issue the show ip route ospfv3 and show ipv6 route ospf commands. Notice that both routing tables only show a single incoming route from the ABR R2, the default route. The default route is injected by the ABR R2. There are no inter-area OSPFv3 routes and no external OSPFv3 routes.

R1# show ip route ospfv3
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.2.2 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/65] via 192.168.2.2, 00:30:38, Serial0/0/0
R1#
R1# show ipv6 route ospf
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       a - Application
OI  ::/0 [110/65]
     via FE80::2, Serial0/0/0
R1#

e. View the output of the show ospfv3 command on ABR R2 to see what type each area is and the number of interfaces in each area.

R2# show ospfv3
 OSPFv3 1 address-family ipv4
 Router ID 2.2.2.2
 Supports NSSA (compatible with RFC 3101)
 Event-log enabled, Maximum number of events: 1000, Mode: cyclic
 It is an area border router
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Retransmission limit dc 24 non-dc 24
 Number of external LSA 2. Checksum Sum 0x012CE5
 Number of areas in this router is 2. 1 normal 1 stub 0 nssa
 Graceful restart helper support enabled
 Reference bandwidth unit is 100 mbps
 RFC1583 compatibility enabled
    Area BACKBONE(0)
        Number of interfaces in this area is 2
        SPF algorithm executed 5 times
        Number of LSA 9. Checksum Sum 0x031327
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 51
        Number of interfaces in this area is 1
        It is a stub area, no summary LSA in this area
        Generates stub default route with cost 1
        SPF algorithm executed 6 times
        Number of LSA 7. Checksum Sum 0x035902
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

OSPFv3 1 address-family ipv6
Router ID 2.2.2.6
Supports NSSA (compatible with RFC 3101)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Retransmission limit dc 24 non-dc 24
Number of external LSA 2. Checksum Sum 0x00CB60
Number of areas in this router is 2. 1 normal 1 stub 0 nssa
Graceful restart helper support enabled
Reference bandwidth unit is 100 mbps
RFC1583 compatibility enabled
   Area BACKBONE(0)
       Number of interfaces in this area is 2
       SPF algorithm executed 7 times
       Number of LSA 9. Checksum Sum 0x0537A4
       Number of DCbitless LSA 0
       Number of indication LSA 0
       Number of DoNotAge LSA 0
       Flood list length 0
    Area 51
        Number of interfaces in this area is 1
        It is a stub area, no summary LSA in this area
        Generates stub default route with cost 1
        SPF algorithm executed 7 times
        Number of LSA 7. Checksum Sum 0x02E9F0
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
R2#

Why does R2 generate a stub default route into area 51? Is this the default route advertised by the ASBR?
______________________________________________________________________

f. View the output of the show ip protocols and show ipv6 protocols commands on R2.

R2# show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway Distance Last Update
  Distance: (default is 4)

Routing Protocol is "ospfv3 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 2.2.2.2
  Area border router
  Number of areas: 1 normal, 1 stub, 0 nssa
  Interfaces (Area 0):
    Serial0/0/1
    GigabitEthernet0/0
  Interfaces (Area 51):
    Serial0/0/0
  Maximum path: 4
  Routing Information Sources:
    Gateway     Distance     Last Update
    3.3.3.3     110          00:02:26
    1.1.1.1     110          00:02:26
  Distance: (default is 110)

R2# show ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "application"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 1"
  Router ID 2.2.2.6
  Area border router
  Number of areas: 1 normal, 1 stub, 0 nssa
  Interfaces (Area 0):
    Serial0/0/1
    GigabitEthernet0/0
  Interfaces (Area 51):
    Serial0/0/0
  Redistribution:
    None
R2#

Is there any information in the output of these commands that indicate G0/0 is a passive interface?
_____________________________________________________________________

g. View the output of the show ospfv3 interface gigabitethernet 0/0 command on R2.

R2# show ospfv3 interface gigabitethernet 0/0
GigabitEthernet0/0 is up, line protocol is up
Link Local Address FE80::2, Interface ID 3
Internet Address 192.168.3.1/24
Area 0, Process ID 1, Instance ID 64, Router ID 2.2.2.2
Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 2.2.2.2, local address FE80::2
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
No Hellos (Passive interface)
Graceful restart helper support enabled
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
GigabitEthernet0/0 is up, line protocol is up
Link Local Address FE80::2, Interface ID 3
Area 0, Process ID 1, Instance ID 0, Router ID 2.2.2.6
Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 2.2.2.6, local address FE80::2
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
No Hellos (Passive interface)
Graceful restart helper support enabled
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
R2#

Is there any information in the output of this command that indicate G0/0 is a passive interface?

_____________________________________________________________________

Why are there two sets of output for the G0/0 interface?

______________________________________________________________________

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x