CCNP ROUTE Chapter 7 Lab 7-5, Configuring MP-BGP (Version 7)

Topology

CCNP ROUTE Chapter 7 Lab 7-5, Configuring MP-BGP (Version 7) 1

Objectives

  • Configure EIGRP on ITA network.
  • Using MP-BGP, configure EBGP for IPv4 and IPv6 between ISP and SanJose1, using IPv4 BGP transport for both protocols.
  • Configure MP-BGP IBGP between SanJose1 and SanJose2.
  • Verify BGP neighbors, BGP tables and routing tables for IPv4 and IPv6.

Background

SanJose1 in AS 65000 is running MP-BGP with the ISP router in AS 65100. The International Travel Agency runs MP-BGP on its SanJose1 and SanJose2 routers in AS 65000. The International Travel Agency and the ISP need to share both IPv4 and IPv6 prefixes. Your job is to configure MP-BGP for this internetwork. You will need to configure internal and external BGP sessions and advertise IPv6 network prefixes via BGP. You will deploy IPv4 and IPv6 transport. You will use route-maps to set the next-hop attribute to an IPv6 address when exchanging the IPv6 networks over a IPv4 transport session between ISP and SanJose1.

Note: This lab uses Cisco 1941 routers with Cisco IOS Release 15.4 with IP Base. The switches are Cisco WS-C2960-24TT-L with Fast Ethernet interfaces, therefore the router will use routing metrics associated with a 100 Mb/s interface. Depending on the router or switch model and Cisco IOS Software version, the commands available and output produced might vary from what is shown in this lab.

Required Resources

  • 3 routers (Cisco IOS Release 15.2 or comparable)
  • 3 switches (LAN interfaces)
  • Serial and Ethernet cables

Step 0: Suggested starting configurations.

a. Apply the following configuration to each router along with the appropriate hostname. The exec-timeout 0 0 command should only be used in a lab environment.

Router(config)# no ip domain-lookup
Router(config)# line con 0
Router(config-line)# logging synchronous
Router(config-line)# exec-timeout 0 0

Step 1: Configure interface addresses.

a. Using the addressing scheme in the diagram, create the loopback interfaces and apply IPv4 addresses to these and the serial interfaces on ISP (R1), SanJose1 (R2), and SanJose2 (R3).

Router R1 (hostname ISP)

ISP(config)# interface gigabitethernet 0/0
ISP(config-if)# ip address 10.1.0.1 255.255.0.0
ISP(config-if)# ipv6 address 2001:db8:beef:1::1/64
ISP(config-if)# ipv6 address fe80::1 link-local
ISP(config-if)# no shutdown
ISP(config-if)# exit
ISP(config)# interface loopback 0
ISP(config-if)# ip address 10.0.0.1 255.255.255.0
ISP(config-if)# ipv6 address 2001:db8:beef:11::1/64
ISP(config-if)# no shutdown
ISP(config-if)# exit
ISP(config)# interface serial 0/0/0
ISP(config-if)# ip address 192.168.1.1 255.255.255.252
ISP(config-if)# ipv6 address 2001:db8:feed:1::1/64
ISP(config-if)# ipv6 address fe80::1 link-local
ISP(config-if)# clock rate 64000
ISP(config-if)# no shutdown

Router R2 (hostname SanJose1)

SanJose1(config)# interface gigabitethernet 0/0
SanJose1(config-if)# ip address 172.16.2.1 255.255.255.0
SanJose1(config-if)# ipv6 address 2001:db8:cafe:2::1/64
SanJose1(config-if)# ipv6 address fe80::2 link-local
SanJose1(config-if)# no shutdown
SanJose1(config-if)# exit
SanJose1(config)# interface serial 0/0/0
SanJose1(config-if)# ip address 192.168.1.2 255.255.255.252
SanJose1(config-if)# ipv6 address 2001:db8:feed:1::2/64
SanJose1(config-if)# ipv6 address fe80::2 link-local
SanJose1(config-if)# no shutdown
SanJose1(config-if)# exit
SanJose1(config)# interface serial 0/0/1
SanJose1(config-if)# ip address 172.16.1.1 255.255.255.252
SanJose1(config-if)# ipv6 address 2001:db8:cafe:1::1/64
SanJose1(config-if)# ipv6 address fe80::2 link-local
SanJose1(config-if)# clock rate 64000
SanJose1(config-if)# no shutdown
SanJose1(config-if)# exit
SanJose1(config)# interface loopback 0
SanJose1(config-if)# ip address 172.17.2.1 255.255.255.0
SanJose1(config-if)# ipv6 address 2001:db8:cafe:22::1/64
SanJose1(config-if)# no shutdown

Router R3 (hostname SanJose2)

SanJose2(config)# interface gigabitethernet 0/0
SanJose2(config-if)# ip address 172.16.3.1 255.255.255.0
SanJose2(config-if)# ipv6 address 2001:db8:cafe:3::1/64 
SanJose2(config-if)# ipv6 address fe80::3 link-local
SanJose2(config-if)# no shutdown
SanJose2(config-if)# exit
SanJose2(config)# interface serial 0/0/1
SanJose2(config-if)# ip address 172.16.1.2 255.255.255.252
SanJose2(config-if)# ipv6 address 2001:db8:cafe:1::2/64
SanJose2(config-if)# ipv6 address fe80::3 link-local
SanJose2(config-if)# no shutdown
SanJose2(config)# interface loopback 0
SanJose2(config-if)# ip address 172.17.3.1 255.255.255.0
SanJose2(config-if)# ipv6 address 2001:db8:cafe:33::1/64

b. Use ping to test the connectivity between the directly connected routers for both IPv4 and IPv6. Both SanJose routers should be able to ping each other and SanJose1 should be able to ping the ISP on the serial link IP addresses. The ISP router cannot reach the segment between SanJose1 and SanJose2, or their LAN interfaces.

Step 2: Configure EIGRP.

Configure EIGRP between the SanJose1 and SanJose2 routers. Both routers should be able to ping the other router’s LAN and loopback interfaces. (Note: If using an IOS prior to 15.0, use the no auto-summary router configuration command to disable automatic summarization. This command is the default beginning with IOS 15.)

Configure EIGRP for IPv4 and IPv6 on SanJose1.

SanJose1(config)# ipv6 unicast-routing 
SanJose1(config)# router eigrp 1
SanJose1(config-router)# eigrp router-id 2.2.2.2
SanJose1(config-router)# network 172.16.0.0
SanJose1(config-router)# network 172.17.0.0

SanJose1(config)# ipv6 router eigrp 2
SanJose1(config-rtr)# eigrp router-id 2.2.2.2

SanJose1(config)# interface gigabitethernet 0/0
SanJose1(config-if)# ipv6 eigrp 2
SanJose1(config-if)# exit
SanJose1(config)# interface serial 0/0/1
SanJose1(config-if)# ipv6 eigrp 2
SanJose1(config-if)# exit
SanJose1(config)# interface loopback 0 
SanJose1(config-if)# ipv6 eigrp 2

Configure EIGRP for IPv4 and IPv6 on SanJose2.

SanJose2(config)# ipv6 unicast-routing 
SanJose2(config)# router eigrp 1
SanJose2(config-router)# eigrp router-id 3.3.3.3
SanJose2(config-router)# network 172.16.0.0
SanJose2(config-router)# network 172.17.0.0

SanJose2(config)# ipv6 router eigrp 2
SanJose2(config-rtr)# eigrp router-id 3.3.3.3

SanJose2(config)# interface gigabitethernet 0/0
SanJose2(config-if)# ipv6 eigrp 2
SanJose2(config-if)# exit
SanJose2(config)# interface serial 0/0/1
SanJose2(config-if)# ipv6 eigrp 2
SanJose2(config-if)# exit
SanJose2(config)# interface loopback 0
SanJose2(config-if)# ipv6 eigrp 2

Step 3: Configure MP-BGP on ISP – EBGP.

a. Configure EBGP between the ISP and SanJose1. ISP and SanJose1 will be using IPv4 as the BGP transport for both IPv4 and IPv6 sessions. After enabling IPv6 routing on ISP, configure BGP for AS 65100 with a router ID of 1.1.1.1. In its peering with SanJose1, the IPv4 address of SanJose1 will be used for the IPv4 BGP transport session.

ISP(config)# ipv6 unicast-routing
ISP(config)# router bgp 65100
ISP(config-router)# bgp router-id 1.1.1.1
ISP(config-router)# neighbor 192.168.1.2 remote-as 65000

b. Enter the router configuration mode for the IPv4 address family. Enter the commands to advertise the 10.1.0.0/16 network and activate the IPv4 neighbor 192.1681.2 within the IPv4 AF.

ISP(config-router)# address-family ipv4 unicast
ISP(config-router-af)# network 10.1.0.0 mask 255.255.0.0
ISP(config-router-af)# neighbor 192.168.1.2 activate
ISP(config-router-af)# exit-address-family

c. Enter the router configuration mode for the IPv6 address family and enter the command to advertise the 2001:DB8:BEEF:1::/64 prefix. Since you are using IPv4 as the BGP transport, you must also activate the IPv4 neighbor 192.168.1.2 within the IPv6 AF. Configure the route-map NEXT-HOP-IPV6 to attach to the BGP neighbor in the outbound direction. Outbound direction means that this information in the route-map will be applied to IPv6 BGP updates as they are sent to SanJose1.

ISP(config-router)# address-family ipv6 unicast
ISP(config-router-af)# network 2001:DB8:BEEF:1::/64
ISP(config-router-af)# neighbor 192.168.1.2 activate
ISP(config-router-af)# neighbor 192.168.1.2 route-map NEXT-HOP-IPV6 out
ISP(config-router-af)# exit-address-family

The route-map is applied in the outbound direction. What will this do?
______________________________________________________________

d. The route-map NEXT-HOP-IPV6 is configured to overwrite the next-hop parameter with the appropriate IPv6 next-hop address. Notice that the next-hop address is the local IPv6 address of this router, ISP. The neighbor, SanJose1, will use this IPv6 address as it’s next-hop address in its IPv6 BGP table.

ISP(config)# route-map NEXT-HOP-IPV6 permit 10
ISP(config-route-map)# set ipv6 next-hop 2001:DB8:FEED:1::1

Step 4: Configure MP-BGP on SanJose1 – EBGP and IBGP.

a. Enable IPv6 routing on SanJose1 and then configure BGP for AS 65000 with a router ID of 2.2.2.2. The IPv4 address of ISP will be used for the IPv4 BGP transport session with ISP.

SanJose1(config)# router bgp 65000
SanJose1(config-router)# bgp router-id 2.2.2.2
SanJose1(config-router)# neighbor 192.168.1.1 remote-as 65100

b. Configure IBGP on SanJose1 to peer with SanJose2 for both IPv4 and IPv6. The update-source loopback 0 command instructs the router to use the IP address of the interface loopback 0 as the source IP address for all BGP messages sent to that neighbor. The IP address of the loopback interface is used in the neighbor command.

SanJose1(config-router)# neighbor 2001:DB8:CAFE:33::1 remote-as 65000
SanJose1(config-router)# neighbor 2001:DB8:CAFE:33::1 update-source Loopback0
SanJose1(config-router)# neighbor 172.17.3.1 remote-as 65000
SanJose1(config-router)# neighbor 172.17.3.1 update-source Loopback0

c. Enter the router configuration mode for the IPv4 address family for SanJose1. Enter the command to advertise the 172.16.2.0/24 network. Activate the IPv4 neighbor within the IPv4 AF for the EBGP peering session with ISP.

SanJose1(config-router)# address-family ipv4 unicast
SanJose1(config-router-af)# network 172.16.2.0 mask 255.255.255.0
SanJose1(config-router-af)# neighbor 192.168.1.1 activate

d. Activate the IPv4 neighbor within the IPv4 AF for the IBGP peering session with SanJose2. Configure the next-hop-self parameter so SanJose1 uses its own IPv4 address as the next-hop address in its IBGP updates to SanJose2. By default, SanJose1 would include the next-hop address the ISP in it IBGP updates to SanJose2. This would be for any routes learned from ISP using EBGP.

SanJose1(config-router-af)# neighbor 172.17.3.1 activate
SanJose1(config-router-af)# neighbor 172.17.3.1 next-hop-self
SanJose1(config-router-af)# exit-address-family

e. Enter the router configuration mode for the IPv6 address family and enter the command to advertise the 2001:DB8:CAFE:2::/64 prefix. Similar to ISP, since you are using IPv4 as our BGP transport, you must also activate the IPv4 neighbor within the IPv6 AF. Configure the route-map NEXT-HOP-IPV6 to attach to the BGP neighbor in the outbound direction. Outbound direction means that this information in the route-map will be applied to IPv6 BGP updates as they are sent to ISP.

SanJose1(config-router)# address-family ipv6 unicast
SanJose1(config-router-af)# network 2001:DB8:CAFE:2::/64
SanJose1(config-router-af)# neighbor 192.168.1.1 activate
SanJose1(config-router-af)# neighbor 192.168.1.1 route-map NEXT-HOP-IPV6 out

f. Activate the IPv6 neighbor within the IPv6 AF for the IBGP peering session with SanJose2. Similar to BGP for IPv4, configure the next-hop-self parameter so SanJose1 uses its own IPv6 address as the next-hop address in its IBGP updates to SanJose2.

SanJose1(config-router-af)# neighbor 2001:DB8:CAFE:33::1 activate
SanJose1(config-router-af)# neighbor 2001:DB8:CAFE:33::1 next-hop-self
SanJose1(config-router-af)# exit-address-family

If the next-hop-self parameter is not used, what needs to be done to ensure reachability to routes advertised by the ISP router?
____________________________________________________________________

g. Because SanJose1 is using IPv4 transport in its peering with ISP, the route-map NEXT-HOP-IPV6 is configured to overwrite the next-hop parameter with the appropriate IPv6 next-hop address. Notice that the next-hop address is the IPv6 address of SanJose1. Using its local IPv6 address in the route-map, neighbor ISP will use this IPv6 address as it’s next-hop address in its IPv6 BGP table.

SanJose1(config)# route-map NEXT-HOP-IPV6 permit 10
SanJose1(config-route-map)# set ipv6 next-hop 2001:DB8:FEED:1::2

Step 4: Configure MP-BGP on SanJose2 – IBGP.

a. Enable IPv6 routing on SanJose2 and then configure BGP for AS 65000 with a router ID of 3.3.3.3.

SanJose2(config)# router bgp 65000
SanJose2(config-router)# bgp router-id 3.3.3.3

b. Configure IBGP on SanJose2 to peer with SanJose1 for both IPv4 and IPv6. SanJose2’s loopback 0 interface will be used in the peering for both IPv4 and IPv6.

SanJose2(config-router)# neighbor 2001:DB8:CAFE:22::1 remote-as 65000
SanJose2(config-router)# neighbor 2001:DB8:CAFE:22::1 update-source Loopback0
SanJose2(config-router)# neighbor 172.17.2.1 remote-as 65000
SanJose2(config-router)# neighbor 172.17.2.1 update-source Loopback0

c. Enter the router configuration mode for the IPv4 address family for SanJose2. Enter the command to advertise the 172.16.3.0/24 network. Activate the IPv4 neighbor within the IPv4 AF for the IBGP peering session with SanJose1.

SanJose2(config-router)# address-family ipv4 unicast
SanJose2(config-router-af)# network 172.16.3.0 mask 255.255.255.0
SanJose2(config-router-af)# neighbor 172.17.2.1 activate
SanJose2(config-router-af)# exit-address-family

d. Enter the router configuration mode for the IPv6 address family and enter the command to advertise the 2001:DB8:CAFE:3::/64 prefix. Activate the IPv6 neighbor within the IPv6 AF for the IBGP peering session with SanJose1.

SanJose2(config-router)# address-family ipv6 unicast
SanJose2(config-router-af)# network 2001:DB8:CAFE:3::/64
SanJose2(config-router-af)# neighbor 2001:DB8:CAFE:22::1 activate
SanJose2(config-router-af)# exit-address-family

Step 5: Verifying BGP neighbor peering relationships for IPv4 and IPv6.

a. Use the show bgp all neighbors command on SanJose1 to display information about BGP connections to neighbors for all (IPv4 and IPv6) address families. Each neighbor shows that it is in the “Established” state indicating the router can send and receive BGP messages.

SanJose1 has two neighbor addresses, ISP and SanJose2, for each address family, IPv4 and IPv6. The internal link is the IBGP neighbor relationship with SanJose2 whereas the external link is the EBGP neighbor relationship with ISP. Notice for the IPv6 address family, there is SanJose2’s IPv6 address and ISP’s IPv4 address. SanJose1 employs IPv6 as the IBGP transport with SanJose2, using the IPv6 address with 2001:DB8:CAFE:33::1. IPv4 is used as the EBGP transport with ISP, so the IPv4 address 192.168.1.1 is shown for the IPv6 address family.

SanJose1# show bgp all neighbors 
For address family: IPv4 Unicast
BGP neighbor is 172.17.3.1,  remote AS 65000, internal link
  BGP version 4, remote router ID 3.3.3.3
  BGP state = Established, up for 03:47:09
  Last read 00:00:33, last write 00:00:53, hold time is 180, keepalive interval is 60 seconds
              
BGP neighbor is 192.168.1.1,  remote AS 65100, external link
  BGP version 4, remote router ID 1.1.1.1
  BGP state = Established, up for 03:47:17
  Last read 00:00:19, last write 00:00:53, hold time is 180, keepalive interval is 60 seconds       

For address family: IPv6 Unicast
BGP neighbor is 2001:DB8:CAFE:33::1,  remote AS 65000, internal link
  BGP version 4, remote router ID 3.3.3.3
  BGP state = Established, up for 03:47:25
  Last read 00:00:38, last write 00:00:04, hold time is 180, keepalive interval is 60 seconds
           
BGP neighbor is 192.168.1.1,  remote AS 65100, external link
  BGP version 4, remote router ID 1.1.1.1
  BGP state = Established, up for 03:47:43
  Last read 00:00:46, last write 00:00:19, hold time is 180, keepalive interval is 60 seconds
   
SanJose1#

What is the relationship between the “remote AS” and whether it is an internal or external link?
______________________________________________________________________

b. Another option to the show bgp all neighbors command, are the show ip bgp neighbors and show bgp ipv6 unicast neighbors commands which can be used for their respective address families. An excerpt from show ip bgp neighbors command is displayed below. In this command, the IPv6 address family information not only displays the IPv4 address used as the transport, but the name of the route map that was used on SanJose1 end of the connection.

SanJose1# show ip bgp neighbors  

 For address family: IPv6 Unicast
  Session: 192.168.1.1
  BGP table version 12, neighbor version 12/0
  Output queue size : 0
  Index 11, Advertise bit 0
  11 update-group member
  Outbound path policy configured
  Route map for outgoing advertisements is NEXT-HOP-IPV6
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
  Interface associated: Serial0/0/0  

SanJose1#

c. Use the show bgp ipv4 unicast summary and show bgp ipv6 unicast summary commands on ISP to display a summary of IPv4/IPv6 peering information with SanJose1. The show bgp ipv4 unicast summary is the equivalent of show ip bgp and either command can be used. Notice that BGP connectivity for both IPv4 and IPv6 is over an IPv4 BGP transport session, using the neighbor address of 192.168.1.2.

ISP# show bgp ipv4 unicast summary
BGP router identifier 1.1.1.1, local AS number 65100
BGP table version is 21, main routing table version 21
3 network entries using 432 bytes of memory
3 path entries using 240 bytes of memory
3/3 BGP path/bestpath attribute entries using 480 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1176 total bytes of memory
BGP activity 9/3 prefixes, 18/12 paths, scan interval 60 secs

Neighbor        V       AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down State/PfxRcd
192.168.1.2     4    65000      80      78       21    0    0 01:03:46        2
ISP#

ISP# show bgp ipv6 unicast summary
BGP router identifier 1.1.1.1, local AS number 65100
BGP table version is 23, main routing table version 23
3 network entries using 504 bytes of memory
3 path entries using 312 bytes of memory
3/3 BGP path/bestpath attribute entries using 480 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1320 total bytes of memory
BGP activity 9/3 prefixes, 18/12 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.1.2     4        65000      86      85       23    0    0 01:09:28        2
ISP#

d. Use the show bgp ipv4 unicast summary command on SanJose1 to display a summary of IPv4 peering information with ISP and SanJose2. Notice that SanJose1 has two IPv4 peers, one in each AS. Also notice, that the IBGP peering relationship with SanJose2 uses SanJose2’s loopback address 172.17.3.1. This is why this network was included in the EIGRP configuration on SanJose1 and SanJose2.

SanJose1# show bgp ipv4 unicast summary
BGP router identifier 2.2.2.2, local AS number 65000
BGP table version is 6, main routing table version 6
3 network entries using 432 bytes of memory
3 path entries using 240 bytes of memory
3/3 BGP path/bestpath attribute entries using 480 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1176 total bytes of memory
BGP activity 23/17 prefixes, 25/19 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.17.3.1      4        65000      93      93        6    0    0 01:19:50        1
192.168.1.1     4        65100      98      98        6    0    0 01:19:50        1
SanJose1#

e. Use the show bgp ipv6 unicast summary command on SanJose1 to display a summary of IPv6 peering information with ISP and SanJose2. Similar to IPv4, notice that SanJose1 has two peers, one in each AS. However, the IPv6 peering session with ISP in AS 65100 uses IPv4 as its transport, so the IPv4 neighbor address 192.168.1.1 is displayed.

SanJose1# show bgp ipv6 unicast summary
BGP router identifier 2.2.2.2, local AS number 65000
BGP table version is 8, main routing table version 8
3 network entries using 504 bytes of memory
3 path entries using 312 bytes of memory
3/3 BGP path/bestpath attribute entries using 480 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1320 total bytes of memory
BGP activity 23/17 prefixes, 25/19 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2001:DB8:CAFE:33::1
                4        65000      93      97        8    0    0 01:19:59        1
192.168.1.1     4        65100      98      98        8    0    0 01:19:59        1
SanJose1#

Step 6: Verifying the BGP tables for IPv4 and IPv6.

a. Use the show bgp ipv4 unicast command on ISP to display its IPv4 BGP table. This command is equivalent to the show ip bgp command and either command can be used. Notice that ISP shows three IPv4 networks in its IPv4 BGP table. Each network is valid “*” and has one path which is the best path “>”. Amongst other information, the next hop IPv4 address and the AS path are included.

ISP# show bgp ipv4 unicast
BGP table version is 22, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.0.0/16      0.0.0.0                  0         32768 i
 *>  172.16.2.0/24    192.168.1.2              0             0 65000 i
 *>  172.16.3.0/24    192.168.1.2                            0 65000 i
ISP#

b. Use the show bgp ipv6 unicast command on ISP to display its IPv6 BGP table. Similar to the BGP table for IPv4, notice that ISP shows three IPv6 prefixes in its IPv6 BGP table. Each network is a valid “*” and has one path which is the best path “>”. The next hop IPv6 address and AS path are also included.

Notice that the next-hop address for the prefixes 2001:DB8:CAFE:2::/64 and 2001:DB8:CAFE:3::/64, advertised by SanJose1, is using the address from SanJose1’s NEXT-HOP-IPV6 route-map, 2001:DB8:FEED:1::2.

ISP# show bgp ipv6 unicast
BGP table version is 26, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  2001:DB8:BEEF:1::/64
                       ::                       0         32768 i
 *>  2001:DB8:CAFE:2::/64
                       2001:DB8:FEED:1::2
                                                0             0 65000 i
 *>  2001:DB8:CAFE:3::/64
                       2001:DB8:FEED:1::2
                                                              0 65000 i
ISP#

c. Using the show bgp ipv4 unicast command on SanJose1 displays information for its IPv4 BGP table. Both the 10.1.0.0/24 network learned via EBGP from the ISP, and its own advertised network of 172.16.2.0/24 are included.

Notice that the 172.16.3.0/24 and 2001:DB8:CAFE:3::/64 prefixes do not include the “*” indicating best path, but rather the “r” signifying a RIB (routing information base) failure. Although these prefixes are being advertised by IBGP with an administrative distance of 200, the router is preferring the EIGRP source with a lower administrative distance of 90. Therefore, the EIGRP route is the preferred source and will be the one added to the IPv4 routing table.

SanJose1# show bgp ipv4 unicast        
BGP table version is 6, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.1.0.0/16      192.168.1.1              0             0 65100 i
 *>  172.16.2.0/24    0.0.0.0                  0         32768 i
 r>i 172.16.3.0/24    172.17.3.1               0    100      0 i
SanJose1#

d. Similarly, the show bgp ipv6 unicast command on SanJose1 displays its IPv6 BGP table. ISP shows three IPv6 prefixes in its IPv6 BGP table. Each network is a valid “*” and has one path which is the best path “>”. Amongst other information, the next hop IPv6 address and AS path are included.

Similar to its IPv4 BGP table, notice that the next-hop address for the prefix 2001:DB8:BEEF:1::/64, advertised by SanJose1, is using the address from ISP’s NEXT-HOP-IPV6 route-map, 2001:DB8:FEED:1::1.

SanJose1# show bgp ipv6 unicast        
BGP table version is 8, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  2001:DB8:BEEF:1::/64
                       2001:DB8:FEED:1::1
                                                0             0 65100 i
 *>  2001:DB8:CAFE:2::/64
                       ::                       0         32768 i
 r>i 2001:DB8:CAFE:3::/64
                       2001:DB8:CAFE:33::1
                                                0    100      0 i
SanJose1#

e. Similar BGP table output is shown for SanJose2. Notice that the next hop address is the loopback interface of SanJose1. In SanJose1’s peering configuration with SanJose2, SanJose1 uses the next-hop-self option and its loopback address 172.17.2.1. Remember, without this option IBGP carries EBGP routes into the domain with the next hop address unchanged – the next hop address of the ISP in this case.

SanJose2# show bgp ipv4 unicast        
BGP table version is 22, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 10.1.0.0/16      172.17.2.1               0    100      0 65100 i
 r>i 172.16.2.0/24    172.17.2.1               0    100      0 i
 *>  172.16.3.0/24    0.0.0.0                  0         32768 i
SanJose2#

SanJose2# show bgp ipv6 unicast
BGP table version is 24, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 2001:DB8:BEEF:1::/64
                       2001:DB8:CAFE:22::1
                                                0    100      0 65100 i
 r>i 2001:DB8:CAFE:2::/64
                       2001:DB8:CAFE:22::1
                                                0    100      0 i
 *>  2001:DB8:CAFE:3::/64
                       ::                       0         32768 i
SanJose2#

Step 6: Verifying the IP routing tables for IPv4 and IPv6.

a. By examining the IPv4 and IPv6 routing tables on ISP you can verify that BGP is receiving the IPv4 and IPv6 prefixes from SanJose1.

ISP# show ip route 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
C        10.0.0.0/24 is directly connected, Loopback0
L        10.0.0.1/32 is directly connected, Loopback0
C        10.1.0.0/16 is directly connected, GigabitEthernet0/0
L        10.1.0.1/32 is directly connected, GigabitEthernet0/0
      172.16.0.0/24 is subnetted, 2 subnets
B        172.16.2.0 [20/0] via 192.168.1.2, 02:59:37
B        172.16.3.0 [20/0] via 192.168.1.2, 03:00:10
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, Serial0/0/0
L        192.168.1.1/32 is directly connected, Serial0/0/0
ISP#

ISP# show ipv6 route
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       a - Application
C   2001:DB8:BEEF:1::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:DB8:BEEF:1::1/128 [0/0]
     via GigabitEthernet0/0, receive
C   2001:DB8:BEEF:11::/64 [0/0]
     via Loopback0, directly connected
L   2001:DB8:BEEF:11::1/128 [0/0]
     via Loopback0, receive
B   2001:DB8:CAFE:2::/64 [20/0]
     via FE80::2, Serial0/0/0
B   2001:DB8:CAFE:3::/64 [20/0]
     via FE80::2, Serial0/0/0
C   2001:DB8:FEED:1::/64 [0/0]
     via Serial0/0/0, directly connected
L   2001:DB8:FEED:1::1/128 [0/0]
     via Serial0/0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive
ISP#

Are the BGP routes learned via EBGP or EBGP? How can you tell by just the information in the routing table?
____________________________________________________________________

b. Examine the IPv4 and IPv6 routing tables on SanJose1. SanJose1 is EIGRP receiving routes from SanJose2 for SanJose2’s LAN and networks. Using EBGP, SanJose1 is receiving IPv4 and IPv6 prefixes from the ISP.

SanJose1# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/16 is subnetted, 1 subnets
B        10.1.0.0 [20/0] via 192.168.1.1, 03:01:19
      172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
C        172.16.1.0/30 is directly connected, Serial0/0/1
L        172.16.1.1/32 is directly connected, Serial0/0/1
C        172.16.2.0/24 is directly connected, GigabitEthernet0/0
L        172.16.2.1/32 is directly connected, GigabitEthernet0/0
D        172.16.3.0/24 [90/2172416] via 172.16.1.2, 04:17:47, Serial0/0/1
      172.17.0.0/16 is variably subnetted, 3 subnets, 2 masks
C        172.17.2.0/24 is directly connected, Loopback0
L        172.17.2.1/32 is directly connected, Loopback0
D        172.17.3.0/24 [90/2297856] via 172.16.1.2, 04:17:47, Serial0/0/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/30 is directly connected, Serial0/0/0
L        192.168.1.2/32 is directly connected, Serial0/0/0
SanJose1#

SanJose1# show ipv6 route
IPv6 Routing Table - default - 12 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       a - Application
B   2001:DB8:BEEF:1::/64 [20/0]
     via FE80::1, Serial0/0/0
C   2001:DB8:CAFE:1::/64 [0/0]
     via Serial0/0/1, directly connected
L   2001:DB8:CAFE:1::1/128 [0/0]
     via Serial0/0/1, receive
C   2001:DB8:CAFE:2::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:DB8:CAFE:2::1/128 [0/0]
     via GigabitEthernet0/0, receive
D   2001:DB8:CAFE:3::/64 [90/2172416]
     via FE80::3, Serial0/0/1
C   2001:DB8:CAFE:22::/64 [0/0]
     via Loopback0, directly connected
L   2001:DB8:CAFE:22::1/128 [0/0]
     via Loopback0, receive
D   2001:DB8:CAFE:33::/64 [90/2297856]
     via FE80::3, Serial0/0/1
C   2001:DB8:FEED:1::/64 [0/0]
     via Serial0/0/0, directly connected
L   2001:DB8:FEED:1::2/128 [0/0]
     via Serial0/0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive
SanJose1#

c. Looking at the IPv4 and IPv6 routing tables on SanJose2 shows that SanJose2 is receiving EIGRP and BGP routes from SanJose1. SanJose1’s LAN and loopback interfaces are being advertised to SanJose2 using EIGRP and for ISPs IPv4/IPv6 prefixes, SanJose1 is advertising them using IBGP.

SanJose2# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/16 is subnetted, 1 subnets
B        10.1.0.0 [200/0] via 172.17.2.1, 03:02:16
      172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
C        172.16.1.0/30 is directly connected, Serial0/0/1
L        172.16.1.2/32 is directly connected, Serial0/0/1
D        172.16.2.0/24 [90/2172416] via 172.16.1.1, 04:18:45, Serial0/0/1
C        172.16.3.0/24 is directly connected, GigabitEthernet0/0
L        172.16.3.1/32 is directly connected, GigabitEthernet0/0
      172.17.0.0/16 is variably subnetted, 3 subnets, 2 masks
D        172.17.2.0/24 [90/2297856] via 172.16.1.1, 04:18:45, Serial0/0/1
C        172.17.3.0/24 is directly connected, Loopback0
L        172.17.3.1/32 is directly connected, Loopback0
SanJose2#

SanJose2# show ipv6 route
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       a - Application
B   2001:DB8:BEEF:1::/64 [200/0]
     via 2001:DB8:CAFE:22::1
C   2001:DB8:CAFE:1::/64 [0/0]
     via Serial0/0/1, directly connected
L   2001:DB8:CAFE:1::2/128 [0/0]
     via Serial0/0/1, receive
D   2001:DB8:CAFE:2::/64 [90/2172416]
     via FE80::2, Serial0/0/1
C   2001:DB8:CAFE:3::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:DB8:CAFE:3::1/128 [0/0]
     via GigabitEthernet0/0, receive
D   2001:DB8:CAFE:22::/64 [90/2297856]
     via FE80::2, Serial0/0/1
C   2001:DB8:CAFE:33::/64 [0/0]
     via Loopback0, directly connected
L   2001:DB8:CAFE:33::1/128 [0/0]
     via Loopback0, receive
L   FF00::/8 [0/0]
     via Null0, receive
SanJose2#

Are the BGP routes learned via EBGP or EBGP? How can you tell by just the information in the routing table?
___________________________________________________________________

d. Verify IPv4 and IPv6 reachability pinging ISP’s LAN interface from the LAN interface on SanJose2.

SanJose2# ping 10.1.0.1 source 172.16.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.0.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.3.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/60 ms
SanJose2#

SanJose2# ping 2001:db8:beef:1::1 source gig 0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:BEEF:1::1, timeout is 2 seconds:
Packet sent with a source address of 2001:DB8:CAFE:3::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/55/56 ms
SanJose2#
Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x