Chapter 11: Quiz – BGP (Answers) CCNPv8 ENCOR

1. Which transport layer port is used in BGP peering?

  • UDP port 289
  • TCP port 289
  • UDP port 179
  • TCP port 179

Explanation: The BGP routing protocol uses an established TCP port 179 connection to maintain connectivity and transmit updates to BGP neighbors.

2. What is the first BGP message type that is sent after a TCP session is established between BGP peers?

  • hello
  • keepalive
  • notification
  • open
  • update

Explanation: In the Connect state of the BGP FSM, BGP initiates the TCP connection. If the three-way TCP handshake is completed, the established BGP session process resets the ConnectRetryTimer and sends the Open message to the neighbor.

3. Refer to the exhibit. Which two configurations will allow RTA to establish a neighbor relationship with RTB? (Choose two.)

Chapter 11: Quiz - BGP (Answers) CCNPv8 ENCOR 1

  • RTA(config)# router bgp 100
    RTA(config-router)# network 17.0.0.0
  • RTA(config)# router bgp 100
    RTA(config-router)# network 14.0.0.0
    RTA(config-router)# neighbor 16.1.1.2 remote-as 200
  • RTA(config)# router bgp 200
    RTA(config-router)# network 17.0.0.0
    RTA(config-router)# neighbor 16.1.1.1 remote-as 100
  • RTB(config)# router bgp 200
    RTB(config-router)# network 14.0.0.0
  • RTB(config)# router bgp 200
    RTB(config-router)# network 14.0.0.0
    RTB(config-router)# neighbor 16.1.1.2 remote-as 200
  • RTB(config)# router bgp 200
    RTB(config-router)# network 17.0.0.0
    RTB(config-router)# neighbor 16.1.1.1 remote-as 100

Explanation: The basic BGP configuration steps include the following:

  • Initialize the BGP routing process with the global command router bgp as-number.
  • Identify the IP address and autonomous system number associated with a BGP neighbor by the BGP router configuration command neighbor ip-address remote-as as-number.
  • Identify the specific network prefixes to be installed into the BGP table with the network statements.

4. Refer to the exhibit. A network administrator issues the show bgp ipv4 unicast 172.16.0.0 command to check the route information in the BGP table. Which statement describes the characteristic of the advertisement of this route?

Chapter 11: Quiz - BGP (Answers) CCNPv8 ENCOR 2

  • The route is advertised through IGP.
  • The route is advertised through a static route.
  • The route is advertised without including path attributes before the aggregation.
  • The route is advertised with the aggregateaddress 172.16.0.0 255.255.240.0 command.

Explanation: As indicated in the BGP table, the route is an aggregate route 172.16.0.0/20 learned from the neighbor 192.168.2.2. The atomic-aggregate attribute indicates loss of path attributes, such as AS_Path in this scenario.

5. What is used by BGP to determine the best path to a destination?

  • cost
  • hop count
  • attributes
  • administrative distance

Explanation: BGP uses attributes, such as AS-path, to determine the best path to a destination.

6. Which routing protocol is used to exchange routing information between autonomous systems on the Internet?

  • IS-IS
  • EIGRP
  • OSPF
  • BGP

Explanation: Exterior routing protocols exchange routing information between autonomous systems. BGP is the only exterior routing protocol in use today on the Internet.

7. True or False? Multiple BGP processes can run on a router.

  • true
  • false

Explanation: Because a BGP router can only belong to a single autonomous system, it can only run a single BGP process.

8. What is the correct BGP command to summarize the addresses from 172.16.0.0 through 172.16.15.0 into a single address that will be advertised by BGP?

  • summary-address 172.16.0.0 0.15.255.255 summary-only
  • summary-address 172.16.0.0 255.255.240.0 summary-only
  • aggregate-address 172.16.0.0 0.15.255.255 summary-only
  • aggregate-address 172.16.0.0 255.255.240.0 summary-only

Explanation: Route summarization on BGP edge routers via dynamic method is configured by specifying an aggregation network prefix. The aggregate-address command advertises the aggregated route (the supernet) in addition to the specific original component network prefixes. By using the optional summary-only keyword, the component network prefixes in the summarized network range are suppressed.

9. Refer to the exhibit. A network administrator issues the command show bgp ipv6 unicast | begin Network to check the BGP table. Which statement describes the routes with an unspecified address (::) in the Next Hop column?

Chapter 11: Quiz - BGP (Answers) CCNPv8 ENCOR 3

  • They are learned through an IGP.
  • They are locally generated network prefixes.
  • They indicate routes created by static route configuration.
  • They are learned through BGP advertisements from the next neighbor.

Explanation: An unspecified address in the BGP table indicates that the local router is generating the prefix for the BGP table. The weight value 32,768 also indicates that the prefix is locally originated by the router.

10. Refer to the exhibit. A network administrator issues the show bgp ipv4 unicast command to check the routes in the BGP table. What does the symbol > indicate about a route?

Chapter 11: Quiz - BGP (Answers) CCNPv8 ENCOR 4

  • It is a route that is learned through IGP.
  • It is the best route for the network prefix.
  • It is a route that is learned through a static route.
  • It is a route to an interface that is connected to the router.

Explanation: BGP only advertises the best path to other BGP peers, regardless of the number of routes (NLRIs) in the BGP Loc-RIB table. The best route is indicated with the symbol >.

11. What change was made to BGP to address the expected depletion of autonomous system numbers?

  • the ability to incorporate hierarchical network design
  • the use of a 2-octet autonomous system number
  • the use of a 4-octet autonomous system number
  • the ability to use RFC 1918 address space

Explanation: Autonomous system number (ASN) was originally 2 bytes (16-bit range) long, which made 65,535 ASNs possible. Due to exhaustion, RFC 4893 expanded the ASN field to accommodate 4 bytes (32-bit range). This allows for 4,294,967,295 unique ASNs.

12. What is a characteristic of an IBGP session type?

  • Neighbors may be located anywhere within multiple autonomous systems, even several hops away from each other.
  • A session typically occurs between routers in different autonomous systems with multiple ISPs.
  • It can be established between routers in the same AS or that participate in the same BGP confederation.
  • It occurs between routers in two different autonomous systems.

Explanation: IBGP sessions are established with IBGP routers that are in the same AS or that participate in the same BGP confederation. IBGP prefixes are assigned an administrative distance (AD) of 200 upon installation in the router RIB.


Related Articles

guest
0 Comments
Inline Feedbacks
View all comments