10.2.4.5 Lab – Troubleshooting Multiarea OSPFv2 and OSPFv3 Answers

10.2.4.5 Lab – Troubleshooting Multiarea OSPFv2 and OSPFv3 (Instructor Version)

Instructor Note: Red font color or Gray highlights indicate text that appears in the instructor copy only.

Topology

Addressing Table

Device Interface IP Address
R1 Lo0 209.165.200.225/30
Lo1 192.168.1.1/24
2001:DB8:ACAD:1::1/64
FE80::1 link-local
Lo2 192.168.2.1/24
2001:DB8:ACAD:2::1/64
FE80::1 link-local
S0/0/0 (DCE) 192.168.12.1/30
2001:DB8:ACAD:12::1/64
FE80::1 link-local
R2 S0/0/0 192.168.12.2/30
2001:DB8:ACAD:12::2/64
FE80::2 link-local
S0/0/1 (DCE) 192.168.23.2/30
2001:DB8:ACAD:23::2/64
FE80::2 link-local
Lo6 192.168.6.1/24
2001:DB8:ACAD:6::1/64
FE80::2 link-local
R3 Lo4 192.168.4.1/24
2001:DB8:ACAD:4::1/64
FE80::3 link-local
Lo5 192.168.5.1/24
2001:DB8:ACAD:5::1/64
FE80::3 link-local
S0/0/1 192.168.23.1/30
2001:DB8:ACAD:23::1/64
FE80::3 link-local

Objectives

Part 1: Build the Network and Load Device Configurations
Part 2: Troubleshoot Layer 3 Connectivity
Part 3: Troubleshoot OSPFv2
Part 4: Troubleshoot OSPFv3

Background / Scenario

Open Shortest Path First (OSPF) is an open-standard link-state routing protocol for IP networks. OSPFv2 is defined for IPv4 networks, while OSPFv3 is defined for IPv6 networks. OSPFv2 and OSPFv3 are completely isolated routing protocols, meaning changes in OSPFv2 do not affect OSPFv3 routing, and vice versa.

In this lab, a multiarea OSPF network running OSPFv2 and OSPFv3 is experiencing problems. You have been assigned to find the problems with the network and correct them.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). Other routers and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Make sure that the routers have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Serial cables as shown in the topology

Part 1: Build the Network and Load Device Configurations

Step 1: Cable the network as shown in the topology.

Step 2: Load router configuration files.

Load the following configurations into the appropriate router. All routers have the same passwords. The enable password is class, and the line password is cisco.

Router R1 Configuration:

enable
conf t
hostname R1
enable secret class
ipv6 unicast-routing
no ip domain lookup
interface Loopback0
ip address 209.165.200.225 255.255.255.252
interface Loopback1
ip address 192.168.1.1 255.255.255.0
ipv6 address 2001:DB80:ACAD:1::1/64
! ipv6 address 2001:DB8:ACAD:1::1/64
! ipv6 ospf 1 area 1
ipv6 ospf network point-to-point
interface Loopback2
ip address 192.168.2.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:2::1/64
ipv6 ospf 1 area 1
ipv6 ospf network point-to-point
interface Serial0/0/0
ip address 192.168.21.1 255.255.255.252
!ip address 192.168.12.1 255.255.255.252
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:12::1/64
ipv6 ospf 1 area 0
clock rate 128000
shutdown
!no shutdown
router ospf 1
router-id 1.1.1.1
passive-interface Loopback1
passive-interface Loopback2
!network 192.168.1.0 0.0.0.255 area 1
network 192.168.2.0 0.0.0.255 area 1
network 192.168.12.0 0.0.0.3 area 0
default-information originate
ipv6 router ospf 1
! router-id 1.1.1.1
ip route 0.0.0.0 0.0.0.0 Loopback0
banner motd @
Unauthorized Access is Prohibited! @
line con 0
password cisco
logging synchronous
login
line vty 0 4
password cisco
logging synchronous
login
transport input all
end

Router R2 Configuration:

enable
conf t
hostname R2
ipv6 unicast-routing
no ip domain lookup
enable secret class
interface Loopback6
ip address 192.168.6.1 255.255.255.0
ipv6 address 2001:DB8:CAD:6::1/64
! ipv6 address 2001:DB8:ACAD:6::1/64
! ipv6 ospf 1 area 3
interface Serial0/0/0
ip address 192.168.12.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:12::2/64
ipv6 ospf 1 area 0
no shutdown
interface Serial0/0/1
ip address 192.168.23.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:23::2/64
ipv6 ospf 1 area 3
clock rate 128000
no shutdown
router ospf 1
router-id 2.2.2.2
passive-interface Loopback6
network 192.168.6.0 0.0.0.255 area 3
network 192.168.12.0 0.0.0.3 area 0
network 192.168.23.0 0.0.0.3 area 3
ipv6 router ospf 1
router-id 2.2.2.2
banner motd @
Unauthorized Access is Prohibited! @
line con 0
password cisco
logging synchronous
login
line vty 0 4
password cisco
logging synchronous
login
transport input all
end

Router R3 Configuration:

enable
conf t
hostname R3
no ip domain lookup
ipv6 unicast-routing
enable secret class
interface Loopback4
ip address 192.168.4.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:4::1/64
ipv6 ospf 1 area 3
interface Loopback5
ip address 192.168.5.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:5::1/64
ipv6 ospf 1 area 3
interface Serial0/0/1
ip address 192.168.23.1 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:23::1/64
ipv6 ospf 1 area 3
no shutdown
router ospf 1
router-id 3.3.3.3
passive-interface Loopback4
passive-interface Loopback5
network 192.168.4.0 0.0.0.255 area 3
network 192.168.5.0 0.0.0.255 area 3
! network 192.168.23.0 0.0.0.3 area 3
ipv6 router ospf 1
router-id 3.3.3.3
banner motd @
Unauthorized Access is Prohibited! @
line con 0
password cisco
logging synchronous
login
line vty 0 4
password cisco
logging synchronous
login
transport input all
end

Step 3: Save your configuration.

Part 2: Troubleshoot Layer 3 Connectivity

In Part 2, you will verify that Layer 3 connectivity is established on all interfaces. You will need to test both IPv4 and IPv6 connectivity for all device interfaces.

Step 1: Verify the interfaces listed in the Addressing Table are active and configured with correct IP address information.

a. Issue the show ip interface brief command on all three routers to verify that the interfaces are in an up/up state.

R1# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down  
GigabitEthernet0/0         unassigned      YES unset  administratively down down  
GigabitEthernet0/1         unassigned      YES unset  administratively down down  
Serial0/0/0                192.168.21.1    YES manual administratively down down  
Serial0/0/1                unassigned      YES unset  administratively down down  
Loopback0                  209.165.200.225 YES manual up                    up  
Loopback1                  192.168.1.1     YES manual up                    up  
Loopback2                  192.168.2.1     YES manual up                    up    

R2# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol  
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down  
GigabitEthernet0/0         unassigned      YES unset  administratively down down  
GigabitEthernet0/1         unassigned      YES unset  administratively down down  
Serial0/0/0                192.168.12.2    YES manual down                  down  
Serial0/0/1                192.168.23.2    YES SLARP  up                    up  
Loopback6                  192.168.6.1     YES manual up                    up    

R3# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol  
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down  
GigabitEthernet0/0         unassigned      YES unset  administratively down down  
GigabitEthernet0/1         unassigned      YES unset  administratively down down  
Serial0/0/0                unassigned      YES unset  administratively down down  
Serial0/0/1                192.168.23.1    YES manual up                    up  
Loopback4                  192.168.4.1     YES manual up                    up  
Loopback5                  192.168.5.1     YES manual up                    up

b. Issue the show run | section interface command to view all the commands related to interfaces.

R1:

R1# show run | section interface
interface Loopback0
ip address 209.165.200.225 255.255.255.252
interface Loopback1
ip address 192.168.1.1 255.255.255.0
ipv6 address 2001:DB80:ACAD:1::1/64
ipv6 ospf 1 area 0
ipv6 ospf network point-to-point
interface Loopback2
ip address 192.168.2.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:2::1/64
ipv6 ospf 1 area 1
ipv6 ospf network point-to-point
interface Embedded-Service-Engine0/0
no ip address
shutdown
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
interface Serial0/0/0
ip address 192.168.21.1 255.255.255.252
shutdown
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:12::1/64
ipv6 ospf 1 area 1
clock rate 128000
interface Serial0/0/1
no ip address
shutdown
passive-interface Loopback1
passive-interface Loopback2

R2:

R2# show run | section interface
interface Loopback6
ip address 192.168.6.1 255.255.255.0
ipv6 address 2001:DB8:CAD:6::1/64
interface Embedded-Service-Engine0/0
no ip address
shutdown
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
interface Serial0/0/0
ip address 192.168.12.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:12::2/64
ipv6 ospf 1 area 0
interface Serial0/0/1
ip address 192.168.23.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:23::2/64
ipv6 ospf 1 area 3
clock rate 128000
passive-interface Loopback6

R3:

R3# show run | section interface
interface Loopback4
ip address 192.168.4.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:4::1/64
ipv6 ospf 1 area 3
interface Loopback5
ip address 192.168.5.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:5::1/64
ipv6 ospf 1 area 3
interface Embedded-Service-Engine0/0
no ip address
shutdown
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
interface Serial0/0/1
ip address 192.168.23.1 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:23::1/64
ipv6 ospf 1 area 3
passive-interface Loopback4
passive-interface Loopback5

c. Resolve all problems found. Record the commands used to correct the configuration.
___________________________________________________

R1(config)# interface s0/0/0
R1(config-if)# ip address 192.168.12.1 255.255.255.252
R1(config-if)# no shutdown
R1(config-if)# interface lo1
R1(config-if)# no ipv6 address 2001:DB80:ACAD:1::1/64
R1(config-if)# ipv6 address 2001:db8:acad:1::1/64
R1(config-if)# end

R2(config)# interface lo6
R2(config-if)# no ipv6 address 2001:DB8:CAD:6::1/64
R2(config-if)# ipv6 address 2001:db8:acad:6::1/64
R2(config-if)# end

R3: No L3 connectivity issues

d. Using the ping command, verify that IPv4 and IPv6 connectivity has been established on all directly connected router interfaces. If problems still exist, continue troubleshooting Layer 3 issues.

Part 3: Troubleshoot OSPFv2

Note: LAN (loopback) interfaces should not advertise OSPF routing information, but routes to these networks should be contained in the routing tables.

Step 1: Test IPv4 end-to-end connectivity.

From each router, ping all interfaces on the other routers. Record your results below as IPv4 OSPFv2 connectivity problems do exist.
______________________________________________________

R1 to R2: All pings were successful.
R1 to R3: All pings failed.
R2 to R1: All pings were successful.
R2 to R3: Pings to the Loopback 4 and 5 failed.
R3 to R1: All pings failed.
R3 to R2: Pings to the Loopback 6 and Serial 0/0/0 failed.

Step 2: Verify that all interfaces are assigned to the proper OSPFv2 areas on R1.

a. Issue the show ip protocols command to verify that OSPF is running and that all networks are being advertised in the correct areas. Verify that the router ID is set correctly, as well for OSPF.

R1# show ip protocols
*** IP Routing is NSF aware ***  
  
Routing Protocol is "ospf 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Router ID 1.1.1.1  
  It is an area border and autonomous system boundary router  
 Redistributing External Routes from,  
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa  
  Maximum path: 4  
  Routing for Networks:  
    192.168.2.0 0.0.0.255 area 1  
    192.168.12.0 0.0.0.3 area 0  
  Passive Interface(s):  
    Loopback1  
    Loopback2  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    2.2.2.2              110      00:10:43  
  Distance: (default is 110)

b. If required, make the necessary changes needed to the configuration on R1 based on the output from the show ip protocols command. Record the commands used to correct the configuration.
________________________________________________________

R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 1
R1(config-router)# end

c. If required, re-issue the show ip protocols command to verify that your changes had the desired effect.

d. Issue the show ip ospf interface brief command to verify that the serial interface and loopback interfaces 1 and 2 are listed as OSPF networks assigned to their respective areas.

R1# show ip ospf interface brief  
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C  
Se0/0/0      1     0               192.168.12.1/30    64    P2P   1/1  
Lo2          1     1               192.168.2.1/24     1     LOOP  0/0  
Lo1          1     1               192.168.1.1/24     1     LOOP  0/0

e. Resolve any problems discovered on R1 for OSPFv2.

Instructor Note: All problems were resolved for OSPFv2 on R1.

Step 3: Verify that all interfaces are assigned to the proper OSPFv2 areas on R2.

a. Issue the show ip protocols command to verify that OSPF is running and that all networks are being advertised in their proper respective areas. Verify that the router ID is also set correctly.

R2# show ip protocols  
*** IP Routing is NSF aware ***
Routing Protocol is "ospf 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Router ID 2.2.2.2  
  It is an area border router  
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa  
  Maximum path: 4  
  Routing for Networks:  
    192.168.6.0 0.0.0.255 area 3  
    192.168.12.0 0.0.0.3 area 0  
    192.168.23.0 0.0.0.3 area 3  
  Passive Interface(s):  
    Loopback6  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    1.1.1.1              110      00:09:33  
  Distance: (default is 110)

b. If required, make any necessary changes to the configuration on R2 based on the output from the show ip protocols command. Record the commands used to correct the configuration.
_______________________________________________________
No changes are necessary on R2 for OSPFv2.

Instructor Note: No changes are necessary on R2 for OSPFv2.

c. If required, re-issue the show ip protocols command to verify that your changes had the desired effect.

d. Issue the show ip ospf interface brief command to verify that all interfaces are listed as OSPF networks assigned to their proper respective areas.

R2# show ip ospf interface brief  
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C  
Se0/0/0      1     0               192.168.12.2/30    64    P2P   1/1  
Lo6          1     3               192.168.6.1/24     1     LOOP  0/0  
Se0/0/1      1     3               192.168.23.2/30    64    P2P   0/0

e. Resolve any problems discovered on R2 for OSPFv2.

Instructor Note: All problems were resolved for OSPFv2 on R2.

Step 4: Verify that all interfaces are assigned to the proper OSPFv2 areas on R3.

a. Issue the show ip protocols command to verify that OSPF is running and that all networks are being advertised in their respective areas. Verify that the router ID is also set correctly.

R3# show ip protocols  
*** IP Routing is NSF aware ***  
  
Routing Protocol is "ospf 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Router ID 3.3.3.3
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa  
  Maximum path: 4  
  Routing for Networks:  
    192.168.4.0 0.0.0.255 area 3  
    192.168.5.0 0.0.0.255 area 3  
  Passive Interface(s):  
    Loopback4  
    Loopback5  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
  Distance: (default is 110)

b. If required, make the necessary changes to the configuration on R3 based on the output from the show ip protocols command. Record the commands used to correct the configuration.
_______________________________________________________

R3(config)# router ospf 1
R3(config-router)# network 192.168.23.0 0.0.0.3 area 3
R3(config-router)# end

c. If required, re-issue the show ip protocols command to verify that your changes had the desired effect.

d. Issue the show ip ospf interface brief command to verify that all interfaces are listed as OSPF networks assigned to their proper areas.

R3# show ip ospf interface brief  
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C  
Lo4          1     3               192.168.4.1/24     1     LOOP  0/0  
Lo5          1     3               192.168.5.1/24     1     LOOP  0/0  
Se0/0/1      1     3               192.168.23.1/30    64    P2P   1/1

e. Resolve any problems discovered on R3 for OSPFv2.

Instructor Note: All problems were resolved for OSPFv2 on R3.

Step 5: Verify OSPFv2 neighbor information.

Issue the show ip ospf neighbor command to verify that each router has all OSPFv2 neighbors listed.

R1# show ip ospf neighbor  
Neighbor ID     Pri   State           Dead Time   Address         Interface  
2.2.2.2           0   FULL/  -        00:00:39    192.168.12.2    Serial0/0/0    

R2# show ip ospf neighbor  
Neighbor ID     Pri   State           Dead Time   Address         Interface  
1.1.1.1           0   FULL/  -        00:00:31    192.168.12.1    Serial0/0/0  
3.3.3.3           0   FULL/  -        00:00:39    192.168.23.1    Serial0/0/1    

R3# show ip ospf neighbor  
Neighbor ID     Pri   State           Dead Time   Address         Interface  
2.2.2.2           0   FULL/  -        00:00:39    192.168.23.2    Serial0/0/1

Step 6: Verify OSPFv2 routing information.

a. Issue the show ip route ospf command to verify that each router has all OSPFv2 routes in their respective routing tables.

R1# show ip route ospf  
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route  
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       + - replicated route, % - next hop override  
  
Gateway of last resort is 0.0.0.0 to network 0.0.0.0  
  
      192.168.4.0/32 is subnetted, 1 subnets  
O IA     192.168.4.1 [110/129] via 192.168.12.2, 00:16:10, Serial0/0/0  
      192.168.5.0/32 is subnetted, 1 subnets  
O IA     192.168.5.1 [110/129] via 192.168.12.2, 00:16:10, Serial0/0/0  
      192.168.6.0/32 is subnetted, 1 subnets  
O IA     192.168.6.1 [110/65] via 192.168.12.2, 00:56:07, Serial0/0/0  
      192.168.23.0/30 is subnetted, 1 subnets  
O IA     192.168.23.0 [110/128] via 192.168.12.2, 00:56:07, Serial0/0/0    

R2# show ip route ospf  
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route  
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       + - replicated route, % - next hop override  
  
Gateway of last resort is 192.168.12.1 to network 0.0.0.0  
  
O*E2  0.0.0.0/0 [110/1] via 192.168.12.1, 00:57:11, Serial0/0/0  
      192.168.1.0/32 is subnetted, 1 subnets  
O IA     192.168.1.1 [110/65] via 192.168.12.1, 00:39:50, Serial0/0/0  
      192.168.2.0/32 is subnetted, 1 subnets  
O IA     192.168.2.1 [110/65] via 192.168.12.1, 00:57:10, Serial0/0/0  
      192.168.4.0/32 is subnetted, 1 subnets  
O        192.168.4.1 [110/65] via 192.168.23.1, 00:17:13, Serial0/0/1  
      192.168.5.0/32 is subnetted, 1 subnets  
O        192.168.5.1 [110/65] via 192.168.23.1, 00:17:13, Serial0/0/1    

R3# show ip route ospf  
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route  
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       + - replicated route, % - next hop override  
  
Gateway of last resort is 192.168.23.1 to network 0.0.0.0  
  
O*E2  0.0.0.0/0 [110/1] via 192.168.23.1, 00:18:06, Serial0/0/1  
      192.168.1.0/32 is subnetted, 1 subnets  
O IA     192.168.1.1 [110/129] via 192.168.23.2, 00:18:06, Serial0/0/1  
      192.168.2.0/32 is subnetted, 1 subnets  
O IA     192.168.2.1 [110/129] via 192.168.23.2, 00:18:06, Serial0/0/1  
      192.168.6.0/32 is subnetted, 1 subnets  
O        192.168.6.1 [110/65] via 192.168.23.2, 00:18:06, Serial0/0/1  
      192.168.12.0/30 is subnetted, 1 subnets  
O IA     192.168.12.0 [110/128] via 192.168.23.2, 00:18:06, Serial0/0/1

b. If any OSPFv2 routes are missing, troubleshoot and resolve the problems.

Instructor Note: All routes for OSPFv2 are in all three routing tables.

Step 7: Verify IPv4 end-to-end connectivity.

From each router, ping all interfaces on other routers. If IPv4 end-to-end connectivity does not exist, then continue troubleshooting to resolve any remaining issues.

Part 4: Troubleshoot OSPFv3

Note: LAN (loopback) interfaces should not advertise OSPFv3 routing information, but routes to these networks should be contained in the routing tables.

Step 1: Test IPv6 end-to-end connectivity.

From each router, ping all interfaces on the other routers. Record your results as IPv6 connectivity problems do exist.
________________________________________________________
R1 to R2: All pings to loopback 6 failed.
R1 to R3: All pings were successful.
R2 to R1: All pings to loopback 1 and 2 failed.
R2 to R3: All pings were successful.
R3 to R1: All pings were successful.
R3 to R2: All pings were successful.

Step 2: Verify that IPv6 unicast routing has been enabled on all routers.

a. An easy way to verify that IPv6 routing has been enabled on a router is to use the show run | section ipv6 unicast command. By adding the pipe section to the show run command, the ipv6 unicast-routing command is displayed if IPv6 routing has been enabled.

R1# show run | section ipv6 unicast
ipv6 unicast-routing

R2# show run | section ipv6 unicast
ipv6 unicast-routing

R3# show run | section ipv6 unicast
ipv6 unicast-routing

b. If IPv6 unicast routing is not enabled on one or more routers, enable it now. If required, record the commands used to correct the configuration.
_______________________________________________________
IPv6 routing has been enabled on all routers.

Step 3: Verify that all interfaces are assigned to the proper OSPFv3 areas on R1.

a. Issue the show ipv6 protocols command to verify that the router ID is correct and the expected interfaces display in their proper areas.

R1# show ipv6 protocols  
IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "ospf 1"  
  Router ID 209.165.200.225  
  Area border router  
  Number of areas: 2 normal, 0 stub, 0 nssa  
  Interfaces (Area 0):  
    Serial0/0/0  
  Interfaces (Area 1):  
    Loopback2  
  Redistribution:  
    None

b. If required, make any necessary changes to the configuration on R1 based on the output from the show ipv6 protocols command. Record the commands used to correct the configuration. It may be necessary to reset OSPF process by issuing the clear ipv6 ospf process command.
________________________________________________________

R1(config)# interface lo1
R1(config-if)# ipv6 ospf 1 area 1
R1(config-if)# ipv6 router ospf 1
R1(config-rtr)# router-id 1.1.1.1

c. Re-issue the show ipv6 protocols command on R1 to make sure changes took effect

R1# show ipv6 protocols  
IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "ospf 1"  
  Router ID 1.1.1.1  
  Area border router  
  Number of areas: 2 normal, 0 stub, 0 nssa  
  Interfaces (Area 0):  
    Serial0/0/0  
  Interfaces (Area 1):  
    Loopback2  
    Loopback1  
  Redistribution:  
    None

d. Enter the show ipv6 route ospf command on R1 to verify that the routes are configured correctly.

R1# show ipv6 route ospf  
IPv6 Routing Table - default - 10 entries  
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route  
       B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2  
       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external  
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect  
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2  
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2  
OI  2001:DB8:ACAD:4::1/128 [110/128]  
     via FE80::2, Serial0/0/0  
OI  2001:DB8:ACAD:5::1/128 [110/128]  
     via FE80::2, Serial0/0/0  
OI  2001:DB8:ACAD:23::/64 [110/128]  
     via FE80::2, Serial0/0/0

Step 4: Verify that all interfaces are assigned to the proper OSPFv3 areas on R2.

a. Issue the show ipv6 protocols command and verify that the router ID is correct and that the expected interfaces are showing up under their proper areas.

R2# show ipv6 protocols  
IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "ospf 1"  
  Router ID 2.2.2.2  
  Area border router  
  Number of areas: 2 normal, 0 stub, 0 nssa  
  Interfaces (Area 0):  
    Serial0/0/0  
  Interfaces (Area 3):  
    Serial0/0/1  
  Redistribution:  
    None

b. If required, make any necessary changes to the configuration on R2 based on the output from the show ipv6 protocols command. Record the commands used to correct the configuration. It may be necessary to reset OSPF process by issuing the clear ipv6 ospf process command.
________________________________________________________

R2(config)# interface lo 6
R2(config-if)# ipv6 ospf 1 area 3

c. Verify that the configuration change has the desired effect.

R2# show ipv6 protocols  
IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "ospf 1"  
  Router ID 2.2.2.2  
  Area border router  
  Number of areas: 2 normal, 0 stub, 0 nssa  
  Interfaces (Area 0):  
    Serial0/0/0  
  Interfaces (Area 3):  
    Loopback6  
    Serial0/0/1  
  Redistribution:  
    None

Step 5: Verify that all interfaces are assigned to the proper OSPFv3 areas on R3.

a. Issue the show ipv6 protocols command to verify that the router ID is correct and the expected interfaces display under their respective areas.

R3# show ipv6 protocols  
IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "ospf 1"  
  Router ID 3.3.3.3  
  Number of areas: 1 normal, 0 stub, 0 nssa  
  Interfaces (Area 3):  
    Loopback4  
    Loopback5  
    Serial0/0/1  
  Redistribution:  
    None

b. If required, make any necessary changes to the configuration on R3 based on the output from the show ipv6 protocols command. Record the commands used to correct the configuration. It may be necessary to reset OSPF process by issuing the clear ipv6 ospf process command.
________________________________________________________
There are no problems with R3.

c. Verify that the configuration changes have the desired effect.

Step 6: Verify that all routers have correct neighbor adjacency information.

a. Issue the show ipv6 ospf neighbor command to verify that adjacencies have formed between neighboring routers.

R1# show ipv6 ospf neighbor  
OSPFv3 Router with ID (1.1.1.1) (Process ID 1)  
  
Neighbor ID     Pri   State           Dead Time   Interface ID    Interface  
2.2.2.2           0   FULL/  -        00:00:37    6               Serial0/0/0    

R2# show ipv6 ospf neighbor  
OSPFv3 Router with ID (2.2.2.2) (Process ID 1)  
  
Neighbor ID     Pri   State           Dead Time   Interface ID    Interface  
1.1.1.1           0   FULL/  -        00:00:39    6               Serial0/0/0  
3.3.3.3           0   FULL/  -        00:00:35    7               Serial0/0/1    

R3# show ipv6 ospf neighbor  
OSPFv3 Router with ID (3.3.3.3) (Process ID 1)  
  
Neighbor ID     Pri   State           Dead Time   Interface ID    Interface  
2.2.2.2           0   FULL/  -        00:00:34    7               Serial0/0/1

Step 7: Verify OSPFv3 routing information.

a. Issue the show ipv6 route ospf command, and verify that OSPFv3 routes exist to all networks.

R1# show ipv6 route ospf  
IPv6 Routing Table - default - 11 entries  
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route  
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1  
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP  
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination  
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1  
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2  
       a - Application  
OI  2001:DB8:ACAD:4::1/128 [110/128]  
     via FE80::2, Serial0/0/0  
OI  2001:DB8:ACAD:5::1/128 [110/128]  
     via FE80::2, Serial0/0/0  
OI  2001:DB8:ACAD:6::1/128 [110/64]  
     via FE80::2, Serial0/0/0  
OI  2001:DB8:ACAD:23::/64 [110/128]  
     via FE80::2, Serial0/0/0    

R2# show ipv6 route ospf  
IPv6 Routing Table - default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route  
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1  
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP  
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination  
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1  
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2  
       a - Application  
OI  2001:DB8:ACAD:1::/64 [110/65]  
     via FE80::1, Serial0/0/0  
OI  2001:DB8:ACAD:2::/64 [110/65]  
     via FE80::1, Serial0/0/0  
O   2001:DB8:ACAD:4::1/128 [110/64]  
     via FE80::3, Serial0/0/1  
O   2001:DB8:ACAD:5::1/128 [110/64]  
     via FE80::3, Serial0/0/1    

R3# show ipv6 route ospf  
IPv6 Routing Table - default - 11 entries  
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route  
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1  
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP  
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination  
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1  
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2  
       a - Application  
OI  2001:DB8:ACAD:1::/64 [110/129]  
     via FE80::2, Serial0/0/1  
OI  2001:DB8:ACAD:2::/64 [110/129]  
     via FE80::2, Serial0/0/1  
O   2001:DB8:ACAD:6::1/128 [110/64]  
     via FE80::2, Serial0/0/1  
OI  2001:DB8:ACAD:12::/64 [110/128]  
     via FE80::2, Serial0/0/1

b. Resolve any routing issues that still exist.

Instructor Note: All OSPFv3 routing issues should have been resolved.

Step 8: Verify IPv6 end-to-end connectivity.

From each router, ping all of the IPv6 interfaces on the other routers. If IPv6 end-to-end issues still exist, continue troubleshooting to resolve any remaining issues.

Reflection

Why not just use the show running-config command to resolve all issues?
_______________________________________________________
Specific show commands give you the appropriate information that you need to verify settings without showing a lot of extraneous information.

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs

Router R1

R1#sh run
Building configuration...

Current configuration : 2041 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
!
!
!
!
!
!
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
interface Loopback0
ip address 209.165.200.225 255.255.255.252
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:1::1/64
ipv6 ospf 1 area 1
ipv6 ospf network point-to-point
!
interface Loopback2
ip address 192.168.2.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:2::1/64
ipv6 ospf 1 area 1
ipv6 ospf network point-to-point
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.12.1 255.255.255.252
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:12::1/64
ipv6 ospf 1 area 0
clock rate 128000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 1.1.1.1
passive-interface Loopback1
passive-interface Loopback2
network 192.168.1.0 0.0.0.255 area 1
network 192.168.2.0 0.0.0.255 area 1
network 192.168.12.0 0.0.0.3 area 0
default-information originate
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Loopback0
!
ipv6 router ospf 1
router-id 1.1.1.1
!
!
!
!
control-plane
!
!
banner motd ^C
Unauthorized Access is Prohibited! ^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
logging synchronous
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router R2

R2#sh run
Building configuration...

Current configuration : 1847 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
!
!
!
!
!
!
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
!
interface Loopback6
ip address 192.168.6.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:6::1/64
ipv6 ospf 1 area 3
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.12.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:12::2/64
ipv6 ospf 1 area 0
!
interface Serial0/0/1
ip address 192.168.23.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:23::2/64
ipv6 ospf 1 area 3
clock rate 128000
!
router ospf 1
router-id 2.2.2.2
passive-interface Loopback6
network 192.168.6.0 0.0.0.255 area 3
network 192.168.12.0 0.0.0.3 area 0
network 192.168.23.0 0.0.0.3 area 3
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ipv6 router ospf 1
router-id 2.2.2.2
!
!
!
!
control-plane
!
!
banner motd ^C
Unauthorized Access is Prohibited! ^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
logging synchronous
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router R3

R3#sh run
Building configuration...

Current configuration : 1853 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
!
!
!
!
!
!
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
!
interface Loopback4
ip address 192.168.4.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:4::1/64
ipv6 ospf 1 area 3
!
interface Loopback5
ip address 192.168.5.1 255.255.255.0
ipv6 address 2001:DB8:ACAD:5::1/64
ipv6 ospf 1 area 3
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
ip address 192.168.23.1 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:23::1/64
ipv6 ospf 1 area 3
!
router ospf 1
router-id 3.3.3.3
passive-interface Loopback4
passive-interface Loopback5
network 192.168.4.0 0.0.0.255 area 3
network 192.168.5.0 0.0.0.255 area 3
network 192.168.23.0 0.0.0.3 area 3
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ipv6 router ospf 1
router-id 3.3.3.3
!
!
!
!
control-plane
!
!
banner motd ^C
Unauthorized Access is Prohibited! ^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
logging synchronous
login
transport input all
!
scheduler allocate 20000 1000
!
end

 


guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x