3.5.3.5 Lab – Configure and Verify eBGP Answers

3.5.3.5 Lab – Configure and Verify eBGP (Instructor Version)

Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

Addressing Table

Device Interface IP Address Subnet Mask
R1 S0/0/0 (DCE) 198.133.219.1 255.255.255.248
R2 S0/0/0 198.133.219.2 255.255.255.248
S0/0/1 (DCE) 209.165.200.2 255.255.255.252
ISP-1 S0/0/1 209.165.200.1 255.255.255.252
Web Server 10.10.10.10 255.255.255.255

Objectives

Part 1: Build the Network and Configure Basic Device Settings
Part 2: Configure eBGP on R1
Part 3: Verify eBGP Configuration

Background / Scenario

In this lab you will configure eBGP for the Company. The ISP will provide the default route to the Internet. Once configuration is complete you will use various show commands to verify that the eBGP configuration is working as expected.

Required Resources

  • 3 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Serial cables as shown in the topology

Part 1: Build the Network and Configure Basic Device Settings

In Part 1, you will set up the network topology and configure basic settings on R1 and R2 routers. You will also copy the provided configuration for ISP-1 on to that router.

Step 1: Cable the network as shown in the topology.

Step 2: Initialize and reload the network devices as necessary.

Step 3: Configure basic settings on R1 and R2.

a. Disable DNS lookup to prevent the routers from attempting to translate incorrectly entered commands as though they were host names.

b. Configure the hostnames according to the topology.

c. Configure interfaces according to the Addressing Table.

d. Save the running configuration to the startup configuration file.

Step 4: Copy configuration to ISP-1.

Copy and paste the following configuration to ISP-1.

hostname ISP-1
no ip domain-lookup
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
interface Serial0/0/1
 ip address 209.165.200.1 255.255.255.252
 no shut
ip route 0.0.0.0 0.0.0.0 lo0
router bgp 65001
 bgp log-neighbor-changes
 network 0.0.0.0
 neighbor 209.165.200.2 remote-as 65000
end

Part 2: Configure eBGP on R2

Configure R2 to become an eBGP peer with ISP-1. Refer to the Topology for BGP AS number information.

Step 1: Enable BGP and identify the AS number for the Company.

R2(config)# router bgp 65000

Step 2: Use the neighbor command to identify ISP-1 as the BGP peer.

R2(config-router)# neighbor 209.165.200.1 remote-as 65001

Step 3: Add the Company’s network to the BGP table so it is advertised to ISP-1.

R2(config-router)# network 198.133.219.0 mask 255.255.255.248

Part 3: Verify eBGP Configuration

In Part 3, use the BGP verifications commands to verify that the BGP configuration is working as expected.

Step 1: Display the IPv4 routing table on R2.

R2# show ip route  
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route  
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       a - application route  
       + - replicated route, % - next hop override  
  
Gateway of last resort is 209.165.200.1 to network 0.0.0.0  
  
B*    0.0.0.0/0 [20/0] via 209.165.200.1, 00:00:07  
      198.133.219.0/24 is variably subnetted, 2 subnets, 2 masks  
C        198.133.219.0/29 is directly connected, Serial0/0/0  
L        198.133.219.2/32 is directly connected, Serial0/0/0  
      209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks  
C        209.165.200.0/30 is directly connected, Serial0/0/1  
L        209.165.200.2/32 is directly connected, Serial0/0/1

Step 2: Display the BGP table on R2.

R2# show ip bgp  
BGP table version is 4, local router ID is 209.165.200.2  
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,   
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,   
              x best-external, a additional-path, c RIB-compressed,   
Origin codes: i - IGP, e - EGP, ? - incomplete  
RPKI validation codes: V valid, I invalid, N Not found  
  
     Network          Next Hop            Metric LocPrf Weight Path  
 *>  0.0.0.0          209.165.200.1            0             0 65001 i  
 *>  198.133.219.0/29 0.0.0.0                  0         32768 i

Step 3: Display the BGP connection status on R2.

R2# show ip bgp summary
BGP router identifier 209.165.200.2, local AS number 65000  
BGP table version is 4, main routing table version 4  
2 network entries using 288 bytes of memory  
2 path entries using 160 bytes of memory  
2/2 BGP path/bestpath attribute entries using 320 bytes of memory  
1 BGP AS-PATH entries using 24 bytes of memory  
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory  
BGP using 792 total bytes of memory  
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs  
  
Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd  
209.165.200.1   4        65001      12      11        4    0    0 00:06:56        1

Step 4: Display the IPv4 routing table on ISP-1.

Verify that the 198.133.218.0/29 network is being advertised to the ISP-1 router.

ISP-1# show ip route  
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route  
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       a - application route  
       + - replicated route, % - next hop override  
  
Gateway of last resort is 0.0.0.0 to network 0.0.0.0  
  
S*    0.0.0.0/0 is directly connected, Loopback0  
      10.0.0.0/32 is subnetted, 1 subnets  
C        10.10.10.10 is directly connected, Loopback0  
      198.133.219.0/29 is subnetted, 1 subnets  
B        198.133.219.0 [20/0] via 209.165.200.2, 00:00:25  
      209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks  
C        209.165.200.0/30 is directly connected, Serial0/0/1  
L        209.165.200.1/32 is directly connected, Serial0/0/1

Ping the Web Server from R1. Were the pings successful?
______________________________________________________
Yes, the pings should have been successful.

Reflection

The topology used in this lab was created to demonstrate how to configure the BGP routing protocol. However, the BGP protocol would not normally be configured for a topology like this in the real world. Explain.
_______________________________________________________
Answers may vary. BGP is normally not needed for a Single-honed network. The ISP would provide an IP Subnet range of IP addresses for the Company to use for Internet Access and the ISP would be responsible for routing the Company traffic to R2. So, only the ISP would need to have BGP configured.

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs

Router R1

R1# show run
Building configuration...
Current configuration : 1334 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
cts logging verbose
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 198.133.219.1 255.255.255.248
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

Router R2

R2# show run
Building configuration...

Current configuration : 1409 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 198.133.219.2 255.255.255.248
!
interface Serial0/0/1
ip address 209.165.200.2 255.255.255.252
clock rate 2000000
!
router bgp 65000
bgp log-neighbor-changes
network 198.233.219.0 mask 255.255.255.248
neighbor 209.165.200.1 remote-as 65001
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

Router ISP-1

ISP-1# show run
Building configuration...

Current configuration : 1535 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP-1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
!
redundancy
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
ip address 209.165.200.1 255.255.255.252
!
router bgp 65001
bgp log-neighbor-changes
network 0.0.0.0
neighbor 209.165.200.2 remote-as 65000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Loopback0
!
control-plane
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x