Redistribute RIP Ver2 vs OSPF vs EIGRP

Redistribute EIGRP RIP OSPF

Redistribute RIP Ver2 vs OSPF vs EIGRP 2

1. Configuration interface of router.

*Configuration On R1
– Configuration rename device

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#
– Configuration Banner motd

R1(config)#banner motd “itexamanswers”

– Configuration console

R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#loggin synchronous
R1(config-line)#exit

– Configuration telnet

R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit

– Configuration password privileged

R1(config)#enable secret itexamanswers

– Configuration enable password

R1(config)#enable password cisco123

– Configuration encryption password trong file Configuration

R1(config)#service password-encryption

– Configuration interface of route

R1(config)#interface serial 0/1
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#description “R1 Connection to R2”
R1(config-if)#no shut
R1(config-if)#clock rate 64000
R1(config-if)#exit

R1(config)#interface loopback 0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#end
*Configuration On R2
– Configuration rename device

Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#

– Configuration Banner motd

R2(config)#banner motd “itexamanswers”

– Configuration console

R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#loggin synchronous
R2(config-line)#exit

– Configuration telnet

R2(config)#line vty 0 4
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#exit
– Configuration password privileged

R2(config)#enable secret itexamanswers

– Configuration enable password

R2(config)#enable password cisco123

– Configuration encryption password trong file Configuration

R2(config)#service password-encryption

– Configuration interface of route

R2(config)#interface serial 0/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#description “R2 Connection to R1”
R2(config-if)#no shut
R2(config-if)#exit

R2(config)#interface serial 0/1
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#description “R2 Connection to R3”
R2(config-if)#no shut
R2(config-if)#clock rate 64000
R2(config-if)#end
*Configuration On R3
– Configuration rename device

Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#

– Configuration Banner motd

R3(config)#banner motd “itexamanswers”

– Configuration console

R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#loggin synchronous
R3(config-line)#exit

– Configuration telnet

R3(config)#line vty 0 4
R3(config-line)#password cisco
R3(config-line)#login
R3(config-line)#exit

– Configuration password privileged

R3(config)#enable secret itexamanswers

– Configuration enable password

R3(config)#enable password cisco123

– Configuration encryption password trong file Configuration

R3(config)#service password-encryption

– Configuration interface of route

R3(config)#interface serial 0/0
R3(config-if)#ip address 192.168.3.2 255.255.255.0
R3(config-if)#description “R3 Connection to R2”
R3(config-if)#no shut
R3(config-if)#exit

R3(config)#interface serial 0/1
R3(config-if)#ip address 192.168.4.1 255.255.255.0
R3(config-if)#description “R3 Connection to R4”
R3(config-if)#no shut
R3(config-if)# clock rate 64000
R3(config-if)#end
R3#

*Configuration On R4
– Configuration rename device

Router>enable
Router#configure terminal
Router(config)#hostname R4
R4(config)#

– Configuration Banner motd

R4(config)#banner motd “itexamanswers”

– Configuration console

R4(config)#line console 0
R4(config-line)#password cisco
R4(config-line)#loggin synchronous
R4 (config-line)#exit

– Configuration telnet

R4(config)#line vty 0 4
R4(config-line)#password cisco
R4(config-line)#login
R4(config-line)#exit
– Configuration password privileged

R4(config)#enable secret itexamanswers

– Configuration enable password

R4(config)#enable password cisco123

– Configuration encryption password

R4(config)#service password-encryption

– Configuration interface route

R4(config)#interface serial 0
R4(config-if)#ip address 192.168.4.2 255.255.255.0
R4(config-if)#description “R4 Connection to R3”
R4 (config-if)#no shut
R4(config-if)#end

R4 (config)#interface loopback 0
R4(config-if)#ip address 192.168.5.1 255.255.255.0
R4(config-if)#exit

2. Ping neighbor

*On Router R1:

R1#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms
R1#

*On Router R2:

R2#ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/8 ms
R2#ping 192.168.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/6 ms
R2#

*On Router R3:

R3#ping 192.168.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms

R3#ping 192.168.4.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.4.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/6 ms
R3#

*On Router R4:

R4#ping 192.168.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/6 ms
R4#

3. Set routing protocol EIGRP On router.

*On Router R1:

R1#configure terminal
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)#no auto-summary
R1(config-router)#end
R1#
*On Router R2:

R2#configure terminal
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 192.168.2.0
R2(config-router)#no auto-summary
R2(config-router)#exit

R2(config)#router eigrp 10
R2(config-router)#network 192.168.3.0
R2(config-router)#no auto-summary
R2(config-router)#exit
R2(config)#

*On Router R3:

R3#configure terminal
R3(config)#router eigrp 10
R3(config-router)#network 192.168.3.0
R3(config-router)#no auto-summary
R3(config-router)#exit
R3(config)#

R3(config)#router ospf 1
R3(config-router)#network 192.168.4.0 0.0.0.255 area 0
R3(config-router)#exit
R3(config)#
*On Router R4:

R4#configure terminal
R4(config)#router ospf 1
R4(config-router)#network 192.168.4.0 0.0.0.255 area 0
R4(config-router)#network 192.168.5.0 0.0.0.255 area 0
R4(config-router)#end
R4#

4. Redistribute:

*On Router R2:

R2(config)#router rip
R2(config-router)#redistribute eigrp 10 metric 1
R2(config-router)#exit

R2(config)#router eigrp 10
R2(config-router)#redistribute rip metric 1000000 10 255 1 1500
R2(config-router)#end
R2#

*On Router R3:

R3(config)#router eigrp 10
R3(config-router)#redistribute ospf 1 metric 1000000 10 255 1 1500
R3(config-router)#exit

R3(config)#router ospf 1
R3(config-router)#redistribute eigrp 10 metric 1 subnets
R3(config-router)#end

5. View routing table.
*On Router R1:

R1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
C 192.168.1.0/24 is directly connected, Loopback0
C 192.168.2.0/24 is directly connected, Serial0/1
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:05, Serial0/1
R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:05, Serial0/1
192.168.5.0/32 is subnetted, 1 subnets
R 192.168.5.1 [120/1] via 192.168.2.2, 00:00:05, Serial0/1
R1#

*On Router R2:

R2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:23, Serial0/0
C 192.168.2.0/24 is directly connected, Serial0/0
C 192.168.3.0/24 is directly connected, Serial0/1
D EX 192.168.4.0/24 [170/2172416] via 192.168.3.2, 00:02:23, Serial0/1
192.168.5.0/32 is subnetted, 1 subnets
D EX 192.168.5.1 [170/2172416] via 192.168.3.2, 00:02:23, Serial0/1
R2#

*On Router R3:

R3#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
D EX 192.168.1.0/24 [170/2172416] via 192.168.3.1, 00:05:42, Serial0/0
D EX 192.168.2.0/24 [170/2172416] via 192.168.3.1, 00:05:42, Serial0/0
C 192.168.3.0/24 is directly connected, Serial0/0
C 192.168.4.0/24 is directly connected, Serial0/1
192.168.5.0/32 is subnetted, 1 subnets
O 192.168.5.1 [110/65] via 192.168.4.2, 00:08:47, Serial0/1
R3#
*On Router R4

R4#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
O E2 192.168.1.0/24 [110/1] via 192.168.4.1, 00:02:38, Serial0/0
O E2 192.168.2.0/24 [110/1] via 192.168.4.1, 00:02:38, Serial0/0
O E2 192.168.3.0/24 [110/1] via 192.168.4.1, 00:02:38, Serial0/0
C 192.168.4.0/24 is directly connected, Serial0/0
C 192.168.5.0/24 is directly connected, Loopback0
R4#

6. Test router can ping mutual.

*On Router R1:
R1#ping 192.168.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/5 ms
R1#ping 192.168.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/8/11 ms
R1#ping 192.168.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/6/8 ms
R1#ping 192.168.4.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.4.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 11/12/14 ms
R1#ping 192.168.5.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/15 ms
R1#

*On Router R2:

R2#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms
R2#ping 192.168.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/5 ms
R2#ping 192.168.4.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.4.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/7/10 ms
R2#ping 192.168.5.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/10 ms
R2#

*On Router R3:

R3#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/8/10 ms
R3#ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/9/11 ms
R3#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/5 ms
R3#ping 192.168.5.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/6 ms
R3#

*On Router R4:

R4#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/7/10 ms
R4#ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/10/16 ms
R4#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/11 ms
R4#ping 192.168.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/6/10 ms
R4#ping 192.168.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Efors to 192.168.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/6 ms
R4#

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x