10.1.2.5 Lab – Configure CDP and LLDP Answers

10.1.2.5 Lab – Configure CDP and LLDP (Instructor Version)

Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

Addressing Table

Device Interface IP Address Subnet Mask
Gateway G0/1 192.168.1.254 255.255.255.0
S0/0/1 209.165.200.226 255.255.255.252
ISP S0/0/1 (DCE) 209.165.200.225 255.255.255.252

Objectives

Part 1: Build the Network and Configure Basic Device Settings
Part 2: Network Discovery with CDP
Part 3: Network Discovery with LLDP

Background / Scenario

Cisco Discovery Protocol (CDP) is a Cisco proprietary protocol for network discovery on the data link layer. It can share information such as device names and IOS versions, with other physically connected Cisco devices. Link Layer Discovery Protocol (LLDP) is vendor-neutral protocol using on the data link layer for network discovery. It is mainly used with network devices in the local area network (LAN). The network devices advertise information, such as their identities and capabilities to their neighbors.

In this lab, you must document the ports that are connected to other switches using CDP and LLDP. You will document your findings in a network topology diagram. You will also enable or disable these discovery protocols as necessary.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Make sure that the routers and switches have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 1 Router (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • 3 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Part 1: Build the Network and Configure Basic Device Settings

In Part 1, you will set up the network topology and configure basic settings on the router and switches.

Step 1: Cable the network as shown in the topology.

The Ethernet ports used on the switches are not specified in the topology. You may choose to use any Ethernet ports to cable the switches as shown in the topology diagram.

Step 2: Initialize and reload the network devices as necessary.

Step 3: Configure basic device settings for the switches.

a. Console into the device and enable privileged EXEC mode.

b. Enter configuration mode.

c. Disable DNS lookup to prevent the switch from attempting to translate incorrectly entered commands as though they were host names.

d. Configure the hostname according to the topology.

e. Verify that the switchports with connected Ethernet cables are enabled.

f. Save the running configuration to the startup configuration file.

Step 4: Configure basic device settings for the routers.

a. Console into the device and enable privileged EXEC mode.

b. Enter configuration mode.

c. Copy and paste the following configurations into the routers.

ISP:

hostname ISP
no ip domain lookup
interface Serial0/0/1
 ip address 209.165.200.225 255.255.255.252
 no shutdown

Gateway:

hostname Gateway
no ip domain lookup
interface GigabitEthernet0/1
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 no shutdown
interface Serial0/0/1
 ip address 209.165.200.226 255.255.255.252
 ip nat outside
 no shutdown
ip nat inside source list 1 interface Serial0/0/1 overload
access-list 1 permit 192.168.1.0 0.0.0.255

d. Save the running configuration to the startup configuration file.

Part 2: Network Discovery with CDP

On Cisco devices, CDP is enabled by default. You will use CDP to discover the ports that are currently connected.

a. On router Gateway, enter the show cdp command in the privileged EXEC mode to verify that CDP is currently enabled on router Gateway.

Gateway# show cdp
Global CDP information:
        Sending CDP packets every 60 seconds
        Sending a holdtime value of 180 seconds
        Sending CDPv2 advertisements is enabled

How often are CDP packets sent?
___________________________________________________
CDP packets are sent out every 60 seconds.

If CDP is disabled on Gateway, enable CDP by issuing the cdp run command in the global configuration mode.

Gateway(config)# cdp run
Gateway(config)# end

b. Issue the show cdp interface to list the interfaces that are participating in CDP advertisements.

Gateway# show cdp interface
Embedded-Service-Engine0/0 is administratively down, line protocol is down
  Encapsulation ARPA
  Sending CDP packets every 60 seconds
  Holdtime is 180 seconds
GigabitEthernet0/0 is administratively down, line protocol is down
  Encapsulation ARPA
  Sending CDP packets every 60 seconds
  Holdtime is 180 seconds
GigabitEthernet0/1 is up, line protocol is up
  Encapsulation ARPA
  Sending CDP packets every 60 seconds
  Holdtime is 180 seconds
Serial0/0/0 is administratively down, line protocol is down
  Encapsulation HDLC
  Sending CDP packets every 60 seconds
  Holdtime is 180 seconds
Serial0/0/1 is up, line protocol is up
  Encapsulation HDLC
  Sending CDP packets every 60 seconds
  Holdtime is 180 seconds

cdp enabled interfaces : 5
interfaces up : 2
interfaces down : 3

How many interfaces are participating in the CDP advertisement? Which interfaces are up?
____________________________________________________
Five interfaces are participating in CDP. The interfaces S0/0/1 and G0/1 are up.

c. Issue the show cdp neighbors command to determine the CDP neighbors.

Gateway# show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID      Local Intrfce     Holdtme    Capability   Platform Port ID
ISP            Ser 0/0/1         158            R B S I CISCO1941 Ser 0/0/1
S3             Gig 0/1           170              S I WS-C2960- Fas 0/5

d. For more details on CDP neighbors, issue the show cdp neighbors detail command.

Gateway# show cdp neighbors detail
-------------------------
Device ID: ISP
Entry address(es):
  IP address: 209.165.200.225
Platform: Cisco CISCO1941/K9, Capabilities: Router Source-Route-Bridge
Switch IGMP
Interface: Serial0/0/1, Port ID (outgoing port): Serial0/0/1
Holdtime : 143 sec

Version :
Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.4(3)M2,
RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Fri 06-Feb-15 17:01 by prod_rel_team
advertisement version: 2
Management address(es):
  IP address: 209.165.200.225

-------------------------
Device ID: S3
Entry address(es):
Platform: cisco WS-C2960-24TT-L, Capabilities: Switch IGMP
Interface: GigabitEthernet0/1, Port ID (outgoing port): FastEthernet0/5
Holdtime : 158 sec

Version :
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 15.0(2)SE7,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Thu 23-Oct-14 14:49 by prod_rel_team

advertisement version: 2
Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload len=27,
value=00000000FFFFFFFF010221FF0000000000000CD996E87400FF0000
VTP Management Domain: ''
Native VLAN: 1
Duplex: full

e. What can you learn about ISP and S3 from the outputs of the show cdp neighbors detail command?
____________________________________________________
The output displays the IOS version, device model, and the IP Address on S0/0/1 interface for ISP. On S3, the output shows information, such as the IOS version, VTP management domain, and native VLAN, duplex.

f. Configure the SVI on S3. Use an available IP address in 192.168.1.0 / 24 network. Configure 192.168.1.254 as the default gateway.

S3(config)# interface vlan 1
S3(config-if)# ip address 192.168.1.3 255.255.255.0
S3(config-if)# no shutdown
S3(config-if)# exit
S3(config)# ip default-gateway 192.168.1.254

g. Issue the show cdp neighbors detail command on Gateway. What additional information is available?
____________________________________________________
The output includes the IP address for SVI on S3 that was just configured.

Gateway# show cdp neighbors detail | begin S3
Device ID: S3
Entry address(es):
   IP address: 192.168.1.3
Platform: cisco WS-C2960-24TT-L, Capabilities: Switch IGMP
Interface: GigabitEthernet0/1, Port ID (outgoing port): FastEthernet0/5
Holdtime : 163 sec

Version :
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 15.0(2)SE7,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Thu 23-Oct-14 14:49 by prod_rel_team

advertisement version: 2
Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload len=27,
value=00000000FFFFFFFF010221FF0000000000000CD996E87400FF0000
VTP Management Domain: ''
Native VLAN: 1
Duplex: full
Management address(es):
   IP address: 192.168.1.3

Total cdp entries displayed : 2

h. For security reasons, it is a good idea to turn off CDP on an interface facing an external network. Issue the no cdp enable in the interface configuration mode on the S0/0/1 interface on Gateway.

Gateway(config)# interface s0/0/1
Gateway(config-if)# no cdp enable
Gateway(config-if)# end

To verify that CDP has been turned off on the interface S0/0/1, issue the show cdp neighbors or show cdp interface command. You may need to wait for the hold time to expire. The hold time is the amount of time the network devices will hold the CDP packets until the devices discard them.

Gateway# show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID     Local Intrfce      Holdtme     Capability  Platform  Port ID
S3            Gig 0/1            161               S I   WS-C2960- Fas 0/5

The interface S0/0/1 on Gateway no longer has a CDP adjacency with the ISP router. But it still has CDP adjacencies with other interfaces.

Gateway# show cdp interface
Embedded-Service-Engine0/0 is administratively down, line protocol is down
  Encapsulation ARPA
  Sending CDP packets every 60 seconds
  Holdtime is 180 seconds
GigabitEthernet0/0 is administratively down, line protocol is down
  Encapsulation ARPA
  Sending CDP packets every 60 seconds
  Holdtime is 180 seconds
GigabitEthernet0/1 is up, line protocol is up
 Encapsulation ARPA
 Sending CDP packets every 60 seconds
 Holdtime is 180 seconds
Serial0/0/0 is administratively down, line protocol is down
 Encapsulation HDLC
 Sending CDP packets every 60 seconds
 Holdtime is 180 seconds

cdp enabled interfaces : 4
interfaces up : 1
interfaces down : 3

i. To disable CDP globally, issue the no cdp run command in the global configuration mode.

Gateway# conf t
Gateway(config)# no cdp run
Gateway(config)# end

Which command(s) would you use to verify that CDP has been disabled?
_____________________________________________________
show cdp, show cdp neighbors, show cdp neighbors detail, or show cdp interface

j. Enable CDP globally on Gateway. How many interfaces are CDP enabled? Which interfaces are CDP disabled?
______________________________________________________
Four interfaces are CDP enabled. The interface S0/0/1 is CDP disabled.

k. Console into all the switches and use the CDP commands to determine the Ethernet ports that connected to other devices. An example of the CDP commands for S3 is displayed below.

S3# show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID     Local Intrfce   Holdtme     Capability  Platform   Port ID
Gateway       Fas 0/5         143            R B S I  CISCO1941  Gig 0/1
S2            Fas 0/2         173                S I  WS-C2960-  Fas 0/4
S1            Fas 0/4         171                S I  WS-C2960-  Fas 0/4

Part 3: Network Discovery with LLDP

On Cisco devices, LLDP maybe enabled by default. You will use LLDP to discover the ports that are currently connected.

a. On Gateway, enter the show lldp command in the privileged EXEC mode.

Gateway# show lldp
% LLDP is not enabled

If LLDP is disabled, enter the lldp run command in the global configuration mode.

Gateway(config)# lldp run

b. Use the show lldp command to verify that LLDP is enabled on Gateway.

Gateway# show lldp

Global LLDP Information:
    Status: ACTIVE
    LLDP advertisements are sent every 30 seconds
    LLDP hold time advertised is 120 seconds
    LLDP interface reinitialisation delay is 2 seconds

Issue the show lldp neighbors command. Which devices are neighbors to Gateway?
___________________________________________________
Currently there are no neighbors.

c. If there are no LLDP neighbors for Gateway, enable LLDP on the switches and ISP. Issue lldp run in the global configuration mode on the devices.

S1(config)# lldp run
S2(config)# lldp run
S3(config)# lldp run
ISP(config)# lldp run

d. Issue the show lldp neighbors command on the switches and router to list the LLDP enabled ports. The output for Gateway is shown below.

Gateway# show lldp neighbors
Capability codes:
    (R) Router, (B) Bridge, (T) Telephone, (C) DOCSIS Cable Device
    (W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other

Device ID      Local Intf      Hold-time    Capability      Port ID
S3             Gi0/1           120          B               Fa0/5

Total entries displayed: 1

e. Issue the show lldp neighbors detail command on Gateway.

Gateway# show lldp neighbors detail
------------------------------------------------
Local Intf: Gi0/1
Chassis id: 0cd9.96e8.7400
Port id: Fa0/5
Port Description: FastEthernet0/5
System Name: S3

System Description:
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 15.0(2)SE7,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Thu 23-Oct-14 14:49 by prod_rel_team

Time remaining: 103 seconds
System Capabilities: B
Enabled Capabilities: B
Management Addresses:
    IP: 192.168.1.3
Auto Negotiation - supported, enabled
Physical media capabilities:
    100base-TX(FD)
    100base-TX(HD)
    10base-T(FD)
    10base-T(HD)
Media Attachment Unit type: 16
Vlan ID: 1

Total entries displayed: 1

What port is used on S3 to connect to the Gateway router?
_______________________________________________________
Port Fa0/5 is used on S3 is connected to the Gi0/1 port on Gateway.

f. Use the show command outputs from CDP and LLDP to document the connected ports in the network topology.

Reflection

Within a network, on which interfaces should you not use discovery protocols? Explain.
_____________________________________________________
Discovery protocols should not be used on interfaces that are facing the external networks because these protocols provide insights about the internal network. This information allows attackers to gain valuable information about the internal network and exploit the network.

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs – Final

Router ISP

ISP# show run
Building configuration...
Current configuration : 1285 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 15
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
!
redundancy
!
lldp run
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
!
interface Serial0/0/1
ip address 209.165.200.225 255.255.255.252
clock rate 125000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

Router Gateway

Gateway# show run
Building configuration...
Current configuration : 1524 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Gateway
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
!
redundancy
!
lldp run
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/0/1
ip address 209.165.200.226 255.255.255.252
ip nat outside
ip virtual-reassembly in
no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Serial0/0/1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

Switch S1

S1# show run
Building configuration...
Current configuration : 1308 bytes
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname S1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
system mtu routing 1500
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
lldp run
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
!
ip http server
ip http secure-server
!
line con 0
line vty 5 15
!
end

Switch S2

S2# show run
Building configuration...
Current configuration : 1308 bytes
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname S2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
system mtu routing 1500
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
lldp run
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
!
ip http server
ip http secure-server
!
line con 0
line vty 5 15
!
end

Switch S3

S3# show run
Building configuration...
Current configuration : 1364 bytes
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname S3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
system mtu routing 1500
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
lldp run
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
!
ip http server
ip http secure-server
!
line con 0
line vty 5 15
!
end

 


guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x