6.1.2 Lab – Investigate Static Routes (Answers)

6.1.2 Lab – Investigate Static Routes (Answers)

Topology

6.1.2 Lab - Investigate Static Routes (Answers) 2

Addressing Table

Device Interface IPv4 Address IPv6 Address IPv6 Link-Local
R1 G0/0/0 10.1.2.1/24 2001:db8:acad:1012::1/64 fe80::1:1
S0/1/0 10.1.3.1/25 2001:db8:acad:1013::1/64 fe80::1:2
S0/1/1 10.1.3.129/25 2001:db8:acad:1014::1/64 fe80::1:3
Loopback0 192.168.1.1/27 2001:db8:acad:1000::1/64 fe80::1:4
R2 G0/0/0 10.1.2.2/24 2001:db8:acad:1012::2/64 fe80::2:1
G0/0/1 10.2.3.2/24 2001:db8:acad:1023::2/64 fe80::2:2
Loopback0 192.168.2.1/27 2001:db8:acad:2000::1/64 fe80::2:3
R3 G0/0/0 10.2.3.3/24 2001:db8:acad:1023::3/64 fe80::3:1
S0/1/0 10.1.3.3/25 2001:db8:acad:1013::3/64 fe80::3:2
S0/1/1 10.1.3.130/25 2001:db8:acad:1014::3/64 fe80::3:3
Loopback0 192.168.3.1/27 2001:db8:acad:3000::1/64 fe80::3:4

Objectives

  • Part 1: Build the Network and Configure Basic Device Settings and Interface Addressing
  • Part 2: Configure and Investigate IPv4 Static Routes
  • Part 3: Configure and Investigate IPv6 Static Routes
  • Part 4: Complete Static Routing Challenge

Background / Scenario

There are several different types of static routes available for you to use. You should fully understand the implications of each type of static route on the routing table and the overall routing scheme in the network. In this lab, you will configure several different types of static routes for both IPv4 and IPv6 and examine the impact of the static route on the routing table and traffic flow in the network.

Note: This lab is an exercise in developing, deploying, and verifying various types of static routes, and does not reflect networking best practices.

Note: The routers used with CCNP hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). Other routers and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs.

Note: Make sure that the routers have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 1 PC (Windows with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and serial cables as shown in the topology

Instructions

Part 1: Build the Network and Configure Basic Device Settings and Interface Addressing

In Part 1, you will set up the network topology and configure basic settings and interface addressing on routers.

Step 1: Cable the network as shown in the topology.

Attach the devices as shown in the topology diagram, and cable as necessary.

Step 2: Configure basic settings for each router.

a. Console into each router, enter global configuration mode, and apply the basic settings and interface addressing using the following startup configurations.

Router R1

hostname R1
no ip domain lookup
ipv6 unicast-routing
banner motd # R1, Investigate Static Routes #
line con 0
 exec-timeout 0 0
 logging synchronous
 exit
line vty 0 4
 privilege level 15
 password cisco123
 exec-timeout 0 0
 logging synchronous
 login
 exit
interface g0/0/0
 ip address 10.1.2.1 255.255.255.0
 ipv6 address fe80::1:1 link-local
 ipv6 address 2001:db8:acad:1012::1/64
 no shutdown
 exit
interface s0/1/0
 ip address 10.1.3.1 255.255.255.128
 ipv6 address fe80::1:2 link-local
 ipv6 address 2001:db8:acad:1013::1/64
 no shutdown
 exit
interface s0/1/1
 ip address 10.1.3.129 255.255.255.128
 ipv6 address fe80::1:3 link-local
 ipv6 address 2001:db8:acad:1014::1/64
 no shutdown
 exit
interface loopback 0
 ip address 192.168.1.1 255.255.255.224
 ipv6 address fe80::1:4 link-local
 ipv6 address 2001:db8:acad:1000::1/64
 no shutdown
 exit
end

Router R2

hostname R2
no ip domain lookup
ipv6 unicast-routing
banner motd # R2, Investigate Static Routes #
line con 0
 exec-timeout 0 0
 logging synchronous
 exit
line vty 0 4
 privilege level 15
 password cisco123
 exec-timeout 0 0
 logging synchronous
 login
 exit
interface g0/0/0
 ip address 10.1.2.2 255.255.255.0
 ipv6 address fe80::2:1 link-local
 ipv6 address 2001:db8:acad:1012::2/64
 no shutdown
 exit
interface g0/0/1
 ip address 10.2.3.2 255.255.255.0
 ipv6 address fe80::2:2 link-local
 ipv6 address 2001:db8:acad:1023::2/64
 no shutdown
 exit
interface loopback 0
 ip address 192.168.2.1 255.255.255.224
 ipv6 address fe80::2:3 link-local
 ipv6 address 2001:db8:acad:2000::1/64
 no shutdown
 exit
end

Router R3

hostname R3
no ip domain lookup
ipv6 unicast-routing
banner motd # R3, Investigate Static Routes #
line con 0
 exec-timeout 0 0
 logging synchronous
 exit
line vty 0 4
 privilege level 15
 password cisco123
 exec-timeout 0 0
 logging synchronous
 login
 exit
interface g0/0/0 
 ip address 10.2.3.3 255.255.255.0
 ipv6 address fe80::3:1 link-local
 ipv6 address 2001:db8:acad:1023::3/64
 no shutdown
 exit
interface s0/1/0
 ip address 10.1.3.3 255.255.255.128
 ipv6 address fe80::3:2 link-local
 ipv6 address 2001:db8:acad:1013::3/64
 no shutdown
 exit
interface s0/1/1
 ip address 10.1.3.130 255.255.255.128
 ipv6 address fe80::3:3 link-local
 ipv6 address 2001:db8:acad:1014::3/64
 no shutdown
 exit
interface loopback 0
 ip address 192.168.3.1 255.255.255.224
 ipv6 address fe80::3:4 link-local
 ipv6 address 2001:db8:acad:3000::1/64
 no shutdown
 exit
end

b. Set the clock on each router to UTC time.

c. Save the running configuration to startup-config.

Part 2: Configure and Investigate IPv4 Static Routes

In Part 2, you will configure and investigate various types of static routes. For this part of the lab, all of your work will be on R1. Once again, the configuration being used here is not meant to represent best practice, but to assess your ability to complete the required configurations.

Step 1: On R1, configure a directly attached static route.

a. Create a directly attached static route for the 192.168.2.0/27 network using G0/0/0 as the exit interface.

Note: This kind of static route with an Ethernet-based exit interface is not recommended. The router would have to send an ARP request for every destination that matches the static route, consuming CPU and memory along the way. This could cause instability in a larger network.

R1# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# ip route 192.168.2.0 255.255.255.224 g0/0/0
R1(config)# end

b. Issue the command show ip route static | begin Gateway and examine the output. As long as interface GigabitEthernet0/0/0 is up and operational, this entry will be present in the routing table. Note that the output does not give you indication of the Administrative Distance or Metric for this route.

R1# show ip route static | begin Gateway
Gateway of last resort is not set

      192.168.2.0/27 is subnetted, 1 subnets
S        192.168.2.0 is directly connected, GigabitEthernet0/0/0

c. To get details on the route, issue the command show ip route 192.168.2.0 255.255.255.224. This output provides the Administrative Distance and Metric for the route. An AD of 1 is the default for static routes and is the second most trusted AD available.

R1# show ip route 192.168.2.0 255.255.255.224
Routing entry for 192.168.2.0/27
  Known via "static", distance 1, metric 0 (connected)
  Routing Descriptor Blocks:
  * directly connected, via GigabitEthernet0/0/0
      Route metric is 0, traffic share count is 1
Step 2: On R1, configure a recursive static route.

Every route lookup must resolve to an exit interface. When the route for a destination is configured with an IP address as its next-hop, the router has to determine what exit interface to use to get to that next-hop, which causes a recursive lookup. A recursive route is one that requires an additional lookup in the routing table.

Cisco Express Forwarding (CEF), which is enabled by default, automatically works through the iterative process of finding the exit interface so the CPU is not involved in that process for each packet matching the recursive route. This helps reduce latency and CPU load.

Note: A recursive static route cannot depend upon a default static route for next-hop resolution. The router must have a valid route to the intermediary network or the recursive static route will not be inserted into the routing table.

a. On R1, configure a recursive static route for the 10.2.3.0/24 network using the next hop address 10.1.2.2.

R1# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# ip route 10.2.3.0 255.255.255.0 10.1.2.2
R1(config)# end

b. Issue the command show ip route static | begin Gateway and examine the output. Notice the entry for 10.2.3.0/24 does not list an exit interface. This indicates that a recursive lookup is necessary.

R1# show ip route static | begin Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
S        10.2.3.0/24 [1/0] via 10.1.2.2
      192.168.2.0/27 is subnetted, 1 subnets
S        192.168.2.0 is directly connected, GigabitEthernet0/0/0

c. Issue the command show ip route 10.2.3.0 255.255.255.0 and examine the output. It shows all the information expected for a static route; an AD of 1 and a metric of 0. Once again, the output does not show a next hop address. Under non-CEF conditions, the router would have to do an additional route lookup to decide how to reach the next-hop address 10.1.2.2.

R1# show ip route 10.2.3.0 255.255.255.0
Routing entry for 10.2.3.0/24
  Known via "static", distance 1, metric 0
  Routing Descriptor Blocks:
  * 10.1.2.2
      Route metric is 0, traffic share count is 1

d. Issue the command show ip cef 10.2.3.0 255.255.255.0 and examine the output. Here is where we see that CEF has stepped in and solved the next-hop question for us, which means the router, in this case, will not have to perform an additional route lookup. This saves time and CPU cycles.

R1# show ip cef 10.2.3.0 255.255.255.0
10.2.3.0/24
  nexthop 10.1.2.2 GigabitEthernet0/0/0
Step 3: On R1, configure a fully specified static route.

A fully specified static route is configured using both the exit interface specification and the next-hop IP address. The route is only valid if the exit interface is up. A fully specified static route is preferred so that recursive lookups do not result in routing decisions that might add latency to the path.

a. Remove the static route you had created for the 10.2.3.0/24 network and add a fully specified static route using interface g0/0/0 as the exit interface.

R1# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# no ip route 10.2.3.0 255.255.255.0 10.1.2.2
R1(config)# ip route 10.2.3.0 255.255.255.0 g0/0/0 10.1.2.2
R1(config)# end

b. Issue the command show ip route static | begin Gateway and examine the output. You now see that the route to 10.2.3.0/24 includes an exit interface.

R1# show ip route static | begin Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
S        10.2.3.0/24 [1/0] via 10.1.2.2, GigabitEthernet0/0/0
      192.168.2.0/27 is subnetted, 1 subnets
S        192.168.2.0 is directly connected, GigabitEthernet0/0/0

c. Issue the command show ip route 10.2.3.0 255.255.255.0 and examine the output. It also shows that 10.1.2.2. is reachable via interface g0/0/0.

R1# show ip route 10.2.3.0 255.255.255.0
Routing entry for 10.2.3.0/24
  Known via "static", distance 1, metric 0
  Routing Descriptor Blocks:
  * 10.1.2.2, via GigabitEthernet0/0/0
      Route metric is 0, traffic share count is 1
Step 4: On R1, configure a floating static route.

Floating static routes typically provide secondary or backup to a primary link. By default, static routes have an administrative distance (AD) of 1 and directly connected routes have an AD of zero. Directly connected routes are seen in the routing table with a code of “C” or “L” with the AD of 0 as shown below:

R1# show ip route 10.1.2.1
Routing entry for 10.1.2.1/32
  Known via "connected", distance 0, metric 0 (connected)
  Routing Descriptor Blocks:
  * directly connected, via GigabitEthernet0/0/0
      Route metric is 0, traffic share count is 1

R1# show ip route 10.1.2.0 255.255.255.0
Routing entry for 10.1.2.0/24
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Routing Descriptor Blocks:
  * directly connected, via GigabitEthernet0/0/0
      Route metric is 0, traffic share count is 1

A floating static route is a static route that has been assigned a higher AD than the default. The classic use case for a floating static route is to provide a backup to a dynamic routing protocol. For example, the AD for OSPF is 110. As long as OSPF is working, destinations are reachable. But what if OSPF fails? Adding a floating static route with an AD of 112 would allow that route to be inserted into the routing table as soon as OSPF fails, and then be removed as soon as OSPF is restored. The key benefit to this is that traffic continues to flow.

For this example, we will consider the connections between R1 and R3. Normally, when there are multiple direct connections between two routers and those connections are included in routing, we can expect equal cost load balancing to occur. In this case, we are going to manually control which connection is used so that we can demonstrate a floating static route.

a. Configure a fully specified static route to the 192.168.3.0/27 network using the exit interface s0/1/0 and the next hop 10.1.3.3

R1# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# ip route 192.168.3.0 255.255.255.224 s0/1/0 10.1.3.3
R1(config)# end

b. Examine the routing table with the show ip route static | begin Gateway command to ensure the route is in place.

R1# show ip route static | begin Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
S        10.2.3.0/24 [1/0] via 10.1.2.2, GigabitEthernet0/0/0
      192.168.2.0/27 is subnetted, 1 subnets
S        192.168.2.0 is directly connected, GigabitEthernet0/0/0
      192.168.3.0/27 is subnetted, 1 subnets
S        192.168.3.0 [1/0] via 10.1.3.3, Serial0/1/0

c. Configure another fully specified static route to the 192.168.3.0/27 network, but this time use the exit interface s0/1/1 and the next hop 10.1.3.130.

R1# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# ip route 192.168.3.0 255.255.255.224 s0/1/1 10.1.3.130
R1(config)# end

d. Examine the routing table with the show ip route static | begin Gateway command and you will see that the router has adopted both routes as valid paths to the 192.168.3.0/27 network.

R1# show ip route static | begin Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
S        10.2.3.0/24 [1/0] via 10.1.2.2, GigabitEthernet0/0/0
      192.168.2.0/27 is subnetted, 1 subnets
S        192.168.2.0 is directly connected, GigabitEthernet0/0/0
      192.168.3.0/27 is subnetted, 1 subnets
S        192.168.3.0 [1/0] via 10.1.3.130, Serial0/1/1
                     [1/0] via 10.1.3.3, Serial0/1/0

e. Look more closely at the route to the 192.168.3.0/27 network and you can verify how the router is going to load balance between the two paths. The traffic share count for each of the routes tells you the number of packets that will be sent using the referenced route. In this case, the s0/1/0 path will get one packet and then the s0/1/1 path will get one packet.

R1# show ip route 192.168.3.0 255.255.255.224
Routing entry for 192.168.3.0/27
  Known via "static", distance 1, metric 0
  Routing Descriptor Blocks:
    10.1.3.130, via Serial0/1/1
      Route metric is 0, traffic share count is 1
  * 10.1.3.3, via Serial0/1/0
      Route metric is 0, traffic share count is 1

f. Now you will adjust this so that the s0/1/1 path is a standby. You will do this by deleting the current route that uses s0/1/1 as an exit interface and adding in another static route via s0/1/1, this time adding an AD of 7.

R1# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# no ip route 192.168.3.0 255.255.255.224 s0/1/1 10.1.3.130
R1(config)# ip route 192.168.3.0 255.255.255.224 s0/1/1 10.1.3.130 7
R1(config)# end

g. Now examine the routing table with the show ip route static | begin Gateway command, and you will see there is only one route to the 192.168.3.0/27 network in the routing table.

R1# show ip route static | begin Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
S        10.2.3.0/24 [1/0] via 10.1.2.2, GigabitEthernet0/0/0
      192.168.2.0/27 is subnetted, 1 subnets
S        192.168.2.0 is directly connected, GigabitEthernet0/0/0
      192.168.3.0/27 is subnetted, 1 subnets
S        192.168.3.0 [1/0] via 10.1.3.3, Serial0/1/0

h. The output of show ip route 192.168.3.0 255.255.255.224 only shows the s0/1/0 path as well.

R1# show ip route 192.168.3.0 255.255.255.224
Routing entry for 192.168.3.0/27
  Known via "static", distance 1, metric 0
  Routing Descriptor Blocks:
  * 10.1.3.3, via Serial0/1/0
      Route metric is 0, traffic share count is 1

i. Now issue the shutdown command on interface s0/1/0, then examine the routing table again. You will see that the route using s0/1/1 is in the routing table and operational, with the AD specified as 7.

R1# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# interface s0/1/0
R1(config-if)# shutdown
R1(config-if)# end

R1# show ip route static | begin Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
S        10.2.3.0/24 [1/0] via 10.1.2.2, GigabitEthernet0/0/0
      192.168.2.0/27 is subnetted, 1 subnets
S        192.168.2.0 is directly connected, GigabitEthernet0/0/0
      192.168.3.0/27 is subnetted, 1 subnets
S        192.168.3.0 [7/0] via 10.1.3.130, Serial0/1/1

j. Issue the command show ip route 192.168.3.0 255.255.255.0 and you will see the AD confirmed.

R1# show ip route 192.168.3.0 255.255.255.224
Routing entry for 192.168.3.0/27
  Known via "static", distance 7, metric 0
  Routing Descriptor Blocks:
  * 10.1.3.130, via Serial0/1/1
      Route metric is 0, traffic share count is 1

k. When s0/1/0 recovers, it is automatically placed into the routing table and the s0/1/1 path is removed. Issue the no shutdown command on interface s0/1/0, and then look at the routing table.

R1# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# interface s0/1/0
R1(config-if)# no shutdown
R1(config-if)# end

R1# show ip route static | begin Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
S        10.2.3.0/24 [1/0] via 10.1.2.2, GigabitEthernet0/0/0
      192.168.2.0/27 is subnetted, 1 subnets
S        192.168.2.0 is directly connected, GigabitEthernet0/0/0
      192.168.3.0/27 is subnetted, 1 subnets
S        192.168.3.0 [1/0] via 10.1.3.3, Serial0/1/0
Step 5: On R1, configure a null static route.

Another type of static route that provides a great deal of utility is the null static route. Using the null static route, you can insert routes into your routing table for destination prefixes that you do not actually have a path for. This allows you to basically drop traffic destined for specific prefixes. The null route can also insert summary routes into your routing table so that dynamic routing protocols can advertise them, while your router routes are based on more specific prefixes within that summary.

For this lab, you will install a null static route just so that you can see it in the routing table and what information the router can show you about it.

a. On R1, configure a null static route for the 209.165.200.0/24 network.

R1# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# ip route 209.165.200.0 255.255.255.0 null 0
R1(config)# end

b. Examine the routing table using the show ip route static | begin Gateway command. Notice that the entry is not really different than any other directly connected static entry, except the next hop is null0.

R1# show ip route static | begin Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
S        10.2.3.0/24 [1/0] via 10.1.2.2, GigabitEthernet0/0/0
      192.168.2.0/27 is subnetted, 1 subnets
S        192.168.2.0 is directly connected, GigabitEthernet0/0/0
      192.168.3.0/27 is subnetted, 1 subnets
S        192.168.3.0 [1/0] via 10.1.3.3, Serial0/1/0
S     209.165.200.0/24 is directly connected, Null0

c. Take a closer look at the route using the show ip route 209.165.200.0 255.255.255.0 command. The route has an AD and a metric. The router will send packets destined to this network to the null0 interface, which is basically throwing them away.

R1# show ip route 209.165.200.0 255.255.255.0
Routing entry for 209.165.200.0/24
  Known via "static", distance 1, metric 0 (connected)
  Routing Descriptor Blocks:
  * directly connected, via Null0
      Route metric is 0, traffic share count is 1

Part 3: Configure and Investigate IPv6 Static Routes

In Part 3, you will configure and examine the different types of static routes available to IPv6. The good news is that all the same types of static route are available! One thing to keep in mind is that if the next-hop address is a link-local address, the only type of route you can use is a fully specified static route. For this part of the lab, all of your work will be on R3. Once again, the configuration being used here is not meant to represent best practice, but to assess your ability to complete the required configurations.

Step 1: On R3, configure a recursive static route.

a. Create a route to the 2001:db8:acad:1012::/64 network via 2001:db8:acad:1023::2.

R3# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)# ipv6 route 2001:db8:acad:1012::/64 2001:db8:acad:1023::2
R3(config)# end

b. Issue the show ipv6 route static command and examine the static route in the routing table.

R3# show ipv6 route static
IPv6 Routing Table - default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
<output omitted>

S   2001:DB8:ACAD:1012::/64 [1/0]
     via 2001:DB8:ACAD:1023::2

c. Examine the route details with the command show ipv6 route 2001:db8:acad:1012::/64.

R3# show ipv6 route 2001:db8:acad:1012::/64
Routing entry for 2001:DB8:ACAD:1012::/64
  Known via "static", distance 1, metric 0
  Route count is 1/1, share count 0
  Routing paths:
    2001:DB8:ACAD:1023::2
      Last updated 00:02:28 ago

d. Examine CEF details with the command show ipv6 cef 2001:db8:acad:1012::/64 detail.

R3# show ipv6 cef 2001:db8:acad:1012::/64 detail
2001:DB8:ACAD:1012::/64, epoch 0
  recursive via 2001:DB8:ACAD:1023::2
    attached to GigabitEthernet0/0/0
Step 2: On R3, configure a fully specified static route.

In this step, you will do something a little different and use a link-local address as the next-hop address. This is not a common requirement, but it differentiates this from the fully specified IPv4 route.

a. What is the neighbor’s link local address? You can see this for Ethernet interfaces using the show ipv6 neighbor command. Neighbors do not appear on serial interfaces.

R3# show ipv6 neighbors
IPv6 Address                              Age Link-layer Addr State Interface
2001:DB8:ACAD:1023::2                      11 7079.b392.3131  STALE Gi0/0/0
FE80::2:2                                  11 7079.b392.3131  STALE Gi0/0/0

b. Remove the recursive route you configured earlier and replace it with a fully specified static route using the link local address of R2 as the next hop IPv6 address.

R3# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)# no ipv6 route 2001:db8:acad:1012::/64 2001:db8:acad:1023::2
R3(config)# ipv6 route 2001:db8:acad:1012::/64 g0/0/0 fe80::2:2
R3(config)# end

c. Examine the routing table with the show ipv6 route static command. You should see the 2001:db8:acad:1012::/64 entry listing fe80::2:2 as the next hop.

R3# show ipv6 route static
IPv6 Routing Table - default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
<output omitted>
S   2001:DB8:ACAD:1012::/64 [1/0]
     via FE80::2:2, GigabitEthernet0/0/0

d. Examine the route with show ipv6 route 2001:db8:acad:1012::/64 command. The next hop address of fe80::2:2 is confirmed in that output.

R3# show ipv6 route 2001:db8:acad:1012::64
Routing entry for 2001:DB8:ACAD:1012::/64
  Known via "static", distance 1, metric 0
  Route count is 1/1, share count 0
  Routing paths:
    FE80::2:2, GigabitEthernet0/0/0
      Last updated 00:03:45 ago
Step 3: On R3, configure a floating static route.

a. On R3, create a static route towards 2001:db8:acad:1000::/64 via the next hop 2001:db8:acad:1013::1 and exit interface s0/1/0.

R3# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)# ipv6 route 2001:db8:acad:1000::/64 s0/1/0 2001:db8:acad:1013::1

b. On R3, create another static route towards 2001:db8:acad:1000::/64 via the next hop 2001:db8:acad:1014::3 and exit interface s0/1/1, with an AD of 17.

R3(config)# ipv6 route 2001:db8:acad:1000::/64 s0/1/1 2001:db8:acad:1014::1 17
R3(config)# end

c. Show the IPv6 routing table and confirm that the first route, exiting s0/1/0, is installed in the routing table.

R3# show ipv6 route static
IPv6 Routing Table - default - 12 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
<output omitted>
S   2001:DB8:ACAD:1000::/64 [1/0]
     via 2001:DB8:ACAD:1013::1, Serial0/1/0
S   2001:DB8:ACAD:1012::/64 [1/0]
     via FE80::2:2, GigabitEthernet0/0/0

d. Shutdown interface s0/1/0 and then verify that the second route, via s0/1/1, is installed in the routing table.

R3# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)# interface s0/1/0
R3(config-if)# shutdown
R3(config-if)# end

R3# show ipv6 route static
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
<output omitted>
S   2001:DB8:ACAD:1000::/64 [17/0]
     via 2001:DB8:ACAD:1014::1, Serial0/1/1
S   2001:DB8:ACAD:1012::/64 [1/0]
     via FE80::2:2, GigabitEthernet0/0/0

e. Issue the no shutdown command on R3 s0/1/0 and confirm that the first route is restored in the routing table.

R3# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)# interface s0/1/0
R3(config-if)#  no shutdown
R3(config-if)#  end

R3# show ipv6 route static
IPv6 Routing Table - default - 12 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
<output omitted>
S   2001:DB8:ACAD:1000::/64 [1/0]
     via 2001:DB8:ACAD:1013::1, Serial0/1/0
S   2001:DB8:ACAD:1012::/64 [1/0]
     via FE80::2:2, GigabitEthernet0/0/0
Step 4: On R3, configure a null static route.

a. Create a null static route to the 3333::/64 network.

R3# config t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)# ipv6 route 3333::/64 null0
R3(config)# end

b. Verify the route is in the routing table.

R3# show ipv6 route static
IPv6 Routing Table - default - 13 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

S   2001:DB8:ACAD:1000::/64 [1/0]
     via 2001:DB8:ACAD:1013::1, Serial0/1/0
S   2001:DB8:ACAD:1012::/64 [1/0]
     via FE80::2:2, GigabitEthernet0/0/0
S   3333::/64 [1/0]
     via Null0, directly connected

c. Examine details about the route.

R3# show ipv6 route 3333::/64
Routing entry for 3333::/64
  Known via "static", distance 1, metric 0
  Route count is 1/1, share count 0
  Routing paths:
    directly connected via Null0
      Last updated 00:01:37 ago

Part 4: Complete Static Routing Challenge

Through the course of this lab, we have installed and examined many different types of static route, both for IPv4 and IPv6. But we have not configured routing on all the routers, nor have we tested any of the routes.

For this part of the lab, your challenge is to configure R1, R2, and R3 with static routes that provide full reachability in the network. You will be successful when you can ping any interface in the network using the ping command while specifying a source interface of Loopback0.

Ping Test Pass?
From R1, ping Loopback 0 on R2 with the command ping 192.168.2.1 source loopback0
From R1, the command traceroute 192.168.3.1 source loopback0 should succeed and show the next hop address as 10.1.3.3
On R1, shutdown interface s0/1/0. The command traceroute 192.168.3.1 source loopback0 should succeed and show the next hop address as 10.1.3.130.

(When complete, issue no shutdown on R1 s0/1/0.)

From R2, ping Loopback 0 on R1 with the command ping 192.168.1.1 source loopback0
From R2, ping Loopback 0 on R3 with the command ping 192.168.3.1 source loopback0
From R3, the command traceroute 192.168.1.1 source loopback0 should succeed and show the next hop address as 10.1.3.1
On R3, shutdown interface s0/1/0. The command traceroute 192.168.1.1 source loopback0 should succeed and show the next hop address as 10.1.3.129
On R3, ping Loopback0 on R2 with the command ping 192.168.2.1 source loopback0
On R1, ping Loopback0 on R2 with the command ping 2001:db8:acad:2000::1 source loopback0
On R1, the command traceroute 2001:db8:acad:3000::1 source loopback0 should succeed and show the next hop address as 2001:db8:acad:1013::1
On R1, shutdown interface s0/1/0 and issue the command traceroute 2001:db8:acad:3000::1 source loopback0. The traceroute should succeed and show the next hop address as 2001:db8:acad:1014::1 (When complete, issue the no shutdown command on s0/1/0.)
On R2, ping Loopback 0 on R1 with the command ping 2001:db8:acad:1000::1 source loopback0
On R2, ping Loopback 0 on R3 with the command ping 2001:db8:acad:3000::1 source loopback0
On R3, the command traceroute 2001:db8:acad:1000::1 source loopback0 should succeed and show the next hop address as 2001:db8:acad:1013::1
On R3, shutdown s0/1/0 and issue the command traceroute 2001:db8:acad:1000::1 source loopback0. The traceroute should succeed and show the next hop as 2001:db8:acad:1014::1 (When complete, issue the no shutdown command on s0/1/0)
On R3, ping Loopback 0 on R2 with the command ping 2001:db8:acad:2000::1 source loopback0
Challenge Answer Routes (Answers may vary)

Router R1:

ipv6 route 2001:db8:acad:2000::/64 g0/0/0 2001:db8:acad:1012::2
ipv6 route 2001:db8:acad:3000::/64 s0/1/0 2001:db8:acad:1013::3
ipv6 route 2001:db8:acad:3000::/64 s0/1/1 2001:db8:acad:1014::3

R2:

ip route 192.168.1.0 255.255.255.0 g0/0/0 10.1.2.1
ip route 192.168.3.0 255.255.255.0 g0/0/1 10.2.3.3
ipv6 route 2001:db8:acad:1000::/64 g0/0/0 2001:db8:acad:1012::1
ipv6 route 2001:db8:acad:3000::/64 g0/0/1 2001:db8:acad:1023::3

R3:
ip route 192.168.1.0 255.255.255.0 s0/1/0 10.1.3.1
ip route 192.168.1.0 255.255.255.0 s0/1/1 10.1.3.129
ip route 192.168.2.0 255.255.255.0 g0/0/0 10.2.3.2
ipv6 route 2001:db8:acad:1000::/64 s0/1/0 2001:db8:acad:1013::1
ipv6 route 2001:db8:acad:1000::/64 s0/1/1 2001:db8:acad:1014::1ipv6 route 2001:db8:acad:2000::/64 g0/0/0 2001:db8:acad:1023::2

Router Interface Summary Table

Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
4221 Gigabit Ethernet 0/0/0 (G0/0/0) Gigabit Ethernet 0/0/1 (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
4300 Gigabit Ethernet 0/0/0 (G0/0/0) Gigabit Ethernet 0/0/1 (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs – Final

Router R1

R1# show run
Building configuration...


Current configuration : 4355 bytes
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
no ip domain lookup
!
ip dhcp pool webuidhcp
!
login on-success log
!
subscriber templating
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
spanning-tree extend system-id
!
redundancy
 mode none
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.224
 ipv6 address FE80::1:4 link-local
 ipv6 address 2001:DB8:ACAD:1000::1/64
!
interface GigabitEthernet0/0/0
 ip address 10.1.2.1 255.255.255.0
 negotiation auto
 ipv6 address FE80::1:1 link-local
 ipv6 address 2001:DB8:ACAD:1012::1/64
!
interface GigabitEthernet0/0/1
 no ip address
 negotiation auto
!
interface Serial0/1/0
 ip address 10.1.3.1 255.255.255.128
 ipv6 address FE80::1:2 link-local
 ipv6 address 2001:DB8:ACAD:1013::1/64
!
interface Serial0/1/1
 ip address 10.1.3.129 255.255.255.128
 ipv6 address FE80::1:3 link-local
 ipv6 address 2001:DB8:ACAD:1014::1/64
!
ip forward-protocol nd
no ip http server
ip http secure-server
ip route 10.2.3.0 255.255.255.0 GigabitEthernet0/0/0 10.1.2.2
ip route 192.168.2.0 255.255.255.224 GigabitEthernet0/0/0
ip route 192.168.3.0 255.255.255.224 Serial0/1/0 10.1.3.3
ip route 192.168.3.0 255.255.255.224 Serial0/1/1 10.1.3.130 7
ip route 209.165.200.0 255.255.255.0 Null0
!
ipv6 route 2001:DB8:ACAD:2000::/64 GigabitEthernet0/0/0 2001:DB8:ACAD:1012::2
ipv6 route 2001:DB8:ACAD:3000::/64 Serial0/1/1 2001:DB8:ACAD:1014::3
ipv6 route 2001:DB8:ACAD:3000::/64 Serial0/1/0 2001:DB8:ACAD:1013::3
!
control-plane
!
banner motd ^C R1, Investigate Static Routes ^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password cisco123
 logging synchronous
 login
!
end

Router R2

R2# show run
Building configuration...


Current configuration : 1789 bytes
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
no ip domain lookup
!
login on-success log
!
subscriber templating
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
spanning-tree extend system-id
!
redundancy
 mode none
!
interface Loopback0
 ip address 192.168.2.1 255.255.255.224
 ipv6 address FE80::2:3 link-local
 ipv6 address 2001:DB8:ACAD:2000::1/64
!
interface GigabitEthernet0/0/0
 ip address 10.1.2.2 255.255.255.0
 negotiation auto
 ipv6 address FE80::2:1 link-local
 ipv6 address 2001:DB8:ACAD:1012::2/64
!
interface GigabitEthernet0/0/1
 ip address 10.2.3.2 255.255.255.0
 negotiation auto
 ipv6 address FE80::2:2 link-local
 ipv6 address 2001:DB8:ACAD:1023::2/64
!
ip forward-protocol nd
no ip http server
ip http secure-server
ip route 192.168.1.0 255.255.255.0 GigabitEthernet0/0/0 10.1.2.1
ip route 192.168.3.0 255.255.255.0 GigabitEthernet0/0/1 10.2.3.3
!
ipv6 route 2001:DB8:ACAD:1000::/64 GigabitEthernet0/0/0 2001:DB8:ACAD:1012::1
ipv6 route 2001:DB8:ACAD:3000::/64 GigabitEthernet0/0/1 2001:DB8:ACAD:1023::3
!
control-plane
!
banner motd ^C R2, Investigate Static Routes ^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password cisco123
 logging synchronous
 login
!
end

Router R3

R3# show run
Building configuration...


Current configuration : 2200 bytes
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
no ip domain lookup
!
login on-success log
!
subscriber templating
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
spanning-tree extend system-id
!
redundancy
 mode none
!
interface Loopback0
 ip address 192.168.3.1 255.255.255.224
 ipv6 address FE80::3:4 link-local
 ipv6 address 2001:DB8:ACAD:3000::1/64
!
interface GigabitEthernet0/0/0
 ip address 10.2.3.3 255.255.255.0
 negotiation auto
 ipv6 address FE80::3:1 link-local
 ipv6 address 2001:DB8:ACAD:1023::3/64
!
interface GigabitEthernet0/0/1
 no ip address
 negotiation auto
!
interface Serial0/1/0
 ip address 10.1.3.3 255.255.255.128
 ipv6 address FE80::3:2 link-local
 ipv6 address 2001:DB8:ACAD:1013::3/64
!
interface Serial0/1/1
 ip address 10.1.3.130 255.255.255.128
 ipv6 address FE80::3:3 link-local
 ipv6 address 2001:DB8:ACAD:1014::3/64
!
ip forward-protocol nd
no ip http server
ip http secure-server
ip route 192.168.1.0 255.255.255.0 Serial0/1/0 10.1.3.1
ip route 192.168.1.0 255.255.255.0 Serial0/1/1 10.1.3.129
ip route 192.168.2.0 255.255.255.0 GigabitEthernet0/0/0 10.2.3.2
!
ipv6 route 2001:DB8:ACAD:1000::/64 Serial0/1/1 2001:DB8:ACAD:1014::1
ipv6 route 2001:DB8:ACAD:1000::/64 Serial0/1/0 2001:DB8:ACAD:1013::1
ipv6 route 2001:DB8:ACAD:1012::/64 GigabitEthernet0/0/0 FE80::2:2
ipv6 route 2001:DB8:ACAD:2000::/64 GigabitEthernet0/0/0 2001:DB8:ACAD:1023::2
ipv6 route 3333::/64 Null0
!
control-plane
!
banner motd ^C R3, Investigate Static Routes ^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password cisco123
 logging synchronous
 login
!
end

Download 6.1.2 Lab – Investigate Static Routes .PDF file:

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x