9.2.2.8 Lab – Configuring Multi-area OSPFv2 Answers

9.2.2.8 Lab – Configuring Multi-area OSPFv2 (Instructor Version)

Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

Addressing Table

Device Interface IP Address Subnet Mask
R1 Lo0 209.165.200.225 255.255.255.252
Lo1 192.168.1.1 255.255.255.0
Lo2 192.168.2.1 255.255.255.0
S0/0/0 (DCE) 192.168.12.1 255.255.255.252
R2 Lo6 192.168.6.1 255.255.255.0
S0/0/0 192.168.12.2 255.255.255.252
S0/0/1 (DCE) 192.168.23.1 255.255.255.252
R3 Lo4 192.168.4.1 255.255.255.0
Lo5 192.168.5.1 255.255.255.0
S0/0/1 192.168.23.2 255.255.255.252

Objectives

Part 1: Build the Network and Configure Basic Device Settings
Part 2: Configure a Multi-area OSPFv2 Network

Background / Scenario

To make OSPF more efficient and scalable, OSPF supports hierarchical routing using the concept of areas. An OSPF area is a group of routers that share the same link-state information in their link-state databases (LSDBs). When a large OSPF area is divided into smaller areas, it is called multi-area OSPF. Multi-area OSPF is useful in larger network deployments to reduce processing and memory overhead.

In the lab, you will configure a multi-area OSPFv2 network.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). Other routers and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Make sure that the routers have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Serial cables as shown in the topology

Part 1: Build the Network and Configure Basic Device Settings

In Part 1, you will set up the network topology and configure basic settings on the routers.

Step 1: Cable the network as shown in the topology.

Step 2: Initialize and reload the routers as necessary.

Step 3: Configure basic settings for each router.

a. Disable DNS lookup.

b. Configure device name, as shown in the topology.

c. Assign class as the privileged EXEC password.

d. Assign cisco as the console and vty passwords.

e. Configure logging synchronous for the console line.

f. Configure an MOTD banner to warn users that unauthorized access is prohibited.

g. Configure the IP addresses listed in the Addressing Table for all interfaces. DCE interfaces should be configured with a clock rate of 128000. Bandwidth should be set to 128 Kb/s on all serial interfaces.

h. Copy the running configuration to the startup configuration.

Step 4: Verify Layer 3 connectivity.

Use the show ip interface brief command to verify that the IP addressing is correct and that the interfaces are active. Verify that each router can ping their neighbor’s serial interface.

Part 2: Configure a Multi-area OSPFv2 Network

In Part 2, you will configure a multi-area OSPFv2 network with a process ID of 1. All LAN loopback interfaces should be passive.

Step 1: Identify the OSPF router types in the topology.

Identify the Backbone router(s): _______________R1 and R2

Identify the Autonomous System Boundary Router(s) (ASBR): _____________R1

Identify the Area Border Router(s) (ABR): _______________R1 and R2

Identify the Internal router(s): ________________R3

Step 2: Configure OSPF on R1.

a. Configure a router ID of 1.1.1.1 with OSPF process ID of 1.

R1(config)# router ospf 1
R1(config-router)# router-id 1.1.1.1

b. Add the networks for R1 to OSPF.

R1(config-router)# network 192.168.1.0 0.0.0.255 area 1
R1(config-router)# network 192.168.2.0 0.0.0.255 area 1
R1(config-router)# network 192.168.12.0 0.0.0.3 area 0

c. Set LAN loopback interfaces, Lo1 and Lo2, as passive.

R1(config-router)# passive-interface lo1
R1(config-router)# passive-interface lo2
R1(config-router)# exit

d. Create a default route to the Internet using exit interface Lo0.

R1(config)# ip route 0.0.0.0 0.0.0.0 lo0

Note: You may see the “%Default route without gateway, if not a point-to-point interface, may impact performance” message. This is normal behavior if using a Loopback interface to simulate a default route.

e. Configure OSPF to propagate the routes throughout the OSPF areas.

R1(config)# router ospf 1
R1(config-router)# default-information originate

Step 3: Configure OSPF on R2.

a. Configure a router ID of 2.2.2.2 with OSPF process ID of 1.

R2(config)# router ospf 1
R2(config-router)# router-id 2.2.2.2

b. Add the networks for R2 to OSPF. Add the networks to the correct area. Write the commands used in the space below.
____________________________________________________

R2(config-router)# network 192.168.12.0 0.0.0.3 area 0
R2(config-router)# network 192.168.23.0 0.0.0.3 area 3
R2(config-router)# network 192.168.6.0 0.0.0.255 area 3

c. Set all LAN loopback interfaces as passive.

R2(config-router)# passive-interface lo6

Step 4: Configure OSPF on R3.

a. Configure a router ID of 3.3.3.3 with OSPF process ID of 1.

R3(config)# router ospf 1
R3(config-router)# router-id 3.3.3.3

b. Add the networks for R3 to OSPF. Write the commands used in the space below.
_____________________________________________________

R3(config-router)# network 192.168.23.0 0.0.0.3 area 3
R3(config-router)# network 192.168.4.0 0.0.0.255 area 3
R3(config-router)# network 192.168.5.0 0.0.0.255 area 3

c. Set all LAN loopback interfaces as passive.

R3(config-router)# passive-interface lo4
R3(config-router)# passive-interface l05

Step 5: Verify that OSPF settings are correct and adjacencies have been established between routers.

a. Issue the show ip protocols command to verify OSPF settings on each router. Use this command to identify the OSPF router types and to determine the networks assigned to each area.

R1# show ip protocols  
*** IP Routing is NSF aware ***  
  
Routing Protocol is "ospf 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Router ID 1.1.1.1  
  It is an area border and autonomous system boundary router  
 Redistributing External Routes from,  
  Number of areas in this router is 2 . 2 normal 0 stub 0 nssa  
  Maximum path: 4  
  Routing for Networks:  
    192.168.1.0 0.0.0.255 area 1  
    192.168.2.0 0.0.0.255 area 1  
    192.168.12.0 0.0.0.3 area 0  
  Passive Interface(s):  
    Loopback1  
    Loopback2  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    2.2.2.2              110      00:01:45
  Distance: (default is 110)  

R2# show ip protocols  

*** IP Routing is NSF aware ***   
Routing Protocol is "ospf 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Router ID 2.2.2.2  
  It is an area border router  
  Number of areas in this router is 2 . 2 normal 0 stub 0 nssa  
  Maximum path: 4  
  Routing for Networks:  
    192.168.6.0 0.0.0.255 area 3  
    192.168.12.0 0.0.0.3 area 0  
    192.168.23.0 0.0.0.3 area 3  
  Passive Interface(s):  
    Loopback6  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    3.3.3.3              110      00:01:20  
    1.1.1.1              110      00:10:12  
  Distance: (default is 110)  

R3# show ip protocols  
*** IP Routing is NSF aware ***  
  
Routing Protocol is "ospf 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Router ID 3.3.3.3  
  Number of areas in this router is 1 . 1 normal 0 stub 0 nssa  
  Maximum path: 4  
  Routing for Networks:  
    192.168.4.0 0.0.0.255 area 3  
    192.168.5.0 0.0.0.255 area 3  
    192.168.23.0 0.0.0.3 area 3  
  Passive Interface(s):  
    Loopback4  
    Loopback5  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    1.1.1.1              110      00:07:46  
    2.2.2.2              110      00:07:46  
  Distance: (default is 110)

What is the OSPF router type for each router?
R1: ____________________________________
R2: ____________________________________
R3: ____________________________________
R1 – ABR and ASBR
R2 – ABR
R3 – No special OSPF router type

b. Issue the show ip ospf neighbor command to verify that OSPF adjacencies have been established between routers.

R1# show ip ospf neighbor  
  
Neighbor ID     Pri   State           Dead Time   Address         Interface  
2.2.2.2           0   FULL/  -        00:00:34    192.168.12.2    Serial0/0/0    

R2# show ip ospf neighbor  
  
Neighbor ID     Pri   State           Dead Time   Address         Interface  
1.1.1.1           0   FULL/  -        00:00:36    192.168.12.1    Serial0/0/0  
3.3.3.3           0   FULL/  -        00:00:36    192.168.23.2    Serial0/0/1    

R3# show ip ospf neighbor  
  
Neighbor ID     Pri   State           Dead Time   Address         Interface  
2.2.2.2           0   FULL/  -        00:00:38    192.168.23.1    Serial0/0/1

c. Issue the show ip ospf interface brief command to display a summary of interface route costs.

R1# show ip ospf interface brief  
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C  
Se0/0/0      1     0               192.168.12.1/30    781   P2P   1/1  
Lo1          1     1               192.168.1.1/24     1     LOOP  0/0  
Lo2          1     1               192.168.2.1/24     1     LOOP  0/0    

R2# show ip ospf interface brief  
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C  
Se0/0/0      1     0               192.168.12.2/30    781   P2P   1/1  
Lo6          1     3               192.168.6.1/24     1     LOOP  0/0  
Se0/0/1      1     3               192.168.23.1/30    781   P2P   1/1    

R3# show ip ospf interface brief  
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C  
Lo4          1     3               192.168.4.1/24     1     LOOP  0/0  
Lo5          1     3               192.168.5.1/24     1     LOOP  0/0  
Se0/0/1      1     3               192.168.23.2/30    781   P2P   1/1

Reflection
What are three advantages for designing a network with multi-area OSPF?
____________________________________________________
1. Smaller routing tables. 2. Reduced link-state update overhead. 3. Reduced frequency of SPF calculations.

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs – Final

Router R1 

R1# show run
Building configuration...

Current configuration : 2062 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
interface Loopback0
ip address 209.165.200.225 255.255.255.252
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
ip address 192.168.2.1 255.255.255.0
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
bandwidth 128
ip address 192.168.12.1 255.255.255.252
clock rate 128000
!
interface Serial0/0/1
no ip address
shutdown
!
router ospf 1
router-id 1.1.1.1
passive-interface Loopback1
passive-interface Loopback2
network 192.168.1.0 0.0.0.255 area 1
network 192.168.2.0 0.0.0.255 area 1
network 192.168.12.0 0.0.0.3 area 0
default-information originate
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Loopback0
!
control-plane
!
!
banner motd @
Unauthorized Access is Prohibited! @
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input none
!
scheduler allocate 20000 1000
!
end

Router R2

R2# show run
Building configuration...

Current configuration : 1905 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
interface Loopback6
ip address 192.168.6.1 255.255.255.0
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
bandwidth 128
ip address 192.168.12.2 255.255.255.252
!
interface Serial0/0/1
bandwidth 128
ip address 192.168.23.1 255.255.255.252
clock rate 128000
!
router ospf 1
router-id 2.2.2.2
passive-interface Loopback6
network 192.168.6.0 0.0.0.255 area 3
network 192.168.12.0 0.0.0.3 area 0
network 192.168.23.0 0.0.0.3 area 3
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
banner motd @
Unauthorized Access is Prohibited! @
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router R3

R3# show run
Building configuration...

Current configuration : 1958 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
interface Loopback4
ip address 192.168.4.1 255.255.255.0
!
interface Loopback5
ip address 192.168.5.1 255.255.255.0
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
bandwidth 128
ip address 192.168.23.2 255.255.255.252
!
router ospf 1
router-id 3.3.3.3
passive-interface Loopback4
passive-interface Loopback5
network 192.168.4.0 0.0.0.255 area 3
network 192.168.5.0 0.0.0.255 area 3
network 192.168.23.0 0.0.0.3 area 3
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
banner motd @
Unauthorized Access is Prohibited! @
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input none
!
scheduler allocate 20000 1000
!
end

guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x