CCNA 3 v6.0 Study Material – Chapter 4: EtherChannel and HSRP

Chapter 4 – Sections & Objectives

4.1 Link Aggregation Concepts

Explain link aggregation operation in a switched LAN environment.

4.2 Link Aggregation Configuration

Implement link aggregation to improve performance on high-traffic switch links.

4.3 First Hop Redundancy Protocols

Implement HSRP to provide first hop redundancy.

 

4.1 Link Aggregation Concepts

Link Aggregation

  • Introduction to Link Aggregation
  • Links with higher bandwidth must be available between the access and distribution switches.
  • Link aggregation combines a number of physical links between the switches to increase the overall bandwidth between two devices.
  • However, by default, STP is enabled on Layer 2 devices such as switches. STP will block redundant links to prevent routing loops.
  • Solution: Implement EtherChannel

  • Advantages of EtherChannel
  • Originally developed by Cisco as an inter switch technique of grouping several Fast Ethernet or Gigabit Ethernet ports into one logical channel.
  • When configured, physical interfaces are bundled together into a virtual interface called a port channel interface.
  • EtherChannel advantages:
  • Configuration tasks configured on port channel ensuring configuration consistency throughout the links.
  • Uses existing switch ports therefore no need to upgrade links/switch.
  • Load balancing occurs between EtherChannel bundled links.
  • EtherChannel works with STP.

 

 

EtherChannel Operation

  • Implementation Restrictions
  • EtherChannel interface types cannot be mixed. for example, Fast Ethernet and Gigabit Ethernet cannot be mixed in a port channel.
  • Up to 8 physical ports can be bundled together providing either up to 800 Mb/s (Fast EtherChannel) or 8 Gb/s (Gigabit EtherChannel)
  • The Cisco IOS switch support up to six EtherChannels.
  • Individual EtherChannel group member port configuration must be consistent on both devices. For example, if the physical ports of one side are configured as trunks, the physical ports of the other side must also be configured as trunks within the same native VLAN.
  • Interfaces do not have to be physically contiguous, or on the same module.
  • There are two main protocols used to help configure EtherChannels: Port Aggregation Protocol (PAgP) and Link Aggregation Control Protocol (LACP).
  • Port Aggregation Protocol
  • Cisco-proprietary protocol used to negotiate the forming of a channel.
  • PAgP sends packets every 30 seconds to check for configuration consistency and manages link additions and failures.
  • PAgP supports three modes.
  • Desirable – Port actively initiates negotiations with other interfaces by sending PAgP packets.
  • Auto – Port passively negotiates state, but does not initiate PAgP negotiation.
  • On – Creates a channel member without negotiation.
  • The modes must be compatible on each side. For example, desirable – desirable or desirable – auto. Note that auto – auto will not created a bundle.
  • Link Aggregation Control Protocol
  • IEEE specification (802.3ad) protocol used to negotiate the forming of a channel with non-Cisco switches.
  • PAgP sends packets every 30 seconds to check for configuration consistency and manages link additions and failures.
  • PAgP supports three modes.
  • Active – Port actively initiates negotiations with other interfaces by sending LACP packets.
  • Passive – Port passively negotiates state, but does not initiate LACP negotiation.
  • On – Creates a channel member without negotiation.
  • The modes must be compatible on each side. For example, active – active or active – passive. Note that passive – passive will not created a bundle.

 

4.2 Link Aggregation Configuration

Configuring EtherChannel

  • Configuration Guidelines
  • EtherChannel support – Bundle interfaces must support EtherChannel.
  • Speed and duplex – Configure all bundle interfaces with the same speed and in the same duplex mode.
  • VLAN match – Assign all bundle interfaces to the same VLAN (unlikely) or configure the bundle as a trunk (most likely).
  • Range of VLANs – A trunking EtherChannel must allow the same VLAN range otherwise the interfaces do not form an EtherChannel, even when set to auto or desirable mode.
  • Configuring LACP Interfaces on S1
S1(config)# interface range fa0/1 - 2
S1(config-if-range)# speed 100
S1(config-if-range)# duplex full
S1(config-if-range)# channel-group 1 mode active
S1(config-if-range)# shutdown
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
%LINK-5-CHANGED: Interface FastEthernet0/2, changed state to administratively down
S1(config-if-range)# exit
S1(config)#
S1(config)# interface port-channel 1
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk  native vlan 99
S1(config-if)# switchport trunk allowed vlan 2,20,99
S1(config-if)# exit
S1(config)#
S1(config)# interface range fa0/1 - 2
S1(config-if-range)# no shut
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINK-5-CHANGED: Interface FastEthernet0/2, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
Creating a port-channel interface Port-channel 1
S1(config-if-range)#
  • Configuring LACP Interfaces on S2
S2(config)# interface range fa0/1 - 2
S2(config-if-range)# speed 100
S2(config-if-range)# duplex full
S2(config-if-range)# channel-group 1 mode active
S2(config-if-range)# shutdown
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
%LINK-5-CHANGED: Interface FastEthernet0/2, changed state to administratively down
S2(config-if-range)# exit
S2(config)#
S2(config)# interface port-channel 1
S2(config-if)# switchport mode trunk
S2(config-if)# switchport trunk  native vlan 99
S2(config-if)# switchport trunk allowed vlan 2,20,99
S2(config-if)# exit
S2(config)#
S2(config)# interface range fa0/1 - 2
S2(config-if-range)# no shut
S2(config-if-range)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
%LINK-5-CHANGED: Interface FastEthernet0/2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
Creating a port-channel interface Port-channel 1

<OUTPUT OMITTED)

%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 1, changed state to up

 

Verifying and Troubleshooting EtherChannel

  • Verifying EtherChannel
  • Use show interfaces port-channel number to display general status information of the port channel.
  • Use the show etherchannel port-channel command to display information about a specific port channel interface.
  • Use the show interfaces etherchannel command to provide information about the role of the interface in the EtherChannel.
  • Use the show etherchannel summary command to view the overall status and general port channel information.
S1# show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+---------------------------
1      Po1(SU)           LACP   Fa0/1(P) Fa0/2(P)
S1#
  • Troubleshooting EtherChannel
  • All interfaces within an EtherChannel must have the same configuration of speed and duplex mode, native and allowed VLANs on trunks, and access VLAN on access ports.
  • The dynamic negotiation options for PAgP and LACP must be compatibly configured on both ends of the EtherChannel.
  • when changes are made to a port channel, it may be useful to disable the port channel interface using the shutdown interface command and then re-enable it using the no shutdown interface command.
  • EtherChannel and spanning tree must interoperate. STP errors can occur if changes are made to an existing port channel. If STP errors occur, it is recommended that the port channel be deleted and recreated.

 

4.3 First Hop Redundancy Protocols

Concepts of First Hop Redundancy Protocols

  • Default Gateway Limitations
  • In a switched network, each client receives only one default gateway and there is no way to use a secondary gateway, even if a second path exists to carry packets off the local segment.
  • If a router or router interface (that serves as a default gateway) fails, the hosts configured with that default gateway are isolated from outside networks.
  • A mechanism is needed to provide alternate default gateways in switched networks where two or more routers are connected to the same VLANs.

  • Router Redundancy
  • Two or more routers share a virtual IP address and a MAC address.
  • Routers identify an active forwarding router and a redundant standby router.

  • Steps for Router Redundancy
  • If the active router fails:
  • Standby router stops seeing Hello messages from active router.
  • Standby router assumes active role.
  • Host devices see no disruption in service.

  • First Hop Redundancy Protocols
  • ICMP Router Discovery Protocol (IRDP) – Legacy FHRP solution specified in RFC 1256.
  • Hot Standby Router Protocol (HSRP) – A Cisco-proprietary FHRP that provides redundancy for IPv4 hosts.
  • HSRP for IPv6 – Same functionality of HSRP in an IPv6 environment.
  • Virtual Router Redundancy Protocol version 2 (VRRPv2) – A non-proprietary similar to HSRP.
  • VRRPv3 – Support IPv4 and IPv6 addresses, works in multi-vendor environments, and is more scalable than VRRPv2.
  • Gateway Load Balancing Protocol (GLBP) – Cisco-proprietary FHRP like HSRP that provides load balancing between redundant routers.
  • GLBP for IPv6 – Same functionality of GLBP in an IPv6 environment.

HSRP Operation

  • HSRP Overview
  • Routers select the active HSRP router that provides default gateway services to hosts.
  • If the active router fails, the standby router automatically assumes the active router role without requiring any configuration changes on hosts.
  • HSRP Versions
  • The default HSRP version for Cisco IOS 15 is version 1.
  • HSRP version 2 expands the number of supported groups from 0 to 255 for HSRPv1 to 0 to 4095 with HSRPv2.
  • HSRPv1 uses the multicast address of 224.0.0.2 while HSRP version 2 uses the multicast address 224.0.0.102 or FF02::66 for IPv6.
  • HSRPv2 adds support for MD5 authentication, which is beyond the scope of this course.
  • HSRP Priority and Preemption
  • Active and standby router roles is determined during the HSRP election. The router with the highest IPv4 address is elected as the active router.
  • The standby priority priority interface command can be used to assign a higher priority to an active router (default priority is 100).
  • An active router will retain the active role even if another router with a higher HSRP priority comes online.
  • To force a new election, use the standby preempt interface command.
  • HSRP States and Timers
  • HSRP routers progress though the Initial, Learn, Listen, Speak, Standby, and Active states.

HSRP Configuration

  • HSRP Configuration Commands
  • Configure HSRPv2 using the standby version 2 interface command.
  • Configure the virtual IP address for the group using the standby [group-number] ip-address interface command.
  • Configure the priority for the desired active router to be greater than 100 using the standby [group-number] priority [priority-value] interface command.
  • Configure the active router to preempt the standby router using the standby [group-number] preempt interface command.
  • HSRP Sample Configuration
R1(config)# int g0/1
R1(config-if)# ip add 172.16.10.2 255.255.255.0
R1(config-if)# standby version 2
R1(config-if)# standby 1 ip 172.16.10.1
R1(config-if)# standby 1 priority 150
R1(config-if)# standby 1 preempt
R1(config-if)# no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R1(config-if)#
%HSRP-6-STATECHANGE: GigabitEthernet0/1 Grp 1 state Speak -> Standby
%HSRP-6-STATECHANGE: GigabitEthernet0/1 Grp 1 state Standby -> Active

R2(config)# int g0/1
R2(config-if)# ip add 172.16.10.3 255.255.255.0
R2(config-if)# standby version 2
R2(config-if)# standby 1 ip 172.16.10.1
R2(config-if)# no shut
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
%HSRP-6-STATECHANGE: GigabitEthernet0/1 Grp 1 state Init -> Init
%HSRP-6-STATECHANGE: GigabitEthernet0/1 Grp 1 state Speak -> Standby
  • HSRP Verification
  • Use the show standby command to verify the HSRP configuration.
  • Use the show standby brief command to verify the status of HSRP.
R1# show standby
GigabitEthernet0/0 - Group 1 (version 2)
  State is Active
    12 state changes, last state change 00:04:54
  Virtual IP address is 172.16.10.1
  Active virtual MAC address is 0000.0C9F.F001
    Local virtual MAC address is 0000.0C9F.F001 (v2 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.519 secs
  Preemption enabled
  Active router is local
  Standby router is 172.16.10.3
  Priority 150 (configured 150)
  Group name is hsrp-Gig0/0-1 (default)
R1#
R1# show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State    Active          Standby         Virtual IP
Gig0/0      1    150 P Active   local           172.16.10.3     172.16.10.1   
R1#

HSRP Troubleshooting

  • HSRP Failure
  • Most HSRP failures will related to:
  • Failing to successfully elect the active router.
  • Failure of the standby router to successfully keep track of the active router.
  • Failing to determine when control of the virtual IP for the group should be handed over to another router.
  • Failure of end devices to successfully configure the virtual IP address as the default gateway.
  • HSRP Debug Commands
  • Use debug standby packets to view the exchange of hello packets.
  • Use debug standby terse to view the HSRP events.
  • Common HSRP Configuration Issues
  • HSRP routers are not connected to the same network segment. Although this could be a physical layer issue, it could also be a VLAN subinterface configuration issue.
  • HSRP routers are not configured with IPv4 addresses from the same subnet. Therefore, a standby router would not know when the active router fails.
  • HSRP routers are not configured with the same virtual IPv4 address. The virtual IPv4 address is the default gateway for end devices.
  • HSRP routers are not configured with the same HSRP group number. This will cause each router to assume the active role.
  • End devices are not configured with the correct default gateway address.

 

4.3 Chapter Summary

EtherChannel aggregates multiple switched links together to load balance over redundant paths between two devices. All ports in one EtherChannel must have the same speed, duplex setting, and VLAN information on all interfaces on the devices at both ends.

Settings configured in the port channel interface configuration mode will also be applied to the individual interfaces in that EtherChannel. Settings configured on individual interfaces will not be applied to the EtherChannel or to the other interfaces in the EtherChannel.

PAgP is a Cisco-proprietary protocol that aids in the automatic creation of EtherChannel links. PAgP modes are on, PAgP desirable, and PAgP auto.

LACP is part of an IEEE specification that also allows multiple physical ports to be bundled into one logical channel. The LACP modes are on, LACP active and LACP passive.

PAgP and LACP do not interoperate.

The on mode is repeated in both PAgP and LACP because it creates an EtherChannel unconditionally, without the use of PAgP or LACP. The default for EtherChannel is that no mode is configured.

First Hop Redundancy Protocols, such as HSRP, VRRP, and GLBP provide alternate default gateways for hosts in the redundant router or multilayer switched environment.

Multiple routers share a virtual IP address and MAC address that is used as the default gateway on a client. This ensures that hosts maintain connectivity in the event of the failure of one device serving as a default gateway for a VLAN or set of VLANs.

When using HSRP or VRRP, one router is active or forwarding for a particular group while others are in standby mode. GLBP allows the simultaneous use of multiple gateways in addition to providing automatic failover.

 

Download Slide PowerPoint (pptx):


Related Articles

Leave a Reply

avatar