CCNA Certification – EIGRP Configuration Lab Simulation

Lab Simulation Question – EIGRP

CCNA Certification - EIGRP Configuration Lab Simulation 1
CCNA.com has a small network that is using EIGRP as its IGP. All routers should be running an EIGRP AS number of 12. Router MGT is also running static routing to the ISP.
CCNA.com has recently adding the ENG router. Currently, the ENG router does not have connectivity to the ISP router. All other interconnectivity and Internet access for the existing locations of the company are working properly.

The task is to identify the fault(s) and correct the router configuration(s) to provide full connectivity between the routers.

  • Access to the router CLI can be gained by clicking on the appropriate host.
  • All passwords on all routers are cisco.
  • IP addresses are listed in the chart below.

MIGT
Fa0/0 – 192.168.77.33
S1/0 – 198.0.18.6
S0/0 – 192.168.27.9
S0/1 – 192.168.50.21

ENG
Fa0/0 – 192.168.77.34
Fa1/0 – 192.168.12.17
Fa0/1 – 192.168.12.1

Parts1
Fa0/0 – 192.168.12.33
Fa0/1 – 192.168.12.49
S0/0 – 192.168.27.10

Parts2
Fa0/0 – 192.168.12.65
Fa0/1 – 192.168.12.81
S0/1 – 192.168.50.22

Answer:

First we should check the configuration of the ENG Router.
Click the console PC “F” and enter the following commands.

ENG> enable
Password: cisco
ENG# show running-config
Building configuration...
Current configuration : 770 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ENG
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
interface FastEthernet0/0
ip address 192.168.77.34 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.60.65 255.255.255.240
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.60.81 255.255.255.240
duplex auto
speed auto
!
router eigrp 22
network 192.168.77.0
network 192.168.60.0
no auto-summary
!
ip classless
!
line con 0
line vty 0 4
login
!
end
ENG#

From the output above, we know that this router was wrongly configured with an autonomous number (AS) of 22. When the AS numbers among routers are mismatched, no adjacency is formed.
(You should check the AS numbers on other routers for sure)
To solve this problem, we simply re-configure router ENG router with the following commands:

ENG# conf t
ENG(config)# no router eigrp 22
ENG(config)# router eigrp 12
ENG(config-router)# network 192.168.60.0
ENG(config-router)# network 192.168.77.0
ENG(config-router)# no auto-summary
ENG(config-router)# end
ENG# copy running-config startup-config

Second we should check the configuration of the MGT Router.
Click the console PC “G” and enter the following commands.

MGT> enable
Password: cisco
MGT# show running-config

Building configuration…
Current configuration : 1029 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname MGT
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
interface FastEthernet0/0
ip address 192.168.77.33 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.36.13 255.255.255.252
clock rate 64000
!
interface Serial0/1
ip address 192.168.60.25 255.255.255.252
clock rate 64000
!
interface Serial1/0
ip address 198.0.18.6 255.255.255.252
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
router eigrp 12
network 192.168.36.0
network 192.168.60.0
network 192.168.85.0
network 198.0.18.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 198.0.18.5
!
line con 0
line vty 0 4
login
!
end
MGT#

Notice that it is missing a definition to the network ENG. Therefore we have to add it so that it can recognize ENG router

MGT# conf t
MGT(config)# router eigrp 12
MGT(config-router)# network 192.168.77.0
MGT(config-router)# end
MGT# copy running-config startup-config

Now the whole network will work well. You should check again with ping command from router ENG to other routers!

In Short:

ENG Router

ENG>enable
Password: cisco ENG# conf t
ENG(config)# no router eigrp 22
ENG(config)# router eigrp 12
ENG(config-router)# network 192.168.60.0
ENG(config-router)# network 192.168.77.0
ENG(config-router)# no auto-summary
ENG(config-router)# end
ENG# copy running-config startup-config

MGT Router

MGT>enable
Password: cisco MGT# conf t
MGT(config)# router eigrp 12
MGT(config-router)# network 192.168.77.0
MGT(config-router)# end
MGT# copy running-config startup-config

Some Modification in Question

After adding ENG Router, no routing updates are being exchanged between MGT and the new location. All other inter connectivity for the existing locations of the company are working properly.
But Internet connection for existing location including Remote1 and Remote2 networks are not working.

Faults Identified:

1. Incorrect Autonomous System Number configured in ENG Router.
2. MGT Router does not advertise route to the new router ENG.
3. Internet Connection is not working all stations.
We need to correct the above two configuration mistakes to have full connectivity
Steps:
1. ENG Router: Change the Autonomous System Number of ENG
2. Perimiter Router: Add the network address of interface of Permiter that link between MGT and
ENG.
3. Perimiter Router: Add default route and default-network.
Check the IP Address of S1/0 interface of MGT Router using show running-config command.

(The interfaced used to connect to the ISP)
!
interface Serial1/0
ip address 198.0.18.6 255.255.255.252
!

For Internet sharing we have create a default route, and add default-network configuration. The IP address is 198.0.18.6/30. Then the next hop IP will be 198.0.18.5.
ENG Router

ENG>enable
Password: cisco ENG# conf t
ENG(config)# no router eigrp 22
ENG(config)# router eigrp 12
ENG(config-router)# network 192.168.60.0
ENG(config-router)# network 192.168.77.0
ENG(config-router)# no auto-summary
ENG(config-router)# end
ENG# copy running-config startup-config

MGT Router

MGT>enable
Password: cisco MGT# conf t
MGT(config)# router eigrp 12
MGT(config-router)# network 192.168.77.0
MGT(config-router)# exit
MGT(config)# ip route 0.0.0.0 0.0.0.0 198.0.18.5
MGT(config)# ip default-network 198.0.18.0
MGT(config)# exit
MGT# copy running-config startup-config
Important:

If you refer the topology and IP chart, the MGT Router uses Fa0/0 to connect ENG Router, S0/0 used to connect Remote1, and S0/1 used to connect Remote2.
Refer to the command show running-config, the command #PASSIVE-INTERFACE will deny EIGRP updates to specified interface. In that case we need to use #no passiveinterface to allow the routing updates to be passed to that interface. For example when used the #show run command and we see the output like below.

!
router eigrp 22
network 192.168.77.0
network 192.168.60.0
passive-interface FastEthernet 0/0
passive-interface Serial 1/0
no auto-summary
!

Then the command would be

MGT(config)#router eigrp 12
MGT(config-router)#no passive-interface Fa0/0
MGT(config-router)#end

Also MGT Router connect to the ISP router using Serial 1/0. If you seen passive-interface s1/0, then do not remove it using #no passive-interface s1/0 command.

Download Cisco Packet Tracer EIGRP Lab .pka file

Subscribe
Notify of
guest

10 Comments
Inline Feedbacks
View all comments
Arun
Arun
4 years ago

Hello Admin /team

in the above Lab sim – please check the ip address of Fa1/0 – 192.168.12.17
Fa0/1 – 192.168.12.1 for router ENG ,as per run -config its 192.168.60.x.

Laurentiu
Laurentiu
4 years ago

On MGT:
“ip default-network 198.0.18.0” is not good. For this network of /30 or (.252) if the Host addresses are .5 and .6, I strongly believe that default network should be 198.0.18.8 (this is the network address).
So it should be “ip default-network 198.0.18.4”

Please correct me if I’m wrong

feri
feri
4 years ago
Reply to  Laurentiu

or we could instead of command ip default-network use this
MGT(config-router)#redistribute static ???

feri
feri
4 years ago
Reply to  feri
Arun
Arun
4 years ago
Reply to  Laurentiu

HI ,
Eigrp ip default network should be classful -so correct ans is
“ip default-network 198.0.18.0 ” ..x.x.18.4 wont work.

kline
kline
4 years ago

what version of packet tracer to be used?

Mohammad
Mohammad
4 years ago

why you didn’t redistribute the static default route in eigrp ?
how other routers will know that ?

yigal
yigal
4 years ago

its not router eigrp 12 its 212

Yasser
Yasser
4 years ago

what is the packet Tracer version is work with EIGRP Lap

10
0
Would love your thoughts, please comment.x
()
x