3.5.3 Packet Tracer – Troubleshooting VLAN Configurations Answers

3.5.3 Packet Tracer – Troubleshooting VLAN Configurations Answers

Topology

3.5.3 Packet Tracer - Troubleshooting VLAN Configurations Answers 2

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
S1 VLAN 56 192.168.56.11 255.255.255.0 N/A
S2 VLAN 56 192.168.56.12 255.255.255.0 N/A
S3 VLAN 56 192.168.56.13 255.255.255.0 N/A
PC1 NIC 192.168.10.21 255.255.255.0 192.168.10.1
PC2 NIC 192.168.20.22 255.255.255.0 192.168.20.1
PC3 NIC 192.168.30.23 255.255.255.0 192.168.30.1
PC4 NIC 192.168.10.24 255.255.255.0 192.168.10.1
PC5 NIC 192.168.20.25 255.255.255.0 192.168.20.1
PC6 NIC 192.168.30.26 255.255.255.0 192.168.30.1

Port Assignments (Switches 2 and 3)

Ports Assignment Network
Fa0/1-0/5 VLAN 56 – Management&Native 192.168.56.0 /24
Fa06-0/10 VLAN 30 – Guest(Default) 192.168.30.0 /24
Fa0/11 – 0/17 VLAN 10 – Faculty/Staff 192.168.10.0 /24
Fa0/18 – 0/24 VLAN 20 – Students 192.168.20.0 /24

Learning Objective

Practice basic VLAN troubleshooting skills.

Scenario

In this lab, you will practice troubleshooting a misconfigured VLAN environment. Load or have your instructor load the configurations below into your lab gear. Your objective is to locate and correct any and all errors in the configurations and establish end-to-end connectivity. Your final configuration should match the topology diagram and addressing table. All passwords are set to cisco, except the enable secret password, which is set to class.

Task 1: Prepare the Network

Step 1: Cable a network that is similar to the one in the topology diagram.

Step 2: Clear any existing configurations on the switches, and initialize all ports in the shutdown state.

Step 3: Import the configurations below.

Switch 1

hostname S1
no ip domain-lookup
enable secret class
!
vlan 10,20,30,56
!It is a common error to forget to create the VLANs on all switches,
especially on a switch where there are no ports in that VLAN. The show vlan
command reveals this problem.
!
interface range FastEthernet0/1-5
switchport trunk native vlan 56
!Forgetting this command causes a native VLAN mismatch. An error should be
produced on the switch. This prevents data for VLAN 56 from being passed
properly from switch to switch.
switchport mode trunk
!
interface range FastEthernet0/6-24
shutdown
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan56
ip address 192.168.56.11 255.255.255.0
no ip route-cache
!
line con 0
logging synchronous
line vty 0 4
no login
line vty 5 15
password cisco
login
!
end

Switch 2

hostname S2
no ip domain-lookup
enable secret class
!
vlan 10,20,30,56
!
interface FastEthernet0/1-5
switchport trunk native vlan 56
switchport mode access
switchport mode trunk
!Accidentally misconfiguring these ports as access ports can cause some
interesting behavior. The port is made an access port in VLAN 1 (the
default). This, combined with the native VLAN on the trunk being 56, results
in traffic on VLAN 56 being sent on VLAN 1. The show interfaces trunk command
reveals this.
!
interface range FastEthernet0/6-10
switchport access vlan 30
switchport mode access
!
interface range FastEthernet0/11-17
switchport access vlan 10
switchport mode access
!
interface range FastEthernet0/18-24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.56.12 255.255.255.0
no ip address
!The default VLAN was configured as the management VLAN. This address is
reachable if the mistake made on the trunk links is not changed. This however
is not correct.
no ip route-cache
shutdown
!
interface Vlan56
ip address 192.168.56.12 255.255.255.0
!
!The correct management VLAN was not configured and the IP address was put on
the default VLAN. The show ip interface brief command reveals this.
line con 0
password cisco
login
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end

Switch 3

hostname S3
no ip domain-lookup
enable secret cisco
!
vlan 10,20,30
vlan 56
!The management VLAN was not configured. It is a common mistake to assume the
VLAN exists if you configured the SVI for that VLAN.
!
interface range FastEthernet0/1-5
switchport trunk native vlan 56
switchport mode trunk
!
interface range FastEthernet0/6-10
switchport access vlan 30
switchport mode access
!
interface range FastEthernet0/11-17
switchport access vlan 10
switchport mode access
!
interface range FastEthernet0/18-24
switchport access vlan 20
switchport mode access
!
!The ports were not put in their respective VLANs. This is evident because
all the hosts connected to this switch can reach the others because they are
all in the default VLAN. This can be seen with a show vlan command.
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan56
ip address 192.168.56.13 255.255.255.0
!This device is not reachable via the management VLAN without an IP address.
The absence of this command is evident through a show ip interface brief
command.
no ip route-cache
!
line con 0
password cisco
login
line vty 0 4
password cisco
login
line vty 5 15
 password cisco
login
!
end

Task 2: Troubleshoot and Repair the VLAN Configuration

Task 3: Document the Switch Configurations

On each switch, capture the running configuration to a text file and save for future reference:

Switch 1

hostname S1
no ip domain-lookup
enable secret cisco
!
vlan 10,20,30,56
!
interface FastEthernet0/1
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/5
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/6
shutdown
!
!<output omitted - remaining ports on S1 are shutdown>
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan56
ip address 192.168.56.11 255.255.255.0
no ip route-cache
!
line con 0
logging synchronous
line vty 0 4
no login
line vty 5 15
 password cisco
login
!
end

Switch 2

hostname S2
no ip domain-lookup
enable secret cisco
!
vlan 10,20,30,56
!
interface FastEthernet0/1
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/5
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
 no ip route-cache
shutdown
!
interface Vlan56
ip address 192.168.56.12 255.255.255.0
no shutdown
!
line con 0
password cisco
login
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end

Switch 3

hostname S3
no ip domain-lookup
enable secret class
!
vlan 10,20,30,56
!
interface FastEthernet0/1
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/5
switchport trunk native vlan 56
switchport mode trunk
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan56
ip address 192.168.56.13 255.255.255.0
no ip route-cache
!
line con 0
password cisco
login
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end

Task 4: Clean Up

Erase the configurations and reload the switches. Disconnect and store the cabling. For PC hosts that are normally connected to other networks (such as the school LAN or to the Internet), reconnect the appropriate cabling and restore the TCP/IP settings.

Download Packet Tracer (.pka) file:

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments