Challenge Lab 15: OSPF Passive Interfaces

Lab Objective:

The objective of this lab exercise is for you to configure Single-Area OSPF on Cisco routers.

Lab Purpose:

Single-Area OSPF is a core ICND/CCNA exam topic so learn it well. Rather than watch a video solution, I have provided show runs and test commands where appropriate.

Certification Level:

This lab is suitable for both CCENT and CCNA certification exam preparation.

Lab Difficulty:

This lab has a difficulty rating of 5/10.

Readiness Assessment:

When you are ready for your certification exam, you should complete this lab in no more than 15 minutes.

Lab Topology:

Please use the following topology to complete this lab exercise:

Challenge Lab 15: OSPF Passive Interfaces 1

Task 1:

Configure the topology above. You should be able to ping across the Serial interface only because there are no routes from the Loopback networks.

Task 2:

Configure Single-Area OSPF on both routers. Put all networks into area 0. Set the router ID for RouterA to 1.1.1.1 and RouterB to 2.2.2.2. Ping all networks to check connectivity and check the routing tables.

Task 3:

Set Loopback0 on both routers to be a passive interface.

Solution

Show Runs 

RouterA 

interface Loopback0 
ip address 192.168.1.1 255.255.255.240 
! 
interface Loopback1 
ip address 192.168.2.1 255.255.255.224 
! 
interface Serial0/0 
ip address 10.0.0.1 255.255.255.0 
clock rate 2000000 
! 
router ospf 1 
router-id 1.1.1.1 
log-adjacency-changes 
passive-interface Loopback0 
network 10.0.0.0 0.0.0.255 area 0 
network 192.168.1.0 0.0.0.15 area 0 
network 192.168.2.0 0.0.0.31 area 0 
! 

RouterB 

interface Loopback0 
ip address 172.16.1.1 255.255.240.0 
! 
interface Loopback1 ip address 172.20.1.1 255.255.252.0
! 
interface Serial0/0 
ip address 10.0.0.2 255.255.255.0 
clock rate 2000000 
! 
router ospf 2 
router-id 2.2.2.2 
log-adjacency-changes 
passive-interface Loopback0 
network 10.0.0.0 0.0.0.255 area 0 
network 172.16.0.0 0.0.15.255 area 0 
network 172.20.0.0 0.0.7.255 area 0 
!

TEST:

R1#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B – BGP, 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area, 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2, 
       E1 - OSPF external type 1, E2 - OSPF external type 2, 
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, 
       L2 - IS-IS level-2, ia - IS-IS inter area, 
       * - candidate default, U - per-user static route, 
       o - ODR, P - periodic downloaded static route 

Gateway of last resort is not set 

  172.16.0.0/32 is subnetted, 1 subnets 
O 172.16.1.1 [110/65] via 10.0.0.2, 00:04:50, Serial0/0 
  172.20.0.0/32 is subnetted, 1 subnets 
O 172.20.1.1 [110/65] via 10.0.0.2, 00:04:50, Serial0/0 
  10.0.0.0/24 is subnetted, 1 subnets 
C 10.0.0.0 is directly connected, Serial0/0
  192.168.1.0/28 is subnetted, 1 subnets 
C 192.168.1.0 is directly connected, Loopback0 
  192.168.2.0/27 is subnetted, 1 subnets 
C 192.168.2.0 is directly connected, Loopback1 

R1#show ip protocols 
Routing Protocol is “ospf 1” 
Outgoing update filter list for all interfaces is not set 
Incoming update filter list for all interfaces is not set 
Router ID 1.1.1.1 
Number of areas in this router is 1. 1 normal 0 stub 0 nssa 
Maximum path: 4 
Routing for Networks: 
10.0.0.0 0.0.0.255 area 0 
192.168.1.0 0.0.0.15 area 0 
192.168.2.0 0.0.0.31 area 0 
Reference bandwidth unit is 100 mbps 
Passive Interface(s): 
Loopback0 
Routing Information Sources: 
Gateway Distance Last Update 
2.2.2.2 110 00:05:12 
1.1.1.1 110 00:06:29 
192.168.2.1 110 00:06:44 
Distance: (default is 110) 

R1#show ip ospf nei 
Neighbor ID Pri State Dead Time Address Interface 
2.2.2.2 0 FULL/ - 00:00:36 10.0.0.2 Serial0/0 

R2#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B – BGP, 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area,
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2, 
       E1 - OSPF external type 1, E2 - OSPF external type 2, 
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, 
       L2 - IS-IS level-2, ia - IS-IS inter area, 
       * - candidate default, U - per-user static route, 
       o - ODR, P - periodic downloaded static route 

Gateway of last resort is not set 

  172.16.0.0/20 is subnetted, 1 subnets 
C 172.16.0.0 is directly connected, Loopback0 
  172.20.0.0/22 is subnetted, 1 subnets 
C 172.20.0.0 is directly connected, Loopback1 
  10.0.0.0/24 is subnetted, 1 subnets 
C 10.0.0.0 is directly connected, Serial0/0 
  192.168.1.0/32 is subnetted, 1 subnets 
O 192.168.1.1 [110/65] via 10.0.0.1, 00:01:11, Serial0/0 
  192.168.2.0/32 is subnetted, 1 subnets 
O 192.168.2.1 [110/65] via 10.0.0.1, 00:01:11, Serial0/0 

R2#show ip prot 
Routing Protocol is “ospf 2” 
Outgoing update filter list for all interfaces is not set 
Incoming update filter list for all interfaces is not set 
Router ID 2.2.2.2 
Number of areas in this router is 1. 1 normal 0 stub 0 nssa 
Maximum path: 4 
Routing for Networks: 
10.0.0.0 0.0.0.255 area 0 
172.16.0.0 0.0.15.255 area 0 
172.20.0.0 0.0.7.255 area 0 
Reference bandwidth unit is 100 mbps 
Passive Interface(s):
Loopback0 
Routing Information Sources: 
Gateway Distance Last Update 
1.1.1.1 110 00:01:48 
2.2.2.2 110 00:01:48 
Distance: (default is 110) 

R2#show ip ospf nei 
Neighbor ID Pri State Dead Time Address Interface 
1.1.1.1 0 FULL/ - 00:00:35 10.0.0.1 Serial0/0 
R2#
Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x