2.4.1.5 Lab – Troubleshooting Basic PPP with Authentication Answers

2.4.1.5 Lab – Troubleshooting Basic PPP with Authentication (Instructor Version)

Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

2.4.1.5 Lab - Troubleshooting Basic PPP with Authentication Answers 2

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
R1 G0/1 192.168.1.1 255.255.255.0 N/A
S0/0/0 (DCE) 192.168.12.1 255.255.255.252 N/A
S0/0/1 192.168.13.1 255.255.255.252 N/A
R2 Lo0 209.165.200.225 255.255.255.252 N/A
S0/0/0 192.168.12.2 255.255.255.252 N/A
S0/0/1 (DCE) 192.168.23.1 255.255.255.252 N/A
R3 G0/1 192.168.3.1 255.255.255.0 N/A
S0/0/0 (DCE) 192.168.13.2 255.255.255.252 N/A
S0/0/1 192.168.23.2 255.255.255.252 N/A
PC-A NIC 192.168.1.3 255.255.255.0 192.168.1.1
PC-C NIC 192.168.3.3 255.255.255.0 192.168.3.1

Objectives

Part 1: Build the Network and Load Device Configurations
Part 2: Troubleshoot the Data Link Layer
Part 3: Troubleshoot the Network Layer

Background / Scenario

The routers at your company were configured by an inexperienced network engineer. Several errors in the configuration have resulted in connectivity issues. Your manager has asked you to troubleshoot and correct the configuration errors and document your work. Using your knowledge of PPP and standard testing methods, find and correct the errors. Ensure that all of the serial links use PPP CHAP authentication, and that all of the networks are reachable.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Make sure that the routers and switches have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • 2 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
  • 2 PCs (Windows with a terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and serial cables as shown in the topology

Part 1: Build the Network and Load Device Configurations

In Part 1, you will set up the network topology, configure basic settings on the PC hosts, and load configurations on the routers.

Step 1: Cable the network as shown in the topology.

Step 2: Configure the PC hosts.

Step 3: Load router configurations.

Load the following configurations into the appropriate router. All routers have the same passwords. The privileged EXEC mode password is class. The password for console and vty access is cisco. All serial interfaces should be configured with PPP encapsulation and authenticated with CHAP using the password of chap123.

Router R1 Configuration:

hostname R1
enable secret class
no ip domain lookup
banner motd #Unauthorized Access is Prohibited!#
username R2 password chap123
username R3 password chap123
interface g0/1
ip address 192.168.1.1 255.255.255.0
no shutdown
interface s0/0/0
ip address 192.168.12.1 255.255.255.252
clock rate 128000
encapsulation ppp
ppp authentication chap
! no shutdown
interface s0/0/1
ip address 192.168.31.1 255.255.255.252
! ip address 192.168.13.1 255.255.255.252
encapsulation ppp
ppp authentication pap
! ppp authentication chap
! no shutdown
exit
router ospf 1
router-id 1.1.1.1
network 192.168.1.0 0.0.0.255 area 0
network 192.168.12.0 0.0.0.3 area 0
network 192.168.13.0 0.0.0.3 area 0
passive-interface g0/1
exit
line con 0
password cisco
logging synchronous
login
line vty 0 4
password cisco
login

Router R2 Configuration:

hostname R2
enable secret class
no ip domain lookup
banner motd #Unauthorized Access is Prohibited!#
username R1 password chap123
username r3 password chap123
! username R3 password chap123
! no username r3 password chap123
interface lo0
ip address 209.165.200.225 255.255.255.252
interface s0/0/0
ip address 192.168.12.2 255.255.255.252
encapsulation ppp
ppp authentication chap
no shutdown
interface s0/0/1
ip address 192.168.23.1 255.255.255.252
clock rate 128000
! encapsulation ppp
! ppp authentication chap
no shutdown
exit
router ospf 1
router-id 2.2.2.2
network 192.168.12.0 0.0.0.3 area 0
network 192.168.23.0 0.0.0.3 area 0
default-information originate
exit
ip route 0.0.0.0 0.0.0.0 loopback0
line con 0
password cisco
logging synchronous
login
line vty 0 4
password cisco
login

Router R3 Configuration:

hostname R3
enable secret class
no ip domain lookup
banner motd #Unauthorized Access is Prohibited!#
username R2 password chap123
username R3 password chap123
!no username R3 password chap123
!username R1 password chap123
interface g0/1
ip address 192.168.3.1 255.255.255.0
no shutdown
interface s0/0/0
ip address 192.168.13.2 255.255.255.252
clock rate 128000
encapsulation ppp
ppp authentication chap
no shutdown
interface s0/0/1
ip address 192.168.23.2 255.255.255.252
encapsulation ppp
ppp authentication chap
no shutdown
exit
router ospf 1
router-id 3.3.3.3
! network 192.168.3.0 0.0.0.255 area 0
network 192.168.13.0 0.0.0.3 area 0
network 192.168.23.0 0.0.0.3 area 0
passive-interface g0/1
line con 0
password cisco
logging synchronous
login
line vty 0 4
password cisco
login

Step 4: Save your running configuration.

In Part 2, you will use show commands to troubleshoot data link layer issues. Be sure to verify settings, such as clock rate, encapsulation, CHAP, and usernames/passwords.

Step 1: Examine the R1 configuration.

a. Use the show interfaces command to determine whether PPP has been established on both serial links.

R1# show interfaces s0/0/0  
Serial0/0/0 is administratively down, line protocol is down  
  Hardware is GT96K Serial  
  Internet address is 192.168.12.1/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,  
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation PPP, LCP Closed, loopback not set  
  Keepalive set (10 sec)  
  Last input never, output never, output hang never  
  Last clearing of "show interface" counters 00:04:41  
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0  
  Queueing strategy: weighted fair  
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)  
     Conversations  0/0/256 (active/max active/max total)  
     Reserved Conversations 0/0 (allocated/max allocated)  
     Available Bandwidth 1158 kilobits/sec  
  5 minute input rate 0 bits/sec, 0 packets/sec  
  5 minute output rate 0 bits/sec, 0 packets/sec  
     0 packets input, 0 bytes, 0 no buffer  
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles  
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort  
     0 packets output, 0 bytes, 0 underruns  
     0 output errors, 0 collisions, 0 interface resets  
     0 unknown protocol drops  
     0 output buffer failures, 0 output buffers swapped out  
     0 carrier transitions  
     DCD=down  DSR=down  DTR=up  RTS=down  CTS=down    

R1# show interfaces s0/0/1  
Serial0/0/1 is administratively down, line protocol is down  
  Hardware is GT96K Serial  
  Internet address is 192.168.31.1/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,  
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation PPP, LCP Closed, loopback not set  
  Keepalive set (10 sec)  
  Last input never, output never, output hang never  
  Last clearing of "show interface" counters 00:09:10  
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0  
  Queueing strategy: weighted fair  
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)  
     Conversations  0/0/256 (active/max active/max total)  
     Reserved Conversations 0/0 (allocated/max allocated)  
     Available Bandwidth 1158 kilobits/sec  
  5 minute input rate 0 bits/sec, 0 packets/sec  
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer  
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles  
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort  
     0 packets output, 0 bytes, 0 underruns  
     0 output errors, 0 collisions, 0 interface resets  
     0 unknown protocol drops  
     0 output buffer failures, 0 output buffers swapped out  
     0 carrier transitions  
     DCD=down  DSR=up  DTR=down  RTS=down  CTS=down

From the show interfaces results for S0/0/0 and S0/0/1, what are possible issues with the PPP links?
____________________________________________________
The output indicates: Both S0/0/0 and S0/0/1 are shut down. PPP encapsulation has been applied to both S0/0/0 and S0/0/1 interfaces. Besides the fact that the serial interface are administratively down, there are still issues with the PPP configurations, such as mismatched authentication.

b. Use the debug ppp authentication command to view real-time PPP authentication output during troubleshooting.

R1# debug ppp authentication
PPP authentication debugging is on

c. Use the show run interface s0/0/0 command to examine the settings on S0/0/0.

R1# show run interface s0/0/0
Building configuration...

Current configuration : 143 bytes
!
interface Serial0/0/0
 ip address 192.168.12.1 255.255.255.252
 encapsulation ppp
 shutdown
 ppp authentication chap
 clock rate 128000
end

Resolve all problems found for S0/0/0. Record the commands used to correct the configuration.
______________________________________________________

R1(config)# interface s0/0/0
R1(config-if)# no shutdown

After correcting the issue, what information does the debug output provide?

R1(config-if)# no shutdown
*Jun 18 12:01:23.931: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Jun 18 12:01:23.931: Se0/0/0 PPP: Using default call direction
*Jun 18 12:01:23.931: Se0/0/0 PPP: Treating connection as a dedicated line
*Jun 18 12:01:23.931: Se0/0/0 PPP: Session handle[F900005A] Session id[90]
*Jun 18 12:01:23.943: Se0/0/0 CHAP: O CHALLENGE id 1 len 23 from "R1"
*Jun 18 12:01:23.947: Se0/0/0 CHAP: I CHALLENGE id 1 len 23 from "R2"
*Jun 18 12:01:23.947: Se0/0/0 PPP: Sent CHAP SENDAUTH Request
*Jun #18 12:01:23.947: Se0/0/0 PPP: Received SENDAUTH Response PASS
*Jun 18 12:01:23.947: Se0/0/0 CHAP: Using hostname from configured hostname
*Jun 18 12:01:23.947: Se0/0/0 CHAP: Using password from AAA
*Jun 18 12:01:23.947: Se0/0/0 CHAP: O RESPONSE id 1 len 23 from "R1"
*Jun 18 12:01:23.947: Se0/0/0 CHAP: I RESPONSE id 1 len 23 from "R2"
*Jun 18 12:01:23.951: Se0/0/0 PPP: Sent CHAP LOGIN Request
*Jun 18 12:01:23.951: Se0/0/0 PPP: Received LOGIN Response PASS
*Jun 18 12:01:23.951: Se0/0/0 CHAP: O SUCCESS id 1 len 4
*Jun 18 12:01:23.951: Se0/0/0 CHAP: I SUCCESS id 1 len 4

_____________________________________________________
The debug output shows a successful CHAP negotiation process. PPP has been established on the link connecting R1 S0/0/0 and R2 S0/0/0.

d. Use the show run interface s0/0/1 command to examine the settings on S0/0/1.

R1# show run interface s0/0/1
Building configuration…

Current configuration : 123 bytes
!
interface Serial0/0/1
 ip address 192.168.31.1 255.255.255.252
 encapsulation ppp
 shutdown
 ppp authentication pap
end

Resolve all problems found for S0/0/1. Record the commands used to correct the configuration.
_______________________________________________________

R1(config)# interface s0/0/1
R1(config-if)# ppp authentication chap
R1(config-if)# no shutdown

After correcting the issue, what information does the debug output provide?

*Jun 18 12:13:57.819: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Jun 18 12:13:57.819: Se0/0/1 PPP: Using default call direction
*Jun 18 12:13:57.819: Se0/0/1 PPP: Treating connection as a dedicated line
*Jun 18 12:13:57.819: Se0/0/1 PPP: Session handle[F300005B] Session id[91]
*Jun 18 12:13:57.831: Se0/0/1 CHAP: O CHALLENGE id 1 len 23 from "R1"
*Jun 18 12:13:57.831: Se0/0/1 CHAP: I CHALLENGE id 1 len 23 from "R3"
*Jun 18 12:13:57.831: Se0/0/1 PPP: Sent CHAP SENDAUTH Request
*Jun 18 12:13:57.831: Se0/0/1 PPP: Received SENDAUTH Response PASS
*Jun 18 12:13:57.831: Se0/0/1 CHAP: Using hostname from configured hostname
*Jun 18 12:13:57.831: Se0/0/1 CHAP: Using password from AAA
*Jun 18 12:13:57.831: Se0/0/1 CHAP: O RESPONSE id 1 len 23 from "R1"
*Jun 18 12:14:01.819: Se0/0/1 PPP: Using default call direction
*Jun 18 12:14:01.819: Se0/0/1 PPP: Treating connection as a dedicated line
*Jun 18 12:14:01.819: Se0/0/1 PPP: Session handle[BC00005C] Session id[92]
*Jun 18 12:14:01.831: Se0/0/1 CHAP: O CHALLENGE id 1 len 23 from "R1"
*Jun 18 12:14:01.851: Se0/0/1 CHAP: I CHALLENGE id 1 len 23 from "R3"
*Jun 18 12:14:01.851: Se0/0/1 PPP: Sent CHAP SENDAUTH Request
*Jun 18 12:14:01.851: Se0/0/1 PPP: Sending AAA radius abort
R1(config-if)#
*Jun 18 12:14:04.860: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1,
changed state to up
*Jun 18 12:14:04.868: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1,
changed state to down
*Jun 18 12:14:06.856: Se0/0/1 PPP: Using default call direction

_____________________________________________________
The debug output shows an unsuccessful CHAP negotiation process and the interface is going up and down. More configuration errors exist for the link connecting R1 S0/0/1 and R3 S0/0/0.

e. Use the no debug ppp authentication or undebug all command to turn off the debug PPP output.

f. Use the show running-config | include username command to verify the correct username and password configurations.

R1# show running-config | include username
username R2 password 0 chap123
username R3 password 0 chap123

Resolve all problems found. Record the commands used to correct the configuration.
______________________________________________________
No problems exist.

Step 2: Examine the R2 configuration.

a. Use the show interfaces command to determine if PPP has been established on both serial links.

R2# show interfaces s0/0/0  
Serial0/0/0 is up, line protocol is up  
  Hardware is GT96K Serial  
  Internet address is 192.168.12.2/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,  
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation PPP, LCP Open  
  Open: IPCP, CDPCP, loopback not set  
  Keepalive set (10 sec)  
  CRC checking enabled  
  Last input 00:00:06, output 00:00:01, output hang never  
  Last clearing of "show interface" counters 00:18:22  
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0  
  Queueing strategy: weighted fair  
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)  
     Conversations  0/1/256 (active/max active/max total)  
     Reserved Conversations 0/0 (allocated/max allocated)  
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec  
  5 minute output rate 0 bits/sec, 0 packets/sec  
     53 packets input, 3055 bytes, 0 no buffer  
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles  
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort  
     52 packets output, 2772 bytes, 0 underruns  
     0 output errors, 0 collisions, 34 interface resets  
     0 unknown protocol drops  
     0 output buffer failures, 0 output buffers swapped out  
     1 carrier transitions  
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up    

R2# show interfaces s0/0/1  
Serial0/0/1 is up, line protocol is down  
  Hardware is GT96K Serial  
  Internet address is 192.168.23.1/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,  
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation HDLC, loopback not set  
  Keepalive set (10 sec)  
  CRC checking enabled  
  Last input 00:00:11, output 00:00:00, output hang never  
  Last clearing of "show interface" counters never  
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0  
  Queueing strategy: weighted fair  
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)  
     Conversations  0/1/256 (active/max active/max total)  
     Reserved Conversations 0/0 (allocated/max allocated)  
     Available Bandwidth 1158 kilobits/sec  
  5 minute input rate 0 bits/sec, 0 packets/sec  
  5 minute output rate 0 bits/sec, 0 packets/sec  
     230 packets input, 4370 bytes, 0 no buffer  
     Received 230 broadcasts, 0 runts, 0 giants, 0 throttles  
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort  
     119 packets output, 3014 bytes, 0 underruns  
     0 output errors, 0 collisions, 42 interface resets  
     230 unknown protocol drops  
     0 output buffer failures, 0 output buffers swapped out  
     121 carrier transitions  
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Have all links been established? _______No

If the answer is no, which links need to be examined? What are the possible issues?
______________________________________________________
The link between R2 and R3 has not been established because S0/0/1 interface is configured with HDLC encapsulation. Beside the encapsulation issue, authentication mismatch can also prevent link establishment.

b. Use the show run interface command to examine links that have not been established.

R2# show run interface s0/0/1
Building configuration...

Current configuration : 89 bytes
!
interface Serial0/0/1
 ip address 192.168.23.1 255.255.255.252
 clock rate 128000
end

Resolve all problems found for the interfaces. Record the commands used to correct the configuration.
_______________________________________________________

R2(config)# interface s0/0/1
R2(config-if)# encapsulation ppp
R2(config-if)# ppp authentication chap

c. Use the show running-config | include username command to verify the correct username and password configurations.

R2# show running-config | include username
username R1 password 0 chap123
username r3 password 0 chap123

Resolve all problems found. Record the commands used to correct the configuration.
_______________________________________________________

R2(config)# no username r3 password chap123
R2(config)# username R3 password chap123

d. Use the show ppp interface serial command for the serial interface that you are troubleshooting.

R2# show interfaces s0/0/1  
Serial0/0/1 is up, line protocol is up  
  Hardware is GT96K Serial  
  Internet address is 192.168.23.1/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,  
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation PPP, LCP Open  
  Open: IPCP, CDPCP, loopback not set  
  Keepalive set (10 sec)  
  CRC checking enabled  
  Last input 00:00:07, output 00:00:00, output hang never  
  Last clearing of "show interface" counters 00:25:09  
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair  
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)  
     Conversations  0/1/256 (active/max active/max total)  
     Reserved Conversations 0/0 (allocated/max allocated)  
     Available Bandwidth 1158 kilobits/sec  
  5 minute input rate 0 bits/sec, 0 packets/sec  
  5 minute output rate 0 bits/sec, 0 packets/sec  
     506 packets input, 27348 bytes, 0 no buffer  
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles  
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort  
     507 packets output, 28030 bytes, 0 underruns  
     0 output errors, 0 collisions, 0 interface resets  
     0 unknown protocol drops  
     0 output buffer failures, 0 output buffers swapped out  
     0 carrier transitions  
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Has the link been established? ______Yes

Step 3: Examine the R3 configuration.

a. Use the show interfaces command to determine whether PPP has been established on both serial links.

R3# show interfaces s0/0/0  
Serial0/0/0 is up, line protocol is down  
  Hardware is GT96K Serial  
  Internet address is 192.168.13.2/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,  
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation PPP, LCP Closed, loopback not set  
  Keepalive set (10 sec)  
  CRC checking enabled  
  Last input 00:00:01, output 00:00:01, output hang never  
  Last clearing of "show interface" counters 00:55:56  
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0  
  Queueing strategy: weighted fair  
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)  
     Conversations  0/1/256 (active/max active/max total)  
     Reserved Conversations 0/0 (allocated/max allocated)  
     Available Bandwidth 1158 kilobits/sec  
  5 minute input rate 0 bits/sec, 3 packets/sec  
  5 minute output rate 0 bits/sec, 2 packets/sec  
     3540 packets input, 70800 bytes, 0 no buffer  
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles  
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort  
     3274 packets output, 60079 bytes, 0 underruns  
     0 output errors, 0 collisions, 821 interface resets  
     0 unknown protocol drops  
     0 output buffer failures, 0 output buffers swapped out  
     1573 carrier transitions  
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R3# show interfaces s0/0/1  
Serial0/0/1 is up, line protocol is up  
  Hardware is GT96K Serial  
  Internet address is 192.168.23.2/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,  
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation PPP, LCP Open  
  Open: IPCP, CDPCP, loopback not set  
  Keepalive set (10 sec)  
  CRC checking enabled  
  Last input 00:00:07, output 00:00:00, output hang never  
  Last clearing of "show interface" counters 00:51:19  
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0  
  Queueing strategy: weighted fair  
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)  
     Conversations  0/1/256 (active/max active/max total)  
     Reserved Conversations 0/0 (allocated/max allocated)  
     Available Bandwidth 1158 kilobits/sec  
  5 minute input rate 0 bits/sec, 0 packets/sec  
  5 minute output rate 0 bits/sec, 0 packets/sec  
     711 packets input, 35022 bytes, 0 no buffer  
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles  
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort  
     847 packets output, 36444 bytes, 0 underruns  
     0 output errors, 0 collisions, 73 interface resets  
     141 unknown protocol drops  
     0 output buffer failures, 0 output buffers swapped out  
     96 carrier transitions  
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Have all links been established? ________No

If the answer is no, which links need to be examined? What are the possible issues?
_______________________________________________________
The serial link between R1 and R3 has not been established. Serial0/0/0 is configured with PPP encapsulation, and the interface is enabled. Therefore, the possible issue is authentication mismatch.

b. Using the show run interface command to examine on any serial link that has not been established.

R3# show run interface s0/0/0
Building configuration...

Current configuration : 134 bytes
!
interface Serial0/0/0
 ip address 192.168.13.2 255.255.255.252
 encapsulation ppp
 ppp authentication chap
 clock rate 2000000
end

Resolve all problems found on the interfaces. Record the commands used to correct the configuration.
_______________________________________________________
No problems exist with the S0/0/0 configuration.

c. Use the show running-config | include username command to verify the correct username and password configurations.

R3# show run | include username
username R2 password 0 chap123
username R3 password 0 chap123

Resolve all problems found. Record the commands used to correct the configuration.
_____________________________________________________

R3(config)# no username R3 password chap123
R3(config)# username R1 password chap123

d. Use the show interface command to verify that serial links have been established.

R3# show interface s0/0/0  
Serial0/0/0 is up, line protocol is up  
  Hardware is GT96K Serial  
  Internet address is 192.168.13.2/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,  
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation PPP, LCP Open  
  Open: IPCP, CDPCP, loopback not set  
  Keepalive set (10 sec)  
  CRC checking enabled  
  Last input 00:00:20, output 00:00:03, output hang never  
  Last clearing of "show interface" counters 01:03:35  
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0  
  Queueing strategy: weighted fair  
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)  
     Conversations  0/1/256 (active/max active/max total)  
     Reserved Conversations 0/0 (allocated/max allocated)  
     Available Bandwidth 1158 kilobits/sec  
  5 minute input rate 0 bits/sec, 0 packets/sec  
  5 minute output rate 0 bits/sec, 0 packets/sec  
     4392 packets input, 88310 bytes, 0 no buffer  
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles  
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort  
     3974 packets output, 74268 bytes, 0 underruns  
     0 output errors, 0 collisions, 994 interface resets  
     0 unknown protocol drops  
     0 output buffer failures, 0 output buffers swapped out  
     1919 carrier transitions  
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

e. Have all PPP links been established?________Yes

f. Can PC-A ping Lo0? _______Yes

g. Can PC-A ping PC-C? ________No

Note: It may be necessary to disable the PC firewall for pings between the PCs to succeed.

Part 3: Troubleshoot the Network Layer

In Part 3, you will verify that Layer 3 connectivity is established on all interfaces by examining IPv4 and OSPF configurations.

Step 1: Verify that the interfaces listed in the Addressing Table are active and configured with the correct IP address information.

Issue the show ip interface brief command on all routers to verify that the interfaces are in an up/up state.

R1# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol  
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down      
GigabitEthernet0/0         unassigned      YES unset  administratively down down      
GigabitEthernet0/1         192.168.1.1     YES manual up                    up        
Serial0/0/0                192.168.12.1    YES manual up                    up        
Serial0/0/1                192.168.31.1    YES manual up                    up        
  
R2# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol  
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down      
GigabitEthernet0/0         unassigned      YES unset  administratively down down      
GigabitEthernet0/1         unassigned      YES unset  administratively down down      
Serial0/0/0                192.168.12.2    YES manual up                    up        
Serial0/0/1                192.168.23.1    YES manual up                    up        
Loopback0                  209.165.200.225 YES manual up                    up     

R3# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol  
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down      
GigabitEthernet0/0         unassigned      YES unset  administratively down down      
GigabitEthernet0/1         192.168.3.1     YES manual up                    up        
Serial0/0/0                192.168.13.2    YES manual up                    up        
Serial0/0/1                192.168.23.2    YES manual up                    up

Resolve all problems found. Record the commands used to correct the configuration.
________________________________________________________

R1(config)# interface s0/0/1
R1(config-if)# ip address 192.168.13.1 255.255.255.252

Step 2: Verify OSPF Routing

Issue the show ip protocols command to verify that OSPF is running and that all networks are advertised.

R1# show ip protocols  
*** IP Routing is NSF aware ***  
Routing Protocol is "ospf 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Router ID 1.1.1.1  
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa  
  Maximum path: 4  
  Routing for Networks:  
    192.168.1.0 0.0.0.255 area 0  
    192.168.12.0 0.0.0.3 area 0  
    192.168.13.0 0.0.0.3 area 0  
  Passive Interface(s):  
    GigabitEthernet0/1  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    3.3.3.3              110      00:01:46  
    2.2.2.2              110      00:01:46  
  Distance: (default is 110)    

R2# show ip protocols  
*** IP Routing is NSF aware ***  
  
Routing Protocol is "ospf 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Router ID 2.2.2.2  
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa  
  Maximum path: 4  
  Routing for Networks:  
    192.168.12.0 0.0.0.3 area 0  
    192.168.23.0 0.0.0.3 area 0  
    209.165.200.224 0.0.0.3 area 0  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    3.3.3.3              110      00:03:53  
    1.1.1.1              110      00:07:45  
  Distance: (default is 110)    

R3# show ip protocols  
*** IP Routing is NSF aware ***  
  
Routing Protocol is "ospf 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Router ID 3.3.3.3  
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa  
  Maximum path: 4  
  Routing for Networks:
    192.168.13.0 0.0.0.3 area 0  
    192.168.23.0 0.0.0.3 area 0  
  Passive Interface(s):  
    GigabitEthernet0/1  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    1.1.1.1              110      00:07:14  
    2.2.2.2              110      00:07:14  
  Distance: (default is 110)

Resolve all problems found. Record the commands used to correct the configuration.
_____________________________________________________

R3(config)# router ospf 1
R3(config-router)# network 192.168.3.0 0.0.0.255 area 0

Can PC-A ping PC-C? _____Yes

If connectivity does not exist between all hosts, then continue troubleshooting to resolve any remaining issues.

Note: It may be necessary to disable the PC firewall for pings between the PCs to succeed.

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs – Final

Router R1

R1#show run
Building configuration...

Current configuration : 1821 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
username R2 password 0 chap123
username R3 password 0 chap123
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.12.1 255.255.255.252
encapsulation ppp
ppp authentication chap
clock rate 128000
!
interface Serial0/0/1
ip address 192.168.13.1 255.255.255.252
encapsulation ppp
ppp authentication chap
!
router ospf 1
router-id 1.1.1.1
passive-interface GigabitEthernet0/1
network 192.168.1.0 0.0.0.255 area 0
network 192.168.12.0 0.0.0.3 area 0
network 192.168.13.0 0.0.0.3 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
banner motd ^CUnauthorized Access is Prohibited!^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router R2

R2#show run
Building configuration...

Current configuration : 1866 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
username R1 password 0 chap123
username R3 password 0 chap123
!
interface Loopback0
ip address 209.165.200.225 255.255.255.252
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.12.2 255.255.255.252
encapsulation ppp
ppp authentication chap
!
interface Serial0/0/1
ip address 192.168.23.1 255.255.255.252
encapsulation ppp
ppp authentication chap
clock rate 128000
!
router ospf 1
router-id 2.2.2.2
network 192.168.12.0 0.0.0.3 area 0
network 192.168.23.0 0.0.0.3 area 0
default-information originate
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Loopback0
!
control-plane
!
banner motd ^CUnauthorized Access is Prohibited!^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router R3

R3#show run
Building configuration...

Current configuration : 1888 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
username R2 password 0 chap123
username R1 password 0 chap123
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.13.2 255.255.255.252
encapsulation ppp
ppp authentication chap
clock rate 128000
!
interface Serial0/0/1
ip address 192.168.23.2 255.255.255.252
encapsulation ppp
ppp authentication chap
!
router ospf 1
router-id 3.3.3.3
passive-interface GigabitEthernet0/1
network 192.168.3.0 0.0.0.255 area 0
network 192.168.13.0 0.0.0.3 area 0
network 192.168.23.0 0.0.0.3 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
banner motd ^CUnauthorized Access is Prohibited!^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
end

 

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x