3.2.1.9 Lab – Configuring Basic RIPv2 Answers

3.2.1.9 Lab – Configuring Basic RIPv2 (Instructor Version – Optional Lab)

Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only. Optional activities are designed to enhance understanding and/or to provide additional practice.

Topology

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
R1 G0/1 172.30.10.1 255.255.255.0 N/A
S0/0/0 (DCE) 10.1.1.1 255.255.255.252 N/A
R2 G0/0 209.165.201.1 255.255.255.0 N/A
S0/0/0 10.1.1.2 255.255.255.252 N/A
S0/0/1 (DCE) 10.2.2.2 255.255.255.252 N/A
R3 G0/1 172.30.30.1 255.255.255.0 N/A
S0/0/1 10.2.2.1 255.255.255.252 N/A
S1 N/A VLAN 1 N/A N/A
S3 N/A VLAN 1 N/A N/A
PC-A NIC 172.30.10.3 255.255.255.0 172.30.10.1
PC-B NIC 209.165.201.2 255.255.255.0 209.165.201.1
PC-C NIC 172.30.30.3 255.255.255.0 172.30.30.1

Objectives

Part 1: Build the Network and Configure Basic Device Settings

Part 2: Configure and Verify RIPv2 Routing
• Configure RIPv2 on the routers and verify that it is running.
• Configure a passive interface.
• Examine routing tables.
• Disable automatic summarization.
• Configure a default route.
• Verify end-to-end connectivity.

Background / Scenario

RIP version 2 (RIPv2) is used for routing of IPv4 addresses in small networks. RIPv2 is a classless, distancevector routing protocol, as defined by RFC 1723. Because RIPv2 is a classless routing protocol, subnet masks are included in the routing updates. By default, RIPv2 automatically summarizes networks at major network boundaries. When automatic summarization has been disabled, RIPv2 no longer summarizes networks to their classful address at boundary routers.

In this lab, you will configure the network topology with RIPv2 routing, disable automatic summarization, propagate a default route, and use CLI commands to display and verify RIP routing information.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in this lab. Refer to the Router Interface Summary Table at the end of the lab for the correct interface identifiers.

Note: Make sure that the routers and switches have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • 2 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
  • 3 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and Serial cables as shown in the topology

Part 1: Build the Network and Configure Basic Device Settings

In Part 1, you will set up the network topology and configure basic settings.

Step 1: Cable the network as shown in the topology.

Step 2: Initialize and reload the router and switch.

Step 3: Configure basic settings for each router and switch.

a. Disable DNS lookup.

b. Configure device names as shown in the topology.

c. Configure password encryption.

d. Assign class as the privileged EXEC password.

e. Assign cisco as the console and vty passwords.

f. Configure a MOTD banner to warn users that unauthorized access is prohibited.

g. Configure logging synchronous for the console line.

h. Configure the IP addresses listed in the Addressing Table for all interfaces.

i. Configure a description for each interface with an IP address.

j. Configure the clock rate, if applicable, to the DCE serial interface.

k. Copy the running-configuration to the startup-configuration.

Step 4: Configure PC IP Addressing.

Refer to the Addressing Table for IP address information of the PCs.

Step 5: Test connectivity.

At this point, the PCs are unable to ping each other.

a. Each workstation should be able to ping the attached router. Verify and troubleshoot if necessary.

b. The routers should be able to ping one another. Verify and troubleshoot if necessary.

Part 2: Configure and Verify RIPv2 Routing

In Part 2, you will configure RIPv2 routing on all routers in the network and then verify that the routing tables are updated correctly. After RIPv2 has been verified, you will disable automatic summarization, configure a default route, and verify end-to-end connectivity.

Step 1: Configure RIPv2 routing.

a. Configure RIPv2 on R1as the routing protocol and advertise the appropriate connected networks.

R1# config t
R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# passive-interface g0/1
R1(config-router)# network 172.30.0.0
R1(config-router)# network 10.0.0.0

The passive-interface command stops routing updates out the specified interface. This process prevents unnecessary routing traffic on the LAN. However, the network that the specified interface belongs to is still advertised in routing updates that are sent out across other interfaces.

b. Configure RIPv2 on R3 and use the network statement to add the appropriate connected networks and prevent routing updates on the LAN interface.

c. Configure RIPv2 on R2 and use the network statements to add the appropriate connected networks. Do not advertise the 209.165.201.0 network.

Note: It is not necessary to make the G0/0 interface passive on R2 because the network associated with this interface is not being advertised.

Step 2: Examine the current state of the network.

a. The status of the two serial links can quickly be verified using the show ip interface brief command on R2.

R2# show ip interface brief
Interface                  IP-Address     OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned     YES unset  administratively down down
GigabitEthernet0/0         209.165.201.1  YES manual up                    up
GigabitEthernet0/1         unassigned     YES unset  administratively down down
Serial0/0/0                10.1.1.2       YES manual up                    up
Serial0/0/1                10.2.2.2       YES manual up                    up

b. Check connectivity between PCs.

From PC-A, is it possible to ping PC-B? Why?
_____________________________________________
No, R2 is not advertising the route to PC-B.

From PC-A, is it possible to ping PC-C? Why?
_____________________________________________
No, R1 and R3 do not have routes to the remote networks, and R2, incorrectly has two equal cost load balancing routes to the 172.30.0.0/16 subnet.

From PC-C, is it possible to ping PC-B? Why?
_____________________________________________
No, R2 is not advertising the route to PC-B.

From PC-C, is it possible to ping PC-A?Why?
_____________________________________________
No, R1 and R3 do not have routes to the remote networks, and R2, incorrectly has two equal cost loadbalancing routes to the 172.30.0.0/16 subnet..

c. Verify that RIPv2 is running on the routers.

You can use the debug ip rip, show ip protocols, and show run commands to confirm that RIPv2 is running. The show ip protocols command output for R1 is shown below.

R1# show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 7 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive 2
  Interface             Send  Recv Triggered RIP Key-chain
  Serial0/0/0           2     2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
  10.0.0.0
  172.30.0.0
Passive Interface(s):
  GigabitEthernet0/1
Routing Information Sources:
  Gateway         Distance         Last Update
  10.1.1.2             120
Distance: (default is 120)

When issuing the debug ip rip command on R2, what information is provided that confirms RIPv2 is running?
________________________________________________
RIP: sending v2 updates to 224.0.0.9 via Serial 0/0/0 (10.1.1.2).

When you are finished observing the debugging outputs, issue the undebug all command at the privileged EXEC prompt.

When issuing the show run command on R3, what information is provided that confirms RIPv2 is running?
________________________________________________

router rip
version 2

d. Examine the automatic summarization of routes.

The LANs connected to R1 and R3 are composed of discontiguous networks. R2 displays two equal-cost paths to the 172.30.0.0/16 network in the routing table. R2 displays only the major classful network address of 172.30.0.0 and does not display any of the subnets for this network.

R2# show ip route
<Output omitted>
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.1.1.0/30 is directly connected, Serial0/0/0
L        10.1.1.2/32 is directly connected, Serial0/0/0
C        10.2.2.0/30 is directly connected, Serial0/0/1
L        10.2.2.2/32 is directly connected, Serial0/0/1
R     172.30.0.0/16 [120/1] via 10.2.2.1, 00:00:23, Serial0/0/1
                    [120/1] via 10.1.1.1, 00:00:09, Serial0/0/0
      209.165.201.0/24 is variably subnetted, 2 subnets, 2 masks
C        209.165.201.0/24 is directly connected, GigabitEthernet0/0
L        209.165.201.1/32 is directly connected, GigabitEthernet0/0

R1 displays only its own subnet for the 172.30.10.0/24 network. R1 does not have a route for the 172.30.30.0/24 subnet on R3.

R1# show ip route
<Output omitted>
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        10.1.1.0/30 is directly connected, Serial0/0/0
L        10.1.1.1/32 is directly connected, Serial0/0/0
R        10.2.2.0/30 [120/1] via 10.1.1.2, 00:00:21, Serial0/0/0
      172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.30.10.0/24 is directly connected, GigabitEthernet0/1
L        172.30.10.1/32 is directly connected, GigabitEthernet0/1

R3 only displays its own subnet for the 172.30.30.0/24 network. R3 does not have a route for the 172.30.10.0/24 subnets on R1.

R3# show ip route
<Output omitted>
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        10.2.2.0/30 is directly connected, Serial0/0/1
L        10.2.2.1/32 is directly connected, Serial0/0/1
R        10.1.1.0/30 [120/1] via 10.2.2.2, 00:00:23, Serial0/0/1
      172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.30.30.0/24 is directly connected, GigabitEthernet0/1
L        172.30.30.1/32 is directly connected, GigabitEthernet0/1

Use the debug ip rip command on R2 to determine the routes received in the RIP updates from R3 and list them here.
_______________________________________________
172.30.0.0/16

R3 is not sending any of the 172.30.0.0 subnets, only the summarized route of 172.30.0.0/16, including the subnet mask. Therefore, the routing tables on R1 and R2 do not display the 172.30.0.0 subnets on R3.

Step 3: Disable automatic summarization.

a. The no auto-summary command is used to turn off automatic summarization in RIPv2. Disable auto summarization on all routers. The routers will no longer summarize routes at major classful network boundaries. R1 is shown here as an example.

R1(config)# router rip
R1(config-router)# no auto-summary

b. Issue the clear ip route * command to clear the routing table.

R1(config-router)# end
R1# clear ip route *

c. Examine the routing tables. Remember that it will take some time to converge the routing tables after clearing them.

The LAN subnets connected to R1 and R3 should now be included in all three routing tables.

R2# show ip route
<Output omitted>
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.1.1.0/30 is directly connected, Serial0/0/0
L        10.1.1.2/32 is directly connected, Serial0/0/0
C        10.2.2.0/30 is directly connected, Serial0/0/1
L        10.2.2.2/32 is directly connected, Serial0/0/1
      172.30.0.0/16 is variably subnetted, 3 subnets, 2 masks
R        172.30.0.0/16 [120/1] via 10.2.2.1, 00:01:01, Serial0/0/1
                       [120/1] via 10.1.1.1, 00:01:15, Serial0/0/0
R        172.30.10.0/24 [120/1] via 10.1.1.1, 00:00:21, Serial0/0/0
R        172.30.30.0/24 [120/1] via 10.2.2.1, 00:00:04, Serial0/0/1
      209.165.201.0/24 is variably subnetted, 2 subnets, 2 masks
C        209.165.201.0/24 is directly connected, GigabitEthernet0/0
L        209.165.201.1/32 is directly connected, GigabitEthernet0/0
R1# show ip route
<Output omitted>
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        10.1.1.0/30 is directly connected, Serial0/0/0
L        10.1.1.1/32 is directly connected, Serial0/0/0
R        10.2.2.0/30 [120/1] via 10.1.1.2, 00:00:12, Serial0/0/0
      172.30.0.0/16 is variably subnetted, 3 subnets, 2 masks
C        172.30.10.0/24 is directly connected, GigabitEthernet0/1
L        172.30.10.1/32 is directly connected, GigabitEthernet0/1
R        172.30.30.0/24 [120/2] via 10.1.1.2, 00:00:12, Serial0/0/0
R3# show ip route
<Output omitted>
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        10.2.2.0/30 is directly connected, Serial0/0/1
L        10.2.2.1/32 is directly connected, Serial0/0/1
R        10.1.1.0/30 [120/1] via 10.2.2.2, 00:00:23, Serial0/0/1
      172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.30.30.0/24 is directly connected, GigabitEthernet0/1
L        172.30.30.1/32 is directly connected, GigabitEthernet0/1
R        172.30.10.0 [120/2] via 10.2.2.2, 00:00:16, Serial0/0/1

d. Use the debug ip rip command on R2 to examine the RIP updates.

R2# debug ip rip

After 60 seconds, issue the no debug ip rip command.

What routes are in the RIP updates that are received from R3?
________________________________________________
172.30.30.0/24

Are the subnet masks included in the routing updates? _____yes

Step 4: Configure and redistribute a default route for Internet access.

a. From R2, create a static route to network 0.0.0.0 0.0.0.0, using the ip route command. This forwards any traffic with an unknown destination address to PC-B at 209.165.201.2, simulating the Internet by setting a Gateway of Last Resort on router R2.

R2(config)# ip route 0.0.0.0 0.0.0.0 209.165.201.2

b. R2 will advertise a route to the other routers if the default-information originate command is added to its RIP configuration.

R2(config)# router rip
R2(config-router)# default-information originate

Step 5: Verify the routing configuration.

a. View the routing table on R1.

R1# show ip route
<Output omitted>
Gateway of last resort is 10.1.1.2 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 10.1.1.2, 00:00:13, Serial0/0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.1.1.0/30 is directly connected, Serial0/0/0
L       10.1.1.1/32 is directly connected, Serial0/0/0
R       10.2.2.0/30 [120/1] via 10.1.1.2, 00:00:13, Serial0/0/0
     172.30.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.30.10.0/24 is directly connected, GigabitEthernet0/1
L       172.30.10.1/32 is directly connected, GigabitEthernet0/1
R       172.30.30.0/24 [120/2] via 10.1.1.2, 00:00:13, Serial0/0/0

How can you tell from the routing table that the subnetted network shared by R1 and R3 has a pathway for Internet traffic?
____________________________________________________
There is a Gateway of Last Resort, and the default route shows up in the table as being learned via RIP.

b. View the routing table on R2.

How is the pathway for Internet traffic provided in its routing table?
___________________________________________________
R2 has a default static route to 0.0.0.0 via 209.165.201.2, which is directly connected to G0/0.

Step 6: Verify connectivity.

a. Simulate sending traffic to the Internet by pinging from PC-A and PC-C to 209.165.201.2.

Were the pings successful? _____Yes

b. Verify that hosts within the subnetted network can reach each other by pinging between PC-A and PC-C.

Were the pings successful? _____Yes

Note: It may be necessary to disable the PCs firewall.

Reflection

1. Why would you turn off automatic summarization for RIPv2?
_________________________________________________
So the routers will no longer summarize routes at major classful network boundaries.

2. How did R1 and R3 learn the pathway to the Internet?
_________________________________________________
From RIP routing updates received from the router where the default route was configured (R2).

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs – Final

Router R1 

R1# show run
Building configuration...
Current configuration : 1787 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
no ip domain lookup
ip cef
!
multilink bundle-name authenticated
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
description R1 LAN
ip address 172.30.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
description Link to R2
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
router rip
version 2
passive-interface GigabitEthernet0/1
network 10.0.0.0
network 172.30.0.0
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
banner motd ^CUnauthorized access is strictly prohibited.^C
!
line con 0
password 7 045802150C2E
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 060506324F41
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router R2 

R2#show run
Building configuration...
Current configuration : 2073 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
no ip domain lookup
ip cef
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description R2 LAN
ip address 209.165.201.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
description Link to R1
ip address 10.1.1.2 255.255.255.252
!
interface Serial0/0/1
description Link to R3
ip address 10.2.2.2 255.255.255.252
clock rate 2000000
!
router rip
version 2
network 10.0.0.0
default-information originate
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 209.165.201.2
!
control-plane
!
banner motd ^CUnauthorized access is strictly prohibited.^C
!
line con 0
password 7 0822455D0A16
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 110A1016141D
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router R3 

R3#show run
Building configuration...
Current configuration : 1847 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
!
multilink bundle-name authenticated
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
description R3 LAN
ip address 172.30.30.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
description Link to R2
ip address 10.2.2.1 255.255.255.252
!
router rip
version 2
passive-interface GigabitEthernet0/1
network 10.0.0.0
network 172.30.0.0
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
banner motd ^CUnauthorized access is strictly prohibited.^C
!
line con 0
password 7 02050D480809
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 14141B180F0B
login
transport input all
!
scheduler allocate 20000 1000
!
end

 


guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x