7.2.3.7 Lab – Troubleshooting Advanced EIGRP Answers

7.2.3.7 Lab – Troubleshooting Advanced EIGRP (Instructor Version)

Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

7.2.3.7 Lab - Troubleshooting Advanced EIGRP Answers 2

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
R1 G0/0 192.168.1.1 255.255.255.0 N/A
Lo1 172.16.11.1 255.255.255.0 N/A
Lo2 172.16.12.1 255.255.255.0 N/A
Lo3 172.16.13.1 255.255.255.0 N/A
Lo4 172.16.14.1 255.255.255.0 N/A
S0/0/0 (DCE) 192.168.12.1 255.255.255.252 N/A
S0/0/1 192.168.13.1 255.255.255.252 N/A
R2 G0/0 192.168.2.1 255.255.255.0 N/A
Lo0 209.165.200.225 255.255.255.252 N/A
S0/0/0 192.168.12.2 255.255.255.252 N/A
S0/0/1 (DCE) 192.168.23.1 255.255.255.252 N/A
R3 G0/0 192.168.3.1 255.255.255.0 N/A
Lo3 172.16.33.1 255.255.255.0 N/A
Lo4 172.16.34.1 255.255.255.0 N/A
Lo5 172.16.35.1 255.255.255.0 N/A
Lo6 172.16.36.1 255.255.255.0 N/A
S0/0/0 (DCE) 192.168.13.2 255.255.255.252 N/A
S0/0/1 192.168.23.2 255.255.255.252 N/A
PC-A NIC 192.168.1.3 255.255.255.0 192.168.1.1
PC-B NIC 192.168.2.3 255.255.255.0 192.168.2.1
PC-C NIC 192.168.3.3 255.255.255.0 192.168.3.1

Objectives

Part 1: Build the Network and Load Device Configurations
Part 2: Troubleshoot EIGRP

Background / Scenario

The Enhanced Interior Gateway Routing Protocol (EIGRP) has advanced features to allow changes related to summarization, default route propagation, bandwidth utilization, metrics, and security.

In this lab, you will troubleshoot a network that is running EIGRP. Advanced EIGRP features have been implemented, but the network is now experiencing problems. You must find and correct the network issues.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS, Release 15.2(4)M3 (universalk9 image). Other routers and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Ensure that the routers have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • 3 PCs (Windows with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Part 1: Build the Network and Load Device Configurations

Step 1: Cable the network as shown in the topology.

Step 2: Configure PC hosts.

Step 3: Load router configurations.

Load the following configurations into the appropriate router. All routers have the same passwords. The privileged EXEC password is class, and cisco is the console and vty password.

Router R1 Configuration: 

conf t  
hostname R1  
enable secret class  
no ip domain lookup  
line con 0  
 password cisco  
 login  
 logging synchronous  
line vty 0 4  
 password cisco  
 login  
banner motd @  
  Unauthorized Access is Prohibited! @  
interface lo1  
 description Connection to Branch 11  
 ip add 172.16.11.1 255.255.255.0  
interface lo2  
 description Connection to Branch 12  
 ip add 172.16.12.1 255.255.255.0  
interface lo3  
 description Connection to Branch 13  
 ip add 172.16.13.1 255.255.255.0
interface lo4  
 description Connection to Branch 14  
 ip add 172.16.14.1 255.255.255.0  
interface g0/0  
 description R1 LAN Connection  
 ip add 192.168.1.1 255.255.255.0  
 no shutdown  
interface s0/0/0  
 description Serial Link to R2  
! clock rate 128000  
! bandwidth 128  
 ip add 192.168.12.1 255.255.255.252  
! ip hello-interval eigrp 1 30  
! ip hold-time eigrp 1 90  
! ip bandwidth-percent eigrp 1 40  
no shutdown  
interface s0/0/1  
 description Serial Link to R3  
! bandwidth 128  
 ip add 192.168.13.1 255.255.255.252  
! ip bandwidth-percent eigrp 1 40  
! ip hello-interval eigrp 1 30  
! ip hold-time eigrp 1 90  
no shutdown  
router eigrp 1  
 router-id 1.1.1.1  
 network 192.168.1.0 0.0.0.255   
 network 192.168.12.0 0.0.0.3   
 network 192.168.13.0 0.0.0.3   
 network 172.16.11.0 0.0.0.255  
 network 172.16.12.0 0.0.0.255  
 network 172.16.13.0 0.0.0.255  
 network 172.16.14.0 0.0.0.255  
 passive-interface g0/0  
! auto-summary  
end

Router R2 Configuration:

conf t  
hostname R2  
enable secret class  
no ip domain lookup  
line con 0  
 password cisco  
 login  
 logging synchronous
line vty 0 4  
 password cisco  
 login  
banner motd @  
  Unauthorized Access is Prohibited! @  
interface g0/0  
 description R2 LAN Connection  
 ip add 192.168.2.1 255.255.255.0  
 no shutdown  
interface s0/0/0  
 description Serial Link to R1  
! bandwidth 128  
 ip add 192.168.12.2 255.255.255.252  
! ip bandwidth-percent eigrp 1 40  
! ip hello-interval eigrp 1 30  
! ip hold-time eigrp 1 90  
 no shutdown  
interface s0/0/1  
 description Serial Link to R3  
! bandwidth 128  
! clock rate 128000  
 ip add 192.168.23.1 255.255.255.252  
! ip bandwidth-percent eigrp 1 40  
! ip hello-interval eigrp 1 30  
! ip hold-time eigrp 1 90  
 no shutdown  
interface lo0  
 ip add 209.165.200.225 255.255.255.252  
 description Connection to ISP  
router eigrp 1  
 router-id 2.2.2.2  
 network 192.168.2.0 0.0.0.255  
 network 192.168.12.0 0.0.0.3   
 network 192.168.23.0 0.0.0.3   
 passive-interface g0/0  
! redistribute static  
ip route 0.0.0.0 0.0.0.0 lo0  
end

Router R3 Configuration: 

conf t  
hostname R3  
enable secret class  
no ip domain lookup  
line con 0  
 password cisco
 login  
 logging synchronous  
line vty 0 4  
 password cisco  
 login  
banner motd @  
  Unauthorized Access is Prohibited! @  
interface lo3  
 description Connection to Branch 33  
 ip add 172.16.33.1 255.255.255.0  
interface lo4  
 description Connection to Branch 34  
 ip add 172.16.34.1 255.255.255.0  
interface lo5  
 description Connection to Branch 35  
 ip add 172.16.35.1 255.255.255.0  
interface lo6  
 description Connection to Branch 36  
 ip add 172.16.36.1 255.255.255.0  
interface g0/0  
 description R3 LAN Connection  
 ip add 192.168.3.1 255.255.255.0  
 no shutdown  
interface s0/0/0  
 description Serial Link to R1  
 ip add 192.168.13.2 255.255.255.252  
! ip bandwidth-percent eigrp 1 40  
! ip hello-interval eigrp 1 30  
! ip hold-time eigrp 1 90  
! clock rate 128000  
! bandwidth 128  
 no shutdown  
interface s0/0/1  
 description Serial Link to R2  
! bandwidth 128  
 ip add 192.168.23.2 255.255.255.252  
! ip bandwidth-percent eigrp 1 40  
! ip hello-interval eigrp 1 30  
! ip hold-time eigrp 1 90  
no shutdown  
router eigrp 1  
 router-id 3.3.3.3  
 network 192.168.3.0 0.0.0.255   
 network 192.168.13.0 0.0.0.3   
 network 192.168.23.0 0.0.0.3
 network 172.16.33.0 0.0.0.255  
 network 172.16.34.0 0.0.0.255  
 network 172.16.35.0 0.0.0.255  
 network 172.16.36.0 0.0.0.255  
 passive-interface g0/0  
! auto-summary  
end

Step 4: Verify end-to-end connectivity.

Note: It may be necessary to disable the PC firewall to ping between PCs.

Step 5: Save the configuration on all routers.

Part 2: Troubleshoot EIGRP

In Part 2, verify that all routers have established neighbor adjacencies, and that all network routes are available.

Additional EIGRP Requirements:

  • All serial interface clock rates should be set at 128 Kb/s and a matching bandwidth setting should be available to allow EIGRP cost metrics to be calculated correctly.
  • Automatic route summarization of the branch networks.
  • EIGRP should redistribute the static default route to the Internet. This is simulated by using Loopback 0 interface on R2.
  • EIGRP should be configured to use no more than 40 percent of the available bandwidth on the serial interfaces.
  • EIGRP Hello/Hold timer intervals should be set to 30/90 on all serial interfaces.

List the commands used during your EIGRP troubleshooting process:
_____________________________________________________
Answers may vary, but the list of commands can include:

  • show controllers,
  • show ip eigrp neighbor
  • show ip eigrp interfaces
  • show ip eigrp interface detail
  • show ip route
  • show ip route eigrp
  • show ip protocols
  • show run
  • show run | section router eigrp

List the changes made to resolve the EIGRP issues. If no problems were found on the device, then respond with “no problems were found”.

R1 Router:
____________________________________________________

R1(config)# interface s0/0/0
R1(config-if)# clock rate 128000
R1(config-if)# bandwidth 128
R1(config-if)# ip hello-interval eigrp 1 30
R1(config-if)# ip hold-time eigrp 1 90
R1(config-if)# ip bandwidth-percent eigrp 1 40
R1(config-if)# interface s0/0/1
R1(config-if)# bandwidth 128
R1(config-if)# ip hello-interval eigrp 1 30
R1(config-if)# ip hold-time eigrp 1 90
R1(config-if)# ip bandwidth-percent eigrp 1 40
R1(config-if)# router eigrp 1
R1(config-router)# auto-summary

R2 Router:
______________________________________________________

R2(config)# interface s0/0/0
R2(config-if)# bandwidth 128
R2(config-if)# ip hello-interval eigrp 1 30
R2(config-if)# ip hold-time eigrp 1 90
R2(config-if)# ip bandwidth-percent eigrp 1 40
R2(config-if)# interface s0/0/1
R2(config-if)# clock rate 128000
R2(config-if)# bandwidth 128
R2(config-if)# ip hello-interval eigrp 1 30
R2(config-if)# ip hold-time eigrp 1 90
R2(config-if)# ip bandwidth-percent eigrp 1 40
R2(config-if)# router eigrp 1
R2(config-router)# redistribute static

R3 Router:
_____________________________________________________

R3(config)# interface s0/0/0
R3(config-if)# clock rate 128000
R3(config-if)# bandwidth 128
R3(config-if)# ip hello-interval eigrp 1 30
R3(config-if)# ip hold-time eigrp 1 90
R3(config-if)# ip bandwidth-percent eigrp 1 40
R3(config-if)# interface s0/0/1
R3(config-if)# bandwidth 128
R3(config-if)# ip hello-interval eigrp 1 30
R3(config-if)# ip hold-time eigrp 1 90
R3(config-if)# ip bandwidth-percent eigrp 1 40
R3(config-if)# router eigrp 1
R3(config-router)# auto-summary

Reflection

1. How can the auto-summary command create routing issues in EIGRP?
____________________________________________________
Answers may vary, but auto-summary may create routing issues by summarizing subnets in a network as a classful route. This may cause traffic to be incorrectly routed. When working with the EIGRP routing protocol, it is often preferable to manually summarize routes in EIGRP instead of allowing them to be automatically summarized. This is why Cisco changed the default setting in IOS 15 to no auto-summary.

2. Why would you want to change the EIGRP Hello and Hold time intervals on an interface?
____________________________________________________
You may want to extend the time between EIGRP hellos on an interface with a low bandwidth clocking speed. This reduces the amount of EIGRP traffic over that interface, providing more availability for data traffic.

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs

Router R1 (Final) 

R1# show run
Building configuration...

Current configuration : 2626 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
interface Loopback1
description Connection to Branch 11
ip address 172.16.11.1 255.255.255.0
!
interface Loopback2
description Connection to Branch 12
ip address 172.16.12.1 255.255.255.0
!
interface Loopback3
description Connection to Branch 13
ip address 172.16.13.1 255.255.255.0
!
interface Loopback4
description Connection to Branch 14
ip address 172.16.14.1 255.255.255.0
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description R1 LAN Connection
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
description Serial Link to R2
bandwidth 128
ip address 192.168.12.1 255.255.255.252
ip bandwidth-percent eigrp 1 40
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
clock rate 128000
!
interface Serial0/0/1
description Serial Link to R3
bandwidth 128
ip address 192.168.13.1 255.255.255.252
ip bandwidth-percent eigrp 1 40
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
!
router eigrp 1
network 172.16.11.0 0.0.0.255
network 172.16.12.0 0.0.0.255
network 172.16.13.0 0.0.0.255
network 172.16.14.0 0.0.0.255
network 192.168.1.0
network 192.168.12.0 0.0.0.3
network 192.168.13.0 0.0.0.3
auto-summary
passive-interface GigabitEthernet0/0
eigrp router-id 1.1.1.1
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
banner motd ^C
Unauthorized Access is Prohibited! ^C
!
line con 0
password cisco
login
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input none
!
scheduler allocate 20000 1000
!
end

Router R2 (Final)

R2# show run
Building configuration...

Current configuration : 2220 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
interface Loopback0
description Connection to ISP
ip address 209.165.200.225 255.255.255.252
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description R2 LAN Connection
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
description Serial Link to R1
bandwidth 128
ip address 192.168.12.2 255.255.255.252
ip bandwidth-percent eigrp 1 40
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
!
interface Serial0/0/1
description Serial Link to R3
bandwidth 128
ip address 192.168.23.1 255.255.255.252
ip bandwidth-percent eigrp 1 40
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
clock rate 128000
!
!
router eigrp 1
network 192.168.2.0
network 192.168.12.0 0.0.0.3
network 192.168.23.0 0.0.0.3
redistribute static
passive-interface GigabitEthernet0/0
eigrp router-id 2.2.2.2
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Loopback0
!
control-plane
!
banner motd ^C
Unauthorized Access is Prohibited! ^C
!
line con 0
password cisco
login
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input none
!
scheduler allocate 20000 1000
!
end

Router R3 (Final)

R3# show run
Building configuration...

Current configuration : 2551 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
interface Loopback3
description Connection to Branch 33
ip address 172.16.33.1 255.255.255.0
!
interface Loopback4
description Connection to Branch 34
ip address 172.16.34.1 255.255.255.0
!
interface Loopback5
description Connection to Branch 35
ip address 172.16.35.1 255.255.255.0
!
interface Loopback6
description Connection to Branch 36
ip address 172.16.36.1 255.255.255.0
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description R3 LAN Connection
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
description Serial Link to R1
bandwidth 128
ip address 192.168.13.2 255.255.255.252
ip bandwidth-percent eigrp 1 40
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
clock rate 128000
!
interface Serial0/0/1
description Serial Link to R2
bandwidth 128
ip address 192.168.23.2 255.255.255.252
ip bandwidth-percent eigrp 1 40
ip hello-interval eigrp 1 30
ip hold-time eigrp 1 90
!
router eigrp 1
network 172.16.33.0 0.0.0.255
network 172.16.34.0 0.0.0.255
network 172.16.35.0 0.0.0.255
network 172.16.36.0 0.0.0.255
network 192.168.3.0
network 192.168.13.0 0.0.0.3
network 192.168.23.0 0.0.0.3
auto-summary
passive-interface GigabitEthernet0/0
eigrp router-id 3.3.3.3
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
banner motd ^C
Unauthorized Access is Prohibited! ^C
!
line con 0
password cisco
login
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input none
!
scheduler allocate 20000 1000
!
end

 

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x