7.2.3.6 Lab – Troubleshooting Basic EIGRP for IPv4 and IPv6 Answers

7.2.3.6 Lab – Troubleshooting Basic EIGRP for IPv4 and IPv6 (Instructor Version)

Instructor Note: Red font color or Gray highlights indicate text that appears in the instructor copy only.

Topology

7.2.3.6 Lab - Troubleshooting Basic EIGRP for IPv4 and IPv6 Answers 2

Addressing Table

Device EIGRP
Router ID
Interface IP Address Default Gateway
R1 1.1.1.1 G0/0 192.168.1.1/24
2001:DB8:ACAD:A::1/64
FE80::1 link-local
N/A
S0/0/0 (DCE) 192.168.12.1/30
2001:DB8:ACAD:12::1/64
FE80::1 link-local
N/A
S0/0/1 192.18.13.1/30
2001:DB8:ACAD:13::1/64
FE80::1 link-local
N/A
R2 2.2.2.2 G0/0 192.168.2.1/24
2001:DB8:ACAD:B::2/64
FE80::2 link-local
N/A
S0/0/0 192.168.12.2/30
2001:DB8:ACAD:12::2/64
FE80::2 link-local
N/A
S0/0/1 (DCE) 192.168.23.1/30
2001:DB8:ACAD:23::2/64
FE80::2 link-local
N/A
R3 3.3.3.3 G0/0 192.168.3.1/24
2001:DB8:ACAD:C::3/64
FE80::3 link-local
N/A
S0/0/0 (DCE) 192.168.13.2/30
2001:DB8:ACAD:13::3/64
FE80::3 link-local
N/A
S0/0/1 192.168.23.2/30
2001:DB8:ACAD:23::3/64
FE80::3 link-local
N/A
PC-A NIC 192.168.1.3/24
2001:DB8:ACAD:A::A/64
192.168.1.1
FE80::1
PC-B NIC 192.168.2.3/24
2001:DB8:ACAD:B::B/64
192.168.2.1
FE80::2
PC-C NIC 192.168.3.3/24
2001:DB8:ACAD:C::C/64
192.168.3.1
FE80::3

Objectives

Part 1: Build the Network and Load Device Configurations
Part 2: Troubleshoot Layer 3 Connectivity
Part 3: Troubleshoot EIGRP for IPv4
Part 4: Troubleshoot EIGRP for IPv6

Background / Scenario

The Enhanced Interior Gateway Routing Protocol (EIGRP) is an advanced distance vector routing protocol developed by Cisco Systems. EIGRP routers discover neighbors and establish and maintain adjacencies with neighbor routers using Hello packets. An EIGRP router assumes that as long as it is receiving Hello packets from a neighboring router, that neighbor is up and its routes remain viable.

EIGRP for IPv4 runs over the IPv4 network layer, communicating with other EIGRP IPv4 peers, and advertising only IPv4 routes. EIGRP for IPv6 has the same functionality as EIGRP for IPv4 but uses IPv6 as the network layer protocol, communicating with EIGRP for IPv6 peers and advertising IPv6 routes.

In this lab, you will troubleshoot a network that runs EIGRP for IPv4 and EIGRP for IPv6 routing protocols. This network is experiencing problems and you are tasked with finding the problems and correcting them.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). Other routers and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Make sure that the routers have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Router (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • 3 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and serial cables as shown in the topology

Part 1: Build the Network and Load Device Configurations

In Part 1, you will set up the network topology and configure basic settings on the PC hosts and routers.

Step 1: Cable the network as shown in the topology.

Step 2: Configure PC hosts.

Step 3: Load router configurations.

Load the following configurations into the appropriate router. All routers have the same passwords. The privileged EXEC password is class, and the console and vty password is cisco.

Router R1 Configuration: 

conf t
service password-encryption
hostname R1
enable secret class
no ip domain lookup
ipv6 unicast-routing
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:A::1/64
ipv6 eigrp 1
no shutdown
interface Serial0/0/0
bandwidth 128
ip address 192.168.21.1 255.255.255.252
!ip address 192.168.12.1 255.255.255.252
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:12::1/64
ipv6 eigrp 1
clock rate 128000
no shutdown
interface Serial0/0/1
!bandwidth 128
ip address 192.168.13.1 255.255.255.252
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:31::1/64
!ipv6 address 2001:DB8:ACAD:13::1/64
ipv6 eigrp 1
no shutdown
router eigrp 1
network 192.168.1.0
network 192.168.12.0 0.0.0.3
network 192.168.13.0 0.0.0.3
passive-interface GigabitEthernet0/0
eigrp router-id 1.1.1.1
ipv6 router eigrp 1
! router-id 1.1.1.1
!passive-interface GigabitEthernet0/0
no shutdown
banner motd @
Unauthorized Access is Prohibited! @
line con 0
password cisco
logging synchronous
line vty 0 4
password cisco
login
transport input all
end

Router R2 Configuration: 

conf t
service password-encryption
hostname R2
enable secret class
no ip domain lookup
ipv6 unicast-routing
interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:B::2/64
ipv6 eigrp 1
! no shutdown
interface Serial0/0/0
! bandwidth 128
ip address 192.168.12.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:12::2/64
ipv6 eigrp 1
no shutdown
interface Serial0/0/1
bandwidth 128
ip address 192.168.23.1 255.255.255.0
!ip address 192.168.23.1 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:23::2/64
ipv6 eigrp 1
clock rate 128000
no shutdown
router eigrp 1
! network 192.168.2.0 0.0.0.255
network 192.168.12.0 0.0.0.3
network 192.168.23.0 0.0.0.3
passive-interface GigabitEthernet0/0
eigrp router-id 2.2.2.2
ipv6 router eigrp 1
! router-id 2.2.2.2
no shutdown
passive-interface GigabitEthernet0/0
banner motd @
Unauthorized Access is Prohibited! @
line con 0
password cisco
login
logging synchronous
line vty 0 4
password cisco
login
transport input all
end

Router R3 Configuration:

conf t
service password-encryption
hostname R3
enable secret class
no ip domain lookup
! ipv6 unicast-routing
interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:C::3/64
ipv6 eigrp 1
! no shutdown
interface Serial0/0/0
! bandwidth 128
ip address 192.168.13.2 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:13::3/64
ipv6 eigrp 1
no shutdown
! clock rate 128000
interface Serial0/0/1
bandwidth 128
ip address 192.168.23.2 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:23::3/64
ipv6 eigrp 1
no shutdown
router eigrp 1
network 192.168.3.0
network 192.168.13.0 0.0.0.3
! network 192.168.23.0 0.0.0.3
passive-interface GigabitEthernet0/0
eigrp router-id 3.3.3.3
!ipv6 router eigrp 1
! router-id 3.3.3.3
! passive-interface GigabitEthernet0/0
! no shutdown
banner motd @
Unauthorized Access is Prohibited! @
line con 0
password cisco
login
logging synchronous
line vty 0 4
password cisco
login
transport input all
end

Step 4: Save the running configuration for all routers.

Part 2: Troubleshoot Layer 3 Connectivity

In Part 2, you will verify that Layer 3 connectivity is established on all interfaces. You will need to test both IPv4 and IPv6 connectivity for all device interfaces.

Note: All serial interfaces should be set with a bandwidth of 128 Kb/s. The clock rate on the DCE interface should be set to 128000.

Step 1: Verify that the interfaces listed in the Addressing Table are active and configured with correct IP address information.

a. Issue the show ip interface brief command on all routers to verify that the interfaces are in an up/up state. Record your findings.
_____________________________________________________
R1 – all interfaces are up/up
R2 – G0/0 is administratively down
R3 – G0/0 is administratively down 

R1# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol  
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down      
GigabitEthernet0/0         192.168.1.1     YES manual up                    up        
GigabitEthernet0/1         unassigned      YES unset  administratively down down      
Serial0/0/0                192.168.21.1    YES manual up                    up        
Serial0/0/1                192.168.13.1    YES manual up                    up          

R2# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down      
GigabitEthernet0/0         192.168.2.1     YES manual administratively down down      
GigabitEthernet0/1         unassigned      YES unset  administratively down down      
Serial0/0/0                192.168.12.2    YES manual up                    up        
Serial0/0/1                192.168.23.1    YES manual up                    up        
  
R3# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol  
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down      
GigabitEthernet0/0         192.168.3.1     YES manual administratively down down      
GigabitEthernet0/1         unassigned      YES unset  administratively down down      
Serial0/0/0                192.168.13.2    YES manual up                    up        
Serial0/0/1                192.168.23.2    YES manual up                   up

b. Issue the show run interface command to verify IP address assignments on all router interfaces. Compare the interface IP addresses against the Addressing Table and verify the subnet mask assignments. For IPv6, verify that the link-local address has been assigned. Record your findings.
_____________________________________________________
R1 – S0/0/0 incorrect IPv4 address should be 192.168.12.1, S0/0/1 incorrect IPv6 address should be 2001:DB8:ACAD:13::1/64
R2 – S0/0/1 incorrect subnet mask should be 255.255.255.252
R3 – all IPs configured correctly

R1# show run interface s0/0/0  
Building configuration...  
  
Current configuration : 188 bytes  
!  
interface Serial0/0/0  
 bandwidth 128  
 ip address 192.168.21.1 255.255.255.252  
 ipv6 address FE80::1 link-local  
 ipv6 address 2001:DB8:ACAD:12::1/64  
 ipv6 eigrp 1  
 clock rate 128000  
end    

R1# show run interface s0/0/1  
Building configuration...  
  
Current configuration : 154 bytes  
!  
interface Serial0/0/1  
 ip address 192.168.13.1 255.255.255.252  
 ipv6 address FE80::1 link-local
 ipv6 address 2001:DB8:ACAD:31::1/64  
 ipv6 eigrp 1  
end   

R2# show run interface s0/0/1  
Building configuration...  
  
Current configuration : 186 bytes  
!  
interface Serial0/0/1  
 bandwidth 128  
 ip address 192.168.23.1 255.255.255.0  
 ipv6 address FE80::2 link-local  
 ipv6 address 2001:DB8:ACAD:23::2/64  
 ipv6 eigrp 1  
 clock rate 128000  
end

c. Issue the show interfaces interface-id command to verify bandwidth setting on the serial interfaces. Record your findings.
_______________________________________________________
R1 – S0/0/1 incorrect bandwidth of 1544 should be 128
R2 – S0/0/0 incorrect bandwidth of 1544 should be 128
R3 – S0/0/0 incorrect bandwidth of 1544 should be 128 

R1# show interfaces s0/0/1  
Serial0/0/1 is up, line protocol is up   
  Hardware is WIC MBRD Serial  
  Internet address is 192.168.13.1/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,   
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation HDLC, loopback not set  
  Keepalive set (10 sec)  
<output omitted>

R2# show interfaces s0/0/0  
Serial0/0/0 is up, line protocol is up   
  Hardware is WIC MBRD Serial  
  Internet address is 192.168.12.2/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,   
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation HDLC, loopback not set  
  Keepalive set (10 sec)  
<output omitted>    

R3# show interfaces s0/0/0
Serial0/0/0 is up, line protocol is up   
  Hardware is WIC MBRD Serial  
  Internet address is 192.168.13.2/30  
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,   
     reliability 255/255, txload 1/255, rxload 1/255  
  Encapsulation HDLC, loopback not set  
  Keepalive set (10 sec)  
<output omitted>

d. Issue the show controllers interface-id command to verify that clock rates have been set to 128 Kb/s on all DCE serial interfaces. Issue the show interfaces interface-id command to verify bandwidth setting on the serial interfaces. Record your findings.
______________________________________________________
R1 – clock rate correctly configured on S0/0/0
R2 – clock rate correctly configured on S0/0/1
R3 – clock rate incorrectly configured 2000000 on S0/0/0 should be 128000

R3# show controllers s0/0/0
Interface Serial0/0/0
Hardware is SCC
DCE V.35, clock rate 2000000

idb at 0x30FE4FB4, driver data structure at 0x29E7C30C
wic_info 0x30FE5EC4
<output omitted>

e. Resolve all problems found. Record the commands used to correct the issues.
_____________________________________________________

R1(config)# interface s0/0/0
R1(config-if)# ip address 192.168.12.1 255.255.255.252
R1(config-if)# interface s0/0/1
R1(config-if)# bandwidth 128
R1(config-if)# no ipv6 address 2001:db8:acad:31::1/64
R1(config-if)# ipv6 address 2001:db8:acad:13::1/64
R1(config-if)# end

R2(config)# interface g0/0
R2(config-if)# no shutdown
R2(config-if)# interface s0/0/0
R2(config-if)# bandwidth 128
R2(config-if)# interface s0/0/1
R2(config-if)# ip address 192.168.23.1 255.255.255.252
R2(config-if)# end

R3(config)# interface g0/0
R3(config-if)# no shutdown
R3(config-if)# interface s0/0/0
R3(config-if)# bandwidth 128
R3(config-if)# clock rate 128000
R3(config-if)# end

Step 2: Verify Layer 3 connectivity.

Use the ping command and verify that each router has network connectivity with the serial interfaces on the neighbor routers. Verify that the PCs can ping their default gateways. If problems still exist, continue troubleshooting Layer 3 issues.

Part 3: Troubleshoot EIGRP for IPv4

In Part 3, you will troubleshoot EIGRP for IPv4 problems and make the necessary changes needed to establish EIGRP for IPv4 routes and end-to-end IPv4 connectivity.

Note: LAN (G0/0) interfaces should not advertise EIGRP routing information, but routes to these networks should be contained in the routing tables.

Step 1: Test IPv4 end-to-end connectivity.

From each PC host, ping the other PC hosts in the topology to verify end-to-end connectivity.

Note: It may be necessary to disable the PC firewall before testing, to ping between PCs.

a. Ping from PC-A to PC-B. Were the pings successful? _____________No

b. Ping from PC-A to PC-C. Were the pings successful? _____________Yes

c. Ping from PC-B to PC-C. Were the pings successful? _____________No

Step 2: Verify that all interfaces are assigned to EIGRP for IPv4.

a. Issue the show ip protocols command to verify that EIGRP is running and that all networks are advertised. This command also allows you to verify that the router ID is set correctly, and that the LAN interfaces are set as passive interfaces. Record your findings.
_____________________________________________________
R1 – router ID, advertised networks, and passive interface are all configure correctly
R2 – router ID is correct, network statement missing for 192.168.2.0 and g0/0 not set to passive
R3 – router ID and passive interface are configured correctly, network statement missing for 192.168.23.0

R1# show ip protocols  
*** IP Routing is NSF aware ***  
  
Routing Protocol is "eigrp 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Default networks flagged in outgoing updates  
  Default networks accepted from incoming updates  
  EIGRP-IPv4 Protocol for AS(1)  
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0  
    NSF-aware route hold timer is 240  
    Router-ID: 1.1.1.1  
    Topology : 0 (base)   
      Active Timer: 3 min  
      Distance: internal 90 external 170  
      Maximum path: 4  
      Maximum hopcount 100  
      Maximum metric variance 1  
  
  Automatic Summarization: disabled  
  Maximum path: 4  
  Routing for Networks:  
    192.168.1.0  
    192.168.12.0/30  
    192.168.13.0/30  
  Passive Interface(s):  
    GigabitEthernet0/0  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    192.168.12.2          90      00:19:19  
    192.168.13.2          90      00:19:20  
  Distance: internal 90 external 170  
  

R2# show ip protocols  
*** IP Routing is NSF aware ***  
  
Routing Protocol is "eigrp 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Default networks flagged in outgoing updates  
  Default networks accepted from incoming updates  
  EIGRP-IPv4 Protocol for AS(1)  
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0  
    NSF-aware route hold timer is 240  
    Router-ID: 2.2.2.2  
    Topology : 0 (base)   
      Active Timer: 3 min
      Distance: internal 90 external 170  
      Maximum path: 4  
      Maximum hopcount 100  
      Maximum metric variance 1  
  
  Automatic Summarization: disabled  
  Maximum path: 4  
  Routing for Networks:  
    192.168.12.0/30  
    192.168.23.0/30  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    192.168.12.1          90      00:13:23  
  Distance: internal 90 external 170  
  

R3# sh ip protocols  
*** IP Routing is NSF aware ***  
  
Routing Protocol is "eigrp 1"  
  Outgoing update filter list for all interfaces is not set  
  Incoming update filter list for all interfaces is not set  
  Default networks flagged in outgoing updates  
  Default networks accepted from incoming updates  
  EIGRP-IPv4 Protocol for AS(1)  
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0  
    NSF-aware route hold timer is 240  
    Router-ID: 3.3.3.3  
    Topology : 0 (base)   
      Active Timer: 3 min  
      Distance: internal 90 external 170  
      Maximum path: 4  
      Maximum hopcount 100  
      Maximum metric variance 1  
  
  Automatic Summarization: disabled  
  Maximum path: 4  
  Routing for Networks:  
    192.168.3.0  
    192.168.13.0/30  
  Passive Interface(s):  
    GigabitEthernet0/0  
  Routing Information Sources:  
    Gateway         Distance      Last Update  
    192.168.13.1          90      00:14:25  
  Distance: internal 90 external 170

b. Make the necessary changes based on the output from the show ip protocols command. Record the commands that were used to correct the issues.
______________________________________________________

R2(config)# router eigrp 1
R2(config-router)# network 192.168.2.0 0.0.0.255
R2(config-router)# passive-interface g0/0
R2(config-router)# end

R3(config)# router eigrp 1
R3(config-router)# network 192.168.23.0 0.0.0.3
R3(config-router)# end

c. Re-issue the show ip protocols command to verify that your changes had the desired effect.

Step 3: Verify EIGRP neighbor information.

a. Issue the show ip eigrp neighbor command to verify that EIGRP adjacencies have been established between the neighboring routers.

R1# show ip eigrp neighbor  
EIGRP-IPv4 Neighbors for AS(1)  
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq  
                                                    (sec)         (ms)       Cnt Num  
1   192.168.12.2            Se0/0/0                  10 00:27:21    5  1170  0  12  
0   192.168.13.2            Se0/0/1                  12 00:47:18    1  1140  0  13  
  

R2# show ip eigrp neighbor  
EIGRP-IPv4 Neighbors for AS(1)  
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq  
                                                    (sec)         (ms)       Cnt Num  
1   192.168.23.2            Se0/0/1                  10 00:06:54   18  1170  0  14  
0   192.168.12.1            Se0/0/0                  11 00:30:35    6  1200  0  20  
  

R3# show ip eigrp neighbor  
EIGRP-IPv4 Neighbors for AS(1)  
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq  
                                                    (sec)         (ms)       Cnt Num  
1   192.168.23.1            Se0/0/1                  14 00:07:23   16  1170  0  13  
0   192.168.13.1            Se0/0/0                  13 00:51:01    2  1140  0  21

b. Resolve any outstanding problems that were discovered.

Instructor Note: All problems were resolved in Step 2b.

Step 4: Verify EIGRP for IPv4 routing information.

a. Issue the show ip route eigrp command to verify that each router has EIGRP for IPv4 routes to all nonadjoining networks.

R1# show ip route eigrp  
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route  
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       + - replicated route, % - next hop override  
  
Gateway of last resort is not set  
  
D     192.168.2.0/24 [90/20514560] via 192.168.12.2, 01:04:13, Serial0/0/0  
D     192.168.3.0/24  [90/20514560] via 192.168.13.2, 01:04:13, Serial0/0/1  
      192.168.23.0/30 is subnetted, 1 subnets  
D        192.168.23.0 [90/21024000] via 192.168.13.2, 01:04:14, Serial0/0/1  
                       [90/21024000] via 192.168.12.2, 01:04:14, Serial0/0/0  
  
R2# show ip route eigrp  
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route  
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       + - replicated route, % - next hop override  
  
Gateway of last resort is not set  
  
D     192.168.1.0/24 [90/20514560] via 192.168.12.1, 01:04:42, Serial0/0/0  
D     192.168.3.0/24 [90/20514560] via 192.168.23.2, 01:04:42, Serial0/0/1  
      192.168.13.0/30 is subnetted, 1 subnets  
D        192.168.13.0 [90/21024000] via 192.168.23.2, 01:04:42, Serial0/0/1  
                       [90/21024000] via 192.168.12.1, 01:04:42, Serial0/0/0  
  
R3# show ip route eigrp  
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route  
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       + - replicated route, % - next hop override  
  
Gateway of last resort is not set  
  
D     192.168.1.0/24 [90/20514560] via 192.168.13.1, 01:05:07, Serial0/0/0  
D     192.168.2.0/24 [90/20514560] via 192.168.23.1, 01:05:07, Serial0/0/1  
      192.168.12.0/30 is subnetted, 1 subnets  
D        192.168.12.0 [90/21024000] via 192.168.23.1, 01:05:07, Serial0/0/1  
                       [90/21024000] via 192.168.13.1, 01:05:07, Serial0/0/0

Are all EIGRP routes available? ________yes

If any EIGRP for IPv4 routes are missing, what is missing?
________________________________________________
All EIGRP routes are present.

b. If any routing information is missing, resolve these issues.

Instructor Note: All problems should have been resolved.

Step 5: Verify IPv4 end-to-end connectivity.

From each PC, verify that IPv4 end-to-end connectivity exists. PCs should be able to ping the other PC hosts in the topology. If IPv4 end-to-end connectivity does not exist, then continue troubleshooting to resolve remaining issues.

Note: It may be necessary to disable the PCs firewall.

Part 4: Troubleshoot EIGRP for IPv6

In Part 3, you will troubleshoot EIGRP for IPv6 problems and make the necessary changes needed to establish EIGRP for IPv6 routes and end-to-end IPv6 connectivity.

Note: LAN (G0/0) interfaces should not advertise EIGRP routing information, but routes to these networks should be contained in the routing tables.

Step 1: Test IPv6 end-to-end connectivity.

From each PC host, ping the IPv6 addresses of the other PC hosts in the topology to verify end-to-end connectivity.

Step 2: Verify that IPv6 unicast routing has been enabled on all routers.

a. An easy way to verify that IPv6 routing has been enabled on a router is to use the show run | section ipv6 unicast command. By adding this pipe to the show run command, the ipv6 unicast-routing command is displayed if IPv6 routing has been enabled.

Note: The show run command can also be issued without any pipe, and then a manual search for the ipv6 unicast-routing command can be done.

Issue the command on each router. Record your findings.
__________________________________________________
R3 does not have IPv6 unicast routing enabled.

b. If IPv6 unicast routing is not enabled on one or more routers, enable it now. Record the commands that were used to correct the issues.
__________________________________________________

R3(config)# ipv6 unicast-routing

Step 3: Verify that all interfaces are assigned to EIGRP for IPv6.

a. Issue the show ipv6 protocols command and verify that the router ID is correct. This command also allows you to verify that the LAN interfaces are set as passive interfaces.

Note: If no output is generated from this command, then the EIGRP for IPv6 process has not been configured.

Record your findings.
_________________________________________________
R1 – router ID is incorrect.and g0/0 not set to passive interface
R2 – router ID is incorrect
R3 – EIGRP had not been configured on this router 

R1# show ipv6 protocols  
IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "eigrp 1"  
EIGRP-IPv6 Protocol for AS(1)  
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0  
  NSF-aware route hold timer is 240  
  Router-ID: 192.168.21.1  
  Topology : 0 (base)   
    Active Timer: 3 min  
    Distance: internal 90 external 170  
    Maximum path: 16  
    Maximum hopcount 100  
    Maximum metric variance 1  
  
  Interfaces:  
    Serial0/0/0  
    Serial0/0/1  
    GigabitEthernet0/0  
  Redistribution:  
    None  
  
R2# show ipv6 protocols  
IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "eigrp 1"  
EIGRP-IPv6 Protocol for AS(1)  
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0  
  NSF-aware route hold timer is 240  
  Router-ID: 192.168.23.1  
  Topology : 0 (base)   
    Active Timer: 3 min  
    Distance: internal 90 external 170  
    Maximum path: 16  
    Maximum hopcount 100  
    Maximum metric variance 1
 Interfaces:  
    Serial0/0/0  
    Serial0/0/1  
    GigabitEthernet0/0  (passive)  
  Redistribution:  
    None  
  
R3# show ipv6 protocols  
IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"
b. Make the necessary configuration changes. Record the commands used to correct the issues.
_________________________________________________
R1(config)# ipv6 router eigrp 1
R1(config-rtr)# router-id 1.1.1.1
R1(config-rtr)# passive-interface g0/0

R2(config-rtr)# end
R2(config)# ipv6 router eigrp 1
R2(config-rtr)# router-id 2.2.2.2
R2(config-rtr)# end

R3(config)# ipv6 router eigrp 1
R3(config-rtr)# router-id 3.3.3.3
R3(config-rtr)# passive-interface g0/0
R3(config-rtr)# no shutdown
R3(config-rtr)# interface g0/0
R3(config-if)# ipv6 eigrp 1
R3(config-if)# interface s0/0/0
R3(config-if)# ipv6 eigrp 1
R3(config-if)# interface s0/0/1
R3(config-if)# ipv6 eigrp 1
R3(config-if)# end

c. Re-issue the show ipv6 protocols command to verify that your changes are correct.

Step 4: Verify that all routers have correct neighbor adjacency information.

a. Issue the show ipv6 eigrp neighbor command to verify that adjacencies have formed between neighboring routers.

R1# show ipv6 eigrp neighbors  
EIGRP-IPv6 Neighbors for AS(1)  
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq  
                                                    (sec)         (ms)       Cnt Num  
1   Link-local address:     Se0/0/1                  13 00:13:38   17  1182  0  7  
    FE80::3  
0   Link-local address:     Se0/0/0                  14 00:17:30   16  1182  0  20  
    FE80::2  
  
R2# show ipv6 eigrp neighbors  
EIGRP-IPv6 Neighbors for AS(1)  
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq  
                                                    (sec)         (ms)       Cnt Num  
1   Link-local address:     Se0/0/1                  13 00:14:36   27  1182  0  8  
    FE80::3  
0   Link-local address:     Se0/0/0                  12 00:18:33   17  1182  0  22  
    FE80::1  
  
R3# show ipv6 eigrp neighbors  
EIGRP-IPv6 Neighbors for AS(1)  
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq  
                                                    (sec)         (ms)       Cnt Num  
1   Link-local address:     Se0/0/1                  12 00:07:39   24  1182  0  21  
    FE80::2  
0   Link-local address:     Se0/0/0                  12 00:07:44   19  1182  0  21  
    FE80::1

b. Resolve any EIGRP adjacency issues that still exist.

Instructor Note: All adjacency issues should have been resolved in earlier steps.

Step 5: Verify EIGRP for IPv6 routing information.

a. Issue the show ipv6 route eigrp command, and verify that EIGRP for IPv6 routes exist to all non-adjoining networks.

R1# show ipv6 route eigrp  
IPv6 Routing Table - default - 10 entries  
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route  
       B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2  
       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external  
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect  
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2  
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2  
D   2001:DB8:ACAD:B::/64 [90/20514560]  
     via FE80::2, Serial0/0/0  
D   2001:DB8:ACAD:C::/64 [90/20514560]  
     via FE80::3, Serial0/0/1
D   2001:DB8:ACAD:23::/64 [90/21024000]  
     via FE80::2, Serial0/0/0  
     via FE80::3, Serial0/0/1  
  
R2# show ipv6 route eigrp  
IPv6 Routing Table - default - 10 entries  
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route  
       B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2  
       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external  
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect  
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2  
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2  
D   2001:DB8:ACAD:A::/64 [90/20514560]  
     via FE80::1, Serial0/0/0  
D   2001:DB8:ACAD:C::/64 [90/20514560]  
     via FE80::3, Serial0/0/1  
D   2001:DB8:ACAD:13::/64 [90/21024000]  
     via FE80::1, Serial0/0/0  
     via FE80::3, Serial0/0/1  
  
R3# show ipv6 route eigrp  
IPv6 Routing Table - default - 10 entries  
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route  
       B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2  
       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external  
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect  
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2  
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2  
D   2001:DB8:ACAD:A::/64 [90/20514560]  
     via FE80::1, Serial0/0/0  
D   2001:DB8:ACAD:B::/64 [90/20514560]  
     via FE80::2, Serial0/0/1  
D   2001:DB8:ACAD:12::/64 [90/21024000]  
     via FE80::1, Serial0/0/0  
     via FE80::2, Serial0/0/1

Are all EIGRP routes available? ________yes

If any EIGRP for IPv6 routes are missing, what is missing?
__________________________________________
All EIGRP for IPv6 routes are present.

b. Resolve any routing issues that still exist.

Instructor Note: All EIGRP for IPv6 routes issues should have been resolved.

Step 6: Test IPv6 end-to-end connectivity.

From each PC, verify that IPv6 end-to-end connectivity exists. PCs should be able to ping the other PC hosts in the topology. If IPv6 end-to-end connectivity does not exist, then continue troubleshooting to resolve remaining issues.

Note: It may be necessary to disable the PCs firewall.

Reflection

Why would you troubleshoot EIGRP for IPv4 and EIGRP for IPv6 separately?
__________________________________________________
EIGRP for IPv4 and EIGRP for IPv6 do not share routing information and their configuration is completely independent. Troubleshooting these two protocols should be done independently.

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs – Final

Router R1 

R1#show run
Building configuration...

Current configuration : 1937 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:A::1/64
ipv6 eigrp 1
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
bandwidth 128
ip address 192.168.12.1 255.255.255.252
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:12::1/64
ipv6 eigrp 1
clock rate 128000
!
interface Serial0/0/1
bandwidth 128
ip address 192.168.13.1 255.255.255.252
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:13::1/64
ipv6 eigrp 1
!
router eigrp 1
network 192.168.1.0
network 192.168.12.0 0.0.0.3
network 192.168.13.0 0.0.0.3
passive-interface GigabitEthernet0/0
eigrp router-id 1.1.1.1
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ipv6 router eigrp 1
passive-interface GigabitEthernet0/0
eigrp router-id 1.1.1.1
!
control-plane
!
banner motd ^C
Unauthorized Access is Prohibited! ^C
!
line con 0
password 7 13061E010803
login
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 060506324F41
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router R2

R2# show run
Building configuration...

Current configuration : 1937 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:B::2/64
ipv6 eigrp 1
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
bandwidth 128
ip address 192.168.12.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:12::2/64
ipv6 eigrp 1
!
interface Serial0/0/1
bandwidth 128
ip address 192.168.23.1 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:23::2/64
ipv6 eigrp 1
clock rate 128000
!
router eigrp 1
network 192.168.2.0
network 192.168.12.0 0.0.0.3
network 192.168.23.0 0.0.0.3
passive-interface GigabitEthernet0/0
eigrp router-id 2.2.2.2
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ipv6 router eigrp 1
passive-interface GigabitEthernet0/0
eigrp router-id 2.2.2.2
!
control-plane
!
banner motd ^C
Unauthorized Access is Prohibited! ^C
!
line con 0
password 7 13061E010803
login
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 070C285F4D06
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router R3

R3# show run
Building configuration...

Current configuration : 1976 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:C::3/64
ipv6 eigrp 1
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
bandwidth 128
ip address 192.168.13.2 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:13::3/64
ipv6 eigrp 1
clock rate 128000
!
interface Serial0/0/1
bandwidth 128
ip address 192.168.23.2 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:23::3/64
ipv6 eigrp 1
!
router eigrp 1
network 192.168.3.0
network 192.168.13.0 0.0.0.3
network 192.168.23.0 0.0.0.3
passive-interface GigabitEthernet0/0
eigrp router-id 3.3.3.3
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ipv6 router eigrp 1
passive-interface GigabitEthernet0/0
eigrp router-id 3.3.3.3
!
control-plane
!
banner motd ^C
Unauthorized Access is Prohibited! ^C
!
line con 0
password 7 13061E010803
login
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 13061E010803
login
transport input all
!
scheduler allocate 20000 1000
!
end

 

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x