9.3.1.5 Lab – Troubleshooting NAT Configurations Answers

9.3.1.5 Lab – Troubleshooting NAT Configurations (Instructor Version – Optional Lab)

Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only. Optional activities are designed to enhance understanding and/or to provide additional practice.

Topology

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
Gateway G0/1 192.168.1.1 255.255.255.0 N/A
S0/0/1 209.165.200.225 255.255.255.252 N/A
ISP S0/0/0 (DCE) 209.165.200.226 255.255.255.252 N/A
Lo0 198.133.219.1 255.255.255.255 N/A
PC-A NIC 192.168.1.3 255.255.255.0 192.168.1.1
PC-B NIC 192.168.1.4 255.255.255.0 192.168.1.1

Objectives

Part 1: Build the Network and Configure Basic Device Settings
Part 2: Troubleshoot Static NAT
Part 3: Troubleshoot Dynamic NAT

Background / Scenario

In this lab, the Gateway router was configured by an inexperienced network administrator at your company. Several errors in the configuration have resulted in NAT issues. Your boss has asked you to troubleshoot and correct the NAT errors and document your work. Ensure that the network supports the following:

  • PC-A acts as a web server with a static NAT and will be reachable from the outside using the 209.165.200.254 address.
  • PC-B acts as a host computer and dynamically receives an IP address from the created pool of addresses called NAT_POOL, which uses the 209.165.200.240/29 range.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other routers, switches and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Make sure that the routers and switch have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 2 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • 1 Switch (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
  • 2 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and serial cables as shown in the topology

Part 1: Build the Network and Configure Basic Device Settings

In Part 1, you will set up the network topology and configure the routers with basic settings. Additional NAT-related configurations are provided. The NAT configurations for the Gateway router contains errors that you will identify and correct as you proceed through the lab.

Step 1: Cable the network as shown in the topology.

Step 2: Configure PC hosts.

Step 3: Initialize and reload the switch and routers.

Step 4: Configure basic settings for each router.

a. Console into the router and enter global configuration mode.

b. Copy the following basic configuration and paste it to the running-configuration on the router.

no ip domain-lookup
service password-encryption
enable secret class
banner motd #
Unauthorized access is strictly prohibited. #
line con 0
password cisco
login
logging synchronous
line vty 0 4
password cisco
login

c. Configure the host name as shown in the topology.

d. Copy the running configuration to the startup configuration.

Step 5: Configure static routing.

a. Create a static route from the ISP router to the Gateway router which was assigned public network address range 209.165.200.224/27.

ISP(config)# ip route 209.165.200.224 255.255.255.224 s0/0/0

b. Create a default route from the Gateway router to the ISP router.

Gateway(config)# ip route 0.0.0.0 0.0.0.0 s0/0/1

Step 6: Load router configurations.

The configurations for the routers are provided for you. There are errors with the configuration for the Gateway router. Identify and correct the configurations errors.

Gateway Router Configuration

interface g0/1
ip nat outside
! ip nat inside
no shutdown
interface s0/0/0
ip nat outside
! no ip nat outside
interface s0/0/1
! ip nat outside
no shutdown
ip nat inside source static 192.168.2.3 209.165.200.254
! ip nat inside source static 192.168.1.3 209.165.200.254
ip nat pool NAT_POOL 209.165.200.241 209.165.200.246 netmask 255.255.255.248
ip nat inside source list NAT_ACL pool NATPOOL
! ip nat inside source list NAT_ACL pool NAT_POOL
ip access-list standard NAT_ACL
permit 192.168.10.0 0.0.0.255
! permit 192.168.1.0 0.0.0.255
banner motd $AUTHORIZED ACCESS ONLY$
end

Step 7: Save the running configuration to the startup configuration.

Part 2: Troubleshoot Static NAT

In Part 2, you will examine the static NAT for PC-A to determine if it is configured correctly. You will troubleshoot the scenario until the correct static NAT is verified.

a. To troubleshoot issues with NAT, use the debug ip nat command. Turn on NAT debugging to see translations in real-time across the Gateway router.

Gateway# debug ip nat

b. From PC-A, ping Lo0 on the ISP router. Do any NAT debug translations appear on the Gateway router?
____________________________________________________
No.

c. On the Gateway router, enter the command that allows you to see all current NAT translations on the Gateway router. Write the command in the space below.
____________________________________________________
show ip nat translations

Gateway# show ip nat translations
Pro Inside global     Inside local    Outside local    Outside global
--- 209.165.200.254   192.168.2.3     ---              ---

Why are you seeing a NAT translation in the table, but none occurred when PC-A pinged the ISP loopback interface? What is needed to correct the issue?
_____________________________________________________
The static translation is for an incorrect inside local address.

d. Record any commands that are necessary to correct the static NAT configuration error.
_____________________________________________________

Gateway(config)# no ip nat inside source static 192.168.2.3 209.165.200.254
Gateway(config)# ip nat inside source static 192.168.1.3 209.165.200.254

e. From PC-A, ping Lo0 on the ISP router. Do any NAT debug translations appear on the Gateway router?
_____________________________________________________
No

f. On the Gateway router, enter the command that allows you to observe the total number of current NATs. Write the command in the space below.
_____________________________________________________
show ip nat statistics

Gateway# show ip nat statistics
Total active translations: 1 (1 static, 0 dynamic; 0 extended)
Peak translations: 1, occurred 00:08:12 ago
Outside interfaces:
  GigabitEthernet0/1, Serial0/0/0
Inside interfaces:
Hits: 0 Misses: 0
CEF Translated packets: 0, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
-- Inside Source
[Id: 1] access-list NAT_ACL pool NATPOOL refcount 0

Total doors: 0
Appl doors: 0
Normal doors: 0
Queued Packets: 0

Is the static NAT occurring successfully? Why?
_____________________________________________________
No NAT translation is occurring because both of G0/1 and S0/0/0 interfaces are configured with the ip nat outside command. No active interfaces area assigned as inside.

g. On the Gateway router, enter the command that allows you to view the current configuration of the router. Write the command in the space below.
______________________________________________________
show running-config

Gateway# show running-config
Building configuration...
Current configuration : 1806 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Gateway
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
redundancy
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
ip nat outside
ip virtual-reassembly in
shutdown
clock rate 2000000
!
interface Serial0/0/1
ip address 209.165.200.225 255.255.255.252
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat pool NAT_POOL 209.165.200.241 209.165.200.246 netmask 255.255.255.248
ip nat inside source list NAT_ACL pool NATPOOL
ip nat inside source static 192.168.1.3 209.165.200.254
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
!
ip access-list standard NAT_ACL
permit 192.168.10.0 0.0.0.255
!
!
!
!
control-plane
!
!
banner motd ^CAUTHORIZED ACCESS ONLY^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
end

h. Are there any problems with the current configuration that prevent the static NAT from occurring?
_____________________________________________________
Yes. The inside and outside NAT interfaces are incorrectly configured.

i. Record any commands that are necessary to correct the static NAT configuration errors.
_____________________________________________________

Gateway(config)# interface g0/1
Gateway(config-if)# no ip nat outside
Gateway(config-if)# ip nat inside
Gateway(config-if)# exit
Gateway(config)# interface s0/0/0
Gateway(config-if)# no ip nat outside
Gateway(config-if)# exit
Gateway(config)# interface s0/0/1
Gateway(config-if)# ip nat outside
Gateway(config-if)# exit

j. From PC-A, ping Lo0 on the ISP router. Do any NAT debug translations appear on the Gateway router?
______________________________________________________
Yes

*Mar 18 23:53:50.707: NAT*: s=192.168.1.3->209.165.200.254, d=198.133.219.1 [187]
*Mar 18 23:53:50.715: NAT*: s=198.133.219.1, d=209.165.200.254->192.168.1.3 [187]
Gateway#
*Mar 18 23:53:51.711: NAT*: s=192.168.1.3->209.165.200.254, d=198.133.219.1 [188]
*Mar 18 23:53:51.719: NAT*: s=198.133.219.1, d=209.165.200.254->192.168.1.3 [188]
*Mar 18 23:53:52.707: NAT*: s=192.168.1.3->209.165.200.254, d=198.133.219.1 [189]
Gateway#
*Mar 18 23:53:52.715: NAT*: s=198.133.219.1, d=209.165.200.254->192.168.1.3 [189]
*Mar 18 23:53:53.707: NAT*: s=192.168.1.3->209.165.200.254, d=198.133.219.1 [190]
Gateway#
*Mar 18 23:53:53.715: NAT*: s=198.133.219.1, d=209.165.200.254->192.168.1.3 [190]

k. Use the show ip nat translations verbose command to verify static NAT functionality.

Note: The timeout value for ICMP is very short. If you do not see all the translations in the output, redo the ping.

Gateway# show ip nat translations verbose
Pro Inside global        Inside local      Outside local      Outside global
icmp 209.165.200.254:1   192.168.1.3:1     198.133.219.1:1    198.133.219.1:1
   create 00:00:04, use 00:00:01 timeout:60000, left 00:00:58,
   flags:
extended, use_count: 0, entry-id: 12, lc_entries: 0
--- 209.165.200.254     192.168.1.3      ---            ---
   create 00:30:09, use 00:00:04 timeout:0,
   flags:
static, use_count: 1, entry-id: 2, lc_entries: 0

Is the static NAT translation occurring successfully? _______________Yes

If static NAT is not occurring, repeat the steps above to troubleshoot the configuration.

Part 3: Troubleshoot Dynamic NAT

a. From PC-B, ping Lo0 on the ISP router. Do any NAT debug translations appear on the Gateway router?
___________No

b. On the Gateway router, enter the command that allows you to view the current configuration of the router. Are there any problems with the current configuration that prevent dynamic NAT from occurring?
__________________________________________________
Yes. The NAT pool is incorrectly identified in the source statement. The NAT access list has an incorrect network statement.

c. Record any commands that are necessary to correct the dynamic NAT configuration errors.
___________________________________________________

Gateway(config)# no ip nat inside source list NAT_ACL pool NATPOOL
Gateway(config)# ip nat inside source list NAT_ACL pool NAT_POOL
Gateway(config)# ip access-list standard NAT_ACL
Gateway(config-std-nacl)# no permit 192.168.10.0 0.0.0.255
Gateway(config-std-nacl)# permit 192.168.1.0 0.0.0.255

d. From PC-B, ping Lo0 on the ISP router. Do any NAT debug translations appear on the Gateway router?
___________________________________________________
Yes

*Mar 19 00:01:17.303: NAT*: s=192.168.1.4->209.165.200.241, d=198.133.219.1 [198]
*Mar 19 00:01:17.315: NAT*: s=198.133.219.1, d=209.165.200.241->192.168.1.4 [198]
Gateway#
*Mar 19 00:01:18.307: NAT*: s=192.168.1.4->209.165.200.241, d=198.133.219.1 [199]
*Mar 19 00:01:18.315: NAT*: s=198.133.219.1, d=209.165.200.241->192.168.1.4 [199]
*Mar 19 00:01:19.303: NAT*: s=192.168.1.4->209.165.200.241, d=198.133.219.1 [200]
Gateway#
*Mar 19 00:01:19.315: NAT*: s=198.133.219.1, d=209.165.200.241->192.168.1.4 [200]
*Mar 19 00:01:20.303: NAT*: s=192.168.1.4->209.165.200.241, d=198.133.219.1 [201]
*Mar 19 00:01:20.311: NAT*: s=198.133.219.1, d=209.165.200.241->192.168.1.4 [201]

e. Use the show ip nat statistics to view NAT usage.

Gateway# show ip nat statistics
Total active translations: 2 (1 static, 1 dynamic; 0 extended)
Peak translations: 3, occurred 00:02:58 ago
Outside interfaces:
  Serial0/0/1
Inside interfaces:
  GigabitEthernet0/1
Hits: 24 Misses: 0
CEF Translated packets: 24, CEF Punted packets: 0
Expired translations: 3
Dynamic mappings:
-- Inside Source
[Id: 2] access-list NAT_ACL pool NAT_POOL refcount 1
 pool NAT_POOL: netmask 255.255.255.248
       start 209.165.200.241 end 209.165.200.246
       type generic, total addresses 6, allocated 1 (16%), misses 0

Total doors: 0
Appl doors: 0
Normal doors: 0
Queued Packets: 0

Is the NAT occurring successfully? ___________Yes

What percentage of dynamic addresses has been allocated? ________16%

f. Turn off all debugging using the undebug all command.

Reflection

1. What is the benefit of a static NAT?
____________________________________________________
A static NAT translation allows users from outside the LAN to access a computer or server on the internal network.

2. What issues would arise if 10 host computers in this network were attempting simultaneous Internet communication?
_____________________________________________________
Not enough public addresses exist in the NAT pool to satisfy 10 simultaneous user sessions. As hosts drop off, different hosts will be able to claim the pool addresses to access the Internet.

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Config

Router Gateway

Gateway#show run
Building configuration...
Current configuration : 1805 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Gateway
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
!
interface Serial0/0/1
ip address 209.165.200.225 255.255.255.252
ip nat outside
ip virtual-reassembly in
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat pool NAT_POOL 209.165.200.241 209.165.200.246 netmask 255.255.255.248
ip nat inside source list NAT_ACL pool NAT_POOL
ip nat inside source static 192.168.1.3 209.165.200.254
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
!
ip access-list standard NAT_ACL
permit 192.168.1.0 0.0.0.255
!
control-plane
!
banner motd ^CAUTHORIZED ACCESS ONLY^C
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router ISP

ISP#show run
Building configuration...
Current configuration : 1482 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
!
no ipv6 cef
multilink bundle-name authenticated
!
interface Loopback0
ip address 198.133.219.1 255.255.255.255
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 209.165.200.226 255.255.255.252
clock rate 128000
!
interface Serial0/0/1
no ip address
shutdown
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 209.165.200.224 255.255.255.224 Serial0/0/0
!
control-plane
!
line con 0
password cisco
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input all
line vty 5 15
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
end

 


guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x