Show run Command on CISCO Router/Switch

Command

Show Running-Config

Use

Shows the current configuration of a device. This is one of the first commands you will enter when trying to understand how a device is configured.

Syntax

Router#show running-config

Example

In this example we display the running configuration of R2.

R2#show run
Building configuration…

Current configuration : 1036 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.2.2.2 255.255.255.0
duplex auto
speed auto
!
ip http server
no ip http secure-server
ip route 1.1.1.1 255.255.255.255 10.1.1.1
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
alias exec sr show ip route
alias exec s show ip int br
alias exec ss show ip int br | ex unass
alias exec sc show cdp ne
alias exec son show ip ospf ne
alias exec sbs show ip bgp sum
alias exec sib show ip bgp
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
line vty 0 4
password cisco
login
transport input telnet ssh
!
!
end

Related Articles

Leave a Reply

avatar