9.6.3 Lab – EIGRP Troubleshooting Answers

9.6.3 Lab – EIGRP Troubleshooting Answers

Topology

9.6.3 Lab - EIGRP Troubleshooting Answers 3

9.6.3 Lab - EIGRP Troubleshooting Answers 4

Device Interface IP Address Subnet Mask Default Gateway
HQ Fa0/0 172.18.64.1 255.255.192.0 N/A
S0/0/0 209.165.202.129 255.255.255.252 N/A
S0/0/1 209.165.202.133 255.255.255.252 N/A
BRANCH1 Fa0/0 172.18.129.1 255.255.255.240 N/A
S0/0/0 209.165.202.130 255.255.255.252 N/A
S0/0/1 209.165.202.137 255.255.255.252 N/A
BRANCH2 Fa0/0 172.18.128.1 255.255.255.0 N/A
S0/0/0 209.165.202.138 255.255.255.252 N/A
S0/0/1 209.165.202.134 255.255.255.252 N/A
PC1 NIC 172.18.129.14 172.18.129.1 255.255.255.240
PC2 NIC 172.18.100.100 172.18.64.1 255.255.192.0
PC3 NIC 172.18.128.10 172.18.128.1 255.255.255.0

Learning Objectives:

  • Discover where communication is not possible.
  • Gather information about the misconfigured portion of the network along with any other errors.
  • Analyze information to determine why communication is not possible.
  • Propose solutions to network errors.
  • Implement solutions to network errors.

Instructions:

In this lab, you will begin by loading configuration scripts on each of the routers. These scripts contain errors that will prevent end-to-end communication across the network. You will need to troubleshoot each router to determine the configuration errors, and then use the appropriate commands to correct the configurations. When you have corrected all of the configuration errors, all of the hosts on the network should be able to communicate with each other. The network should also have the following requirements met:

  • EIGRP routing is configured on the BRANCH1 router.
  • EIGRP routing is configured on the BRANCH2 router.
  • EIGRP routing is configured on the HQ router.
  • EIGRP updates must be disabled on the BRANCH1, BRANCH2, and HQ LAN interfaces.
  • All EIGRP routers must use an autonomous system number of 1.

Task 1: Connect, remove and reload routers.

Step 1: Connect a network.

Connect a network that is similar to the one in the Topology Diagram.

Step 2: Delete the configuration on each router.

Erase the configuration of each of the routers using the erase startup-config command and then reload to reload the routers. If you are asked if you want to save the changes, answer no.

Task 2: Load the routers with the provided scripts.

Step 1: Load the following script on the BRANCH1 router:

[Instructor Note: Missing or misconfigured commands are displayed in red]

hostname BRANCH1
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.18.129.1 255.255.255.240
 duplex auto
speed auto
! the no shutdown command is missing
!
interface Serial0/0/0
ip address 209.165.202.130 255.255.255.252
clock rate 64000
no shutdown
!
interface Serial0/0/1
ip address 209.165.202.137 255.255.255.252
no shutdown
!
router eigrp 2
!The AS number should be 1
passive-interface FastEthernet0/0
network 209.165.202.128 0.0.0.3
network 209.165.202.136 0.0.0.3
network 172.18.129.0 0.0.0.7
!The 172.18.129.0 network mask should be 0.0.0.15
no auto-summary
!
ip classless
!
line con 0
line vty 0 4
login
!
end

Corrected script:

hostname BRANCH1
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.18.129.1 255.255.255.240
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 209.165.202.130 255.255.255.252
clock rate 64000
no shutdown
!
interface Serial0/0/1
ip address 209.165.202.137 255.255.255.252
no shutdown
!
router eigrp 1
passive-interface FastEthernet0/0
network 209.165.202.128 0.0.0.3
network 172.18.129.0 0.0.0.15
network 209.165.202.136 0.0.0.3
no auto-summary
! 
ip classless
!
line con 0
line vty 0 4
login
!
end!
!
end

The errors in the students’ scripts are the following:

  • The no shutdown command is missing on the FastEthernet0/0 interface.
  • EIGRP AS number is incorrect
  • The netmask for network 172.18.129.0/28 is incorrect.

Step 2: Load the following script on the BRANCH2 router:

hostname BRANCH2
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.18.128.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 209.165.202.138 255.255.255.252
clock rate 64000
no shutdown
!
interface Serial0/0/1
ip address 209.165.202.134 255.255.255.252
no shutdown
!
router eigrp 1
passive-interface FastEthernet0/0
network 172.18.128.0 0.0.0.255
network 209.165.202.132 0.0.0.3
network 209.165.202.136 0.0.0.3
!The no auto-summary command is missing
!
ip classless
!
line con 0
line vty 0 4
login
!
end

Corrected script:

hostname BRANCH2
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.18.128.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 209.165.202.138 255.255.255.252
clock rate 64000
no shutdown
!
interface Serial0/0/1
ip address 209.165.202.134 255.255.255.252
no shutdown
!
router eigrp 1
passive-interface FastEthernet0/0
network 172.18.128.0 0.0.0.255
network 209.165.202.132 0.0.0.3
network 209.165.202.136 0.0.0.3
no auto-summary
!
ip classless
!
line con 0
line vty 0 4
login
!
end

The errors in the students’ scripts are the following:

  • The no auto-summary command is missing from the EIGRP configuration.

Step 3: Upload the following script to the HQ router:

hostname HQ
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.18.64.1 255.255.192.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 209.165.202.129 255.255.255.252
no shutdown
!
interface Serial0/0/1
ip address 209.165.202.133 255.255.255.252
clock rate 64000
no shutdown
!
router eigrp 1
passive-interface Serial0/0/0
!The passive-interface command should use FastEthernet0/0
network 172.18.64.0
!The mask 0.0.63.255 is missing
!from the network statement for 172.18.64.0
network 209.165.202.128 0.0.0.3
network 209.165.202.132 0.0.0.3
no auto-summary
!
ip classless
!
line con 0
line vty 0 4
login
!
end

Corrected script

hostname HQ
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.18.64.1 255.255.192.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 209.165.202.129 255.255.255.252
no shutdown
!
interface Serial0/0/1
 ip address 209.165.202.133 255.255.255.252
clock rate 64000
no shutdown
!
router eigrp 1
passive-interface FastEthernet0/0
network 172.18.64.0 0.0.63.255
network 209.165.202.128 0.0.0.3
network 209.165.202.132 0.0.0.3
no auto-summary
!
ip classless
!
line con 0
line vty 0 4
login
!
end

The errors in the students’ scripts are the following:

  • The passive-interface command is configured for the wrong interface.
  • Mask 0.0.63.255 is missing from the network statement for network 172.18.64.0/18.

Task 3: Troubleshoot the BRANCH1 router.

Step 1: Begin troubleshooting on the host connected to the BRANCH1 router.

Is it possible to ping from host PC1 to PC2? _No

Is it possible to ping from host PC1 to PC3? _No

Is it possible to ping from host PC1 to the default gateway?_No

Step 2: Check the BRANCH1 router for possible configuration errors.

Start by reviewing the summary status information for each router interface.

Is there a problem with the configuration of the interfaces?
Yes, the FastEthernet0/0 interface is administratively down.

If there are problems with the configuration of the interfaces, record all the commands that you will need to correct the configuration errors.

configure terminal
interface FastEthernet0/0
no shutdown

Step 3: If any of the previous commands have been registered, apply them now to the router configuration.

Step 4: View the status information summary.

If configuration changes were made in the previous step, view the router interfaces status information summary again.

Does the status summary interface information indicate any configuration errors on router BRANCH1? _No

If yes, troubleshoot the status of the interfaces again.

Step 5: Troubleshoot routing configuration on the BRANCH1 router:

What routes are shown in the routing table?
172.18.129.0 is connected directly
209.165.202.128 is connected directly
209.165.202.136 is connected directly

Is there a problem with the routing table or EIGRP configuration?
Yes, there are no EIGRP routes in the routing table. The EIGRP process ID is incorrect.
The netmask 172.18.129.0 is incorrect. It should be 0.0.0.15.

If there are problems with the EIGRP configuration, record all the commands you will need to correct the configuration errors.

no router eigrp 2
router eigrp 1
passive-interface FastEthernet0/0
network 209.165.202.128 0.0.0.3
network 209.165.202.136 0.0.0.3
network 172.18.129.0 0.0.0.15
no auto-summary

Are there any connectivity problems that could be caused by errors in other parts of the network?
No

What connected networks are shown in the EIGRP topology table on router BRANCH1?172.18.129.0/28
209.165.202.128/30
209.165.202.136/30

Is there a problem with the connected networks in the EIGRP topology table?
No

Step 6: If any of the previous commands have been registered, apply them now to the router configuration.

Step 7: View routing information.

If any configuration changes are made in the previous steps, view the routing information again.

Does the routing table information indicate any configuration errors on router BRANCH1?
_No

Does the EIGRP topology information indicate any configuration errors on router BRANCH1?
_No

If the answer to any of these questions is yes, troubleshoot your routing configuration again.

What routes are shown in the routing table?
172.18.64.0/18 via 209.165.202.129
172.18.129.0/28 is directly connected
209.165.202.128 is directly connected
209.165.202.132 via 209.165.202.129

Step 8: Try to ping between the hosts again.

Is it possible to ping from host PC1 to PC2? _No

Is it possible to ping from host PC1 to PC3? _No

From host PC1, is it possible to ping the serial interface 0/0/0 of the HQ router? _Yes

From host PC1, is it possible to ping serial interface 0/0/1 of router HQ? _Yes

Task 4: Troubleshoot the HQ router

Step 1: Begin troubleshooting on host PC2.

Is it possible to ping from host PC2 to PC1? _No

Is it possible to ping from host PC2 to PC3? _Yes

Is it possible to ping from host PC2 to the default gateway? _Yes

Step 2: Check the HQ router for possible configuration errors.

Start by reviewing the summary status information for each router interface.

Is there a problem with the configuration of the interfaces?

Start by reviewing the summary status information for each router interface.

Is there a problem with the configuration of the interfaces?
No

If there are problems with the configuration of the interfaces, record all the commands that you will need to correct the configuration errors.

Step 3: If any of the previous commands have been registered, apply them now to the router configuration.

Step 4: View the status information summary.

If configuration changes were made in the previous step, view the router interfaces status information summary again.

Does the status summary interface information indicate any configuration errors on the HQ router? _No

If yes, troubleshoot the status of the interfaces again.

Step 5: Troubleshoot routing configuration on the HQ router.

What routes are shown in the routing table?

172.18.0.0/16 is a summary
172.18.64.0/18 is directly connected
209.165.202.0/24 is a summary
209.165.202.128/30 is directly connected
209.165.202.132/30 is directly connected
209.165.202.136 via 209.165.202.134

Is there a problem with the routing table or EIGRP configuration?

Network 172.18.128.0/24 is missing from the routing table.
The network summary route 172.18.0.0/16 is only received by the BRANCH2 router.
The mask is missing from the network statement for network 172.16.64.0/18.
The passive-interface command is configured for the wrong interface.

If there are problems with the EIGRP configuration, record all the commands you will need to correct the configuration errors.

router eigrp 1
no network 172.18.64.0
network 172.18.64.0 0.0.63.255
no passive-interface serial0/0
passive-interface FastEthernet0/0

Are there any connectivity problems that could be caused by errors in other parts of the network? _No

What connected networks are shown in the HQ router’s EIGRP topology table?
172.18.0.0/16
172.18.64.0/18
209.165.202.128/30
209.165.202.132/30
209.165.202.136/30

Is there a problem with the connected networks in the EIGRP topology table? No

Step 6: If any of the previous commands have been registered, apply them now to the router configuration.

Step 7: View routing information.

If any configuration changes are made in the previous steps, view the routing information again.

Does the information in the routing table indicate any configuration errors on the HQ router?
_No

Does the EIGRP topology information indicate any configuration errors on the HQ router? _No

If the answer to any of these questions is yes, troubleshoot your routing configuration again.

Step 8: Try to ping between the hosts again.

Is it possible to ping from host PC2 to PC1? _No

Is it possible to ping from host PC2 to PC3? _Yes

From host PC2, is it possible to ping the serial interface 0/0/0 of the BRANCH2 router? _Yes

From host PC2, is it possible to ping serial interface 0/0/1 of router BRANCH2? _Yes

Task 5: Troubleshoot the BRANCH2 router

Step 1: Begin troubleshooting on host PC3.

Is it possible to ping from host PC3 to PC1? _No

Is it possible to ping from host PC3 to PC2? _Yes

Is it possible to ping from host PC3 to the default gateway? _Yes

Step 2: Check the BRANCH2 router for possible configuration errors.

Is there a problem with the configuration of the interfaces?
No

If there are problems with the configuration of the interfaces, record all the commands that you will need to correct the configuration errors.
none

Step 3: If any of the previous commands have been registered, apply them now to the router configuration.

Step 4: View the status information summary.

If configuration changes were made in the previous step, view the router interfaces status information summary again.

Does the status summary interface information indicate any configuration errors on the BRANCH2 router? _No

If yes, troubleshoot the status of the interfaces again.

Step 5: Troubleshoot routing configuration on the BRANCH2 router.

What routes are shown in the routing table?

172.18.0.0/16 is a summary
172.18.64.0/18 via 209.165.202.133
172.18.128.0/24 is directly connected
172.18.129.0/28 via 209.165.202.137
209.165.202.0/24 is a summary
209.165.202.128/30 via 209.165.202.133
via 209.165.202.137
209.165.202.132/30 is directly connected
209.165.202.136/30 is directly connected

Is there a problem with the routing table or EIGRP configuration?
The no auto-summary command is missing.

If there are problems with the EIGRP configuration, record all the commands you will need to correct the configuration errors.

router eigrp 1
no auto-summary

Are there any connectivity problems that could be caused by errors in other parts of the network?
No

What connected networks are shown in the BRANCH2 router’s EIGRP topology table?
172.18.128.0/24
209.165.202.132/30
209.165.202.136/30

Is there a problem with the connected networks in the EIGRP topology table?
No

Step 6: If any of the previous commands have been registered, apply them now to the router configuration.

Step 7: View routing information.

If any configuration changes are made in the previous steps, view the routing information again.

Does the routing table information indicate any configuration errors on the BRANCH2 router? _No

Does the EIGRP topology information indicate any configuration errors on the BRANCH2 router? _No

If the answer to any of these questions is yes, troubleshoot your routing configuration again.

What routes are shown in the routing table?
172.18.0.0/16 is a summary
172.18.64.0/18 via 209.165.202.133
172.18.128.0/24 is directly connected
172.18.129.0/28 via 209.165.202.137
209.165.202.0/24 is a summary
209.165.202.128/30 via 209.165.202.133
via 209.165.202.137
209.165.202.132/30 is directly connected
209.165.202.136/30 is directly connected

Step 8: Try to ping between the hosts again.

Is it possible to ping from host PC3 to PC1? _Yes

Is it possible to ping from host PC3 to PC2? _Yes

From host PC3, is it possible to ping serial interface 0/0/0 of router BRANCH1?_Yes

From host PC3, is it possible to ping serial interface 0/0/1 of router BRANCH1? _Yes

Task 6: Reflection

There were some configuration errors in the scripts that were prepared for this lab. Use the space below to briefly describe the errors you found.

Task 7: Documentation

On each router, capture the following command output to a text file (.txt) for future reference.

• show running-config
• show ip route
• show ip interface brief
• show ip protocols

If you need to review the procedures for capturing command output, see Lab 1.5.1.

Task 8: Cleaning

Clear the configurations and reload the routers. Disconnect and store the cables. For host PCs that are typically connected to other networks (such as the school LAN or the Internet), reconnect the appropriate cables and reset the TCP/IP settings.

Download Packet Tracer (.pka) file:

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments