7.5.1 Lab – RIPv2 Basic Configuration Answers

7.5.1 Lab – RIPv2 Basic Configuration Answers

Topology

7.5.1 Lab - RIPv2 Basic Configuration Answers 2

Learning Objectives:

  • Cable a network according to the topology diagram.
  • Load provided scripts onto the routers.
  • Examine the current status of the network.
  • Configure RIPv2 on all routers.
  • Examine the automatic summarization of routes.
  • Examine routing updates with debug ip rip.
  • Disable automatic summarization.
  • Examine the routing tables.
  • Verify network connectivity.
  • Document the RIPv2 configuration.

Scenario:

This activity uses a topology with a discontiguous network, 172.30.0.0. This network has been subnetted using VLSM. The 172.30.0.0 subnets are physically and logically divided by at least one other classful or major network, in this case the two serial networks 209.165.200.228/30 and 209.165.200.232/30. This can be an issue when the routing protocol used does not include enough information to distinguish the individual subnets. RIPv2 is a classless routing protocol that can be used to provide subnet mask information in the routing updates. This will allow VLSM subnet information to be propagated throughout the network.

Task 1: Cable the network.

Step 1 Cable the network using the chart and the existing devices in the activity.

Task 2: Load the routers with the supplied scripts.

Step 1 Load the following script onto R1.

!
hostname R1
!
!
!
interface FastEthernet0/0
ip address 172.30.1.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface FastEthernet0/1
ip address 172.30.2.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 209.165.200.230 255.255.255.252
clock rate 64000
no shutdown
!
router rip
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 172.30.0.0
network 209.165.200.0
!
line con 0
line vty 0 4
login
!
end

Step 2 Load the following script onto R2.

!
hostname R2
!
!
!
interface FastEthernet0/0
ip address 10.1.0.1 255.255.0.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 209.165.200.229 255.255.255.252
no shutdown
!
interface Serial0/0/1
ip address 209.165.200.233 255.255.255.252
clock rate 64000
no shutdown
!
router rip
passive-interface FastEthernet0/0
network 10.0.0.0
network 209.165.200.0
!
line con 0
line vty 0 4
login
!
end

Step 3 Load the following script onto R3.

!
hostname R3
!
!
!
interface FastEthernet0/0
ip address 172.30.100.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/1
ip address 209.165.200.234 255.255.255.252
no shutdown
!
interface Loopback0
ip address 172.30.110.1 255.255.255.0
!
interface Loopback1
ip address 172.30.200.17 255.255.255.240
!
interface Loopback2
ip address 172.30.200.33 255.255.255.240
!
router rip
passive-interface FastEthernet0/0
network 172.30.0.0
network 209.165.200.0
!
line con 0
line vty 0 4
login
!
end

Task 3: Examine the current status of the network.

The status of the two serial links can quickly be verified using the show ip interface brief command on R2. Both serial interfaces should show Status as up and Protocol as up.

Step 2- Check the connectivity from R2 to the hosts on the R1 and R3 LANs.

From the R2 router, how many ICMP messages are successful when pinging PC1?
From the R2 router, how many ICMP messages are successful when pinging PC4?

Step 3 Check the connectivity between the PCs.

From PC1, is it possible to ping PC2? What is the success rate?
From PC1, is it possible to ping PC3? What is the success rate?
From PC1, is it possible to ping PC4? What is the success rate?
From PC4, is it possible to ping PC2? What is the success rate?
From PC4, is it possible to ping PC3? What is the success rate?

Step 4- View the routing table on R2.

Use the show ip route command to view the routing table on R2. Both the R1 and R3 are advertising routes to the 172.30.0.0/16 network; therefore, there are two entries for this network in the R2 routing table. The R2 routing table only shows the major classful network address of 172.30.0.0—it does not show any of the subnets for this network that are used on the LANs attached to R1 and R3. Because the routing metric is the same for both entries, the router alternates the routes that are used when forwarding packets that are destined for the 172.30.0.0/16 network.

Step 5- Examine the routing table on R1.

Use the show ip route command to view the routing table on R1. Both R1 and R3 are configured with interfaces on a discontiguous network, 172.30.0.0. The 172.30.0.0 subnets are physically and logically divided by at least one other classful or major network—in this case, the two serial networks 209.165.200.228/32 and 209.165.200.232/30. Classful routing protocols like RIPv1 summarize networks at major network boundaries. Both R1 and R3 will be summarizing 172.30.0.0 subnets to 172.30.0.0. Because the route to 172.30.0.0/16 is directly connected, and because R1 does not have any specific routes for the 172.30.0.0 subnets on R3, packets destined for the R3 LANs will not be forwarded properly.

Step 6- Examine the routing table on R3.

Use the show ip route command to view the routing table on R3. R3 only shows its own subnets for 172.30.0.0 network: 172.30.100/24, 172.30.110/24, 172.30.200.16/28, and 172.30.200.32/28. R3 does not have any routes for the 172.30.0.0 subnets on R1.

Step 7-Examine the RIPv1 packets that are being received by R2.

Use the debug ip rip command to display RIP routing updates. R2 is receiving the route 172.30.0.0, with 1 hop, from both R1 and R3. Because these are equal cost metrics, both routes are added to the R2 routing table. Because RIPv1 is a classful routing protocol, no subnet mask information is sent in the update.

When you are finished, disable the debugging:

R2#undebug all
Task 4: Configure RIP Version 2.
Step 1 Use the version 2 command to enable RIP version 2 on each router.
R2(config)#router rip
R2(config-router)#version 2

R1(config)#router rip
R1(config-router)#version 2

R3(config)#router rip
R3(config-router)#version 2

RIPv2 messages include the subnet mask in a field in the routing updates. This allows subnets and their masks to be included in the routing updates. However, by default RIPv2 summarizes networks at major network boundaries, just like RIPv1, except that the subnet mask is included in the update.

Step 8 Verify that RIPv2 is running on the routers.

The debug ip rip, show ip protocols, and show run commands can all be used to confirm that RIPv2 is running.

Task 4: Examine the Automatic Summarization of Routes.

Step 1 Use the version 2 command to enable RIP version 2 on each router.

Use the show ip route command on each router. The LANs connected to R1 and R3 are still composed of discontiguous networks. R2 still shows two equal cost paths to the 172.30.0.0/16 network in the routing table. R2 still shows only the major classful network address of 172.30.0.0 and does not show any of the subnets for this network.

Use the output of the debug ip rip command to answer the following questions:

What entries are included in the RIP updates sent out from R3?
On R2, what routes are in the RIP updates that are received from R3?
R3 is not sending any of the 172.30.0.0 subnets—only the summarized route of 172.30.0.0/16, including the subnet mask. This is why R2 and R1 are not seeing the 172.30.0.0 subnets on R3.

Task 5: Disable Automatic Summarization.

The no auto-summary command is used to turn off automatic summarization in RIPv2. Disable auto summarization on all routers. The routers will no longer summarize routes at major network boundaries.

R2(config)#router rip
R2(config-router)#no auto-summary

R1(config)#router rip
R1(config-router)#no auto-summary

R3(config)#router rip
R3(config-router)#no auto-summary

Task 6: Examine the routing tables.

Use the show ip route commands on all three routers to view the routing tables. The LANs connected to R1 and R3 should now be included in all three routing tables.

Use the output of the debug ip rip command to answer the following questions:

What entries are included in the RIP updates sent out from R1?
On R2, what routes are in the RIP updates that are received from R1?
Are the subnet masks now included in the routing updates?

Task 7: Verify network connectivity.

Step 1 Check connectivity between R2 router and PCs.

From R2, how many ICMP messages are successful when pinging PC1?
From R2, how many ICMP messages are successful when pinging PC4?

Step 2 Check the connectivity between the PCs.

From PC1, is it possible to ping PC2? What is the success rate?
From PC1, is it possible to ping PC3? What is the success rate?
From PC1, is it possible to ping PC4? What is the success rate?
From PC4, is it possible to ping PC2? What is the success rate?
From PC4, is it possible to ping PC3? What is the success rate?

Download Packet Tracer (.pka) file:

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x