CCNA 200-125 Exam: RIP Questions With Answers

  1. How to configure RIPv2? (Choose two)
    • A. Enable RIP*
    • B. Connect RIP to WAN interface
    • C. Enable auto-summary*
    • D. Enable authentication

    Show (Hide) Explanation/Reference
    “Enable RIP” is surely correct to configure RIPv2 but “enable auto-summary” is not recommended. Maybe there is another suitable option for this question (like “use ‘version 2’ command” or “Allowing Unicast Updates for RIP”).
  2. Which two options are requirements for configuring RIPv2 for IPv4 (Choose two)?
    • A. enabling RIP authentication
    • B. connecting RIP to a WAN Interface
    • C. enabling auto route summarization
    • D. allowing unicast updates for RIP*
    • E. enabling RIP on the router*

    Show (Hide) Explanation/Reference
    To enable RIP surely we have to enable it first (with the “router rip” command in global configuration mode) -> E is correct.

    RIPv2 sends its updates via multicast but in Nonbroadcast Multiple Access (NBMA) environment, multicast is not allowed so we have to use unicast to send RIPv2 updates -> D is correct.

  3. What does split-horizon do?
    • A. Prevent routing loop in distance vector protocol*
    • B. Prevent switching loop in distance vector protocol
    • C. Prevent switching loop in link-state protocol
    • D. Prevent routing loop in link-state protocol

    Show (Hide) Explanation/Reference
    The split-horizon rule states that “a router never sends information about a route back in same direction which is original information came”. This rule is used in distance vector protocol (like RIP or EIGRP) to prevent Layer 3 routing loop.
  4. Which effect of the passive-interface command on R1 is true?
    R1
    interface FastEthernet0/0
    description site id:14254489 
    ip address 172.16.0.1 255.255.0.0
    
    interface FastEthernet0/1 
    description site id:14254489 
    ip address 172.17.0.1 255.255.0.0
    
    router rip
    passive-interface FastEthernet0/0 
    network 172.16.0.0 
    network 172.17.0.0 
    version 2
    • A. It prevents interface Fa0/0 from sending updates.*
    • B. Interface Fa0/0 operates in RIPv1 mode.
    • C. It removes the 172.16.0.0 network from all updates on all interfaces on R1.
    • D. It removes the 172.17.0.0 network from all updates on all interfaces on R1.

    Show (Hide) Explanation/Reference
    A passive-interface with RIP prevents that interface from sending RIP advertisements but it is still receiving RIP updates from other RIP neighbors. This behavior is different from EIGRP and OSPF where the passive-interface statement stops forming neighbor adjacencies over that link.
  5. Which type of routing protocol operates by exchanging the entire routing information?
    • A. distance vector protocols*
    • B. link state protocols
    • C. path vector protocols
    • D. exterior gateway protocols

    Show (Hide) Explanation/Reference
    Distance vector protocols (like RIP) exchanges the entire routing information each time the routers send the updates.

    Note: EIGRP is considered an advanced distance vector protocol so it does not send the whole routing table for each update.

  6. Refer to the exhibit. After you apply the given configuration to R1, you determine that it is failing to advertise the 172.16.10.32/28 network .Which action most likely to correct the problem?
    R1
    interface FastEthernet0/0
     ip address 172.16.10.1 255.255.255.224
    
    interface FastEthernet0/1
     ip address 172.16.10.33 255.255.255.240
    
    router rip
     network 172.16.0.0
     no auto-summary
    • A. Enable passive interface
    • B. Enable RIPv2*
    • C. Enable manual summarization
    • D. Enable autosummarization

    Show (Hide) Explanation/Reference
    The difference between RIPv1 and RIPv2 is RIPv1 is a classful protocol (no support for VLSM or CIDR) while RIPv2 is a classless protocol (which supports VLSM and CIDR). Therefore in this question if we forget to enable RIPv2 then the router will use RIPv1 and it only advertise major network 172.16.0.0/16 to other routers. By enabling RIPv2 (via the “version 2” command) the router will advertise two subnets 172.16.10.0/27 & 172.16.10.32/28.
  7. Which two statements about RIPv2 are true? (Choose two)
    • A. It must be manually enabled after RIP is configured as the routing protocol*
    • B. It uses multicast address 224.0.0.2 to share routing information between peers
    • C. Its default administrative distances 120*
    • D. It is a link-state routing protocol
    • E. It is an EGP routing protocol

Related Articles

Leave a Reply

avatar