8.3.1.1 Documentation Development Instructions Answers

8.3.1.1 Documentation Development (Instructor Version)

Instructor Note: Red font color or Gray highlights indicate text that appears in the instructor copy only.

Objective

Using a systematic approach, troubleshoot issues in a small- to medium-sized business network.

Instructor Note: This activity is best completed in small groups. It can then be shared with another group, the class, or the instructor (as a group project).

Scenario

As the network administrator for a small business, you want to implement a documentation system to use with troubleshooting network-based problems.

After much thought, you decide to compile simple network documentation information into a file to be used when network problems arise. You also know that if the company gets larger in the future, this file can be used to export the information to a computerized, network software system.

To start the network documentation process, you include:

  • A physical diagram of your small business network.
  • A logical diagram of your small business network.
  • Network configuration information for major devices, including routers and switches.

Resources

  • Packet Tracer software
  • Word processing software

Step 1: Create a Packet Tracer file to simulate a very small business network. Include these devices:

  • One router with at least two Ethernet ports
  • Two switches connected to the router (LAN1 and LAN2)
  • Five user devices to include PCs, laptops, servers, and printers connected either of the two LANs.

Step 2: Create a word-processing file in matrix format to record each of the following main network-documentation areas:

a. Physical topology and information

1) Type of device and model name
2) Network hostname
3) Location of the device
4) Cable connections types and ports

b. Logical topology information

1) IOS or OS image versions
2) IP addresses (IPv4, IPv6, or both)
3) Data-link addresses (MAC)
4) VLAN addresses

c. Network device configuration information

1) Location of backup file (TFTP server, USB, text file)
2) Text-formatted, configuration script per router and switch devices

Step 3: Share your Packet Tracer file and network documentation with a classmate, another group, the class, or your Instructor according to the instructions provided. Discuss how this information could be useful to any network administrator.

Suggested Activity Example Solution: (all student solutions will vary)

Instructor Note: Network configuration output is included for the router only.

Physical Topology Network Diagram

Logical Network Topology Diagram 

Network Documentation Information 

Physical Network Documentation
Type of Device Router
Model Name Cisco 1941 (modular router)
Network Hostname R1-MDF
Physical Network Location Main Distribution Facility (MDF)
Interface Type(s) and Link Connections GigabitEthernet0/0 Link to S1-MDF GigabitEthernet1/1
GigabitEthernet0/1 Link to S2-1151 GigabitEthernet0/1

 

Logical Topology and Information
IOS and System Image file name
or workstation OS version
C1900 Software (C1900-UNIVERSALK9-M), Version 15.1(4)M4
flash0:c1900-universalk9-mz.SPA.151-1.M4.bin
IP address 192.168.1.1 GigabitEthernet0/0
10.10.10.1 GigabitEthernet0/1
MAC address 0001.63b1.2701 (bia 0001.63b1.2701 GigabitEthernet0/0
0001.63b1.2702 (bia 0001.63b1.2702 GigabitEthernet0/1
VLAN address(es) none

 

Network Device Configuration Information
Backup File Location External USB (see network administrator)
TFTP server space on Server 2-MDF
Network Configuration
Script (running-configuration)
R1-MDF# show running-config
Building configuration...
Current configuration : 667 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1-MDF
!
license udi pid CISCO1941/K9 sn FTX1524CE1T
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.224
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.10.10.1 255.255.255.224
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Identify elements of the model that map to IT-related content:

  • Network documentation for troubleshooting
  • Physical network topology
  • Logical network topology

guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x