5.6.3 Packet Tracer – RIP Troubleshooting Answers

5.6.3 Packet Tracer – RIP Troubleshooting Answers

Topology

5.6.3 Packet Tracer - RIP Troubleshooting Answers 2

Addressing table

Device Interface IP Address Subnet Mask Default Gateway
BRANCH Fa0/0 192.168.1.1 255.255.255.0 N/A
S0/0/0 10.45.1.254 255.255.255.0 N/A
HQ Fa0/0 10.45.2.1 255.255.255.0 N/A
S0/0/0 10.45.1.1 255.255.255.0 N/A
S0/0/1 172.20.20.254 255.255.255.0 N/A
ISP Fa0/0 172.16.1.1 255.255.255.0 N/A
S0/0/1 172.20.20.1 255.255.255.0 N/A
PC1 NIC 192.168.1.254 255.255.255.0 192.168.1.1
PC2 NIC 10.45.2.254 255.255.255.0 10.45.2.1
PC3 NIC 172.16.1.254 255.255.255.0 172.16.1.1

Learning objectives

By completing this lab, you will be able to:

  • Connect a network according to the Topology Diagram.
  • Delete startup configuration and reload a router to default state.
  • Load the routers with the provided scripts.
  • Find where convergence is not complete.
  • Collect information about the non-converged portion of the network, along with other errors.
  • Analyze the information to determine why convergence is not complete.
  • Propose solutions for network errors.
  • Implement solutions for network errors.
  • Document the corrected network.

Scenery

In this lab you will begin by loading configuration scripts on each of the routers. These scripts contain errors that will prevent end-to-end communication over the network. You will need to troubleshoot each router to determine any configuration errors and then use the appropriate commands to correct the configurations. When you have corrected all configuration errors, all hosts on the network should be able to communicate with each other.

The network must also meet the following requirements:

  • RIPv1 routing is configured on the BRANCH router.
  • RIPv1 routing is configured on the HQ router.
  • RIP updates should be disabled on the LAN BRANCH and HQ interfaces.
  • The default static route is configured on the HQ router and is shared with the BRANCH router through RIP updates.
  • Static routes for all HQ and BRANCH networks must be configured on the ISP router. Routes should be summarized where possible.

Task 1: Connect, remove and reload routers.

Step 1: Connect a network.

Connect a network that is similar to the one in the Topology Diagram.

Step 2: Delete the configuration on each router.

Erase the configuration of each of the routers using the erase startup-config command and then reload to reload the routers. If you are asked if you want to save the changes, answer no.

Task 2: Load the routers with the provided scripts.

Step 1: Upload the following script to the BRANCH router.

[Instructor Note: Missing or misconfigured commands are displayed in red]

hostname BRANCH
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!The no shutdown command is missing
!
interface Serial0/0/0
ip address 10.45.1.254 255.255.255.0
clock rate 64000
no shutdown
!
router rip
passive-interface FastEthernet0/0
network 10.0.0.0
!The network statement is missing for the 192.168.1.0 network
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end

Corrected script:

hostname Branch
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!The no shutdown command is missing
!
interface Serial0/0/0
ip address 10.45.1.254 255.255.255.0
clock rate 64000
no shutdown
!
router rip
passive-interface FastEthernet0/0
network 10.0.0.0
network 192.168.1.0
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end

The errors in the students’ scripts are the following:

  • The no shutdown command is missing on the FastEthernet0/0 interface.
  • The network statement for network 192.168.1.0 is missing in the RIP configuration.

Step 2: Upload the following script to the HQ router.

hostname HQ
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 10.45.2.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 10.45.1.1 255.255.255.0
no shutdown
!
interface Serial0/0/1
ip address 172.20.20.254 255.255.255.0
clock rate 64000
no shutdown
!
router rip
passive-interface Serial0/0/0
! Fa0/0 should be configured as passive, not S0/0/0
network 10.0.0.0
network 172.0.0.0
!The default-information originate command is missing
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end

Corrected script:

hostname HQ
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 10.45.2.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 10.45.1.1 255.255.255.0
no shutdown
!
interface Serial0/0/1
ip address 172.20.20.254 255.255.255.0
clock rate 64000
no shutdown
!
router rip
passive-interface FastEthernet0/0/0
network 10.0.0.0
network 172.0.0.0
default-information originate
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end

The errors in the students’ scripts are the following:

  • The FastEthernet 0/0 interface must be configured as passive, not the Serial 0/0/0 interface.
  • The default-information originate command is missing from the RIP configuration.

Step 3: Upload the following script to the ISP router.

hostname ISP
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/1
ip address 172.20.20.1 255.255.255.0
no shutdown
!
ip route 10.45.0.0 255.255.254.0 Serial0/0/1
! The subnet mask is incorrect
ip route 192.168.1.0 255.255.255.0 Serial0/0/1
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end

Corrected script:

hostname ISP
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
no shutdown
!
interface Serial0/0/1
ip address 172.20.20.1 255.255.255.0
no shutdown
!
ip route 10.45.0.0 255.255.252.0 Serial 0/0/1
ip route 192.168.1.0 255.255.255.0 Serial0/0/1
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end

The errors in the students’ scripts are the following:

  • The IP address and subnet mask in the path to the 10.45.1.0/22 ​​network are incorrect.

Task 3: Troubleshoot the BRANCH router

Step 1: Start by troubleshooting the host connected to the BRANCH router.

Is it possible to ping from host PC1 to PC2? _No_

Is it possible to ping from host PC1 to PC3? _No_

Is it possible to ping from host PC1 to the default gateway? _No_

Step 2: Examine the BRANCH router for possible configuration errors.

Start by reviewing the summary status information for each interface on the router.

Is there a problem with the state of the interfaces?
Interface Fa0/0 is administratively down

If there are problems with the configuration of the interfaces, record all the commands that you will need to correct the configuration errors.

configure terminal
interface Fa0/0
no shutdown

Step 3: If any of the previous commands have been registered, apply them now to the configuration of the router.

Step 4: View the status information summary.

If configuration changes were made in the previous step, view the router interfaces status information summary again.

Does the interface status summary information indicate any configuration errors?
No

If yes, troubleshoot the status of the interfaces again.

Step 5: Troubleshoot routing configuration on the BRANCH router.

What networks are shown in the routing table?
10.0.0.0/24
192.168.1.0/24 

Is there a problem with the routing table?
There is no way to reach remote networks

If there are problems with the routing table, record all the commands you will need to correct the configuration errors.
____________________________________________

What networks are included in RIP updates?
No RIP update is being sent.

Is there a problem with the RIP updates being sent from the router?
192.168.1.0/24 should be published in RIP updates.

If there are problems with the RIP configuration, record all the commands you will need to correct the configuration errors.

configure terminal
router rip
network 192.168.1.0

Step 6: If any of the previous commands have been registered, apply them now to the router configuration.

Step 7: View routing information.

If any configuration changes are made in the previous steps, view the routing information again.

Does the information in the routing table indicate any configuration errors?
No

Does the information included in the RIP updates that are sent indicate any configuration errors?
No

If the answer to any of these questions is yes, troubleshoot your routing configuration again.

What networks are included in RIP updates?
192.168.1.0

Step 8: Try to ping between the hosts again.

Is it possible to ping from host PC1 to PC2?
No

Is it possible to ping from host PC1 to PC3?
No

Is it possible to ping the serial interface 0/0 of the HQ router from host PC1?
Yes

Task 4: Troubleshoot the HQ router

Step 1: Start by troubleshooting the host connected to router R2.

Is it possible to ping from host PC2 to PC1?
No

Is it possible to ping from host PC2 to PC3?
No

Is it possible to ping from host PC2 to the default gateway?
Yeah

Step 2: Check the HQ router for possible configuration errors.

Start by reviewing the summary status information for each router interface.

Is there a problem with the state of the interfaces?
No

If there are problems with the configuration of the interfaces, record all the commands that you will need to correct the configuration errors.
____________________________________________

Step 3: If any of the previous commands have been registered, apply it now to the router configuration.

Step 4: View the status information summary.

If configuration changes were made in the previous step, view the router interfaces status information summary again.

Does the interface status summary information indicate any configuration errors?
No

If yes, troubleshoot the status of the interfaces again.

Step 5: Troubleshoot routing configuration on the HQ router.

What networks are shown in the routing table?
0.0.0.0/0
10.0.0.0/24
192.168.1.0/24
172.20.20.0/24

Is there a problem with the routing table?
No

If there are problems with the routing table, record all the commands you will need to correct the configuration errors.
____________________________________

What networks are included in RIP updates?
 0.0.0.0
10.45.1.0
192.168.1.0

Is there a problem with the RIP updates being sent from the router?

Routing updates for interface Serial 0/0/0 are not being sent due to the passive-interface Serial 0/0 command. This command should be replaced by the passive-interface FastEthernet0/0 command.

If there are problems with the RIP configuration, record all the commands you will need to correct the configuration errors.

configure terminal
router rip
no passive-interface Serial 0/0/0
passive-interface FastEthernet 0/0

Step 6: If any of the previous commands have been registered, apply them now to the router configuration.

Step 7: View routing information.

If any configuration changes are made in the previous steps, view the routing information again.

Does the information in the routing table indicate any configuration errors?
No

Does the information included in the RIP updates that are sent indicate any configuration errors?
No

If the answer to any of these questions is yes, troubleshoot your routing configuration again.

What networks are included in RIP updates?

0.0.0.0
10.45.2.0

Step 8: Verify that the HQ router is sending a default route to the BRANCH router.

Is there a default route in the BRANCH routing table?
No

If not, what commands are needed to configure it on the HQ router?

configure terminal
router rip 
default-information originate

Step 9: If you previously recorded any command, apply it now in the HQ router configuration.

Step 10: Observe the BRANCH routing table.

If any configuration changes were made in the previous step, look at the BRANCH routing table again.

Is there a default route in the BRANCH routing table? _Yes_

If the answer is no, troubleshoot the RIP configuration again.

Step 11: Try to ping between the hosts again.

Is it possible to ping from host PC2 to PC1? _Yes_

Is it possible to ping the serial interface 0/1 of the ISP router from host PC2? _No_

Is it possible to ping from host PC1 to PC3? _Yes_

Task 5: Troubleshoot the ISP router.

Step 1: Start by troubleshooting the host connected to the ISP router.

Is it possible to ping from host PC3 to PC1? _Yes_

Is it possible to ping from host PC3 to PC2? _No_

Is it possible to ping from host PC3 to the default gateway? _Yes_

Step 2: Examine the ISP router for possible configuration errors.

Start by reviewing the summary status information for each interface on the router.

Is there a problem with the state of the interfaces? _No_

If there are problems with the configuration of the interfaces, record all the commands that you will need to correct the configuration errors.

Step 3: If any of the previous commands have been registered, apply them now to the router configuration.

Step 4: View the status information summary.

If configuration changes were made in the previous step, view the router interfaces status information summary again.

Does the interface status summary information indicate any configuration errors? _No_

If yes, troubleshoot the status of the interfaces again.

Step 5: Troubleshoot static routing configuration on the ISP router.

Start by looking at the routing table.

What networks are shown in the routing table?

10.0.0.0/23
172.16.0.0/24
172.20.0.0/24
192.168.1.0/24

Is there a problem in the routing configuration?
In the routing table, the subnet mask on network 10.0.0.0 should be /22. The summary of routes 10.45.1.0/24 and 10.45.2.0/24 was done incorrectly.

If there are problems with the routing configuration, record all the commands you will need to correct the configuration errors.

configure terminal
no ip route 10.45.0.0 255.255.254.0 Serial0/1
ip route 10.45.0.0 255.255.252.0 Serial0/1

Step 6: If any of the previous commands have been registered, apply them now to the router configuration.

Step 7: View the routing table.

If any changes are made to the configuration in the previous step, view the routing table again.

Does the information in the routing table indicate any configuration errors? _No_

If yes, troubleshoot your routing configuration again.

Step 8: Try to ping between the hosts again.

Is it possible to ping from host PC3 to PC1? _Yes_

Is it possible to ping from host PC3 to PC2? _Yes_

Is it possible to ping the BRANCH router’s WAN interface from host PC3? _Yes_

Task 6: Reflection

There were some configuration errors in the scripts that were prepared for this lab. Use the space below to briefly describe the errors you found.

Task 7: Documentation

On each router, capture the output of the following commands and save it to a text file (.txt) for future reference.

  • show running-config
  • show ip route
  • show ip interface brief
  • show ip protocols

If you need to review the procedures for capturing command results, see the Practice of
laboratory 1.5.1.

Task 8: Cleaning

Clear the configurations and reload the routers. Disconnect and store the cables. For host PCs that are typically connected to other networks (such as the school LAN or the Internet), reconnect the appropriate cables and reset the TCP/IP settings.

Download Packet Tracer (.pka) file:

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments