Section 33 – EtherChannels and Link Aggregation Protocols

Section 33 Tasks

  • Read today’s lesson notes (below)
  • Review yesterday’s lesson notes
  • Complete today’s lab
  • Read the ICND2 cram guide
  • Spend 15 minutes on the subnetting.org website

Cisco IOS software allows administrators to combine multiple physical links in the chassis into a single logical link. This provides an ideal solution for load sharing, as well as link redundancy, and can be used by both Layer 2 and Layer 3 subsystems.

Today you will learn about the following:

  • Understanding EtherChannels
  • Port Aggregation Protocol (PAgP) overview
  • PAgP port modes
  • PAgP EtherChannel Protocol packet forwarding
  • Link Aggregation Control Protocol (LACP) overview
  • LACP port modes
  • EtherChannel load-distribution methods
  • EtherChannel configuration guidelines
  • Configuring and verifying Layer 2 EtherChannels

This lesson maps to the following ICND2 syllabus requirement:

  • EtherChannels

Understanding EtherChannels

An EtherChannel is comprised of physical, individual FastEthernet, GigabitEthernet, or Ten- GigabitEthernet (10Gbps) links that are bundled together into a single logical link, as illustrated in Figure 33.1 below. An EtherChannel comprised of FastEthernet links is referred to as a FastEtherChannel (FEC); an EtherChannel comprised of GigabitEthernet links is referred to as a GigabitEtherChannel (GEC); and, finally, an EtherChannel comprised of Ten-GigabitEthernet links is referred to as a Ten-GigabitEtherChannel (10GEC):

Section 33 – EtherChannels and Link Aggregation Protocols 1

Figure 33.1 – EtherChannel Physical and Logical Views

Each EtherChannel can consist of up to eight ports. Physical links in an EtherChannel must share similar characteristics, such as be defined in the same VLAN or have the same speed and duplex settings, for example. When configuring EtherChannels on Cisco Catalyst switches, it is important to remember that the number of supported EtherChannels will vary between the different Catalyst switch models.

For example, on the Catalyst 3750 series switches, the range is 1 to 48; on the Catalyst 4500 series switches, the range is 1 to 64; and on the flagship Catalyst 6500 series switches, the number of valid values for EtherChannel configuration depends on the software release. For releases prior to Release 12.1(3a)E3, valid values are from 1 to 256; for Releases 12.1(3a)E3, 12.1(3a)E4, and 12.1(4)E1, valid values are from 1 to 64. Release 12.1(5c)EX and later support a maximum of 64 values, ranging from 1 to 256.

NOTE: You are not expected to known the values supported in each different IOS version.

There are two link aggregation protocol options that can be used to automate the creation of an EtherChannel group: Port Aggregation Protocol (PAgP) and Link Aggregation Control Protocol (LACP). PAgP is a Cisco proprietary protocol, while LACP is part of the IEEE 802.3ad specification for creating a logical link from multiple physical links. These two protocols will be described in detail throughout this module.

Port Aggregation Protocol Overview

Port Aggregation Protocol (PAgP) is a Cisco proprietary link aggregation protocol that enables the automatic creation of EtherChannels. By default, PAgP packets are sent between EtherChannel-capable ports in order to negotiate the forming of an EtherChannel. These packets are sent to the destination Multicast MAC address 01-00-0C-CC-CC-CC, which is also the same Multicast address that is used by CDP, UDLD, VTP, and DTP. Figure 33.2 below shows the fields contained within a PAgP frame as seen on the wire:

Section 33 – EtherChannels and Link Aggregation Protocols 2

Figure 33.2 – PAgP Ethernet Header

Although going into detail on the PAgP packet format is beyond the scope of the CCNA exam requirements, Figure 33.3 below shows the fields contained in a typical PAgP packet. Some of the fields contained within the PAgP packet are of relevance to the CCNA exam and will be described in detail as we progress through this module:

Section 33 – EtherChannels and Link Aggregation Protocols 3

Figure 33.3 – The Port Aggregation Protocol Frame

PAgP Port Modes

PAgP supports different port modes that determine whether an EtherChannel will be formed between two PAgP-capable switches. Before we delve into the two PAgP port modes, one particular mode deserves special attention. This mode (the “on” mode) is sometimes incorrectly referenced as a PAgP mode. The truth, however, is that it is not a PAgP port mode.

The on mode forces a port to be placed into a channel unconditionally. The channel will only be created if another switch port is connected and is configured in the on mode. When this mode is enabled, there is no negotiation of the channel performed by the local EtherChannel protocol. In other words, this effectively disables EtherChannel negotiation and forces the port to the channel. The operation of this mode is similar to the operation of the switchport nonegotiate command on trunk links. It is important to remember that switch interfaces that are configured in the on mode do not exchange PAgP packets.

Switch EtherChannels using PAgP may be configured to operate in one of two modes: auto or desirable. These two PAgP modes of operation are described in the following sections.

Auto Mode

Auto mode is a PAgP mode that will negotiate with another PAgP port only if the port receives a PAgP packet. When this mode is enabled, the port(s) will never initiate PAgP communications but will instead listen passively for any received PAgP packets before creating an EtherChannel with the neighbouring switch.

Desirable Mode

Desirable mode is a PAgP mode that causes the port to initiate PAgP negotiation for a channel with another PAgP port. In other words, in this mode, the port actively attempts to establish an EtherChannel with another switch running PAgP.

In summation, it is important to remember that switch interfaces configured in the on mode do not exchange PAgP packets, but they do exchange PAgP packets with partner interfaces configured in the auto or desirable modes. Table 33.1 shows the different PAgP combinations and the result of their use in establishing an EtherChannel:

Table 33.1 – EtherChannel Formation Using Different PAgP Modes

Section 33 – EtherChannels and Link Aggregation Protocols 4

PAgP EtherChannel Protocol Packet Forwarding

While PAgP allows for all links within the EtherChannel to be used to forward and receive user traffic, there are some restrictions that you should be familiar with regarding the forwarding of traffic from other protocols. DTP and CDP send and receive packets over all the physical interfaces in the EtherChannel. PAgP sends and receives PAgP Protocol Data Units only from interfaces that are up and have PAgP enabled for auto or desirable modes.

When an EtherChannel bundle is configured as a trunk port, the trunk sends and receives PAgP frames on the lowest numbered VLAN. Spanning Tree Protocol (STP) always chooses the first operational port in an EtherChannel bundle. The show pagp [channel number] neighbor command, which can also be used to validate the port that will be used by STP to send and receive packets, determines the port STP will use in an EtherChannel bundle, as shown in the following output:

Switch-1#show pagp neighbor
Flags:  S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode.       P - Device learns on physical port.
Channel group 1 neighbors
Partner     Partner          Partner         Partner Group
Port      Name        Device ID        Port       Age  Flags   Cap.
Fa0/1     Switch-2    0014.a9e5.d640   Fa0/1      2s   SC      10001
Fa0/2     Switch-2    0014.a9e5.d640   Fa0/2      1s   SC      10001
Fa0/3     Switch-2    0014.a9e5.d640   Fa0/3      15s  SC      10001

Referencing the above output, STP will send packets only out of port FastEthernet0/1 because it is the first operational interface. If that port fails, STP will send packets out of FastEthernet0/2. The default port used by PAgP can be viewed with the show EtherChannel summary command, as illustrated in the following output:

Switch-1#show EtherChannel summary
Flags:  D - down
        I - stand-alone
        H - Hot-standby (LACP only)
        R - Layer3
        u - unsuitable for bundling
        U - in use
        d - default port
        P - in port-channel
        s - suspended
        S - Layer2
        f - failed to allocate aggregator
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+--------------------------------
1      Po1(SU)       PAgP        Fa0/1(Pd)   Fa0/2(P)    Fa0/3(P)

When configuring additional STP features such as Loop Guard on an EtherChannel, it is very important to remember that if Loop Guard blocks the first port, no BPDUs will be sent over the channel, even if other ports in the channel bundle are operational. This is because PAgP will enforce uniform Loop Guard configuration on all of the ports that are part of the EtherChannel group.

Real-World Implementation

In production networks, you may run across the Cisco Virtual Switching System (VSS), which is comprised of two physical Catalyst 6500 series switches acting as a single logical switch. In the VSS, one switch is selected as the active switch, while the other is selected as the standby switch. The two switches are connected together via an EtherChannel, which allows for the sending and receiving of control packets between them.

Access switches are connected to the VSS using Multichassis EtherChannel (MEC). An MEC is simply an EtherChannel that spans the two physical Catalyst 6500 switches but terminates to the single logical VSS. Enhanced PAgP (PAgP+) can be used to allow the Catalyst 6500 switches to communicate via the MEC in the event that the EtherChannel between them fails, which would result in both switches assuming the active role (dual active), effectively affecting forwarding of traffic within the switched network. This is illustrated in the diagram below:

Section 33 – EtherChannels and Link Aggregation Protocols 5

While VSS is beyond the scope of the CCNA exam requirements, it is beneficial to know that only PAgP can be used to relay VSS control packets. Therefore, if implementing EtherChannels in a VSS environment, or an environment in which VSS may eventually be implemented, you may want to consider running PAgP instead of LACP, which is an open standard that does not support the proprietary VSS frames. VSS will not be described any further in this guide.

Link Aggregation Control Protocol Overview

Link Aggregation Control Protocol (LACP) is part of the IEEE 802.3ad specification for creating a logical link from multiple physical links. Because LACP and PAgP are incompatible, both ends of the link need to run LACP in order to automate the formation of EtherChannel groups.

As is the case with PAgP, when configuring LACP EtherChannels, all LAN ports must be the same speed and must all be configured as either Layer 2 or Layer 3 LAN ports. If a link within a port channel fails, traffic previously carried over the failed link is switched over to the remaining links within the port channel. Additionally, when you change the number of active bundled ports in a port channel, traffic patterns will reflect the rebalanced state of the port channel.

LACP supports the automatic creation of port channels by exchanging LACP packets between ports. It learns the capabilities of port groups dynamically and informs the other ports. Once LACP identifies correctly matched Ethernet links, it facilitates grouping the links into a GigabitEthernet port channel. Unlike PAgP, where ports are required to have the same speed and duplex settings, LACP mandates that ports be only full-duplex, as half-duplex is not supported. Half-duplex ports in an LACP EtherChannel are placed into the suspended state.

By default, all inbound Broadcast and Multicast packets on one link in a port channel are blocked from returning on any other link of the port channel. LACP packets are sent to the IEEE 802.3 Slow Protocols Multicast group address 01-80-C2-00-00-02. LACP frames are encoded with the EtherType value 0x8809. Figure 33.4 below illustrates these fields in an Ethernet frame:

Section 33 – EtherChannels and Link Aggregation Protocols 6

Figure 33.4 – IEEE 802.3 LACP Frame

LACP Port Modes

LACP supports the automatic creation of port channels by exchanging LACP packets between ports. LACP does this by learning the capabilities of port groups dynamically and informing the other ports. Once LACP identifies correctly matched Ethernet links, it facilitates grouping the links into a port channel. Once an LACP mode has been configured, it can only be changed if a single interface has been assigned to the specified channel group. LACP supports two modes: active and passive. These two modes of operation are described in the following sections.

LACP Active Mode

LACP active mode places a switch port into an active negotiating state in which the switch port initiates negotiations with remote ports by sending LACP packets. Active mode is the LACP equivalent of PAgP desirable mode. In other words, in this mode, the switch port actively attempts to establish an EtherChannel with another switch that is also running LACP.

LACP Passive Mode

When a switch port is configured in passive mode, it will negotiate with an LACP channel only if it receives another LACP packet. In passive mode, the port responds to LACP packets that the interface receives but does not start LACP packet negotiation. This setting minimises the transmission of LACP packets. In this mode, the port channel group attaches the interface to the EtherChannel bundle. This mode is similar to the auto mode that is used with PAgP.

It is important to remember that the active and passive modes are valid on non-PAgP interfaces only. However, if you have a PAgP EtherChannel and want to convert it to LACP, then Cisco IOS software allows you to change the protocol at any time. The only caveat is that this change causes all existing EtherChannels to reset to the default channel mode for the new protocol. Table 33.2 below shows the different LACP combinations and the result of their use in establishing an EtherChannel between two switches:

Table 33.2 – EtherChannel Formation Using Different LACP Modes

Section 33 – EtherChannels and Link Aggregation Protocols 7

EtherChannel Load-Distribution Methods

For both PAgP and LACP EtherChannels, Catalyst switches use a polymorphic algorithm that utilises key fields from the header of the packet to generate a hash, which is then matched to a physical link in the EtherChannel group. In other words, the switch distributes the traffic load across the links in an EtherChannel by reducing part of the binary pattern formed from the addresses in the frame to a numerical value that selects one of the links in the EtherChannel.

This operation can be performed on MAC addresses or IP addresses and can be based solely on source or destination addresses, or even both source and destination addresses. While delving into detail on the actual computation of the hash used in EtherChannel load distribution is beyond the scope of the CCNA exam requirements, it is important to know that the administrator can define which fields in the header can be used as input to the algorithm used to determine the physical link transport to the packet.

The load-distribution method is configured via the port-channel load-balance [method] global configuration command. Only a single method can be used at any given time. Table 33.3 below lists and describes the different methods available in Cisco IOS Catalyst switches when configuring EtherChannel load distribution:

Table33.3 – EtherChannel Load-Distribution (Load-Balancing) Options

Section 33 – EtherChannels and Link Aggregation Protocols 8

EtherChannel Configuration Guidelines

The following section lists and describes the steps that are required to configure Layer 2 PAgP EtherChannels. However, before we delve into these configuration steps, it is important that you are familiar with the following caveats when configuring Layer 2 EtherChannels:

  • Each EtherChannel can have up to eight compatibly configured Ethernet interfaces. LACP allows you to have more than eight ports in an EtherChannel group. These additional ports are hot-standby ports.
  • All interfaces in the EtherChannel must operate at the same speed and duplex modes. Keep in mind, however, that unlike PAgP, LACP does not support half-duplex ports.
  • Ensure that all interfaces in the EtherChannel are enabled. In some cases, if the interfaces are not enabled, the logical port channel interface will not be created automatically.
  • When first configuring an EtherChannel group, it is important to remember that ports follow the parameters set for the first group port added.
  • If Switch Port Analyzer (SPAN) is configured for a member port in an EtherChannel, then the port will be removed from the EtherChannel group.
  • It is important to assign all interfaces in the EtherChannel to the same VLAN or configure them as trunk links. If these parameters are different, the channel will not form.
  • Keep in mind that similar interfaces with different STP path costs (manipulated by an administrator) can still be used to form an EtherChannel.
  • It is recommended to shut down all member interfaces prior to beginning channelling configuration.

Configuring and Verifying Layer 2 EtherChannels

This section describes the configuration of Layer 2 EtherChannels by unconditionally forcing the selected interfaces to establish an EtherChannel.

  1. The first configuration step is to enter Interface Configuration mode for the desired EtherChannel interface(s) via the interface [name] or interface range [range] global configuration command.
  2. The second configuration step is to configure the interfaces as Layer 2 switch ports via the switchport interface configuration command.
  3. The third configuration step is to configure the switch ports as either trunk or access links
    via the switchport mode [access|trunk] interface configuration command.
  4. Optionally, if the interface or interfaces have been configured as access ports, assign them to the same VLAN using the switchport access vlan [number] command. If the interface or interfaces have been configured as a trunk port, select the VLANs allowed to traverse the trunk by issuing the switchport trunk allowed vlan [range] interface configuration command; if VLAN 1 will not be used as the native VLAN (for 802.1Q), enter the native VLAN by issuing the switchport trunk native vlan [number] interface configuration command. This configuration must be the same on all of the port channel member interfaces.
  5. The next configuration step is to configure the interfaces to unconditionally trunk via the channel-group [number] mode on interface configuration command.

The configuration of unconditional EtherChannels using the steps described above will be based on the network topology illustrated in Figure 33.5 below:

Section 33 – EtherChannels and Link Aggregation Protocols 9

Figure 33.5 – Network Topology for EtherChannel Configuration Output Examples

The following output illustrates how to configure unconditional channelling on Switch 1 and Switch 2 based on the network topology depicted in Figure 33.5. The EtherChannel will be configured as a Layer 2 802.1Q trunk using default parameters:

Switch-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch-1(config)#interface range fa0/1 – 3
Switch-1(config-if-range)#no shutdown
Switch-1(config-if-range)#switchport
Switch-1(config-if-range)#switchport trunk encapsulation dot1q
Switch-1(config-if-range)#switchport mode trunk
Switch-1(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1
Switch-1(config-if-range)#exit
Switch-1(config)#exit

NOTE: Notice that the switch automatically creates interface port-channel 1 by default (refer to the output below). No explicit user configuration is required to configure this interface.

Switch-2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch-2(config)#interface range fa0/1 - 3
Switch-2(config-if-range)#switchport
Switch-2(config-if-range)#switchport trunk encapsulation dot1q
Switch-2(config-if-range)#switchport mode trunk
Switch-2(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel 1
Switch-2(config-if-range)#exit
Switch-2(config)#exit

The show EtherChannel [options] command can then be used to verify the configuration of the EtherChannel. The available options (which may vary depending upon platform) are printed in the following output:

Switch-2#show EtherChannel ?
<1-6>          Channel group number
detail         Detail information
load-balance  Load-balance/frame-distribution scheme among ports in port-channel
port           Port information
port-channel   Port-channel information
protocol       protocol enabled
summary        One-line summary per channel-group
|              Output modifiers
<cr>

The following output illustrates the show EtherChannel summary command:

Switch-2#show EtherChannel summary
Flags:  D - down
        I - stand-alone
        H - Hot-standby (LACP only)
        R - Layer3
        u - unsuitable for bundling
        U - in use
        d - default port
        P - in port-channel
        s - suspended
        S - Layer2
        f - failed to allocate aggregator
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+--------------------------------
1      Po1(SU)          -        Fa0/1(Pd)   Fa0/2(P)    Fa0/3(P)

In the output above, you can see that there are three links in Channel Group 1. Interface FastEthernet0/1 is the default port; this port will be used to send STP packets, for example. If this port fails, FastEthernet0/2 will be designated as the default port, and so forth. You can also see that this is an active Layer 2 EtherChannel by looking at the SU flag next to Po1. The following output shows the information printed by the show EtherChannel detail command:

Switch-2#show EtherChannel detail
                                     Channel-group listing:
                                     ----------------------
Group: 1
----------Group state = L2
Ports: 3   Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol:    -
                                     Ports in the group:
                                     -------------------
Port: Fa0/1
------------
Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = On/FEC           Gcchange = -
Port-channel  = Po1         GC   = -     Pseudo port-channel = Po1
Port index    = 0           Load = 0x00             Protocol = -
Age of the port in the current state: 0d:00h:20m:20s
Port: Fa0/2
------------
Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = On/FEC          Gcchange = -
Port-channel  = Po1         GC   = -    Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol = -
Age of the port in the current state: 0d:00h:21m:20s
Port: Fa0/3
------------
Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = On/FEC          Gcchange = -
Port-channel  = Po1         GC   = -    Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol = -
Age of the port in the current state: 0d:00h:21m:20s
                                     Port-channels in the group:
                                     ---------------------------
Port-channel: Po1
------------
Age of the Port-channel   = 0d:00h:26m:23s
Logical slot/port   = 1/0             Number of ports = 3
GC                  = 0x00000000      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            = -
Ports in the Port-channel:
Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
0       00     Fa0/1    On/FEC          0
0       00     Fa0/2    On/FEC          0
0       00     Fa0/3    On/FEC          0
Time since last port bundled:    0d:00h:21m:20s    Fa0/3

In the output above, you can see that this is a Layer 2 EtherChannel with three out of a maximum of eight possible ports in the channel group. You can also see that the EtherChannel mode is on, based on the protocol being denoted by a dash (-). In addition, you can also see that this is a FastEtherChannel (FEC).

Finally, you can also verify the Layer 2 operational status of the logical port-channel interface by issuing the show interfaces port-channel [number] switchport command. This is illustrated in the following output:

Switch-2#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Protected: false
Appliance trust: none

Configuring and Verifying PAgP EtherChannels

This section describes the configuration of PAgP Layer 2 EtherChannels. The following steps need to be executed in order to configure and establish a PAgP EtherChannel.

  1. The first configuration step is to enter Interface Configuration mode for the desired EtherChannel interface(s) via the interface [name] or interface range [range] global configuration command.
  2. The second configuration step is to configure the interfaces as Layer 2 switch ports via the switchport interface configuration command.
  3. The third configuration step is to configure the switch ports as either trunk or access links via the switchport mode [access|trunk] interface configuration command.
  4. Optionally, if the interface or interfaces have been configured as access ports, assign them to the same VLAN using the switchport access vlan [number] command. If the interface or interfaces have been configured as a trunk port, select the VLANs allowed to traverse the trunk by issuing the switchport trunk allowed vlan [range] interface configuration command; if VLAN 1 will not be used as the native VLAN (for 802.1Q), enter the native VLAN by issuing the switchport trunk native vlan [number] interface configuration command. This configuration must be the same on all of the port channel member interfaces.
  5. Optionally, configure PAgP as the EtherChannel protocol by issuing the channel-protocol pagp interface configuration command. Because EtherChannels default to PAgP, this command is considered optional and is not required. It is considered good practice to issue this command just to be absolutely sure of your configuration.
  6. The next configuration step is to configure the interfaces to unconditionally trunk via the channel-group [number] mode interface configuration command.

The following output illustrates how to configure PAgP channelling on Switch 1 and Switch 2 based on the network topology depicted in Figure 33.5 above. The EtherChannel will be configured as a Layer 2 802.1Q trunk using default parameters:

Switch-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch-1(config)#interface range fa0/1 - 3
Switch-1(config-if-range)#switchport
Switch-1(config-if-range)#switchport trunk encap dot1q
Switch-1(config-if-range)#switchport mode trunk
Switch-1(config-if-range)#channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
Switch-1(config-if-range)#exit

NOTE: In the output above, the port channel desirable mode has been selected. An additional keyword, [non-silent], may also be appended to the end of this command. This is because, by default, PAgP auto and desirable modes default to a silent mode. The silent mode is used when the switch is connected to a device that is not PAgP-capable and that seldom, if ever, transmits packets. An example of a silent partner is a file server or a packet analyser that is not generating traffic. It is also used if a device will not be sending PAgP packets (such as in auto mode).

In this case, running PAgP on a physical port connected to a silent partner prevents that switch port from ever becoming operational; however, the silent setting allows PAgP to operate, to attach the interface to a channel group, and to use the interface for transmission. In this example, because Switch 2 will be configured for auto mode (passive mode), it is preferred that the port uses the default silent mode operation. This is illustrated in the PAgP EtherChannel configuration output below:

Switch-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch-1(config)#interface range fa0/1 - 3
Switch-1(config-if-range)#switchport
Switch-1(config-if-range)#switchport trunk encap dot1q
Switch-1(config-if-range)#switchport mode trunk
Switch-1(config-if-range)#channel-group 1 mode desirable ?
  non-silent Start negotiation only after data packets received
  <cr>
Switch-1(config-if-range)#channel-group 1 mode desirable non-silent
Creating a port-channel interface Port-channel 1
Switch-1(config-if-range)#exit

Proceeding with PAgP EtherChannel configuration, Switch 2 is configured as follows:

Switch-2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch-2(config)#int range fa0/1 - 3
Switch-2(config-if-range)#switchport
Switch-2(config-if-range)#switchport trunk encapsulation dot1q
Switch-2(config-if-range)#switchport mode trunk
Switch-2(config-if-range)#channel-group 1 mode auto
Creating a port-channel interface Port-channel 1
Switch-2(config-if-range)#exit

The following output illustrates how to verify the PAgP EtherChannel configuration by using the show EtherChannel summary command on Switch 1 and Switch 2:

Switch-1#show EtherChannel summary
Flags:  D - down
        I - stand-alone
        H - Hot-standby (LACP only)
        R - Layer3
        u - unsuitable for bundling
        U - in use
        d - default port
        P - in port-channel
        s - suspended
        S - Layer2
        f - failed to allocate aggregator
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+--------------------------------
1      Po1(SU)         PAgP      Fa0/1(Pd)   Fa0/2(P)    Fa0/3(P)

PAgP EtherChannel configuration and statistics may also be viewed by issuing the show pagp [options] command. The options available with this command are illustrated in the following output:

Switch-1#show pagp ?
  <1-6>     Channel group number
  counters  Traffic information
  internal  Internal information
  neighbor  Neighbor information

NOTE: Entering the desired port channel number provides the same options as the last three options printed above. This is illustrated in the following output:

Switch-1#show pagp 1 ?
  counters Traffic information
  internal Internal information
  neighbor Neighbor information

The [counters] keyword provides information on PAgP sent and received packets. The [internal] keyword provides information such as the port state, Hello interval, PAgP port priority, and the port learning method, for example. Using the show pagp internal command, this is illustrated in the following output:

Switch-1#show pagp 1 internal
Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        d - PAgP is down.
Timers: H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.
Channel group 1
                 Hello    Partner PAgP      Learning Group
Port    Flags State  Timers Interval Count Priority Method   Ifindex
Fa0/1   SC    U6/S7  H      30s      1     128      Any      29
Fa0/2   SC    U6/S7  H      30s      1     128      Any      29
Fa0/3   SC    U6/S7  H      30s      1     128      Any      29

The [neighbor] keyword prints out the neighbour name, ID of the PAgP neighbour, the neighbour device ID (MAC), and the neighbour port. The flags also indicate the mode the neighbour is operating in, as well as if it is a physical learner, for example. Using the show pagp neighbor command, this is illustrated in the following output:

Switch-1#show pagp 1 neighbor
Flags:  S - Device is sending Slow hello. C - Device is in Consistent state.
        A - Device is in Auto mode.       P - Device learns on physical port.
Channel group 1 neighbors
          Partner     Partner          Partner        Partner Group
Port      Name        Device ID        Port      Age  Flags   Cap.
Fa0/1     Switch-2    0014.a9e5.d640   Fa0/1     19s  SAC     10001
Fa0/2     Switch-2    0014.a9e5.d640   Fa0/2     24s  SAC     10001
Fa0/3     Switch-2    0014.a9e5.d640   Fa0/3     18s  SAC     10001

Configuring and Verifying LACP EtherChannels

This section describes the configuration of LACP Layer 2 EtherChannels. The following steps need to be executed in order to configure and establish an LACP EtherChannel.The first configuration step is to enter Interface Configuration mode for the desired EtherChannel interface(s) via the interface [name] or interface range [range] global configuration command.

  1. The second configuration step is to configure the interfaces as Layer 2 switch ports via the switchport interface configuration command.
  2. The third configuration step is to configure the switch ports as either trunk or access links via the switchport mode [access|trunk] interface configuration command.
  3. Optionally, if the interface or interfaces have been configured as access ports, assign them to the same VLAN using the switchport access vlan [number] command. If the interface or interfaces have been configured as a trunk port, select the VLANs allowed to traverse the trunk by issuing the switchport trunk allowed vlan [range] interface configuration command; if VLAN 1 will not be used as the native VLAN (for 802.1Q), enter the native VLAN by issuing the switchport trunk native vlan [number] interface configuration command. This configuration must be the same on all of the port channel member interfaces.
  4. Configure LACP as the EtherChannel protocol by issuing the channel-protocol lacp interface configuration command. Because EtherChannels default to PAgP, this command is considered mandatory for LACP and is required.
  5. The next configuration step is to configure the interfaces to unconditionally trunk via the channel-group [number] mode interface configuration command.

In the above output illustrating how to configure LACP channelling on Switch 1 and Switch 2 based on the network topology depicted in Figure 33.5, the EtherChannel will be configured as a Layer 2 802.1Q trunk using default parameters, as shown in the following outputs:

Switch-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch-1(config)#int range FastEthernet0/1 - 3
Switch-1(config-if-range)#switchport
Switch-1(config-if-range)#switchport trunk encapsulation dot1q
Switch-1(config-if-range)#switchport mode trunk
Switch-1(config-if-range)#channel-protocol lacp
Switch-1(config-if-range)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1
Switch-1(config-if-range)#exit
Switch-2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch-2(config)#interface range FastEthernet0/1 - 3
Switch-2(config-if-range)#switchport
Switch-2(config-if-range)#switchport trunk encapsulation dot1q
Switch-2(config-if-range)#switchport mode trunk
Switch-2(config-if-range)#channel-protocol lacp
Switch-2(config-if-range)#channel-group 1 mode passive
Creating a port-channel interface Port-channel 1
Switch-2(config-if-range)#exit

The following output illustrates how to verify the LACP EtherChannel configuration by using the show EtherChannel summary command on Switch 1 and Switch 2:

Switch-1#show EtherChannel summary
Flags:  D - down
        I - stand-alone
        H - Hot-standby (LACP only)
        R - Layer3
        u - unsuitable for bundling
        U - in use
        d - default port
        P - in port-channel
        s - suspended
        S - Layer2
        f - failed to allocate aggregator
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+--------------------------------
1      Po1(SU)       LACP        Fa0/1(Pd)   Fa0/2(P)    Fa0/3(P)

By default, LACP allows up to 16 ports to be entered into a port channel group. The first eight operational interfaces will be used by LACP, while the remaining eight interfaces will be placed into the hot-standby state. The show EtherChannel detail command shows the maximum number of supported links in an LACP EtherChannel, as illustrated in the following output:

Switch-1#show EtherChannel 1 detail
Group state = L2
Ports: 3   Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol:   LACP
                Ports in the group:
                -------------------
Port: Fa0/1
------------Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = Active      Gcchange = -
Port-channel  = Po1         GC   = -       Pseudo port-channel = Po1
Port index    = 0           Load = 0x00        Protocol = LACP
Flags:  S - Device is sending Slow LACPDUs.  F - Device is sending fast
                                                 LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.
Local information:
                     LACP port     Admin     Oper    Port     Port
Port   Flags  State  Priority      Key       Key     Number   State
Fa0/1  SA     bndl   32768         0x1       0x1     0x0      0x3D
Partner’s information:
          Partner               Partner                     Partner
Port      System ID             Port Number     Age         Flags
Fa0/1     00001,0014.a9e5.d640  0x1             4s          SP
          LACP Partner         Partner         Partner
          Port Priority        Oper Key        Port State
          32768                0x1             0x3C
Age of the port in the current state: 00d:00h:00m:35s
Port: Fa0/2
------------
Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = Active      Gcchange = -
Port-channel  = Po1         GC   = -       Pseudo port-channel = Po1
Port index    = 0           Load = 0x00        Protocol = LACP
Flags:  S - Device is sending Slow LACPDUs.  F - Device is sending fast
                                                 LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.
Local information:
                      LACP port   Admin     Oper    Port     Port
Port    Flags  State  Priority    Key       Key     Number   State
Fa0/2   SA     bndl   32768       0x1       0x1     0x1      0x3D
Partner’s information:
          Partner               Partner                     Partner
Port      System ID             Port Number     Age         Flags
Fa0/2     00001,0014.a9e5.d640  0x2             28s         SP
          LACP Partner         Partner         Partner
          Port Priority        Oper Key        Port State
          32768                0x1             0x3C
Age of the port in the current state: 00d:00h:00m:33s
Port: Fa0/3
------------Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = Active      Gcchange = -Port-channel  = Po1         GC   = -       Pseudo port-channel = Po1
Port index    = 0           Load = 0x00        Protocol = LACP
Flags:  S - Device is sending Slow LACPDUs.  F - Device is sending fast
                                                 LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.
Local information:
                     LACP port     Admin     Oper    Port     Port
Port   Flags  State  Priority      Key       Key     Number   State
Fa0/3  SA     bndl   32768         0x1       0x1     0x2      0x3D
Partner’s information:
          Partner               Partner                     Partner
Port      System ID             Port Number     Age         Flags
Fa0/3     00001,0014.a9e5.d640  0x3             5s          SP
          LACP Partner         Partner         Partner
          Port Priority        Oper Key        Port State
          32768                0x1             0x3C
Age of the port in the current state: 00d:00h:00m:29s
                Port-channels in the group:
                ----------------------
Port-channel: Po1    (Primary Aggregator)
------------
Age of the Port-channel = 00d:00h:13m:50s
Logical slot/port   = 1/0          Number of ports = 3
HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            = LACP
Ports in the Port-channel:
Index   Load   Port    EC state
------+------+------+------------
0       00     Fa0/1   Active
0       00     Fa0/2   Active
0       00     Fa0/3   Active
Time since last port bundled:    00d:00h:00m:32s    Fa0/3
Time since last port Un-bundled: 00d:00h:00m:49s    Fa0/1

LACP configuration and statistics may also be viewed by issuing the show lacp [options] command. The options available with this command are illustrated in the following output:

Switch-1#show lacp ?
  <1-6>     Channel group number
  counters  Traffic information
  internal  Internal information
  neighbor  Neighbor information
  sys-id    LACP System ID

The [counters] keyword provides information on LACP sent and received packets. The output printed by this command is illustrated below:

Switch-1#show lacp counters
             LACPDUs         Marker      Marker Response    LACPDUs
Port       Sent   Recv     Sent   Recv     Sent   Recv      Pkts Err
---------------------------------------------------------------------
Channel group: 1
Fa0/1      14     12       0      0        0      0         0
Fa0/2      21     18       0      0        0      0         0
Fa0/3      21     18       0      0        0      0         0

The [internal] keyword provides information such as the port state, administrative key, LACP port priority, and the port number, for example. This is illustrated in the following output:

Switch-1#show lacp internal
Flags:  S - Device is sending Slow LACPDUs. F - Device is sending Fast
                                                LACPDUs.
        A - Device is in Active mode.       P - Device is in Passive mode.
Channel group 1
                        LACP port    Admin    Oper   Port    Port
Port      Flags  State  Priority     Key      Key    Number  State
Fa0/1     SA     bndl   32768        0x1      0x1    0x0     0x3D
Fa0/2     SA     bndl   32768        0x1      0x1    0x1     0x3D
Fa0/3     SA     bndl   32768        0x1      0x1    0x2     0x3D

The [neighbor] keyword prints out the neighbour name, ID of the LACP neighbour, the neighbour device ID (MAC), and the neighbour port. The flags also indicate the mode the neighbour is operating in, as well as whether it is a physical learner, for example. This is illustrated in the following output:

Switch-1#show lacp neighbor
Flags:  S - Device is sending Slow LACPDUs. F - Device is sending Fast
                                                LACPDUs.
        A - Device is in Active mode.       P - Device is in Passive mode.
Channel group 1 neighbors
Partner’s information:
          Partner               Partner                     Partner
Port      System ID             Port Number     Age         Flags
Fa0/1     00001,0014.a9e5.d640  0x1             11s         SP
          LACP Partner         Partner         Partner
          Port Priority        Oper Key        Port State
          32768                0x1             0x3C
Partner’s information:
          Partner               Partner                     Partner
Port      System ID             Port Number     Age         Flags
Fa0/2     00001,0014.a9e5.d640  0x2             19s         SP
          LACP Partner         Partner         Partner
          Port Priority        Oper Key        Port State
          32768                0x1             0x3C
Partner’s information:
          Partner               Partner                     Partner
Port      System ID             Port Number     Age         Flags
Fa0/3     00001,0014.a9e5.d640  0x3             24s         SP
          LACP Partner         Partner         Partner
          Port Priority        Oper Key        Port State
          32768                0x1             0x3C

Finally, the [sys-id] keyword provides the system ID of the local switch. This is a combination of the switch MAC and LACP priority, as illustrated in the following output:

Switch-1#show lacp sys-id
1    ,000d.bd06.4100

Section 33 Questions

  1. What type of ports does a FastEtherChannel contain?
  2. How many ports can a standard EtherChannel contain?
  3. What are the two protocol options you have when configuring EtherChannels on a Cisco switch?
  4. Which of the protocols mentioned above is Cisco proprietary?
  5. PagP packets are sent to the destination Multicast MAC address 01-00-0C-CC-CC-CC. True or false?
  6. What are the two port modes supported by PagP?
  7. What are the two port modes supported by LACP?
  8. If more than eight links are assigned to an EtherChannel bundle running LACP, the protocol uses the port priority to determine which ports are placed into a standby mode. True or false?
  9. LACP automatically configures an administrative key value on each port configured to use LACP. The administrative key defines the ability of a port to aggregate with other ports. Only ports that have the same administrative key are allowed to be aggregated into the same port channel group. True or false?
  10. What is the command used to assign a port to a channel group?

Section 33 Answers

  1. 100 Mbps ports.
  2. Up to eight ports.
  3. PagP and LACP.
  4. PagP.
  5. True.
  6. Auto and desirable.
  7. Active and passive.
  8. True.
  9. True.
  10. The channel-group [number] mode command in Interface Configuration mode.

Section 33 Lab

EtherChannel Lab

Test the configuration commands presented in this module on a simple topology that includes two directly connected switches (at least two links between them). Connect them via Fa1/1 and Fa2/2 (Fa1/1 to Fa1/1 and Fa2/2 to Fa2/2):

  • Configure PagP on the two links in mode auto-desirable
  • Configure the EtherChannel link as a trunk and allow a couple of VLANs through it
  • Issue a show etherchannel summary command and verify that the port channel is up
  • Issue a show mac-address-table command and see the learned MAC addresses on each switch
  • Issue a show papg neighbor command and verify the results
  • Repeat the steps above using LACP mode passive-active
  • Verify the configuration using the show EtherChannel detail and show lacp neighbor commands
  • Verify the configuration using the show interface port-channel [number] switchport command
  • Issue some traffic (ping) across the port channel and verify the counters using the show lacp counters command
  • Configure a different lacp system-priority output and verify it with the show lacp sysid command
  • Configure a different lacp port-priority output and verify it with the show lacp internal command
  • Configure LACP load balancing using the port-channel load-balance command and verify this with the show etherchannel load-balance command

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x