2.8.3 Packet Tracer – Troubleshooting Static Routes Answers
Topology
Device | Interface | IP Address | Subnet Mask | Default Gateway |
---|---|---|---|---|
Branch | Fa0/0 | 172.20.1.129 | 255.255.255.128 | N/A |
S0/0/0 | 172.20.1.1 | 255.255.255.128 | N/A | |
HQ | Fa0/0 | 172.20.0.129 | 255.255.255.128 | N/A |
S0/0/0 | 172.20.1.2 | 255.255.255.128 | N/A | |
S0/0/1 | 192.168.38.254 | 255.255.255.252 | N/A | |
ISP | FA0/0 | 192.168.39.65 | 255.255.255.192 | N/A |
S0/0/1 | 192.168.38.253 | 255.255.255.252 | N/A | |
PC1 | NIC | 172.20.1.135 | 255.255.255.128 | 172.20.1.129 |
PC2 | NIC | 172.20.0.135 | 255.255.255.128 | 172.20.0.129 |
Web Server | NIC | 192.168.39.70 | 255.255.255.192 | 192.168.39.65 |
Scenario
In this lab, you will begin by loading configuration scripts on each of the routers. These scripts contain errors that will prevent end to end communication across the network. You will need to troubleshoot each router to determine the configuration errors, and then use the appropriate commands to correct the configurations. When you have corrected all of the configuration errors, all of the hosts on the network should be able to communicate with each other.
Task 1: Cable, Erase, and Reload the Routers
Step 1 Cable a network that is similar to the one in the Topology Diagram.
On all routers the Lan interface will be Fa0/0
Connection from Branch to HQ is S0/0/0 to S0/0/0
Connection from HQ to ISP is S0/0/1 to S0/0/1
Step 2 Clear the configuration on each of routers using the erase startup-config command and then reload the routers. Answer ‘no’ if asked to save changes. (The enable password is class.)
Step 3 Configure the hosts with the addresses in the table.
Task 2: Load Routers with the Supplied Scripts
Step 1 Load the following script onto the Branch router. Make sure you are in global configuration mode prior to pasting the script to the router.
hostname Branch
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.20.1.129 255.255.255.128
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 172.20.1.1 255.255.255.128
clock rate 64000
no shutdown
!
ip route 0.0.0.0 0.0.0.0 172.20.0.129
! the destination in the ip route command should be 172.20.1.2
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end
Corrected script:
hostname BRANCH ! ! no ip domain-lookup ! interface FastEthernet0/0 ip address 172.20.1.129 255.255.255.128 duplex auto speed auto no shutdown ! interface Serial0/0/0 ip address 172.20.1.1 255.255.255.128 clock rate 64000 no shutdown ! ip route 0.0.0.0 0.0.0.0 172.20.0.2 ! line con 0 line vty 0 4 password cisco login ! end
The errors in the students’ scripts are the following:
- The destination address in the default route is incorrect. The correct command is ip route 0.0.0.0 0.0.0.0 172.20.1.2
Step 2 Load the following script onto the HQ router
hostname HQ
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.20.0.129 255.255.255.128
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 172.20.1.2 255.255.255.128
no shutdown
!
interface Serial0/0/1
ip address 192.168.38.254 255.255.255.252
no shutdown
!
ip route 192.168.39.64 255.255.255.192 192.168.38.253
!ip route statement for the BRANCH LAN is missing
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end
Corrected script:
hostname HQ ! no ip domain-lookup ! interface FastEthernet0/0 ip address 172.20.0.129 255.255.255.128 duplex auto speed auto no shutdown ! interface Serial0/0/0 ip address 172.20.1.2 255.255.255.128 no shutdown ! interface Serial0/0/1 ip address 192.168.38.254 255.255.255.252 clock rate 64000 no shutdown ! ip route 192.168.39.64 255.255.255.192 192.168.38.253 ip route 172.20.1.128 255.255.255.128 17.20.1.1 ! line con 0 line vty 0 4 password cisco login ! end
The errors in the students’ scripts are the following:
- The ip route statement is missing for the BRANCH LAN The command should be ip route
172.20.1.128 255.255.255.128 Serial0/0/0 o ip route 172.20.1.128
255.255.255.128 172.20.1.1
Step 3 Load the following script onto the ISP router
hostname ISP ! ! no ip domain-lookup ! interface FastEthernet0/0 ip address 192.168.39.65 255.255.255.192 !no shutdown duplex auto speed auto ! interface Serial0/0/0 ip address 192.168.38.253 255.255.255.252 no shutdown ! ip route 172.20.0.0 255.255.255.0 192.168.38.254 !The subnet mask for this route should be 255.255.254.0 ! ! ! ! line con 0 line vty 0 4 password cisco login ! end
Corrected script:
hostname ISP ! no ip domain-lookup ! interface FastEthernet0/0 ip address 192.168.39.65 255.255.255.192 no shutdown ! interface Serial0/0/1 ip address 192.168.38.253 255.255.255.252 no shutdown ! ip route 172.20.0.0 255.255.254.0 192.168.38.254 ! line con 0 line vty 0 4 password cisco login ! end
The errors in the students’ scripts are the following:
- The no shutdown command is missing on the FastEthernet0/0 interface.
- The wrong subnet mask is used in the ip route statement.
Task 3: Troubleshoot the Branch Router
Step 1 Begin troubleshooting at the Host connected to the Branch router.
From the host PC1, is it possible to ping PC2? no
From the host PC1, is it possible to ping the web server on the ISP LAN? no
From the host PC1, is it possible to ping the default gateway? yes
Step 2 Next, examine the Branch router to find possible configuration errors. Begin by viewing the summary of status information for each interface on the router.
Are there any problems with the status of the interfaces? no
If there are any problems with the status of the interfaces, record any commands that will be necessary to correct the configuration errors.
______________________________________________________
Step 3 If you have recorded any commands above, apply them to the router configuration now.
Step 4 View the status information summary.
If configuration changes were made in the previous step, view the router interfaces status information summary again.
Does the interface status summary information indicate any configuration errors? __No
If yes, troubleshoot the status of the interfaces again.
Step 5 Troubleshoot the static route configuration on the Branch router. Begin by viewing the routing table.
What networks are shown in the routing table?
172.20.1.0 is directly connected, Serial0/0/0
172.20.1.128 is directly connected, FastEthernet0/0
Are there any problems with the routing table?
BRANCH(config)#no ip route 0.0.0.0 0.0.0.0 172.20.1.129 BRANCH(config)#ip route 0.0.0.0 0.0.0.0 172.20.1.2
If there are any problems with the routing table, record any commands that will be necessary to correct the configuration errors.
________________________________________________________
Step 6 If you have recorded any commands above, apply them to the router configuration now.
Step 7 If any changes were made to the configuration in the previous step, view the routing table again.
Does the information in routing table indicate any configuration errors? no
If the answer is yes, troubleshoot the routing table again.
Step 8 Attempt to ping between the hosts again.
From the host PC1, is it possible to ping PC2? no
From the host PC1, is it possible to ping the web server on the ISP LAN? no
From the host PC1, is it possible to ping the Serial 0/0/0 interface of HQ? yes
Task 4: Troubleshoot the HQ Router
Step 1 Begin troubleshooting at the Host connected to the HQ router.
From the host PC2, is it possible to ping PC1? no
From the host PC2, is it possible to ping the web server on the ISP LAN? no
From the host PC2, is it possible to ping the default gateway? yes
Step 2 Next, examine the HQ router to find possible configuration errors. Begin by viewing the summary of status information for each interface on the router.
Are there any problems with the status of the interfaces? no
If there are any problems with the status of the interfaces, record any commands that will be necessary to correct the configuration errors. no
Step 3 If you have recorded any commands above, apply them to the router configuration now.
Step 4 If any changes were made to the configuration in the previous step, view the summary of the status information for the router interfaces again.
Does the information in the interface status summary indicate any configuration errors? no
If the answer is yes, troubleshoot the interface status of the interfaces again.
Step 5 Troubleshoot the static routing configuration on the HQ router. Begin by viewing the routing table.
What networks are shown in the routing table?
172.20.1.0 is directly connected, Serial0/0/0
192.168.38.252 is directly connected, Serial0/0/1
192.168.39.64 [1/0] via 192.168.38.253
Are there any problems with the routing table?
The route for the LAN BRANCH, 172.20.1.128/25, is missing from the routing table.
If there are any problems with the routing table, record any commands that will be necessary to correct the configuration errors.
HQ(config)#ip route 172.20.1.128 255.255.255.128 172.20.1.1
Step 6 If you have recorded any commands above, apply them to the router configuration now.
Step 7 If any changes were made to the configuration in the previous step, view routing table again.
Does the information in routing table indicate any configuration errors? no
If the answer is yes, troubleshoot the routing table again.
Step 8 Attempt to ping between the hosts again.
From the host PC2, is it possible to ping PC1?
yes
From the host PC2, is it possible to ping the Serial 0/0/1 interface of the ISP router?
yes
From the host PC1, is it possible to ping the web server on the ISP LAN?
no
Task 5: Troubleshoot the ISP Router
Step 1 Begin troubleshooting at the Host connected to the ISP router.
From Simulation mode, is it possible to ping from the Web Server on the ISP LAN to PC1?
no
From Simulation mode, is it possible to ping from the Web Server on the ISP LAN to PC2?
no
From Simulation mode, is it possible to ping from the Web Server on the ISP LAN to the default gateway?
yes
Step 2 Next, examine the ISP router to find possible configuration errors. Begin by viewing the summary of status information for each interface on the router.
Are there any problems with the status of the interfaces?
Interface FastEthernet0/0 is administratively down.
If there are any problems with the status of the interfaces, record any commands that will be necessary to correct the configuration errors.
ISP(config)#interface FastEthernet0/0 ISP(config-if)#no shutdown
Step 3 If you have recorded any commands above, apply them to the router configuration now.
Step 4 If any changes were made to the configuration in the previous step, view the summary of the status information for the router interfaces again.
Does the information in the interface status summary indicate any configuration errors?
no
If the answer is yes, troubleshoot the interface status of the interfaces again.
Step 5 Troubleshoot the static routing configuration on the ISP router. Begin by viewing the routing table.
What networks are shown in the routing table?
172.20.0.0 [1/0] via 192.168.38.254
192.168.38.252 is directly connected, Serial0/0/1
192.168.39.64 is directly connected, FastEthernet0/0
Are there any problems with the routing table?
The incorrect subnet mask is used in the ip route statement for network 172.0.0.0.
If there are any problems with the routing table, record any commands that will be necessary to correct the configuration errors.
ISP(config)#no ip route 172.20.0.0 255.255.255.0 192.168.38.254 ISP(config)#ip route 172.20.0.0 255.255.254.0 192.168.38.254
Step 6 If you have recorded any commands above, apply them to the router configuration now.
Step 7 if any changes were made to the configuration in the previous step, view routing table again.
Does the information in routing table indicate any configuration errors?
no
If the answer is yes, troubleshoot the routing table again.
Step 8 Attempt to ping between the hosts again.
From Simulation mode, is it possible to ping from the Web Server on the ISP LAN to PC1?
yes
From Simulation mode, is it possible to ping from the Web Server on the ISP LAN to PC2?
yes
From Simulation mode, is it possible to ping from the Web Server on the ISP LAN to the WAN interface of the Branch router?
yes
Task 6: Reflection
There were a number of configuration errors in the scripts that were provided for this lab. Use the space below to write a brief description of the errors that you found.
_________________________________________________________
Task 7: Documentation
On each router, capture the following command output to a text (.txt) file for future reference.
- show running-config
- show ip route
- show ip interface brief
If you need to review the procedures for capturing the output of a command, see Lab 1.5.1: “Network Cabling and Basic Router Configuration.”